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COURSE CONTENT 

COMPUTATIONAL STRUCTURE LABORATORY 

VI Semester: AE 

Course Code Category Hours / Week Credits Maximum Marks 

 

AAED40 

 

CORE 
L T P C CIA SEE Total 

- - 2 1 40 60 100 

Contact Classes: Nil Tutorial Classes: Nil Practical Classes: 45 Total Classes: 45 

Prerequisite:  

I. COURSE OVERVIEW: 

Computational Structure Laboratory course imparts detailed explanation on how to set up, run and 

interpret the results of various structures and covers all the necessary theoretical background for the 

industrial applications. Throughout the course ANSYS workbench will be used for all the structural 

analysis. This course offers a wide range of applications in aircraft structural analysis such as deflection of 

truss, frames, beams, stress and strain distributions in a plate as well as a solid continuum. It forms an 

essential cornerstone for mechanical, civil and aerospace engineers and plays a pivotal role in the efficient 

design of various structural systems. 

 

II. COURSE OBJECTIVES: 

The students will try to learn: 

1. The structural analysis problems by defining proper boundary conditions, loads, and constraints, to 

accurately represent real-world scenarios.  

2. The appropriate analysis method for different scenarios such as static analysis, dynamic analysis, 

linear and nonlinear analysis, and buckling analysis  

3. The behavior of structures under different loading conditions, such as mechanical, thermal, or fluid 

loads using computational tools 

4. The visualization of simulation results, including stress distributions, deformation patterns, and safety 

factors 

 

III. COURSE OUTCOMES: 

After successful completion of the course, students should be able to: 
 

CO1 Utilize the static structural analysis of beams, truss, frame structure for assessing the structural 

behavior, integrity of system components. 

CO2 Examine the dynamic behavior of spring mass system, simply supported beam for predicting 

natural frequency, mode shapes and resonance phenomenon in structural system. 

CO3 Inspect the thermal behavior of bars and beams for the design and performance prediction of 

various structures in engineering applications. 

CO4 Make use of nonlinear analysis for predicting failure modes and critical points in a system under 

nonlinear loading. 

CO5 Identify the static, dynamic behavior of wing, fuselage and landing gear for deducing their 

structural integrity 

CO6 Examine the static, dynamic behavior of composite materials under different loading and dynamic 

conditions for their suitability in aerospace applications. 
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COMPUTATIONAL STRUCTURE (CS) LABORATORY COURSE CONTENT 

S. No                                             Topic Name Page No. 

1 Getting Started Exercises 4 

 a. ANSYS Student Version Installation procedure  

 b. Getting Started with Ansys workbench  

2 Exercises on Static analysis of Trusses 7 

 a. Static analysis (2D-Trusses)  

 b. Static analysis (3D-Trusses)  

3 Exercises on Static analysis of beams 9 

 a. Static analysis (Straight beam)  

 b. Static analysis (Stepped beam)  

4 Exercises on Static Analysis of Two-Dimensional Structures 11 

 a. Static analysis (Plate with a hole)  

 b. Static analysis (Plate with a two holes)  

5 Exercises on Dynamic Analysis: Modal and Transient Analysis 13 

 a. Dynamic Analysis (Model analysis of beam) - Cantilever Beam  

 b. Dynamic Analysis (Model analysis of beam)- Simply Supported Beam  

6 Exercises on Thermal Analysis 15 

 a. Thermal Analysis (Steady State conduction through plate)  

 b. Thermal Analysis for a square plate with a hole at the center (Steady 

State conduction through plate) 
 

7 Exercises on Nonlinear Analysis 16 

 a. Nonlinear Analysis (Cantilever beam)  

 b. Nonlinear Analysis for Circular cross section (Cantilever beam)  

8 Exercises on Harmonic Response Analysis 17 

 a. Harmonic Response Analysis (Cantilever beam)  

 b. Harmonic Response Analysis (Simply supported beam)  

9 Exercises on Analysis of Aircraft Structure: Wing 19 

 a. Static structural (Wing)  

 b. Dynamic Analysis (Model analysis of wing)  

10 Exercises on Analysis of Aircraft Structure: Fuselage 20 

 a. Static structural (Fuselage)  

 b. Dynamic analysis (Model analysis of Fuselage)  

11 Exercises on Analysis of Aircraft Structure: Landing Gear 21 

 a. Static structural (Landing gear)  

 b. Dynamic analysis (Model analysis of Landing Gear)  

12 Exercises on Static Analysis of Composite Structures 24 

 a. Static analysis (Carbon fiber reinforced composite) - Cantilever beam  

 b. Static analysis (Carbon fiber reinforced composite) - Simply Supported 

Beam 
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13 Exercises on Analysis of Thin-Walled Open Section Beam 25 

 a. Static Analysis-Shear Force (Thin-Walled Open Section Beam)  

 b. Static analysis - Torsion (Thin-Walled Open Section Beam)  

14 Exercises on Analysis of Thin-Walled Closed Section Beam 27 

 a. Shear Force (Thin-Walled Closed Section Beam)  

 b. Torsion (Thin-Walled closed Section Beam)  
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IV. COURSE CONTENT: 

EXERCISES FOR COMPUTATIONAL STRUCTURAL ANALYSIS 

LABORATORY 
Note: Students are encouraged to bring their own laptops for laboratory 

practice sessions. 
 

1.  Getting Started with Ansys Student Version 

1.1 Ansys Student Version Installation procedure 

System requirement 

Supported Platforms and Operating Systems: 

Microsoft Windows 10, 64-bit 

Minimum Hardware Requirements for Ansys Student Product: 

Processor(s): Workstation class 

4 GB RAM 

25 GB hard drive space 

Computer must have a physical C:/” drive present 

Graphics card and driver: Professional workstation class 3-D 

OpenGL-capable 

Installation Procedure 

1. Extract (unzip) the downloaded installation files. 

2. Right-click on setup.exe and select Run as Administrator. (This will run setup.exe from the 

extracted files.) 

3. Read and accept the clickwrap to continue. 

4. Click the right arrow button to accept the default values throughout the installation. 

5. Click the exit button to close the installer. 

6. The Ansys Student software is now installed. 

7. Reboot your machine and then run the Ansys Student product from your Start menu by selecting 

Workbench. 

Problem size limits 

• No Geometry Export 

Limits for Ansys Student and Discovery (Refine Mode) 

• Structural Physics: 128K nodes/elements 

• Fluid physics: 1 Million cells/nodes 
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1.2 Getting Started with Ansys workbench 

Open ANSYS Workbench: Windows Start Menu button → Ansys → Workbench • Under the Toolbox 
Analysis Systems category, click and drag analysis system Static Structural onto the Project Schematic, 
drop it on target Create standalone system as shown in Fig. 1.1 (this will be the only target available) 

  

 

 

Fig. 1.1: Creating Standalone system of Static Structural 

• RMB—Geometry → Import Geometry → Browse… → valve_body_demo.scdoc → Open as shown in 
figure 1.2 

 

Fig. 1.2: Importing of geometry 

RMB—Engineering Data → Edit…  

• Toggle toolbar button Engineering Data Sources to “on”  

• Click Data Source General Materials  

• In table Outline, click + icon next to Gray Cast Iron as shown in figure 1.3 
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Fig. 1.3: Selecting the material 

• RMB—Model → Edit…  

• Expand branch Geometry  

• Select branch Component1\body as shown in figure 1.4 

• In view Details, set Material →Assignment to Gray Cast Iron using drop-down menu 

 

Fig. 1.4: Details of component body 
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2.  Exercises on Static analysis of Trusses 

Static analysis is a fundamental engineering technique used to determine the forces, displacements, and 

stresses within structures under static loads. Trusses and frame structures are common examples of 

architectural and engineering designs that benefit from static analysis. Static analysis is crucial in 

designing trusses and frames that can safely support various loads while ensuring structural stability. 

2.1 Static analysis (2D-Trusses)  

Calculate the vertical deflection of the joint B and the horizontal movement of the support D in the truss 

shown in Fig. 2.1 The cross-sectional area of each member is 1800 mm2 and Young’s modulus, E, for the 

material of the members is 200,000 N/mm2 

.  

Fig. 2.1: 2DTruss with point loads 

Hints 

1. Pre-processor  

• Element → Add → Link → 2D Spar → OK.  
• Real constants → Add Set 1 → Cross section area → OK.  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex= 2.5e + 11 → PRXY=0.28 → OK.  
• Modeling → Create → nodes → Inactive CS → enter node coordinates → OK → 
Elements → Auto numbered → Thru nodes → OK. 

2. Solution  

• Analysis Type → New analysis → Static → Ok  
• Define loads → Apply → Structural → Displacement → On nodes → OK → All degrees 
of freedom constrained → apply → Fx = − → OK  
• Solve → Current LS → OK 3. General Post Processing  
• Plot results → Deformed Shapes → Deformed + Undeformed  

3. General Post Processing  

• Plot results → Deformed Shapes → Deformed + Undeformed 
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Try 

1. Modify the angle of load in 2D truss and determine the deflection 

2. Modify the magnitude of load in 2D truss and determine the deflection 

2.2 Static analysis (3D-Trusses)  

A three-dimensional truss has the cross sections of each of the truss members is 1.56e-3 sq meter as 

shown in Fig. 2.2. Assume the structure is made of aluminum with modulus of elasticity E=75 GPa. The 

structure is constrained in the X, Y and Z directions at the bottom three corners. The tower is loaded at 

the top tip. The load is in the YZ plane and makes an angle of 75 with the negative Y axis direction. The 

load value is 2500 N. Determine deflection at each joint, stress in each member and reaction forces at the 

base. 

 

Fig. 2.2: 3D Truss with point loads 

Hints 

1. Pre-processor  

• Element → Add → Link → 3D Spar → OK.  
• Real constants → Add Set 1 → Cross section area → OK.  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex= 2.5e + 11 → PRXY=0.28 → OK.  
• Modeling → Create → nodes → Inactive CS → enter node coordinates → OK → 
Elements → Auto numbered → Thru nodes → OK. 

2. Solution  

• Analysis Type → New analysis → Static → Ok  
• Define loads → Apply → Structural → Displacement → On nodes → OK → All degrees 
of freedom constrained → apply → Fx = −3.5 → OK  
• Solve → Current LS → OK 3. General Post Processing  
• Plot results → Deformed Shapes → Deformed + Undeformed ...... 

3. General Post Processing  

• Plot results → Deformed Shapes → Deformed + Undeformed 
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Try 

1. Modify the angle of load in 3D truss and deflection at each joint, stress in each member and 

reaction forces at the base. 

2. Modify the magnitude of load in 3D truss and deflection at each joint, stress in each member and 

reaction forces at the base. 

 

3.  Exercises on Static analysis of beams 

Static analysis of beams involves determining the internal forces, reactions, and deflections in 

a beam structure under various loading conditions. This analysis helps engineers design 

beams that can safely support applied loads.  

3.1 Static analysis (Straight beam)  

A cantilever beam made of mild steel is subjected to a point load as shown in Fig 3.1. Calculate the shear 

force, bending moment and stress distribution in the beam. L=150 cm, P=10kN, b=10cm, h=10cm 

 
Fig. 3.1: Cantilever beam with point load at tip 

Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam3 • Real constants → Add Set1 → Cross section area = 100 
cmˆ2 → Izz = 833.33 cmˆ4 → Height = 10 cm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0) ;(100,0,0) ;(150,0,0) 
→ Ok → Lines → Straight Lines → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok  

2. Solution:  

• Analysis Type → New analysis → Static → Ok  
• Define Loads → Apply → Structural → Displacement → On Key Points → Ok → All 
DOF Constrained → Ok → Force/Moments → On Key Points → FY = - 10000 → Ok  
• Solve → Current LS → Ok   

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed  
• Contour Plots → Nodal Solutions → DOF Solution → Y- Component Displacement 
Ok  
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Try 

1. Change the location of point load and calculate the shear force, bending moment and stress   

distribution in the beam 

2. Change the location of point loads in tapered beam and find the deflection and the displacement 

variation along the beam length 

3. 2 Static analysis (Stepped beam)  

A stepped cantilever beam as shown in Fig. 3.2 made of mild steel is subjected to two pointed loads, one 

at the free end and one at the step as shown in figure below. Find the deflection and the displacement 

variation along the beam length. L=150cm, L1=100 cm, P1= P2=5kN, b1=12cm, b2=8cm, h1=12cm, 

h2=8cm. 

 

 
 

Fig. 3.2: Stepped Cantilever beam with point loads. 

Hints 

1. Preferences: Structural Preprocessor:  

Element → Add → Beam3  
• Real constants → Add Set1 → Cross section area = 144 cmˆ2 → Izz = 1728 cmˆ4 
→ Height = 12 cm → Ok → Add Set2 → Cross section area = 64 cmˆ2 → Izz = 341.33 
cmˆ4 → Height = 8 cm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Ok 
• Modeling → Create → Key points → Inactive CS → (0,0,0) ;(100,0,0) ;(150,0,0) 
→Ok → Lines → Straight Lines → Ok  
•Meshing → Mesh Attributes → Picked Lines → Ok → Real Constant set No.1 → Ok → 
Picked Lines → Ok → Real Constant set No.2 → Ok → Size Controls → Manual 
Sizing → Lines → Picked Lines → No. of elements = 10 → Ok → Mesh →Lines → Ok 

2. Solution:  

• Analysis Type → New analysis → Static → Ok  

P1 

P2 
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• Define Loads → Apply → Structural → Displacement → On Key Points → Ok → All 
DOF Constrained → Ok → Force/Moments → On Key Points → FY = - 5000 → Ok  
• Solve → Current LS → Ok 

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed 
• Contour Plots → Nodal Solutions → DOF Solution → Y- Component Displacement 
Ok  

 

Try 

1. Change the location of point load and calculate the shear force, bending moment and stress   

distribution in the beam. 

2. Change the location of point loads in tapered beam and find the deflection and the displacement 

variation along the beam length 

 

4.  Exercises on Static Analysis of Two-Dimensional Structures 

4.1 Static analysis (Plate with a hole) 

A plate with length of L=50mm and height of h=30 mm having hole at the center with radius r=15 mm is 

subjected to tensile load F= 100 N/mm2 as shown in Fig. 4.1. The plate is made of aluminum with 3 mm 

thickness. Find the stress, strain and displacement. 

 
Fig. 4.1: Plate with hole 

Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Solid → Quad 4 node 42 → Ok → Options → Element Behavior = 
Plane stress w/thk → Ok  
• Real constants → Add Set1 → THK = 3 mm → Ok → Close 
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 0.7e5 → PRXY = 0.32 → Ok  
• Modeling → Create → Areas → Rectangle → By Centre and Corner → PX = 0,PY = 
0, Width = 50, Height = 30 → Ok → Circle → Two end pts →(-10,0),(10,0) → Ok  
• Operate → Booleans → Subtract → Select Area → Ok 
• Meshing → Size Controls → Manual Sizing → Areas → All Areas → Element Edge     
Length = 5 → Ok → Mesh → Areas → Free → Ok 
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2. Solution: 

• Analysis Type → New analysis → Static → Ok • Sol’n Controls → Automatic Time 
Stepping = On → No. of Sub-steps = 5 → Max. No. of Sub-steps = 1000 → Min. No 
of Sub-steps = 1 → Ok 
• Define Loads → Apply → Structural → Displacement → On lines → Ok → All DOF 
Constrained → Ok → Pressure → On lines → 100 N/(mmˆ2) → Ok  
• Solve → Current LS → Ok 

3. General Post Processing:  

 • Plot results → Deformed Shapes → Deformed + Un deformed  
 • Contour Plots → Nodal Solution → Stress → X Comp. → Ok  
 • Contour Plots → Nodal Solution → Stress → XY Shear → Ok  
 • Contour Plots → Nodal Solution → Stress → Von Mises Stress → Ok Results: 

Try 

1. Change the diameter of holes, location and find the maximum stress concentration, strain and 

displacement. 

2. Fix the left side of plate and apply compressive loads on other three sides and find the maximum 

stress concentration, strain and displacement.  

 

4.2 Static analysis (Plate with a two holes) 

A plate with length of L=20mm, l=50mm and height of b=30 mm having hole at the center with d=10 

mm is subjected to tensile load F= 100 N/mm2 as shown in Fig. 4.2. The plate is made of aluminum with 3 

mm thickness. Find the stress, strain and displacement. 

 
Fig. 4.2: Plate with two holes 

Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Solid → Quad 4 node 42 → Ok → Options → Element Behavior = 
Plane stress w/thk → Ok  
• Real constants → Add Set1 → THK = 3 mm → Ok → Close 
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 0.7e5 → PRXY = 0.32 → Ok  
• Modeling → Create → Areas → Rectangle → By Centre and Corner → PX = 0,PY = 
0, Width = 50, Height = 30 → Ok → Circle → Two end pts →(-10,0),(10,0) → Ok  
• Operate → Booleans → Subtract → Select Area → Ok 
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• Meshing → Size Controls → Manual Sizing → Areas → All Areas → Element Edge     
Length = 5 → Ok → Mesh → Areas → Free → Ok 

2. Solution: 

• Analysis Type → New analysis → Static → Ok • Sol’n Controls → Automatic Time 
Stepping = On → No. of Sub-steps = 5 → Max. No. of Sub-steps = 1000 → Min. No 
of Sub-steps = 1 → Ok 
• Define Loads → Apply → Structural → Displacement → On lines → Ok → All DOF 
Constrained → Ok → Pressure → On lines → 100 N/(mmˆ2) → Ok  
• Solve → Current LS → Ok 

3. General Post Processing:  

 • Plot results → Deformed Shapes → Deformed + Un deformed  
 • Contour Plots → Nodal Solution → Stress → X Comp. → Ok  
 • Contour Plots → Nodal Solution → Stress → XY Shear → Ok  
 • Contour Plots → Nodal Solution → Stress → Von Mises Stress → Ok Results: 

Try 

1. Fix the left side of plate and apply compressive loads on other three sides and find the maximum 

stress concentration, strain and displacement.  

2. Change the hole’s location and find the maximum stress concentration, strain and displacement. 

 

5. Exercises on Dynamic Analysis: Modal and Transient Analysis 

5.1 Dynamic Analysis (Model analysis of beam) - Cantilever Beam 

A cantilever beam made of mild steel as following specifications L=150 cm, b=10cm, h=10cm shown in 

Fig 5.1. Calculate the natural frequency of beam and compare it with the analytical results. 

 

Fig. 5.1: Cantilever beam  

Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam3 21  
• Real constants → Add Set1 → Cross section area = 100 cmˆ2 → Izz = 833.33 
cmˆ4 → Height = 10 cm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Density = 7800kg/(mˆ3) →Ok  
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• Modeling → Create → Key points → Inactive CS → (0,0,0) ;(100,0,0) ;(150,0,0) 
→ Ok → Lines →Straight Lines → Ok 
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 10 → Ok → Mesh → Lines → Ok 6.4.2  

2. Solution: 

• Analysis Type → New analysis → Modal → Ok  
• Analysis Option → Block Lancoz → No. of Modes to extract = 5 → No. of Modes 
to expand = 5 → Ok  
• Solve → Current LS → Ok  

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed 

Try 

1. Use the aluminum as material and find the natural frequency for same beam. 

2. Use the stainless steel as material and find the natural frequency for same beam. 

 

5.2 Dynamic Analysis (Model analysis of beam)- Simply Supported Beam 

A simply supported beam of mild steel as following specifications L=150 cm, b=10cm, h=10cm. Calculate 

the natural frequency of beam and compare it with the analytical results. 

Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam3 21  
• Real constants → Add Set1 → Cross section area = 100 cmˆ2 → Izz = 833.33 cmˆ4 
→ Height = 10 cm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Density = 7800kg/(mˆ3) →Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0) ;(100,0,0) ;(150,0,0) 
→ Ok → Lines →Straight Lines → Ok 
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 10 → Ok → Mesh → Lines → Ok 6.4.2  

2. Solution: 

• Analysis Type → New analysis → Modal → Ok  
• Analysis Option → Block Lancoz → No. of Modes to extract = 5 → No. of Modes 
to expand = 5 → Ok  
• Solve → Current LS → Ok  

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed 

Try 

1. Use the aluminum as material and find the natural frequency for same beam. 

2. Use the stainless steel as material and find the natural frequency for same beam. 
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6.  Exercises on Thermal Analysis 

6.1. Thermal Analysis (Steady State conduction through plate) 

Consider a square plate has thermal conductivity of 10 W/m0C. The top side is maintained at 2500C and 
other three sides are maintained at 400C. Determine temperature at the center of the plate and 
temperature distribution from top to bottom passing through the center. 

Hints 

1. Preferences: Structural Preprocessor:  

Preprocessor → Modeling → Create → Areas → Rectangle → By 2 Corners → X=0, 
Y=0, Width=1, Height=1 
BLC4,0,0,1,1 
Preprocessor → Element Type → Add/Edit/Delete... → click ’Add’ → Select 
Thermal Mass Solid, Quad 4Node 55 ET,1, PLANE55 
Preprocessor → Material Props → Material Models → Thermal → Conductivity → 
Isotropic → KXX = 10 (Thermal conductivity) MP, KXX,1,10 
Preprocessor → Meshing → Size Cntrls → ManualSize → Areas → All Areas → 0.05 
AESIZE,ALL,0.05 
Preprocessor → Meshing → Mesh → Areas → Free → Pick All AMESH, ALL 

2. Solution 

• Solve → Current LS → Ok  

3. General Post Proc:  

• Plot results → Temperature distribution  

Try  

1. Instead of temperature apply heat flux on the sides of square and find the temperature 

distribution. 

2. Apply the temperature and heat flux on the sides for a rectangular cross section and find the 

temperature distribution. 

 

 

6.2. Thermal Analysis for a square plate with a hole at the center (Steady 

State conduction through plate) 

Consider a square plate with a hole at the center, has a thermal conductivity of 10 W/m0C. The top side is 

maintained at 2500C and other three sides are maintained at 400C. Determine temperature at the center 
of the plate and temperature distribution from top to bottom passing through the center. 

Hints 

1. Preferences: Structural Preprocessor:  

• Preprocessor → Modeling → Create → Areas → Rectangle → By 2 Corners → X=0, 
Y=0, Width=1, Height=1 BLC4,0,0,1,1 
• Preprocessor → Element Type → Add/Edit/Delete... → click ’Add’ → Select 
Thermal Mass Solid, Quad 4Node 55 ET,1, PLANE55 
• Preprocessor → Material Props → Material Models → Thermal → Conductivity → 
Isotropic → KXX = 10 (Thermal conductivity) MP, KXX,1,10 
• Preprocessor → Meshing → Size Cntrls → ManualSize → Areas → All Areas → 0.05 
AESIZE, ALL,0.05 
• Preprocessor → Meshing → Mesh → Areas → Free → Pick All AMESH, ALL 
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2. Solution 

• Solve → Current LS → Ok  

3. General Post Proc:  

• Plot results → Temperature distribution  

Try  

1. Instead of temperature apply heat flux on the sides of square and find the temperature distribution. 

2. Apply the temperature and heat flux on the sides for a rectangular cross section with multiple holes 

and find the temperature distribution. 

 

7.  Exercises on Nonlinear Analysis 

7.1 Nonlinear Analysis (Cantilever beam) 

A cantilever beam with length of 550 cm and cross section area of 100 mm2 subjected to nonlinear load. 

Find the deflection and nonlinear behavior. 

Hints 

1.  Preferences: Structural Preprocessor:  

• Element → Add → Beam 3  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2e11 → PRXY = 0.33 → Density = 7850kg/(mˆ3) →Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0); (100,0,0) → Ok → 
Lines → Areas → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok 
• Select parameters → select functions define 

2. Solution: 

• Analysis Type → New analysis →Transient → Ok 
• Parameters →functions→ define/edit→ type in result 
• Select file→ file name= transient→ desktop→ save 
• Parameters→ functions→ read from file→ open transient→ give table parameter 
name 
cantilever 
• Select loads→ define loads→ apply→ structural→ displacement→ on keypoints→ 
all 
DOF→ keypoint 1→ ok 

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed 

Try  

1. Use the same cantilever beam subjected to torque and find its nonlinear behavior. 

2. Use the simply supported beam subjected to torque and find its nonlinear behavior. 

 

7.2 Nonlinear Analysis for Circular cross section (Cantilever beam) 

A cantilever beam with length of 550 cm and cross section area of 100 mm2 subjected to nonlinear load. 

Find the deflection and nonlinear behavior. 

Hints 

1. Preferences: Structural Preprocessor:  
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• Element → Add → Beam 3  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2e11 → PRXY = 0.33 → Density = 7850kg/(mˆ3) →Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0); (100,0,0) → Ok → 
Lines → Areas → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok 
• Select parameters → select functions define 

2. Solution: 

• Analysis Type → New analysis →Transient → Ok 
• Parameters →functions→ define/edit→ type in result 
• Select file→ file name= transient→ desktop→ save 
• Parameters→ functions→ read from file→ open transient→ give table parameter 
name 
cantilever 
• Select loads→ define loads→ apply→ structural→ displacement→ on keypoints→ 
all 
DOF→ keypoint 1→ ok 

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed 

Try  

1. Use the same cantilever beam with circular cross section subjected to torque and find its 

nonlinear behavior. 

2. Use the simply supported beam with circular cross section subjected to torque and find its 

nonlinear behavior. 

 

8.  Exercises on Harmonic Response Analysis 

8.1 Harmonic Response Analysis (Cantilever beam) 

A cantilever beam made of mild steel as following specifications L=150 cm, b=10cm, h=10cm shown in 

Fig 8.1 is subjected to a periodic force, which is mathematically represented below. The amplitude of the 

force is 1000 N. F = 1000k sin ( ). Find the deflection of beam. 

 
Fig 8.1. Cantilever beam with periodic force 

Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam 3  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2e11 → PRXY = 0.33 → Density = 7850kg/(mˆ3) →Ok  
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• Modeling → Create → Key points → Inactive CS → (0,0,0); (100,0,0) → Ok → 
Lines → Areas → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok 
• Select parameters → select functions define 

2. Solution: 

• Analysis Type → New analysis → → Ok 
• Parameters →functions→ define/edit→ type in result 1000k sin (πt/4)  
• Select file→ file name= transient→ desktop→ save  
• Parameters→ functions→ read from file→ open transient→ give table parameter 
name cantilever  
• Select loads→ define loads→ apply→ structural→ displacement→ on keypoints→ 
all DOF→ keypoint 1→ ok  
• Solve → Current LS → Ok  

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed 

Try  

1. Repeat the above analysis for fixed support beam. 

2. Change the magnitude of periodic load and repeat the same analysis. 

 

8.2 Harmonic Response Analysis (Simply supported beam) 

A simply supported beam made of mild steel as following specifications L=150 cm, b=10cm, h=10cm 

shown in Fig 8.1.is subjected to a periodic force, which is mathematically represented below. The 

amplitude of the force is 1000 N. F = 1000k sin ( ). Find the deflection of beam 

Hint 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam 3  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2e11 → PRXY = 0.33 → Density = 7850kg/(mˆ3) →Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0); (100,0,0) → Ok → 
Lines → Areas → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok 
• Select parameters → select functions define 

2. Solution: 

• Analysis Type → New analysis → → Ok 
• Parameters →functions→ define/edit→ type in result 1000k sin ( πt/4)  
• Select file→ file name= transient→ desktop→ save  
• Parameters→ functions→ read from file→ open transient→ give table parameter 
name cantilever  
• Select loads→ define loads→ apply→ structural→ displacement→ on keypoints→ 
all DOF→ keypoint 1→ ok  
• Solve → Current LS → Ok  

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed 
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Try  

1. Change the magnitude of periodic load and repeat the same analysis. 

2. Change the material and repeat the same analysis. 

 

9.  Exercises on Analysis of Aircraft Structure: Wing 

9.1 Static structural (Wing)  

Perform static structural analysis of an aircraft rectangular wing of a span 100 cm and the chord length of 

wing is 10 cm and cross-sectional area is 100 cm2. Find the deflection and deformation of wing. 

1. Preferences: Structural Preprocessor:  

• Element → Add → wing • Real constants → Add Set1 → Cross section area = 100 
cmˆ2 → Izz = 833.33 cmˆ4 → Height = 10 cm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0) ;(100,0,0) ;(150,0,0) 
→ Ok → Lines → Straight Lines → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok  

2. Solution:  

• Analysis Type → New analysis → Static → Ok  
• Define Loads → Apply → Structural → Displacement → On Key Points → Ok → All 
DOF Constrained → Ok → Force/Moments → On Key Points → FY = - 10000 → Ok  
• Solve → Current LS → Ok   

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed  
• Contour Plots → Nodal Solutions → DOF Solution → Y- Component Displacement 
Ok  

Try  

1. Repeat the above analysis for a tapered wing. 

2. Repeat the above analysis for tapered wing with uniformly varying load. 

9.2 Dynamic Analysis (Model analysis of wing) 

Perform model analysis of an aircraft rectangular wing of a span 100 cm and the chord length of wing is 

10 cm and cross-sectional area is 100 cm2. Calculate the natural frequency of wing. 

Hints 

 

1.  Preferences: Structural Preprocessor:  

• Element → Add → wing  
• Real constants → Add Set1 → Cross section area = 100 cmˆ2 → Izz = 833.33 
cmˆ4 → Height = 10 cm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Density = 7800kg/(mˆ3) →Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0) ;(100,0,0) ;(150,0,0) 
→ Ok → Lines →Straight Lines → Ok 
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 10 → Ok → Mesh → Lines → Ok 6.4.2  
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2. Solution: 

• Analysis Type → New analysis → Modal → Ok  
• Analysis Option → Block Lancoz → No. of Modes to extract = 5 → No. of Modes 
to expand = 5 → Ok  
• Solve → Current LS → Ok  

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed 

Try  

1. Repeat the above analysis for a tapered wing. 

2. Repeat the above analysis for tapered wing with uniformly varying load. 

 

10.  Exercises on Analysis of Aircraft Structure: Fuselage 

10.1 Static structural (Fuselage) 

Calculate the deformation of the aluminum fuselage section under the application of internal load of 

100000 Pa. The radius of fuselage is 0.15m and thickness is 2 mm.  

1. Preferences: Structural Preprocessor:  

•Element type → Add / edit/Delete → Add → Solid – 10 node 92→ Apply Add → Beam 
2 Node 188 → Apply → Add → Shell →Elastic 4 node 63 Real Constants → Add → 
Select shell → give thickness (I) = 1→ ok → close. 
•Material properties → material models → Structural → Linear → Elastic → 
Isotropic EX = 0.7e11; PRXY = 0.3; Density = 2700 
•Pre-processor → modelling → Create → Areas → Circle → Annulus WP x = 0 ; WP y 
= 0; Rad – 1 = 2.5; Rad - 2 = 2.3 OK Pre-processor → Modelling → Create → 
Circle → Solid – WP x = 0; X = 2.25; Y = 0 Radius = 0.15 Apply WP x = 0; X = -
2.25; Y = 0 Radius = 0.15 Apply WP x = 0; X =0; Y = 2.25; Radius = 0.15 Apply 
WP x = 0; X = 0; Y = -2.25 Radius = 0.15 OK 
•Pre-processor → Modelling → Operate → Booleans → Add → Areas – Pick all OK 
•Preprocessor → Modelling → Operate → Extrude → Areas → By XYZ offset X= 0; 
Y=0; Z = 5 
•Pre-processor →Meshing → Size controls → Manual Size → All Areas → give 
element edge length as 0.15 → ok 
• Meshing → Size controls → Manual Size → All lines → give element edge length 
as→ ok  
•Meshing → Mesh → areas → free → select box type instead of single → select 
the total volume → ok 

2. Solution: 

•Loads → define loads → Apply → Structural → Displacement → On areas → select 
box type → select box (4 points at centre) → all DOF → ok Select → ALL DOF 
arrested Define loads → Apply → Structural → Pressure → on areas → select the 
internal surface of the fuselage and give value (100000) → ok 
• Solve → Current LS → Ok  

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed 

Try  

1. Repeat the above analysis for a monocoque fuselage. 
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2. Repeat the above analysis for a monocoque fuselage with both internal and external load.  

 

 

10.2 Dynamic analysis (Model analysis of Fuselage) 

Calculate the natural frequency of the aluminum fuselage section under the application of internal load of 

100000 Pa. The radius of fuselage is 0.15m and thickness is 2 mm.  

1. Preferences: Structural Preprocessor:  

•Element type → Add / edit/Delete → Add → Solid – 10 node 92→ Apply Add → Beam 
2 Node 188 → Apply → Add → Shell →Elastic 4 node 63 Real Constants → Add → 
Select shell → give thickness (I) = 1→ ok → close. 
•Material properties → material models → Structural → Linear → Elastic → 
Isotropic EX = 0.7e11; PRXY = 0.3; Density = 2700 
•Pre-processor → modelling → Create → Areas → Circle → Annulus WP x = 0 ; WP y 
= 0; Rad – 1 = 2.5; Rad - 2 = 2.3 OK Pre-processor → Modelling → Create → 
Circle → Solid – WP x = 0; X = 2.25; Y = 0 Radius = 0.15 Apply WP x = 0; X = -
2.25; Y = 0 Radius = 0.15 Apply WP x = 0; X =0; Y = 2.25; Radius = 0.15 Apply 
WP x = 0; X = 0; Y = -2.25 Radius = 0.15 OK 
•Pre-processor → Modelling → Operate → Booleans → Add → Areas – Pick all OK 
•Preprocessor → Modelling → Operate → Extrude → Areas → By XYZ offset X= 0; 
Y=0; Z = 5 
•Pre-processor →Meshing → Size controls → Manual Size → All Areas → give 
element edge length as 0.15 → ok 
• Meshing → Size controls → Manual Size → All lines → give element edge length 
as→ ok  
•Meshing → Mesh → areas → free → select box type instead of single → select 
the total volume → ok 
 

2. Solution: 

• Analysis Type → New analysis → Modal → Ok  
• Analysis Option → Block Lancoz → No. of Modes to extract = 5 → No. of Modes 
to expand = 5 → Ok  
• Solve → Current LS → Ok  

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed 

Try  

1. Repeat the above analysis for a monocoque fuselage. 

2. Repeat the above analysis for a monocoque fuselage with both internal and external load. 

  

11. Exercises on Analysis of Aircraft Structure: Landing Gear 

11.1 Static structural (Landing gear) 

A simple retractable landing gear subjected to a load of 10000 N. Find the deformation and stress 

developed in the landing gear. 

1. Preferences: Structural Preprocessor:  

•Preferences → Structural → H-Method → OK 
•Preprocessor → Element Type → Add → Add → Select Link → 2D spar 1 → Apply 
•Preprocessor → Element Type → Add → Add → Select Beam → 2 Node 188 → OK → 
Close  
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•Real Constants → Add → Add → Select Type Link 1 → Click OK 
•Enter the cross-sectional area =1 → OK → Close 
•Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic Enter 
the Young’s Modulus (EXY) = 3e7 
Poisson’s Ratio (PRXY) = 0.3 
Sections →Beam →Common Sections →Subtype → Select Solid Circle R=0.5 N=20 
T=0, Mesh view  
•Preprocessor → Modeling → Create → Key points → In Active CS  
•Create the key points according to the table 

KP no X Y Z 
1 0 0 0 
2 -12 0 0 
3 12 0 0 
4 0 -12 0 
5 0 -12 0 
6 0 12 0 

•Modeling → Create → Lines → Lines → Straight Lines →  
•Join the key points according to table 

Line no Join 
1 1&4 
2 4&5 
3 5&6 
4 2&5 
5 3&4 

•Preprocessor → Meshing → Mesh Attributes → All lines → Select element type 
Beam 188, Ok  
•Meshing → Mesh tool→ set →Global 1Link1→Ok  
•Lines→set→3&4 line click→2&5 line click→ok No of divisions 1→ok 
• Mesh Tool→Mesh→Mesh only strut→ok Meshing → Mesh tool→ set →Global 2 Beam 
188→Ok Lines→set→1&4 line click→4&5 line click→5&6 line click→ok Element egde 
length→1→ok 
•Mesh Tool→Mesh→Mesh only Vertical line→ok Main menu→ plot Cntrls → Style → 
Size and Shape Click in the box against Display Element Type 
 

2. Solution: 

•Define Loads → Apply → Structural → Displacement → On key Points → Select 
keypoints 2 & 3→select UX,UY,UZ,ROTX,ROTY→Ok Select keypoints 2 & 3→select 
UX,UZ→Ok  
•Modeling →Create¿Nodes→Rotate nodes CS¿By angles¿click 6th keypoint THXY 
→60→ok •Loads¿Apply→Structural¿Force/Moment→ click on nodes 28/Key point 
6→Force/Moment value →10000 
•Solution → Solve 

3. General Post processing: 

•List results→ Rection solution→ Plot results→ Deformed shape 

Try  

1. Repeat the above analysis for a landing gear subjected to compression load. 

2. Change the landing gear material properties and repeat the same analysis. 
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11.2 Dynamic analysis (Model analysis of Landing Gear) 

A simple retractable landing gear subjected to a load of 10000 N. Find the deformation and stress 

developed in the landing gear. 

1. Preferences: Structural Preprocessor:  

•Preferences → Structural → H-Method → OK 
•Preprocessor → Element Type → Add → Add → Select Link → 2D spar 1 → Apply 
•Preprocessor → Element Type → Add → Add → Select Beam → 2 Node 188 → OK → 
Close  
•Real Constants → Add → Add → Select Type Link 1 → Click OK 
•Enter the cross sectional area =1 → OK → Close 
•Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic Enter 
the Young’s Modulus (EXY) = 3e7 
Poisson’s Ratio (PRXY) = 0.3 
Sections →Beam →Common Sections →Subtype → Select Solid Circle R=0.5 N=20 
T=0, Mesh view  
•Preprocessor → Modeling → Create → Key points → In Active CS  
•Create the key points according to the table 

KP no X Y Z 
1 0 0 0 
2 -12 0 0 
3 12 0 0 
4 0 -12 0 
5 0 -12 0 
6 0 12 0 

•Modeling → Create → Lines → Lines → Straight Lines →  
•Join the key points according to table 

Line no Join 
1 1&4 
2 4&5 
3 5&6 
4 2&5 
5 3&4 

•Preprocessor → Meshing → Mesh Attributes → All lines → Select element type 
Beam 188, Ok  
•Meshing → Mesh tool→ set →Global 1Link1→Ok  
•Lines→set→3&4 line click→2&5 line click→ok No of divisions 1→ok 
• Mesh Tool→Mesh→Mesh only strut→ok Meshing → Mesh tool→ set →Global 2 Beam 
188→Ok Lines→set→1&4 line click→4&5 line click→5&6 line click→ok Element egde 
length→1→ok 
•Mesh Tool→Mesh→Mesh only Vertical line→ok Main menu→ plot Cntrls → Style → 
Size and Shape Click in the box against Display Element Type 
 

2. Solution: 

• Analysis Type → New analysis → Modal → Ok  
• Analysis Option → Block Lancoz → No. of Modes to extract = 5 → No. of Modes 
to expand = 5 → Ok  
• Solve → Current LS → Ok 

3. General Post processing: 
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•List results→ Rection solution→ Plot results→ Defromed shape 

Try  

1. Repeat the above analysis for a landing gear subjected to compression load. 

2. Change the landing gear material properties and repeat the same analysis. 

 

12.  Exercises on Static Analysis of Composite Structures 

Static analysis of composite structures involves determining the internal forces, reactions and deflections 

in a beam structure under various loading conditions. This analysis helps engineers design composite 

structures that can safely support applied loads. 

12.1 Static analysis (Carbon fiber reinforced composite) - Cantilever Beam 

A cantilever beam made of Carbon fiber reinforced composite is subjected to a point load as shown in 

Fig.3.1. Calculate the shear force, bending moment and stress distribution in the beam. L=150 cm, 

P=10kN, b=10cm, h=10cm 

Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam3 • Real constants → Add Set1 → Cross section area = 100 
cmˆ2 → Izz = 833.33 cmˆ4 → Height = 10 cm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0) ;(100,0,0) ;(150,0,0) 
→ Ok → Lines → Straight Lines → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok  

2. Solution:  

• Analysis Type → New analysis → Static → Ok  
• Define Loads → Apply → Structural → Displacement → On Key Points → Ok → All 
DOF Constrained → Ok → Force/Moments → On Key Points → FY = - 10000 → Ok  
• Solve → Current LS → Ok   

3. General Post Proc:  

• Plot results → Deformed Shapes → Deformed + Un deformed  

• Contour Plots → Nodal Solutions → DOF Solution → Y- Component Displacement 
Ok 

Try  

1. Repeat the above analysis for a beam made of glass fiber reinforced composite. 

2. Repeat the above analysis for a fixed support beam. 
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12.2 Static analysis (Carbon fiber reinforced composite)- Simply Supported 

Beam 

A simply supported beam made of Carbon fiber reinforced composite is subjected to a point load. 

Calculate the shear force, bending moment and stress distribution in the beam. L=150 cm, P=10kN, 

b=10cm, h=10cm. 

Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam3 • Real constants → Add Set1 → Cross section area = 100 
cmˆ2 → Izz = 833.33 cmˆ4 → Height = 10 cm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0) ;(100,0,0) ;(150,0,0) 
→ Ok → Lines → Straight Lines → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok  

2. Solution:  

• Analysis Type → New analysis → Static → Ok  
• Define Loads → Apply → Structural → Displacement → On Key Points → Ok → All 
DOF Constrained → Ok → Force/Moments → On Key Points → FY = - 10000 → Ok  
• Solve → Current LS → Ok   

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed  

• Contour Plots → Nodal Solutions → DOF Solution → Y- Component Displacement 
Ok 

Try  

1. Repeat the above analysis for a beam made of glass fiber reinforced composite. 

2. Repeat the above analysis for a fixed support beam. 

 

13.  Exercises on Analysis of Thin-Walled Open Section Beam 

Static and torsional analysis of thin-walled open section beams involves in determining the shear stress 

distribution and torsion strength of an open section beam under different loading conditions. It enables 

engineers to create efficient, reliable, and compliant aircraft that meet the high demands of aviation. 

13.1 Static Analysis-Shear Force (Thin-Walled Open Section Beam)  

A thin walled I section beam is subjected to a shear force and torsional moment. Calculate the shear stress 

distribution in the open section beam.  Length L=2 m, web height h=100 mm, flange width b=50 mm, 

thickness t=5 mm, Shear Force: V=10 kN. 

Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam4 • Real constants → Add Set1 → Cross section area = 
1000 mmˆ2 → Izz = 1252083.34 mmˆ4 → Height = 100 mm → Ok → Close  
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• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Ok  
• Modeling → Create → Key points → Inactive CS →  
Web: 
Bottom of the Web (Point A) :(0, −h/2) = (0, −50mm) 
Top of the Web (Point B): (0, h/2) =(0,50mm) 
2. Flanges: 
Left Flange Bottom (Point C): (−b/2, −h/2) = (−25mm, −50mm) 
Left Flange Top (Point D): (−b/2, −h/2+t) = (−25mm, −45mm) 
Right Flange Bottom (Point E): (b/2, −h/2) = (25mm, −50mm) 
Right Flange Top (Point F): (b/2, −h/2+t) = (25mm, −45mm) 
3. Top Flange: 
Left Flange Bottom (Point G): (−b/2, h/2−t) =(−25mm,45mm) 
Left Flange Top (Point H): (−b/2, h/2) =(−25mm,50mm) 
Right Flange Bottom (Point I): (b/2, h/2−t) =(25mm,45mm) 
Right Flange Top (Point J): (b/2, h/2) =(25mm,50mm) 
 → Ok → Lines → Straight Lines → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok  

2. Solution:  

• Analysis Type → New analysis → Static → Ok  
• Define Loads → Apply → Structural → Displacement → On Key Points → Ok → All 
DOF Constrained → Ok → Force/Moments → On Key Points → FY = - 10000 → Ok  
• Solve → Current LS → Ok   

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed  

• Contour Plots → Nodal Solutions → DOF Solution → Y- Component Displacement 
Ok 

Try  

1. Repeat the above analysis for channel section beam. 

2. Repeat the above analysis for T section beam. 

13.2 Static analysis - Torsion (Thin-Walled Open Section Beam)  

A thin walled I section beam is subjected to a shear force and torsional moment. Calculate the shear stress 

distribution in the open section beam.  Length L=2 m, web height h=100 mm, flange width b=50 mm, 
thickness t=5 mm, Torsion Mt=500 Nm  
Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam4 • Real constants → Add Set1 → Cross section area = 
1000 mmˆ2 → Izz = 1252083.34 mmˆ4 → Height = 100 mm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Ok  
• Modeling → Create → Key points → Inactive CS →  
Web: 
Bottom of the Web (Point A) :(0, −h/2) = (0, −50mm) 
Top of the Web (Point B): (0, h/2) =(0,50mm) 
2. Flanges: 
Left Flange Bottom (Point C): (−b/2, −h/2) = (−25mm, −50mm) 
Left Flange Top (Point D): (−b/2, −h/2+t) = (−25mm, −45mm) 



Page | 27  
 

Right Flange Bottom (Point E): (b/2, −h/2) = (25mm, −50mm) 
Right Flange Top (Point F): (b/2, −h/2+t) = (25mm, −45mm) 
3. Top Flange: 
Left Flange Bottom (Point G): (−b/2, h/2−t) =(−25mm,45mm) 
Left Flange Top (Point H): (−b/2, h/2) =(−25mm,50mm) 
Right Flange Bottom (Point I): (b/2, h/2−t) =(25mm,45mm) 
Right Flange Top (Point J): (b/2, h/2) =(25mm,50mm) 
 → Ok → Lines → Straight Lines → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok  

2. Solution:  

• Analysis Type → New analysis → Static → Ok  
• Define Loads → Apply → Structural → Displacement → On Key Points → Ok → All 
DOF Constrained → Ok → Force/Moments → On Key Points → Torsion = 500 → Ok  
• Solve → Current LS → Ok   

3. General Post Proc:  

• Plot results → Deformed Shapes → Deformed + Un deformed  

• Contour Plots → Nodal Solutions → DOF Solution → Y- Component Displacement 
Ok 

Try  

1. Repeat the above analysis for channel section beam with different torsion values.  

2. Repeat the above analysis for T section beam with different torsion values.  

 

14.  Exercises on Analysis of Thin-Walled Closed Section Beam 

Static and torsional analysis of thin-walled closed section beams involves in determining the shear stress 

distribution and torsion strength of an open section beam under different loading conditions. It enables 

engineers to create efficient, reliable, and compliant aircraft that meet the high demands of aviation. 

14.1 Shear Force (Thin-Walled Closed Section Beam)  
A thin-walled rectangular section beam is subjected to a shear force and torsional moment. Calculate the 

shear stress distribution in the open section beam.  Length L=150 cm, web height h=10 cm, flange width 
b=5 cm, shear force=10kN  
Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam3 • Real constants → Add Set1 → Cross section area = 100 
cmˆ2 → Izz = 833.33 cmˆ4 → Height = 10 cm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0) ;(100,0,0) ;(150,0,0) 
→ Ok → Lines → Straight Lines → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok  

2. Solution:  

• Analysis Type → New analysis → Static → Ok  
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• Define Loads → Apply → Structural → Displacement → On Key Points → Ok → All 
DOF Constrained → Ok → Force/Moments → On Key Points → FY = - 10000 → Ok  
• Solve → Current LS → Ok   

3. General Post Processing:  

• Plot results → Deformed Shapes → Deformed + Un deformed  

• Contour Plots → Nodal Solutions → DOF Solution → Y- Component Displacement 
Ok 

Try  

1. Repeat the above analysis for square cross section beam. 

2. Repeat the above analysis for cylindrical cross section beam. 

 

14.2 Torsion (Thin-Walled closed Section Beam)  

A thin-walled rectangular section beam is subjected to a shear force and torsional moment. Calculate the 

shear stress distribution in the open section beam.  Length L=150 cm, web height h=10 cm, flange width 

b=5 cm, Torsion Mt=500 Nm  
Hints 

1. Preferences: Structural Preprocessor:  

• Element → Add → Beam3 • Real constants → Add Set1 → Cross section area = 100 
cmˆ2 → Izz = 833.33 cmˆ4 → Height = 10 cm → Ok → Close  
• Material Properties → Material Models → Structural → Linear → Elastic → 
Isotropic → Ex = 2.5e7 → PRXY = 0.28 → Ok  
• Modeling → Create → Key points → Inactive CS → (0,0,0) ;(100,0,0) ;(150,0,0) 
→ Ok → Lines → Straight Lines → Ok  
• Meshing → Size Controls → Manual Sizing → Lines → Picked Lines → No. of 
elements = 20 → Ok → Mesh → Lines → Ok  

2. Solution:  

• Analysis Type → New analysis → Static → Ok  
• Define Loads → Apply → Structural → Displacement → On Key Points → Ok → All 
DOF Constrained → Ok → Force/Moments → On Key Points → Torsion= 500 → Ok  
• Solve → Current LS → Ok   

3. General Post Proc:  

• Plot results → Deformed Shapes → Deformed + Un deformed  

• Contour Plots → Nodal Solutions → DOF Solution → Y- Component Displacement 
Ok 

Try  

1. Repeat the above analysis for square cross section beams with other torsion values.  

2. Repeat the above analysis for cylindrical cross section beams with other torsion values. 
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