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I. COURSE OVERVIEW: 

Computational aerodynamics laboratory focus on the creation of geometry, meshing (Discretization) and the 

physics applied to aerodynamics in order to visualize fluid flow and temperature distribution, and estimating the 

flow parameters around the aerodynamic body. It also covers the usage of finite difference methods and 

necessary coding techniques. In this lab course, the students are trained on conducting simulations using the 

numerical methods analysis tool of CAD systems. The simulations include fluid, structural, thermal systems in 

the emerging technologies of interdisciplinary applications such as mechanical, aerospace, and refrigeration 

systems. 

 

II. COURSES OBJECTIVES: 

The students will try to learn: 

I. The concepts of grid generation techniques for simple and complex domains to model. 

II. The aspects of numerical discretization techniques such as finite volume and finite difference methods. 

III. The mathematical modelling of different classes of partial differential equations to show their impact on 

computational fluid dynamics. 

IV. The characteristics of different turbulence models and numerical schemes for estimating the criteria of 

stability, convergence, and error of fluid flow problem. 

 

III. COURSE OUTCOMES: 

After successful completion of the course, students should be able to: 
 

CO1 Choose the finite difference method at grid points of the domain for understanding discretization 

technique in solving fluid flow problem. 

CO2 Classify the nature of fluid flow problems for solving the governing equations using computational               

methods. 

CO3 Make use of the computational methods and algorithms for obtaining solutions of fluid flow problems             

using Ansys 

CO4 Modify the parameters of thermo-fluid systems using simulation methods for validating numerical and             

experimental results. 

CO5 Calculate the aerodynamic forces on the slender and bluff bodies for calculating the lift and drag             

coefficients. 

CO6 Interpret the numerical solution of fluid flow problems using discretization methods and convergence 

criteria for better results and minimize the errors. 



EXERCISES FOR COMPUTATIONAL AERODYNAMICS  

LABORATORY 

 
Note: Students are encouraged to bring their own laptops for 

laboratory practice sessions. 
 

1.  Getting Started with Ansys Student Version 

1.1 Ansys Student Version Installation procedure 

System requirement 

Supported Platforms and Operating Systems: 

Microsoft Windows 10, 64-bit 

 

Minimum Hardware Requirements for Ansys Student Product: 

Processor(s): Workstation class 

4 GB RAM 

25 GB hard drive space 

Computer must have a physical C:/” drive present 

Graphics card and driver: Professional workstation class 3-D 

OpenGL-capable 

 

Installation Procedure 

1. Extract (unzip) the downloaded installation files. 

2. Right-click on setup.exe and select Run as Administrator. (This will run setup.exe from the 

extracted files.) 

3. Read and accept the clickwrap to continue. 

4. Click the right arrow button to accept the default values throughout the installation. 

5. Click the exit button to close the installer. 

6. The Ansys Student software is now installed. 

7. Reboot your machine and then run the Ansys Student product from your Start menu by 

selecting Workbench. 

 

Problem size limits 

• No Geometry Export 

Limits for Ansys Student and Discovery (Refine Mode) 

• Structural Physics: 128K nodes/elements 

• Fluid physics: 1 Million cells/nodes 

 



1.2 Getting Started with Ansys CFX/ICEM CFD  

Open Ansys ICEM CFD: Windows Start Menu button → Ansys → ICEM CFD  

 

Ansys ICEM CFD provides a direct link between geometry and analysis. In Ansys ICEM CFD, you can 

input geometry in almost any format, whether a commercial CAD design package, third-party 

universal database, scan data, or point data available. The overall process has shown in Fig 1.1. 

 

The general meshing workflow is:  

1. Create a working directory.  

2. Create a new project (or open an existing project).  

3. Create or import the geometry.  

4. If necessary, repair the geometry before meshing.  

5. If necessary, block the geometry. 

6. Compute the mesh 

7. Check the mesh for errors and edit as required.  

8. Describe the physics.  

9. Generate the input for the solver 

 

The ICEM CFD graphical user interface was shown in Fig 1.1. 

 

Fig 1.1: ICEM CFD GUI 

 

Geometry Preparation 

Geometry → Creating or Importing the Geometry→ Open 

Describing the Physics 

 

 



Parts 

All geometry entities—including surfaces, curves and points—are tagged or associated into a 

grouping called a part.  

Blocking the Geometry 

 The blocking step is used when a structured, hexa-mesh is desired in one or more parts 

Computing the Mesh 

 To proceed from geometry and parts to a completed mesh requires two steps:  

1. Set up Mesh Parameters-You should specify mesh size, type, and method along with several 

type- and method-specific controls.  

2. Compute the Mesh 

Checking/Editing the Mesh 

The mesh editing tools in Ansys ICEM CFD enable you to diagnose and fix problems in the mesh.  

 

2. Getting Started with FLUENT 

Ansys Fluent to set up and solve the CFD problem, then visualize the results in both Ansys 

Fluent and in the CFD-Post postprocessing tool. The FLUENT GUI is arranged such that the 

tasks are generally arranged from top to bottom in the project setup tree. Selecting an 

item in the tree opens the relevant input items in the center pane.  

2.1 Fluent GUI 

Set up the CFD simulation in Ansys Fluent, which includes: 

-Governing equations 

-Turbulence models 

– Setting material properties and boundary conditions for a turbulent forced -convection   

   problem.  

– Initiating the calculation with residual plotting.  

– Calculating a solution using the pressure-based solver. 

– Examining the flow and temperature fields using Ansys Fluent and CFD-Post. 
 

The fluent graphical user interface was shown in Fig 2.1. 

.  

Fig. 2.1: Fluent GUI 



2.2 Material selection 

Material properties need to be defined for all fluids and solids to be simulated . 
The parameters asked for will depend on the models selected for the simulation .  
Many common materials are already defined in the ‘FLUENT Database’ and can easily be 

copied over to the model are shown in Fig 2.2. 

 

 

Fig. 2.2: Material properties 

3.  Exercises on FLOW OVER A FLAT PLATE  

3.1 Flow over a flat plate – Laminar flow  

Simulate the two-dimensional laminar flow on a horizontal flat plate. The size of the plate 

is considered being infinite in the spanwise direction and therefore the flow is 2D instead 

of 3D. The inlet velocity for the 1 m long plate is 5 m/s and we will be using air as the fluid 

for laminar simulations. Determine the velocity profiles and plot the profiles for flow over 

shown in Fig 3.1. 

 

 

Fig. 3.1: LAMINAR FLOW OVER FLAT PLATE 



Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

 

3.2 Flow over a flat plate – Turbulent flow   

Simulate the two-dimensional turbulent flow on a horizontal flat plate. The size of the plate 

is considered being infinite in the spanwise direction and therefore the flow is 2D instead 

of 3D. The inlet velocity for the 1 m long plate is 100 m/s and we will be using air as the 

fluid for laminar simulations. Determine the velocity profiles and plot the profiles.  

 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 



• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

 

3.3 Flow over a flat plate – Mach number   

Model two-dimensional laminar flow on a horizontal flat plate. The size of the plate is  

considered being infinite in the spanwise direction and therefore the flow is 2D instead of 

3D. The inlet Mach number for the 1 m long plate is 0.5 and we will be using air as the 

fluid for laminar simulations. Determine the velocity profiles and plot the profiles.  

 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 



• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

 

Try 

1. Model and analyze the flow over the flat plate with vortex generator of triangular shape as per 

the dimensions and plot the variation at pressure over the flat plate and XY plot using the 

available tools at a velocity of 0.5 m/s by considering the flow to be viscous. Use the flow 

parameters as Length =10 M and Breadth =5M. 

2. Model and analyze the flow over the flat plate as per the dimensions and plot the variation at 

pressure over the flat plate and XY plot using the available tools at a velocity of 1 m/s by 

considering the flow to be viscous. Use the flow parameters as Length =5 M and Breadth =3M. 

 

4.  Exercises on flow through pipe 

4.1 Flow through pipe - Laminar 

Study characteristics of laminar flow through a pipe. Consider a pipe of breadth 0.05 and 1 m length 

as shown in Fig. 4.1.  The freestream velocity considered is 0.5 m/s. Determine the flow development 

inside the pipe at laminar and turbulent zone. 

 

 
Fig. 4.1: Flow through pipe  

 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 



• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Models > laminar 
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 
 

 

4.2 Flow through pipe -Turbulent 

Study characteristics of turbulent flow through a rectangular pipe. Consider a pipe of breadth 0.05m, 

h=0.1 and 1 m length. The freestream velocity considered is 50 m/s. Determine the flow development 

inside the pipe at laminar and turbulent zone. 

 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  



• Main Menu > Define > Models > Viscous 
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

Try 

1. Change the velocity, dimensions of the pipe and plot the velocity and pressure contours. 

2. Modify the Reynolds number, dimensions of the pipe and plot the velocity magnitude and 

pressure contours. 

 

5.  Exercises on flow over a circular cylinder 

5.1 Flow over a circular cylinder – Laminar 

Model and analyze the flow over the cylinder as per the dimensions shown in Fig 5.1 and plot the 

variation at pressure over the cylinder and evaluate the CL and CD values using the available tools at a 

velocity of 0 .5 m/s by considering the flow to be viscous. Diameter of the cylinder is 0.5 m. 

 

 
Fig. 5.1: Flow over the cylinder  

 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 



• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Models > Viscous 
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

 

5.2 Flow over a circular cylinder – Turbulent 

Model and analyze the flow over the cylinder as per the dimensions shown in Fig 5.2 and plot the 

variation of pressure distribution over the cylinder and evaluate the CL and CD values using the 

available tools at a velocity of 50 m/s by considering the flow to be viscous. Diameter of the cylinder = 

2m. 

 
Fig. 5.2: Flow over the cylinder  

 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 



• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh.. 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

Try 

1. Change the diameter, location of circle and plot the variation of pressure over the cylinder. 

2. Change the velocity and dimensions plot the velocity and pressure contours. 

 

6. Exercises on flow over a cambered aerofoil 

6.1 Flow over a cambered aerofoil - NACA 2412 

Consider air flowing over NACA 2412 airfoil as shown in Fig 6.1 at the free stream Mach number is 1.2. 

Assume standard sea-level values for the free stream properties: 

 Pressure = 101,325 Pa 

 Density = 1.2250 kg/m3 

 Temperature = 288.16 K 

 Kinematic viscosity v = 1.4607e-5 m2/s 

 

 

Fig. 6.1: Flow over a airfoil – NACA2412 



Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh.. 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

Try 

1. Consider the different Reynolds number and evaluate the CL and Cd and Cp distribution. 

2. Consider the different angle of attack and evaluate the CL and Cd and Cp distribution. 

 

7.  Exercises on flow over a symmetric aerofoil  

7.1. Flow over a symmetric aerofoil - NACA 0012 

Consider air flowing over NACA 0012 airfoil as shown in Fig 7.1 at the free stream Mach number is 1.2. 

Assume standard sea-level values for the free stream properties: 

 Pressure = 101,325 Pa 

 Density = 1.2250 kg/m3 

 Temperature = 288.16 K 

 Kinematic viscosity v = 1.4607e-5 m2/s 

 



 
Fig. 6.2: Flow over a airfoil – NACA0012 

 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

Try  

1. Consider the different Reynolds number and evaluate the CL and Cd and Cp distribution. 

2. Consider the different angle of attack and evaluate the CL and Cd and Cp distribution. 

 



8.  Exercises on flow over wedge 

8.1 Flow over wedge - zero angle of attack 

Consider a 15° angle wedge at zero angle of attack shown in Fig 8.1. The incoming flow conditions 

are: Mach no= 3, p1=1 atm, T1=273 K. Use FLUENT to obtain the flow field over the wedge. Evaluate 

the results of pressure, boundary layer profile variation by contours and plots. 

 

 

Fig. 8.1: Flow over a wedge - Mach number 3 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 
 

 

 



8.2 Flow over wedge – Mach number 

Consider a 15° angle wedge at zero angle of attack shown in Fig.8.2. The incoming flow conditions 

are: Mach no= 4, p1=1 atm, T1=273 K. Use FLUENT to obtain the flow field over the wedge. Evaluate 

the results of pressure, boundary layer profile variation by contours and plots. 

 

 

Fig. 8.2: Flow over a wedge – Mach number 4 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Models > Viscous 
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 
 

 



Try  

1. Consider different angle wedge at zero angle of attack. Evaluate the results of pressure, boundary 

layer profile variation by contours and plots. 

2. Consider different flow over a wedge at zero angle of attack. Evaluate the results of pressure, 

boundary layer profile variation by contours and plots. 

 

9.  Exercises on flow over a cone 

9.1 Flow over a cone  

Study supersonic flow past a 3D Cone at an angle of attack as shown in Fig 9.1. Analyze the simulation 

and understand the physics of supersonic flows over cone. 

 

 
Fig 9.1. 3D Cone at an angle of attack  

 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Models > Viscous 
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 



• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

 

9.2 Flow over a wedge and cone – results comparison  

Study supersonic flow past a 3D Cone and wedge at an angle of attack. Analyze the simulation and 

understand the physics of supersonic flows over cones and wedge for different contours in Fig 9.2. 

 
Fig 9.2. Results comparison between wedge and cone   

 

Hints 

1. Results and discussion  

• General Post Processing:   
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

Try  

1. Repeat the above analysis at different angle of attack and visualize the shock. 

2. Change the Mach number and observes the shock waves and 3D relieving effect. 

 

10.  Exercises on flow analysis of aircraft structure: Wing 

10.1 Flow analysis of aircraft structure: Wing (Onera M6 wing)  

Flow over the Onera M6 wing is transonic and compressible as shown in Fig 10.1. The wing flow 

experiences supersonic conditions, a shock, and boundary layer separation. There is no wing twist, 

with all chords being on the same plane. Therefore, the angle of attack is simply the angle between 

the free stream and the chord line. There is no side-slip in the simulation. The flow conditions are 

given below  

 

 



The half span dimension is 1 ft and from there we were able to calculate a scaling factor for the entire 

wing. More about the geometry creation can be found on the exercises page. The table below 

describes some key geometries, the leading and trailing edge angles are measured from the vertical. 

 

 
 

 
10.1 Onera M6 wing  

 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Models > Viscous 
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 



• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

 

10.2 Flow analysis (Rectangular Wing)  

Perform flow analysis of an aircraft rectangular wing of a span 100cm and the chord length of wing is 

10 cm and cross-sectional area is 100 cm2 as shown in Fig 10.2. Evaluate the CL and CD values using the 

available tools at a velocity of 5 m/s by considering the flow to be viscous. 

 
10.2 Rectangular wing 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Models > Viscous 
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 



• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

 

Try  

1. Calculate lift and drag coefficient of an elliptical wing. 

2. Calculate lift and drag coefficient of tapered wing with different Mach number and angle of 

attack.  
 

11.  Exercises on Compressible flow in a nozzle 

11.1 Compressible flow in a nozzle – Correctly expanded case 

Consider air flowing at high-speed through a convergent-divergent nozzle in Fig 11.1 having a circular 

cross-sectional area, A, that varies with axial distance from the throat, x, according to the formula 

A = 0.1 + x2; -0.5 < x < 0.5 

where A is in square meters and x is in meters. The stagnation pressure po at the inlet is 101,325 Pa. 

The stagnation temperature To at the inlet is 300 K. The static pressure p at the exit is 3,738.9 Pa. 

Calculate the Mach number, pressure and temperature distribution in the nozzle using Ansys Fluent.  

 

 
11.1 convergent-divergent nozzle 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 



• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

 

11.2 Compressible flow in a nozzle – under expanded case 

Consider air flowing at high-speed through a convergent-divergent nozzle in Fig 11.2 having a circular 

cross-sectional area, A, that varies with axial distance from the throat, x, according to the formula 

 

A = 0.1 + x2; -0.5 < x < 0.5 

 

where A is in square meters and x is in meters. The stagnation pressure po at the inlet is 101,325 Pa. 

The stagnation temperature To at the inlet is 400 K. The static pressure p at the exit is 3,738.9 Pa. 

Calculate the Mach number, pressure and temperature distribution in the nozzle using Ansys Fluent 

and compare the solution to quasi-1D nozzle flow results.  

 

11.2 convergent-divergent nozzle 

Hints 

1. Pre-processor  

• Create new project file - File → New Project → Select folders in turn → 
Save project with name 
• Geometry → Create Point → specify values → Apply.  
• Geometry → Create and modify curve → Select points → OK.  
• Geometry → Right click “Parts” → Part = “Specify name” → OK. 
• Blocking → OK. 
• Mesh → Select geometry → Global Mesh Size → Compute Mesh icon→ OK. 
• Output → Output Solver: Fluent V6 → apply 
• Write Input → Save project → save as filename “.msh” → Done 
• Main Menu → File → Export → Mesh... 

2. Solution  

• Start → Programs → Fluent Inc → FLUENT 6.0 →  
• Main Menu > File > Read > Case... 
• Main Menu > Display > Grid... 
• Main Menu > Define > Models > Solver  
• Main Menu > Define > Models > Viscous 



• Main Menu > Define > Materials... Click Change/Create. 
• Main Menu > Define > Operating Conditions... Operating Pressure. 
• Main Menu > Define > Boundary Conditions... 
• Main Menu > Solve > Controls > Solution...  
• Main Menu > Solve > Initialize > Initialize... Set Initial Guess 
• Main Menu > Solve > Monitors > Residual... Set Convergence Criteria 
• Main Menu > File > Write > Case... 
• Main Menu > Solve > Iterate... Iterate Until Convergence 
• Main Menu > File > Write > Data... 

3. General Post Processing:   

• General Post Processing  
• Main Menu > Report > Reference Values... 
• Main Menu > Plot > XY Plot... Save Plot 
• Main Menu > Plot > contours... Save Plot 

 

Try  

1. Change the inlet Mach number to supersonic and analysis its behavior as diffuser. 

2. Change the dimensions and repeat the above analysis for a diffuser. 

 

12. Exercises on one dimensional wave equation using 

explicit method of lax 

12.1 One dimensional wave equation using explicit method of lax  Method 

Write a program to solve one dimensional wave equation using explicit method of lax method -

MATLAB.  

Hints 

1. Lax Method 

• N=40; % No. of grid points 
• Tmax=1; % time period 
• alpha=1;  %given 
• h=1; %given value of delX 

2. Solution  

delt=1; 
maxt=Tmax/delt; %Number of time steps 
c=alpha*delt/h;  
u=zeros(N+1,maxt+1); 
x=zeros(N+1,1); 
% Initial condition 
for i=1:N+1 
  x(i)=(i-1)*h; 
  u(i,1)=sin((2*pi*x(i)/40)); 
end 
for k=1:maxt 
  u0 = u(N,k); 
  u(1,k+1)=(1-c)/2*(u(2,k)-u0)+(1+c)/2*(u(2,k)); 
  for i=2:N 
    u(i,k+1) =(1-c)/2*(u(i+1,k)+(1+c))/2*(u(i+1,k)); 
  end 
  uNp2 = u(2,k); 



  u(N+1,k+1) =(1-c)/2*(uNp2-u(N,k))+(1+c)/2*(uNp2-2*u(N+1,k));   
end 
plot(x,u) 

 

12.2 One dimensional heat conduction equation using explicit method. 

Write a program to solve one dimensional heat conduction equation using explicit method – MATLAB.  

 

Hints 

1.  Lax Method 

% Parameters 
L = 1;          % Length of the rod 
T = 1;          % Total simulation time 
alpha = 0.01;   % Thermal diffusivity 
Nx = 50;        % Number of spatial grid points 
Nt = 1000;      % Number of time steps 
 
% Discretization 
dx = L / (Nx - 1); 
dt = T / Nt; 
% Initial conditions 
u = zeros(Nx, 1); 
x = linspace(0, L, Nx)'; 
u(:, 1) = sin(pi * x / L);  % Example: Initial temperature distribution 
 

2. Solution  

% Explicit method time-stepping loop 
for n = 1:Nt 
for i = 2:Nx-1 
u(i, n+1) = u(i, n) + alpha * dt / dx^2 * (u(i+1, n) - 2*u(i, n) + u(i-1, 
n)); 
    end 
end 
 
% Plot the results 
figure; 
surf(linspace(0, T, Nt), x, u', 'EdgeColor', 'none'); 
title('One-dimensional Heat Conduction'); 
xlabel('Time'); 
ylabel('Position'); 
zlabel('Temperature'); 

 

Try  

1. Solve for one-dimensional heat conduction equation using explicit method with fixed boundary 

conditions. 

2. Solve for one-dimensional heat conduction equation using implicit method with fixed boundary 

conditions. 

 



13.  Exercises on generating algebraic grids using MATLAB for 

CFD applications: 

13.1 Generating algebraic grids using MATLAB for CFD applications:  

Write a program to generating algebraic grids using MATLAB for Computational fluid dynamics 

applications. 

 

Hints 

% Parameters 
Lx = 1;         % Length of the grid in x-direction 
Ly = 1;         % Length of the grid in y-direction 
Nx = 50;        % Number of grid points in x-direction 
Ny = 50;        % Number of grid points in y-direction 
 
% Generate Cartesian grid 
x_cartesian = linspace(0, Lx, Nx); 
y_cartesian = linspace(0, Ly, Ny); 
[x, y] = meshgrid(x_cartesian, y_cartesian); 
 
% Plot 
figure; 
plot(x(:), y(:), 'o', 'LineWidth', 2); 
title('Regular Cartesian Grid'); 
xlabel('X'); 
ylabel('Y'); 
axis equal; 
grid on; 

 

13.2 Generating Elliptic grids using MATLAB for CFD applications:  

Write a program to generating elliptic grids using MATLAB for Computational fluid dynamics 

applications. 

 

Hints 

% Parameters 
Lx = 1;         % Length of the grid in x-direction 
Ly = 1;         % Length of the grid in y-direction 
Nx = 50;        % Number of grid points in x-direction 
Ny = 50;        % Number of grid points in y-direction 
 
% Generate elliptic grid 
x_elliptic = linspace(0, Lx, Nx); 
y_elliptic = linspace(0, Ly, Ny); 
 
% Create meshgrid and transform to elliptic coordinates 
[x, y] = meshgrid(x_elliptic, y_elliptic); 
alpha = 1;  % Ellipticity factor 
theta = linspace(0, 2*pi, Ny); 
x_elliptic = x .* cos(alpha * theta); 
y_elliptic = y .* sin(alpha * theta); 
 
% Plot 
figure; 
plot(x_elliptic(:), y_elliptic(:), 'o', 'LineWidth', 2); 



title('Elliptic Grid'); 
xlabel('X'); 
ylabel('Y'); 
axis equal; 
grid on; 

 

Try  

1. Write a program to generating algebraic grids – Stretched grid using MATLAB for Computational 

fluid dynamics applications. 

2. Write a program to generating elliptic grids – stretch grid using MATLAB for Computational fluid 

dynamics applications. 

 

14.  Exercises on linear convection equation (wave equation) 

by Lax Wendroff Scheme for CFD applications: 

14.1 linear convection equation (wave equation) by Lax Wendroff 

Scheme:  

Write a program to solve linear convection equation (wave equation) by Lax Wendroff Scheme using 

MATLAB for Computational fluid dynamics applications 

 

Hints 

% Parameters 
L = 1;          % Length of the domain 
T = 1;          % Total simulation time 
Nx = 100;       % Number of spatial grid points 
Nt = 200;       % Number of time steps 
c = 1;          % Wave speed 
 
% Discretization 
dx = L / Nx;    % Spatial step 
dt = T / Nt;    % Time step 
x = linspace(0, L, Nx+1);   % Spatial grid 
t = linspace(0, T, Nt+1);   % Time grid 
 
% Initial condition 
u0 = sin(2*pi*x); 
 
% Lax-Wendroff scheme 
u = zeros(Nx+1, Nt+1); 
u(:,1) = u0; 
 
for n = 1:Nt 
    % Lax-Wendroff update 
    u(2:end-1, n+1) = u(2:end-1, n) - 0.5*c*dt/dx*(u(3:end, n) - u(1:end-2, 
n)) + ... 
   0.5*(c*dt/dx)^2 * (u(3:end, n) - 2*u(2:end-1, n) + u(1:end-2, n)); 
     
    % Periodic boundary conditions 
    u(1, n+1) = u(end-1, n+1); 
    u(end, n+1) = u(2, n+1); 
end 
 
% Plotting 
figure; 



surf(x, t, u'); 
xlabel('Spatial Domain (x)'); 
ylabel('Time (t)'); 
zlabel('u(x, t)'); 
title('Lax-Wendroff Scheme for Linear Convection Equation'); 

 

14.2 Upwind scheme for solving the linear convection equation:  

Write a program to solve linear convection equation (wave equation) by Upwind scheme Scheme 

using MATLAB for Computational fluid dynamics applications. 

 

Hints 

% Parameters 
L = 1;          % Length of the domain 
T = 1;          % Total simulation time 
Nx = 100;       % Number of spatial grid points 
Nt = 200;       % Number of time steps 
c = 1;          % Wave speed 
 
% Discretization 
dx = L / Nx;    % Spatial step 
dt = T / Nt;    % Time step 
x = linspace(0, L, Nx+1);   % Spatial grid 
t = linspace(0, T, Nt+1);   % Time grid 
 
% Initial condition 
u0 = sin(2*pi*x); 
 
% Upwind scheme 
u = zeros(Nx+1, Nt+1); 
u(:,1) = u0; 
 
for n = 1:Nt 
    % Upwind update 
    u(2:end, n+1) = u(2:end, n) - c*dt/dx*(u(2:end, n) - u(1:end-1, n)); 
     
    % Periodic boundary conditions 
    u(1, n+1) = u(end, n+1); 
end 
 
% Plotting 
figure; 
surf(x, t, u'); 
xlabel('Spatial Domain (x)'); 
ylabel('Time (t)'); 
zlabel('u(x, t)'); 
title('Upwind Scheme for Linear Convection Equation'); 

 

Try  

1. Write a program to solve Crank Nicholson technique using MATLAB for Computational fluid 

dynamics applications. 

2. Write a program to solve Relaxation technique using MATLAB for Computational fluid dynamics 

applications. 

 



15.  Exercises on 1D advection equation using the forward-

time finite difference method for CFD applications: 

15.1 1D advection equation using the forward-time finite difference 

method:  

Write a program to solve the 1D advection equation using the forward-time finite difference method 

for Computational fluid dynamics applications. 

 

Hints 

% Parameters 
L = 1;          % Length of the domain 
T = 0.2;        % Total simulation time 
Nx = 50;        % Number of spatial grid points 
Nt = 100;       % Number of time steps 
c = 1;          % Advection velocity 
 
% Discretization 
dx = L / Nx;    % Spatial step 
dt = T / Nt;    % Time step 
x = linspace(0, L, Nx+1);   % Spatial grid 
t = linspace(0, T, Nt+1);   % Time grid 
 
% Initial condition 
u0 = sin(2*pi*x); 
 
% Forward-time finite difference method for advection 
u = zeros(Nx+1, Nt+1); 
u(:,1) = u0; 
 
for n = 1:Nt 
    for i = 2:Nx 
        u(i, n+1) = u(i, n) - c * dt / dx * (u(i, n) - u(i-1, n)); 
    end 
     
    % Periodic boundary conditions 
    u(1, n+1) = u(end-1, n+1); 
end 
 
% Plotting 
figure; 
surf(x, t, u'); 
xlabel('Spatial Domain (x)'); 
ylabel('Time (t)'); 
zlabel('u(x, t)'); 
title('Advection using Forward-Time Finite Difference Method');  

 

15.2 1D advection equation using the backward-time finite difference 

method:  

Write a program to solve the 1D advection equation using the backward -time finite difference 

method for Computational fluid dynamics applications 

 



 

Hints 

%% Parameters 
L = 1;          % Length of the domain 
T = 0.2;        % Total simulation time 
Nx = 50;        % Number of spatial grid points 
Nt = 100;       % Number of time steps 
c = 1;          % Advection velocity 
 
% Discretization 
dx = L / Nx;    % Spatial step 
dt = T / Nt;    % Time step 
x = linspace(0, L, Nx+1);   % Spatial grid 
t = linspace(0, T, Nt+1);   % Time grid 
 
% Initial condition 
u0 = sin(2*pi*x); 
 
% Backward-time finite difference method for advection 
u = zeros(Nx+1, Nt+1); 
u(:,1) = u0; 
 
% Coefficient matrix for backward-time scheme 
A = spdiags(ones(Nx-1,1)*[-c*dt/dx, 1 + c*dt/dx], [-1, 0], Nx-1, Nx-1); 
 
for n = 1:Nt 
    % Update using implicit backward-time scheme 
    u(2:end, n+1) = A \ u(2:end, n); 
     
    % Periodic boundary conditions 
    u(1, n+1) = u(end-1, n+1); 
end 
 
% Plotting 
figure; 
surf(x, t, u'); 
xlabel('Spatial Domain (x)'); 
ylabel('Time (t)'); 
zlabel('u(x, t)'); 
title('Advection using Backward-Time Finite Difference Method'); 

 

Try  

1. Write a program to solve the 1D advection equation using the central finite difference method for 

Computational fluid dynamics applications.  

2. Write a program to solve the 1D advection equation using forward finite difference method for 

Computational fluid dynamics applications.  
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