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COMPUTATIONAL AERODYNAMICS LABORATORY 

OBJECTIVE: 
The objective of this lab complements the computational Aerodynamics course. Students will gain experience in 

computing aerodynamic problems and understanding flow physics over flat plate, pipe, cylinder, over a wedge and 
flow over an airfoil. They can gain knowledge in estimating flow analysis for different mach numbers in determining 

the pressure coefficients over different structural objects and can find lift and drag counters. 

OUTCOMES: 

After completing this course the student must demonstrate the knowledge and ability to: 

 

1. Understand the behavior of flows around different structured objects.  

2. Implement the computational fluid dynamic and computational aerodynamic fundamentals by using advanced solvers.  

3. Explain the usage of modern tools like ICEM-CFD& FLUENT. 

4. Understand the flow properties of flat plate to demonstrate Reynolds number. 

5. Understand the Aerodynamic properties for flow through circular pipe.  

6. Understand the Aerodynamic properties foe flow through cylinder.  

7. Observe the properties at separation region and wake region of circular cylinder at different Reynolds numbers  

8. Understand the aerodynamic properties of supersonic flow over a wedge. 

9. Understand the aerodynamic properties of flow over an airfoil.  

10. Differentiate the flow properties around symmetrical and cambered airfoil. 

11. Analyze the errors and cause of errors in the computational analysis.  

12. Analyze the coefficient of pressure, lift, drag and moment for different bodies for different flow conditions.  

13. Determine the shock wave around cone and wedges for supersonic flow conditions. 

14. Observe flow properties and compare the computation results with experimental results. 

15. Observe the shock waves and 3D relieving effect around the cone at supersonic Mach number. 

16. Solve the One dimensional wave equation using explicit method of lax equations using finite difference method  

17. Solve the One dimensional heat conduction equation using explicit method  

18. Generate the Algebraic and Elliptic grids for computational domains.
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INSTITUTE OF AERONAUTICAL ENGINEERING 
Dundigal, Hyderabad - 500 043 

PROGRAM OUTCOMES 
 

 

 
PO1 

 

Engineering knowledge: Apply the knowledge of mathematics, science, engineering fundamentals, and an 

engineering specialization to the solution of complex engineering problems. 

 
PO2 

Problem analysis: Identify, formulate, review research literature, and analyze complex engineering 

problems reaching substantiated conclusions using first principles of mathematics, natural sciences, and 

engineering sciences. 

 
PO3 

Design/development of solutions: Design solutions for complex engineering problems and design system 

components or processes that meet the specified needs with appropriate consideration for the public health 

and safety, and the cultural, societal, and environmental considerations. 

 
PO4 

Conduct investigations of complex problems: Use research-based knowledge and research methods, 

including design of experiments, analysis and interpretation of data, and synthesis of the information to 

provide valid conclusions. 

PO5 
Modern tool usage: Create, select, and apply appropriate techniques, resources, and modern 
engineering and IT tools including prediction and modeling to complex engineering activities with an 

understanding of the limitations. 
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PROGRAM SPECIFIC OUTCOMES 
 

 

 
AERONAUTICAL ENGINEERING 

 
PSO1 

Professional skills: Able to utilize the knowledge of aeronautical/aerospace engineering in innovative, 

dynamic and challenging environment for design and development of new products. 

 
PSO2 

Problem solving skills: imparted through an understanding of experimental facilities and techniques, to 

solve practical, design and analysis problems of components to complete the challenge of airworthiness for 

flightvehicles. 

 
PSO3 

Practical implementation and testing skills: Providing different types of in house and training and industry 
practice to fabricate and test and develop the products with more innovative technologies. 

 

PSO4 
Successful career and entrepreneurship: To prepare the students with broad aerospace knowledge to 
design and develop systems and subsystems of aerospace and allied systems and becometechnocrats. 
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ATTAINMENT OF PROGRAM OUTCOMES & PROGRAM SPECIFIC 

OUTCOMES 
 
 

Expt. 

No. 

 

Program 

Outcomes 

Attained 

Program Specific Outcomes 

Attained 

1 PO1, PO2, PO3 PSO1, PSO2, PSO3 

2 PO1, PO2, PO3 PSO1, PSO2, PSO3 

3 PO1, PO2 PSO1, PSO2, PSO3 

4 PO1, PO2, PO4 PSO1, PSO2, PSO3 

5 PO1, PO2, PO3 PSO1, PSO2, PSO3 

6 PO1, PO3, PO4, PSO1, PSO2, PSO3 

7 PO1, PO2 PSO1, PSO2, PSO3 

8 PO1, PO2 PSO1, PSO2, PSO3 

9 PO1, PO2, PO3 PSO1, PSO2, PSO3 

10 PO1, PO3, PO2 PSO1, PSO2, PSO3 

11 PO1, PO3, PO4 PSO1, PSO2, PSO3 

12 PO1, PO3, PO2 PSO1, PSO2, PSO3 
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EXPERIMENT - 1 

INTRODUCTION 

Computational fluid dynamics (CFD) is a branch of fluid mechanics that uses numerical 
analysis and data structures to analyze and solve problems that involve fluid flows. Computers are used to 

perform the calculations required to simulate the free-stream flow of the fluid, and the interaction of the 

fluid (liquids and gases) with surfaces defined by boundary conditions. With high-speed supercomputers, 
better solutions can be achieved, and are often required to solve the largest and most complex problems. 

Ongoing research yields software that improves the accuracy and speed of complex simulation scenarios 

such as transonic or turbulent flows. Initial validation of such software is typically performed using 

experimental apparatus such as wind tunnels. In addition, previously 
performed analytical or empirical analysis of a particular problem can be used for comparison. A final 

validation is often performed using full-scale testing, such as flight tests. 

CFD is applied to a wide range of research and engineering problems in many fields of study and 
industries, including aerodynamics and aerospace analysis, weather simulation, natural science 

and environmental engineering, industrial system design and analysis, biological engineering and fluid 

flows, and engine and combustion analysis. 
  
Methodology 
In all of these approaches the same basic procedure is followed. 

• During preprocessing 
• The geometry and physical bounds of the problem can be defined using computer aided 

design (CAD). From there, data can be suitably processed (cleaned-up) and the fluid 
volume (or fluid domain) is extracted. 

• The volume occupied by the fluid is divided into discrete cells (the mesh). The mesh may 
be uniform or non-uniform, structured or unstructured, consisting of a combination of 
hexahedral, tetrahedral, prismatic, pyramidal or polyhedral elements. 

• The physical modeling is defined – for example, the equations of fluid motion 
+ enthalpy + radiation + species conservation 

• Boundary conditions are defined. This involves specifying the fluid behaviour and 
properties at all bounding surfaces of the fluid domain. For transient problems, the initial 
conditions are also defined. 

• The simulation is started and the equations are solved iteratively as a steady-state or transient. 
• Finally a postprocessor is used for the analysis and visualization of the resulting solution. 

 
 
Concept of Computational Fluid Dynamics 
 
Computational Fluid Dynamics (CFD) is the simulation of fluids engineering systems using 
modeling (mathematical physical problem formulation) and numerical methods (discretization methods, 
solvers, numerical parameters, and grid generations, etc.).  
 
Process of Computational Fluid Dynamics 
 
Firstly, we have a fluid problem. To solve this problem, we should know the physical properties of fluid 
by using Fluid Mechanics. Then we can use mathematical equations to describe these physical properties. 
This is Navier-Stokes Equation and it is the governing equation of CFD. As the Navier-Stokes Equation is 
analytical, human can understand it and solve them on a piece of paper. But if we want to solve this 
equation by computer, we have to translate it to the discretized form. The translators are numerical 

https://en.wikipedia.org/wiki/Fluid_mechanics
https://en.wikipedia.org/wiki/Numerical_analysis
https://en.wikipedia.org/wiki/Numerical_analysis
https://en.wikipedia.org/wiki/Data_structure
https://en.wikipedia.org/wiki/Fluid_dynamics
https://en.wikipedia.org/wiki/Liquid
https://en.wikipedia.org/wiki/Gas
https://en.wikipedia.org/wiki/Boundary_value_problem#Boundary_value_conditions
https://en.wikipedia.org/wiki/Supercomputer
https://en.wikipedia.org/wiki/Transonic
https://en.wikipedia.org/wiki/Turbulence
https://en.wikipedia.org/wiki/Wind_tunnel
https://en.wikipedia.org/wiki/Closed-form_solution
https://en.wikipedia.org/wiki/Empirical_research
https://en.wikipedia.org/wiki/Flight_test
https://en.wikipedia.org/wiki/Aerodynamics
https://en.wikipedia.org/wiki/Numerical_weather_prediction
https://en.wikipedia.org/wiki/Environmental_engineering
https://en.wikipedia.org/wiki/Biological_engineering
https://en.wikipedia.org/wiki/Engine
https://en.wikipedia.org/wiki/Combustion
https://en.wikipedia.org/wiki/Preprocessor_(CAE)
https://en.wikipedia.org/wiki/Geometry
https://en.wikipedia.org/wiki/Computer-aided_design
https://en.wikipedia.org/wiki/Computer-aided_design
https://en.wikipedia.org/wiki/Volume
https://en.wikipedia.org/wiki/Enthalpy
https://en.wikipedia.org/wiki/Computer_simulation
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discretization methods, such as Finite Difference, Finite Element, Finite Volume methods. Consequently, 
we also need to divide our whole problem domain into many small parts because our discretization is 
based on them. Then, we can write programs to solve them.  
 
The typical languages are Fortran and C. Normally the programs are run on workstations or  
supercomputers. At the end, we can get our simulation results. We can compare and analyze the 
simulation results with experiments and the real problem. If the results are not sufficient to solve the 
problem, we have to repeat the process until find satisfied solution. This is the process of CFD. 
 
Importance of Computational Fluid Dynamics 
There are three methods in study of Fluid: theory analysis, experiment and simulation (CFD). As a new 
method, CFD has many advantages compared to experiments. 
 

➢ Simulation (CFD) Experiment 
➢ Cost Cheap Expensive 
➢ Time Short Long 
➢ Scale Any Small/Middle 
➢ Information All Measured Point 
➢ Repeatable Yes Some 
➢ Safety Yes Some Dangerous 

 
 
Application of Computational Fluid Dynamics 
 
As CFD has so many advantages, it is already generally used in industry such as aerospace, 
automotive, biomedicine, chemical processing, heat ventilation air condition, hydraulics, power 
generation, sports and marine etc. 
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EXPERIMENT - 2 

INTRODUCTION TO ICEM CFD 
 
ANSYS ICEM CFD is a popular proprietary software package which provides advanced geometry/mesh 
generation as well as mesh diagnostics and repair functions useful for in-depth analysis. Its design is 
centered around aerospace, automotive and electrical engineering applications with a specific focus on 
computational fluid dynamics and structural analysis. The ability to accurately create a computational 
grids about geometrically complex configurations is becoming increasingly important in the analysis 
world.  
ANSYS ICEM CFD offers mesh generation with the capacity to compute meshes with various different 
structures depending on the users requirements. It is a powerful and highly manipulative software which 
allows the user to generate grids of high resolution.This is a requirement as mesh generation is an 
inherently geometry dependent problem meaning there is no singular meshing method which can be used 
for every problem. ICEM CFD allows the following different types of grid structures to be created  
Multi-block structured meshes, Unstructured meshes, Hybrid meshes. A simplified overview of the 
meshing methodology provides an indication of how to begin the meshing procedure with the different 
stages shown. 
 

 
 
 
Geometry Modelling 
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ICEM CFD allows for its geometry to either be made using its own geometry topology package or to 
import geometry via external CAD software. For simple geometries the former tends to be used and for 
more complex geometries the latter is often used. Regardless of this, the geometry should be checked 
using the geometry analysis to ensure the model contains a closed volume, meaning there are no holes or 
gaps within the geometry, so that further down the line, no negative volume elements are present.  
 
 
Negative volume elements are not permitted in external solvers. These maybe present due to differences 
in geometrical and meshing tolerances. There is hence an emphasis in ICEM CFD to create a mesh that 
has a 'water-tight' geometry. It means if there is a source of water inside a region, the water should be 
contained and not leak out of the BODY. 
 
Apart from the regular points, curves, surface creation and editing tools, ICEM CFD especially has the 
capability to do BUILD TOPOLOGY which removes unwanted surfaces and then you can view if there 
are any 'holes' in the region of interest for meshing. Existence of holes would mean that the algorithm 
which generates the mesh would cause the mesh to 'leak out' of the domain. Holes are typically identified 
through the colour of the curves. The following is the colour coding in ICEM CFD, after the BUILD 
TOPOLOGY option has been implemented: 
 
YELLOW: curve attached to a single surface 
RED: curve shared by two surface 
BLUE: curve shared by more than two surface. 
Green: curve not attached to any surface 
An analysis post building the topology is then required, whereby if it is clear a curve is supposed to share 
two surfaces yet is being displayed as yellow, a hole exists and it is likely there will be meshing problems. 
 
Geometrical entities which may include points, curves and surfaces must also be associated to a given 
part. Each part can then be controlled for meshing, visualisation or various other purposes and is stored 
within the aforementioned tetin file. 
 

The unstructured mesh generation procedure will now be considered: 

1. Create/Import geometry 

2. Repair geometry ensuring a closed volume 

3. Determine global meshing parameter 

4. Specify part mesh setup 

5. Specify curves and surface mesh size 

6. Compute mesh 

The structured mesh generation procedure will now be considered: 
1. Create/Import geometry. 
2. Initialise blocking with respect to geometry dimension 
3. Generate block structure using the split, merge, Ogrid definition. 
4. Associate vertices to points, edges to curve and block faces to geometry face. 
5. Check block structure quality to ensure the block model meets specified quality threshold. 
6. Determine edge meshing parameters and using spacing 1 or spacing 2 for increasing mesh density 

in specific zone. 
7. using pre-mesh to update mesh 
8. Check the cell quality of the mesh once its generated. 
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9. convert structure mesh to substructure mesh by right click on the re-compute mesh 
10. Write output files to desired solver like ansys fluent or Star CCM 

 
Exporting Mesh 
ICEM CFD allows the user to export their mesh into various different formats for compatibility with 
other external solvers. The meshing topology, associated parts, boundary conditions and loads should all 
be predefined before this stage. Some of the possible supported output solvers are: 

➢ ANSYS CFX 
➢ ANSYS Fluent 
➢ CGNS 
➢ Plot3D 
➢ STAR-CCM 
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EXPERIMENT - 3 

INTRODUCTION TO ANSYS FLUENT 
 
ANSYS Fluent is a state-of-the-art computer program for modeling fluid flow, heat transfer, and chemical 
reactions in complex geometries. 
ANSYS Fluent is written in the C computer language and makes full use of the flexibility and power 
offered by the language. Consequently, true dynamic memory allocation, efficient data structures, and 
flexible solver control are all possible. In addition, ANSYS Fluent uses a client/server architecture, which 
enables it to run as separate simultaneous processes on client desktop workstations and powerful 
computer servers. This architecture allows for efficient execution, interactive control, and complete 
flexibility between different types of machines or operating systems. 
ANSYS Fluent provides complete mesh flexibility, including the ability to solve your flow problems 
using unstructured meshes that can be generated about complex geometries with relative ease. Supported 
mesh types include 2D triangular/quadrilateral, 3D tetrahedral/hexahedral/pyramid/wedge/polyhedral, and 
mixed (hybrid) meshes. ANSYS Fluent also enables you to refine or coarsen your mesh based on the flow 
solution. 
You can read your mesh into ANSYS Fluent, or, for 3D geometries, create your mesh using the meshing 
mode of Fluent (see the Fluent Meshing User’s Guide for further details). All remaining operations are 
performed within the solution mode of Fluent, including setting boundary conditions, defining fluid 
properties, executing the solution, refining the mesh, and post processing and viewing the results. 
The ANSYS Fluent serial solver manages file input and output, data storage, and flow field calculations 
using a single solver process on a single computer. ANSYS Fluent also uses a utility called cortex that 
manages ANSYS Fluent’s user interface and basic graphical functions. ANSYS Fluent’s parallel solver 
enables you to compute a solution using multiple processes that may be executing on the same computer, 
or on different computers in a network. 
Parallel processing in ANSYS Fluent involves an interaction between ANSYS Fluent, a host process, and 
a set of compute-node processes. ANSYS Fluent interacts with the host process and the collection of 
compute nodes using the cortex user interface utility. 
  

 
 

Figure 1.1:  Parallel ANSYS Fluent Architecture 
 

https://www.sharcnet.ca/Software/Ansys/16.2.3/en-us/help/tgd_usr/tgd_usr.html
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For more information about ANSYS Fluent’s parallel processing capabilities, message passing interfaces 
(MPI), and so on, refer to Parallel Processing in the User's Guide. 
All functions required to compute a solution and display the results are accessible in ANSYS Fluent 
through an interactive interface. 
 
 
 
 

https://www.sharcnet.ca/Software/Ansys/16.2.3/en-us/help/flu_ug/flu_ug_chp_parallel.html
https://www.sharcnet.ca/Software/Ansys/16.2.3/en-us/help/flu_ug/flu_ug.html
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EXPERIMENT - 4 

FLOW OVER A FLAT PLATE 
 
Solve this problem in FLUENT. Validate the solution by plotting the y+ values at the plate. Also plot the 
velocity profile at x = 1m. Compare the accuracy of your results from FLUENT with empirical 
correlations. 

 

Preliminary Analysis 

 
We expect the turbulent boundary layer to grow along the plate. As the boundary layer grows in 
thickness, the rate of heat transfer (q'') and thus the heat transfer coefficient (h) will decrease. 
 
 
 
 
 
 
 
 
 
 
We will compare the numerical results with experimentally-derived heat transfer correlations. We will 
create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem. 
 

Step 1: Create Geometry in ICEM CFD 

 

Start ICEM CFD & Select Solver 

 

Main Menu > Solver > FLUENT 5/6 

 

Verify this has been done by looking in the Transcript Window where you should see: 
 
Create Vertices 

 
We will treat this problem as a 2-dimensional problem by assuming that the plate is infinitely wide. 
Let's begin by creating the vertices that define our flow region. 

 

Create the vertex at the lower-left corner of the rectangle:  
Next to x:, enter value 0. Next to y:, enter value 0. Next to z:, enter value 0 (these values should be 
defaults). Click Apply. 
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This creates the vertex (0,0,0) which is displayed in the graphics window. 
 
In the Transcriptwindow, ICEM CFD reports that it "Created vertex: vertex.1". The vertices are 
numbered vertex.1, vertex.2 etc. in the order in which they are created. 
 

Repeat this process to create three more vertices: 

 

Vertex 2: (1,0,0)  
Vertex 3: (1,1,0) 

Vertex 4: (0,1,0) 

 

Note that for a 2D problem, the z-coordinate can always be left to the default value of 0. 

 

Operation Toolpad > Global Control > Fit to Window Button  
 
This fits the four vertices of the rectangle we have created to the size of the Graphics Window. 
 
 
Create Edges 

 

An edge is created by selecting two vertices and creating a line between them. 

 

Operation Toolpad > Geometry Command Button > Edge Command Button > Create 

Edge  

 

Click the up arrow button next to the vertices box in the Create Straight Edge window. 
 
 
This brings up a list of vertices, from which vertices 1 and 2 can be selected. Select Vertex.1 and  

Vertex.2. The push the right arrow button  to bring these vertices into the Picked column. 
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Click Close. Then click Apply in the Create Straight Edge window to create this edge.   
Alternately, these vertices can be selected by holding down the Shift button and clicking on the 
corresponding vertices. As each vertex is picked, it will appear red in the Graphics Window. Then let go 
of the Shift button and click Apply in the Create Straight Edge window. 

 

Repeat this process to create edges between vertices 2 & 3, vertices 3 & 4, and vertices 4 & 1. 
 
Create Face 

 

Operation Toolpad > Geometry Command Button > Face Command Button > Form 

Face  

 
To form a face out of the area enclosed by the four lines, we need to select the four edges that enclose 
this area. This is done in much the same way as when we selected the vertices. 

 

Click the up arrow button  next to the vertices box in the Create Face From Wireframe  

window. Then push the All right arrow button  to bring these vertices into the Picked column. 

  
Click Close. Then click Apply in the Create Face From Wireframe window to create the face. The 
edges and vertices will become blue, indicating that they now form a face. 
 
Save 

 

Save your ICEM CFD file in your working directory. 

 

Main Menu > File > Save As... > Browse... 

 
Find your working directory and save your ICEM CFD file there. Make sure to enter the file name, 
plate.dbs, in the Selection box in addition to the path. 
Step 2: Mesh Geometry in ICEM CFD 

 

We'll now create a mesh on the rectangular face with 100 divisions in the vertical direction and 30 
divisions in the horizontal direction. We'll first mesh the four edges and then the face. The desired grid 
spacing is specified through the edge mesh. 

 

Mesh Edges 

 

Operation Toolpad > Mesh Command Button > Edge Command Button > Mesh Edges 

 
 

Mesh Strategy 

 

In creating this mesh, it is desirable to have more cells near the plate (Edge 1) because we want to resolve 
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the turbulent boundary layer, which is very thin compared to the height of the flow field. 

 

Click the up arrow button next to the Edges box in the Mesh Edges window. Select edge  

Edge.2. Then push the right arrow button to bring this vertex into the Picked column. Notice that 

the arrow on the selected edge should be pointing upwards. An upwards pointing arrow indicates the 

direction of closely spaced nodes to widely spaced nodes 
 
The proper arrow direction is necessary to ensure a proper mesh. Select Edge.4 in the Mesh Edges 
window. The arrow on this edge is pointing downwards, which needs to be changed. Shift + Middle-click 
on the selected edge to change the direction of the arrow to upward. 

 
Under Type, select Successive Ratio, if it is not already selected. Set Ratio to 1.08. Under Spacing, select 
Interval Count. Set Interval Count to 100 and then click Apply. 

 

Select Edge.1 and Edge.3 in the Mesh Edges Window. The direction of the arrows on these edges is 
irrelevant because the divisions will be the same length. Leave the Successive Ratio set to 1 and set the 
Inteval Count to 30. Click Apply. 
 
 
Mesh Face 

 

Operation Toolpad > Mesh Command Button > Face Command Button > Mesh Faces 

 
 

Shift left-click on the face or use the up arrow next to Faces to select the face. Click Apply. 
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Step 3: Specify Boundary Types in ICEM CFD 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Create Boundary Types 

 

We'll next set the boundary types in ICEM CFD. The left edge is the inflow of the flow field, the right 
edge the outflow, the top edge the open top of the flow field, and the bottom edge the plate. 

 

Operation Toolpad > Zones Command Button > Specify Boundary Types Command Button 

 

 

This will bring up the Specify Boundary Types window on the Operation Panel. We will first specify 
that the left edge is the inflow. Under Entity:, pick Edges so that ICEM CFD knows we want to pick 
an edge (face is default). 
 
 
 
 
 
 
 
 
 

 
Now select the left edge by Shift-clicking on it. The selected edge should appear in the yellow box next 
to the Edges box as well as the Label/Type list under the Edges box. 

 

Next to Name:, enter inflow. 
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For Type:, select VELOCITY_INLET. You may have to move the Specify Boundary Types box up in 
order to see the bottom of the list and select VELOCITY_INLET. 
 
 
Click Apply. You should see the new entry appear under Name/Type box near the top of the 
window. 
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Repeat this process for the other three edges according to the following table: 

 

Edge Position Name Type 

Left inflow VELOCITY_INLET 

Right outflow PRESSURE_OUTLET 

Top top SYMMETRY 

Bottom plate WALL 

 

You should have the following edges in the Name/Type list when finished: 
 
 
 
 
 
 
 
 
 
 
 

 

Save and Export 

 

Main Menu > File > Save 

 

Main Menu > File > Export > Mesh... 

 
Type in plate.msh for the File Name:. Select Export 2d Mesh because this is a 2 dimensional mesh. 
Click Accept. 

 

It is important to check that plate.msh has been created in your working directory. ICEM CFD may 
periodically fail to write the .msh file. If this should happen, simply try writing the .msh file to another 
directory and then coping it into your working directory. 
 
Step 4: Set Up Problem in FLUENT 

 

Launch Fluent 6.0 

 

Start > Programs > Fluent Inc > FLUENT 6.0 

 

Select the 2ddp version and click Run. 

 

The "2ddp" option is used to select the 2-dimensional, double-precision solver. In the double-precision 
solver, each floating point number is represented using 64 bits in contrast to the single-precision solver 
which uses 32 bits. The extra bits increase not only the precision but also the range of magnitudes that can 
be represented. The downside of using double precision is that it requires more memory. 
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Import Grid 

 

Main Menu > File > Read > Case... 

 

Navigate to the working directory and select the plate.msh file. This is the mesh file that was created 
using the preprocessor ICEM CFD in the previous step. FLUENT reports the mesh statistics as it reads in 
the mesh: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Check the number of nodes, faces (of different types) and cells. There are 3000 quadrilateral cells in this 
case. This is what we expect because we used 30 divisions in the horizontal direction and 100 divisions in 
the vertical direction while generating the grid. So the total number of cells is 30*100 = 3000. 

 
Also, take a look under zones. We can see the four zones inflow, outflow, top, and plate that we defined 
in ICEM CFD. 
Check and Display Grid 

 

First, we check the grid to make sure that there are no errors. 

 

Main Menu > Grid > Check 

 
Any errors in the grid would be reported at this time. Check the output and make sure that there are no 
errors reported. Check the grid size: 

 

Main Menu > Grid > Info > Size 

 

The following statistics should appear: 
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Display the grid: 

 

Main Menu > Display > Grid... 

 

Make sure all 5 items under Surfaces are selected. 
 

 
Then click Display. The graphics window opens and the grid is displayed in it. Your grid should look like 
this: 
 

 

 

 
 

 

 
 

 

 
 

 

 

 
 

 

 
 

 

 

Define Solver Properties 

 

Main Menu > Define > Models > Solver 

 
We'll use the defaults of 2D space, segregated solver, implicit formulation, steady flow and 
absolute velocity formulation. Click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



24 | P a g e  

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

Main Menu > Define > Models > Energy 

 
We are interested in solving the temperature distribution, so we need to solve the energy 
equation. Select the Energy Equation and click OK to exit the menu. 
 
 
 
 
 
 
 
 
 
 
 
 

Main Menu > Define > Models > Viscous 

 

Under Model, select the k-epsilon turbulence model. We will use the Realizable model in the k-epsilon 
Model box. The Realizable k-epsilon model produces more accurate results for boundary layer flows than 
the Standard k-epsilon model. In the Near-Wall Treatment box, observe the Enhanced Wall Treatment 
option, which deals with the resolution of the boundar layer in our model. There are 3 regions in the 
boundary layer that we are concerned with, starting at the wall: 

 

1. Laminar sublayer (y+ < 5)  

 

2. Buffer region (5 < y+ < 30)  

 

3. Turbulent region (y+ > 30) 
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4. Click OK.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Define Material Properties 

 

Main Menu > Define > Materials... 

 

Change Density to ideal gas because we are treating the flow as compressible. FLUENT will calcualte the 
density of the flow at each point based on the pressure and temperature it calculates at that point. Leave 
Cp set as the default value of 1006.43. Change Thermal Conductivity to 9.4505 e-4. Change Viscosity to 
6.667e-7. Scroll down to see Molecular Weight. Leave Molecular Weight set to the default value of 
28.966. These are the values that we specified under . 

 
Click Change/Create. Simply clicking close without clicking Change/Create will cause these 
properties to revert back to their default values. 

 

Define Operating Conditions 

 

Main Menu > Define > Operating Conditions... 

 

For all flows, FLUENT uses gauge pressure internally. Any time an absolute pressure is needed, it is 
generated by adding the operating pressure to the gauge pressure. We'll use the default value of 1 atm 
(101,325 Pa) as the Operating Pressure. 

 

Click Cancel to leave the default value in place. 
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Define Boundary Conditions 

 

We'll now set the value of the velocity at the inflow and pressure at the outflow. 

 

Main Menu > Define > Boundary Conditions... 

 

We note here that the four types of boundaries we defined are specified as zones on the left side of the 
Boundary Conditions Window. There are also 2 zones default-interior fluid, used to define the interior of 
the flow field. We will not need to change any setting for these 2 zones. 

 

Move down the list and select inflow under Zone. Note that FLUENT indicates that the Type of this 
boundary is velocity-inlet. Recall that the boundary type for the inflow was set in ICEM CFD. If 
necessary, we can change the boundary type set previously in ICEM CFD in this menu by selecting a 
different type from the list on the right. Click Set.... 

 

Enter 1 for Velocity Magnitude. This sets the velocity of the fluid entering at the left boundary to a 
uniform velocity profile of 1m/s. Set Temperature to 353K. Change Turbulence Specification Method to 
Intensity and Viscosity Ratio. Set Turbulence Intensity to 1 and Turbulent Viscosity Ratio to 1. Click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Choose outflow under Zone. The Type of this boundary is pressure-outlet. Click Set.... The default 
value of the Gauge Pressure is 0. The (absolute) pressure at the outflow is 1 atm. Since the operating 
pressure is set to 1 atm, the outflow gauge pressure = outflow absolute pressure - operating pressure = 
0. Because we do not expect any backflow, we do not need to set any backflow conditions. Click 
Cancel to leave the defaults in place. 
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Click on plate under Zones and make sure Type is set as wall. Click Set.... Because we have a heated 
isothermal plate, we need to set the temperature. On the Thermal tab, select Temperature under Thermal 
Conditions. Change Temperatureto 413. The material selected is inconsequential because the plate has 
zero thickness in our model, thus the material properties of the plate do not affect the heat transfer 
properties of the plate. Click OK. 
 
The last boundary condition to set is for the top of the flow field. Click on top under Zones and make sure 
Type is set as symmetry. Click Set... to see that there is nothing to set for this boundary. Click OK. 

 

Click Close to close the Boundary Conditions menu. 

 

Step 5: Solve! 

 

We'll use a second-order discretization scheme. 

 

Main Menu > Solve > Controls > Solution... 

 

Change Density, Momentum, Turbulence Kinetic Energy, Turbulence Dissipation Rate, and  
Energy all to Second Order Upwind. Leave Pressure and Pressure-Velocity Coupling set to the default 
methods (Standard and SIMPLE, respectively). The other Pressure and Pressure-Velocity Coupling 
methods are useful for flows with particular characteristics not present in our problem. 
 
 
Click OK. 

Set Initial Guess 

 

Initialize the flow field to the values at the inflow: 

 

Main Menu > Solve > Initialize > Initialize... 

 

In the Solution Initialization window that comes up, choose inflow under Compute From. The X Velocity 
for all cells will automatically be set to 1 m/s, the Y Velocity to 0 m/s and the Gauge Pressure to 0 Pa. 
These values have been taken from the inflow boundary condition. 
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Click Init. This completes the initialization. Then click Close. 

 

Set Convergence Criteria 

 

FLUENT reports a residual for each governing equation being solved. The residual is a measure of how 
well the current solution satisfies the discrete form of each governing equation. We will iterate until the 
residual for each equation falls below 1e-6. 

 

Main Menu > Solve > Monitors > Residual... 

 
Change the residual under Convergence Criterion for continuity, x-velocity, and y-velocity, energy, 
k, and epsilon all to 1e-6. 

 
Also, under Options, select Print and Plot. This will print the residuals in the main window and plot the 
residuals in the graphics window as they are calculated. 



29 | P a g e  

 

 

Click OK. 

 

This completes the problem specification. Save your work: 

 

Main Menu > File > Write > Case... 

 

Type in plate.cas for Case File. Click OK. Check that the file has been created in your working directory. 
If you exit FLUENT now, you can retrieve all your work at any time by reading in this case file.  

 

Iterate Until Convergence 

 
Start the calculation by running 10,000 iterations. The solution will converge before 10,000 iterations are 
performed, which will stop the iteration process. 

 

Main Menu > Solve > Iterate... 

 

In the Iterate Window, change the Number of Iterations to 10000. Click Iterate. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
The residuals for each iteration are printed out as well as plotted in the graphics window as they are 
calculated. 
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The residuals fall below the specified convergence criterion of 1e-6 in approximately 1623 
iterations. 
 
 
Main Menu > File > Write > Data... 

 
Enter plate.dat for Data File and click OK. Check that the file has been created in your working 
directory. You can retrieve the current solution from this data file at any time. 
 

Step 6: Analyze Results 

 

First, we need to set the reference values needed to calculate y+. 

 

Main Menu > Report > Reference Values... 

 

Select inflow under Compute From to tell FLUENT to use values at the inflow for the reference values. 
Check that the reference value for velocity is 1 m/s, temperature is 353 K, and coefficient of viscosity is 
6.667e-7 kg/m-s Click OK. 
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By using the following method, plot y+ values for wall-adjacent cells to check how they compare with 
the recommendation mentioned above. 

 

Main Menu > Plot > XY Plot... 

 

Make sure that Position on X Axis is set under Options, that 1 is the value next to X, and 0 is the value 
next to Y under Plot Direction. Recall that this tells FLUENT to plot the x-coordinate value on the 
abscissa of the graph. Select Turbulence... under Y Axis Function and select Wall Yplus from the drop 
down list under that. Since we want the y+ value for cells adjacent to the wall of the pipe, choose plate 
under Surfaces. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Click Plot. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
As we can see, the wall y+ value is between 1.0 and 1.4 (ignoring the anamolous at the inflow). 
Because these values are less than 5, the near-wall mesh resolution is in the laminar sublayer, which is 
the most accurate region to which we can resolve the boundary layer. 
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Save Plot 

 

In the Solution XY Plot Window, check the Write to File box under Options. The Plot button should have 
changed to the Write... button. Click on Write.... Enter yplus.xy as the filename and click OK. Check that 
this file has been created in your FLUENT working directory. 

 

Velocity at x = 1m 

 

Main Menu > Plot > XY Plot... 

 

Under Options, unselect Position on X Axis and select Position on Y Axis. Under Plot Direction, enter 0 
in the X box and 1 in the Y box. This tells FLUENT to plot a vertical rather than horizontal profile. 

 

Under X Axis Function, pick Velocity... and then in the box under that, pick X Velocity. Finally, select 
outflow under Surfaces since we are plotting the velocity profile at the outflow. De-select plate under 
Surfaces. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click on Axes... in the Solution XY Plot window. Select X in the Axis box. In the Options box select 
Major Rules to turn on the grid lines in the plot. Click Apply. Then select the Y in the Axis box, select 
Major Rules again, and turn off Auto Range. In the Range box enter 0.1 for the Maximum so that we 
may view the velocity profile in the boundary layer region more closely. Click Apply and Close. 
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Uncheck Write to File. Click Plot. 
 
 
Select Write to File and save the data for this plot as outflow_profile.xy. 

 

Main Menu > Plot > XY Plot... 

 

In the Options box, change back to Position on X Axis. In the Plot Direction box, enter the default values 
of 1 in the X box and 0 in the Y box. Under Y-Axis Function choose Wall Fluxes. In the box below, chose 
Total Surface Heat Flux. Select Plate under Surfaces. Before plotting, be sure to turn on Auto Range for 
the Y axis under Axes.... 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Click Plot. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Now Select Write to File. Save the data for this plot as heatflux.xy. Click Write.... 

 
Open the file heatflux.xy using Wordpad or a similar application. You can simply copy and paste the 
data into Excel. 
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EXPERIMENT - 5 

FLOW THROUGH PIPE 
 

  
We will compare the numerical results with experimentally-derived heat transfer correlations. We will 
create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem. 
 

Step 1: Create Geometry in ICEM CFD 

 

Start ICEM CFD & Select Solver 

 

Main Menu > Solver > FLUENT 5/6 

 

Verify this has been done by looking in the Transcript Window where you should see: 
 
Create Vertices 

 
We will treat this problem as a 2-dimensional problem by assuming that the pipe  is infinitely wide. 
Let's begin by creating the vertices that define our flow region. 

 

Create the vertex at the lower-left corner of the rectangle:  
Next to x:, enter value 0. Next to y:, enter value 0. Next to z:, enter value 0 (these values should be 
defaults). Click Apply. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This creates the vertex (0,0,0) which is displayed in the graphics window. 
 
In the Transcriptwindow, ICEM CFD reports that it "Created vertex: vertex.1". The vertices are 
numbered vertex.1, vertex.2 etc. in the order in which they are created. 
 

Repeat this process to create three more vertices: 

 

Vertex 2: (1,0,0)  
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Vertex 3: (1,1,0) 
Vertex 4: (0,1,0) 

 

Note that for a 2D problem, the z-coordinate can always be left to the default value of 0. 

 

Operation Toolpad > Global Control > Fit to Window Button  
 
This fits the four vertices of the rectangle we have created to the size of the Graphics Window. 
 
 
Create Edges 

 

An edge is created by selecting two vertices and creating a line between them. 

 

Operation Toolpad > Geometry Command Button > Edge Command Button > Create 

Edge  

 

Click the up arrow button next to the vertices box in the Create Straight Edge window. 
 
 
This brings up a list of vertices, from which vertices 1 and 2 can be selected. Select Vertex.1 and  

Vertex.2. The push the right arrow button  to bring these vertices into the Picked column. 

 

Click Close. Then click Apply in the Create Straight Edge window to create this edge.   
Alternately, these vertices can be selected by holding down the Shift button and clicking on the 
corresponding vertices. As each vertex is picked, it will appear red in the Graphics Window. Then let go 
of the Shift button and click Apply in the Create Straight Edge window. 

 

Repeat this process to create edges between vertices 2 & 3, vertices 3 & 4, and vertices 4 & 1. 
 
Create Face 

 

Operation Toolpad > Geometry Command Button > Face Command Button > Form 

Face  

 
To form a face out of the area enclosed by the four lines, we need to select the four edges that enclose 
this area. This is done in much the same way as when we selected the vertices. 

 

Click the up arrow button  next to the vertices box in the Create Face From Wireframe  

window. Then push the All right arrow button  to bring these vertices into the Picked column. 

  
Click Close. Then click Apply in the Create Face From Wireframe window to create the face. The 
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edges and vertices will become blue, indicating that they now form a face. 
 
Save 

 

Save your ICEM CFD file in your working directory. 

 

Main Menu > File > Save As... > Browse... 

 
Find your working directory and save your ICEM CFD file there. Make sure to enter the file name, 
plate.dbs, in the Selection box in addition to the path. 
Step 2: Mesh Geometry in ICEM CFD 

 

We'll now create a mesh on the rectangular face with 100 divisions in the vertical direction and 30 
divisions in the horizontal direction. We'll first mesh the four edges and then the face. The desired grid 
spacing is specified through the edge mesh. 

 

Mesh Edges 

 

Operation Toolpad > Mesh Command Button > Edge Command Button > Mesh Edges 

 
 

Mesh Strategy 

 

In creating this mesh, it is desirable to have more cells near the plate (Edge 1) because we want to resolve 
the turbulent boundary layer, which is very thin compared to the height of the flow field. 

 

Click the up arrow button next to the Edges box in the Mesh Edges window. Select edge  

Edge.2. Then push the right arrow button to bring this vertex into the Picked column. Notice that 

the arrow on the selected edge should be pointing upwards. An upwards pointing arrow indicates the 

direction of closely spaced nodes to widely spaced nodes 
 
The proper arrow direction is necessary to ensure a proper mesh. Select Edge.4 in the Mesh Edges 
window. The arrow on this edge is pointing downwards, which needs to be changed. Shift + Middle-click 
on the selected edge to change the direction of the arrow to upward. 

 
Under Type, select Successive Ratio, if it is not already selected. Set Ratio to 1.08. Under Spacing, select 
Interval Count. Set Interval Count to 100 and then click Apply. 

 

Select Edge.1 and Edge.3 in the Mesh Edges Window. The direction of the arrows on these edges is 
irrelevant because the divisions will be the same length. Leave the Successive Ratio set to 1 and set the 
Inteval Count to 30. Click Apply. 
 
 
Mesh Face 
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Operation Toolpad > Mesh Command Button > Face Command Button > Mesh Faces 

 
 

Shift left-click on the face or use the up arrow next to Faces to select the face. Click Apply. 
 
 
 
 
Step 3: Specify Boundary Types in ICEM CFD 
 
 
Create Boundary Types 

 

We'll next set the boundary types in ICEM CFD. The left edge is the inflow of the flow field, the right 
edge the outflow, the top edge the open top of the flow field, and the bottom edge the plate. 

 

Operation Toolpad > Zones Command Button > Specify Boundary Types Command Button 

 
This will bring up the Specify Boundary Types window on the Operation Panel. We will first specify 
that the left edge is the inflow. Under Entity:, pick Edges so that ICEM CFD knows we want to pick 
an edge (face is default). 
 
 
 
 
 
 

 
Now select the left edge by Shift-clicking on it. The selected edge should appear in the yellow box next 
to the Edges box as well as the Label/Type list under the Edges box. 

 

Next to Name:, enter inflow. 

 
For Type:, select VELOCITY_INLET. You may have to move the Specify Boundary Types box up in 
order to see the bottom of the list and select VELOCITY_INLET. 
 
 
Click Apply. You should see the new entry appear under Name/Type box near the top of the 
window. 
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Repeat this process for the other three edges according to the following table: 

 

Edge Position Name Type 

Left inflow VELOCITY_INLET 

Right outflow PRESSURE_OUTLET 

Top top SYMMETRY 

Bottom plate WALL 

 

You should have the following edges in the Name/Type list when finished: 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

Save and Export 
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Main Menu > File > Save 

 

Main Menu > File > Export > Mesh... 

 
Type in plate.msh for the File Name:. Select Export 2d Mesh because this is a 2 dimensional mesh. 
Click Accept. 

 

It is important to check that plate.msh has been created in your working directory. ICEM CFD may 
periodically fail to write the .msh file. If this should happen, simply try writing the .msh file to another 
directory and then coping it into your working directory. 
 
Step 4: Set Up Problem in FLUENT 

 

Launch Fluent 6.0 

 

Start > Programs > Fluent Inc > FLUENT 6.0 

 

Select the 2ddp version and click Run. 

 

The "2ddp" option is used to select the 2-dimensional, double-precision solver. In the double-precision 
solver, each floating point number is represented using 64 bits in contrast to the single-precision solver 
which uses 32 bits. The extra bits increase not only the precision but also the range of magnitudes that can 
be represented. The downside of using double precision is that it requires more memory. 
 

 

Import Grid 

 

Main Menu > File > Read > Case... 

 

Navigate to the working directory and select the plate.msh file. This is the mesh file that was created 
using the preprocessor ICEM CFD in the previous step. FLUENT reports the mesh statistics as it reads in 
the mesh: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Check the number of nodes, faces (of different types) and cells. There are 3000 quadrilateral cells in this 
case. This is what we expect because we used 30 divisions in the horizontal direction and 100 divisions in 
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the vertical direction while generating the grid. So the total number of cells is 30*100 = 3000. 

 
Also, take a look under zones. We can see the four zones inflow, outflow, top, and plate that we defined 
in ICEM CFD. 
Check and Display Grid 

 

First, we check the grid to make sure that there are no errors. 

 

Main Menu > Grid > Check 

 
Any errors in the grid would be reported at this time. Check the output and make sure that there are no 
errors reported. Check the grid size: 

 

Main Menu > Grid > Info > Size 

 

The following statistics should appear: 
 
 
 
 
 
 
 
 
 
 
Display the grid: 

 

Main Menu > Display > Grid... 

 

Make sure all 5 items under Surfaces are selected. 
 

 
Then click Display. The graphics window opens and the grid is displayed in it. Your grid should look like 
this: 
 

Define Solver Properties 

 

Main Menu > Define > Models > Solver 

 

We'll use the defaults of 2D space, segregated solver, implicit formulation, steady flow and 
absolute velocity formulation. Click OK. 
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Main Menu > Define > Models > Energy 

 
We are interested in solving the temperature distribution, so we need to solve the energy 
equation. Select the Energy Equation and click OK to exit the menu. 
 
 
 
 
 
 
 
 
 
 
 
 

Main Menu > Define > Models > Viscous 

 

Under Model, select the k-epsilon turbulence model. We will use the Realizable model in the k-epsilon 
Model box. The Realizable k-epsilon model produces more accurate results for boundary layer flows than 
the Standard k-epsilon model. In the Near-Wall Treatment box, observe the Enhanced Wall Treatment 
option, which deals with the resolution of the boundar layer in our model. There are 3 regions in the 
boundary layer that we are concerned with, starting at the wall: 

 

5. Laminar sublayer (y+ < 5)  

 

6. Buffer region (5 < y+ < 30)  
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7. Turbulent region (y+ > 30) 

Click OK.  

Define Material Properties 

 

Main Menu > Define > Materials... 

 

Change Density to ideal gas because we are treating the flow as compressible. FLUENT will calcualte the 
density of the flow at each point based on the pressure and temperature it calculates at that point. Leave 
Cp set as the default value of 1006.43. Change Thermal Conductivity to 9.4505 e-4. Change Viscosity to 
6.667e-7. Scroll down to see Molecular Weight. Leave Molecular Weight set to the default value of 
28.966. These are the values that we specified under . 

 
Click Change/Create. Simply clicking close without clicking Change/Create will cause these 
properties to revert back to their default values. 

 

Define Operating Conditions 

 

Main Menu > Define > Operating Conditions... 

 

For all flows, FLUENT uses gauge pressure internally. Any time an absolute pressure is needed, it is 
generated by adding the operating pressure to the gauge pressure. We'll use the default value of 1 atm 
(101,325 Pa) as the Operating Pressure. 

 

Click Cancel to leave the default value in place. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Define Boundary Conditions 

 

We'll now set the value of the velocity at the inflow and pressure at the outflow. 
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Main Menu > Define > Boundary Conditions... 

 

We note here that the four types of boundaries we defined are specified as zones on the left side of the 
Boundary Conditions Window. There are also 2 zones default-interior fluid, used to define the interior of 
the flow field. We will not need to change any setting for these 2 zones. 

 

Move down the list and select inflow under Zone. Note that FLUENT indicates that the Type of this 
boundary is velocity-inlet. Recall that the boundary type for the inflow was set in ICEM CFD. If 
necessary, we can change the boundary type set previously in ICEM CFD in this menu by selecting a 
different type from the list on the right. Click Set.... 

 

Enter 1 for Velocity Magnitude. This sets the velocity of the fluid entering at the left boundary to a 
uniform velocity profile of 1m/s. Set Temperature to 353K. Change Turbulence Specification Method to 
Intensity and Viscosity Ratio. Set Turbulence Intensity to 1 and Turbulent Viscosity Ratio to 1. Click OK. 
 
Choose outflow under Zone. The Type of this boundary is pressure-outlet. Click Set.... The default 
value of the Gauge Pressure is 0. The (absolute) pressure at the outflow is 1 atm. Since the operating 
pressure is set to 1 atm, the outflow gauge pressure = outflow absolute pressure - operating pressure = 
0. Because we do not expect any backflow, we do not need to set any backflow conditions. Click 
Cancel to leave the defaults in place. 
 
Click on plate under Zones and make sure Type is set as wall. Click Set.... Because we have a heated 
isothermal plate, we need to set the temperature. On the Thermal tab, select Temperature under Thermal 
Conditions. Change Temperatureto 413. The material selected is inconsequential because the plate has 
zero thickness in our model, thus the material properties of the plate do not affect the heat transfer 
properties of the plate. Click OK. 
 
The last boundary condition to set is for the top of the flow field. Click on top under Zones and make sure 
Type is set as symmetry. Click Set... to see that there is nothing to set for this boundary. Click OK. 

 

Click Close to close the Boundary Conditions menu. 

 

Step 5: Solve! 

 

We'll use a second-order discretization scheme. 

 

Main Menu > Solve > Controls > Solution... 

 

Change Density, Momentum, Turbulence Kinetic Energy, Turbulence Dissipation Rate, and  
Energy all to Second Order Upwind. Leave Pressure and Pressure-Velocity Coupling set to the default 
methods (Standard and SIMPLE, respectively). The other Pressure and Pressure-Velocity Coupling 
methods are useful for flows with particular characteristics not present in our problem. 
 
 
Click OK. 
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Set Initial Guess 

 

Initialize the flow field to the values at the inflow: 

 

Main Menu > Solve > Initialize > Initialize... 

 

In the Solution Initialization window that comes up, choose inflow under Compute From. The X Velocity 
for all cells will automatically be set to 1 m/s, the Y Velocity to 0 m/s and the Gauge Pressure to 0 Pa. 
These values have been taken from the inflow boundary condition. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Click Init. This completes the initialization. Then click Close. 

 

Set Convergence Criteria 

 

FLUENT reports a residual for each governing equation being solved. The residual is a measure of how 
well the current solution satisfies the discrete form of each governing equation. We will iterate until the 
residual for each equation falls below 1e-6. 

 

Main Menu > Solve > Monitors > Residual... 

 
Change the residual under Convergence Criterion for continuity, x-velocity, and y-velocity, energy, 
k, and epsilon all to 1e-6. 

 
Also, under Options, select Print and Plot. This will print the residuals in the main window and plot the 
residuals in the graphics window as they are calculated. 
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Click OK. 

 

This completes the problem specification. Save your work: 

 

Main Menu > File > Write > Case... 

 

Type in plate.cas for Case File. Click OK. Check that the file has been created in your working 
directory. If you exit FLUENT now, you can retrieve all your work at any time by reading in this case 
file. 
Iterate Until Convergence 
Start the calculation by running 10,000 iterations. The solution will converge before 10,000 iterations 
are performed, which will stop the iteration process. 
Main Menu > Solve > Iterate... 

 

In the Iterate Window, change the Number of Iterations to 10000. Click Iterate. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
The residuals for each iteration are printed out as well as plotted in the graphics window as they are 
calculated. 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
The residuals fall below the specified convergence criterion of 1e-6 in approximately 1623 
iterations. 
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EXPERIMENT - 6 

FLOW OVER A CIRCULAR CYLINDER 

Problem Specification 

 

 
 

Consider the steady state case of a fluid flowing past a cylinder, as illustrated above. Obtain the velocity 

and pressure distributions when the Reynolds number is chosen to be 20. In order to simplify the 
computation, the diameter of the cylinder is set to 1 m, the x component of the velocity is set to 1 m/s and 

the density of the fluid is set to 1 kg/m^3. Thus, the dynamic viscosity must be set to 0.05 kg/m*s in 

order to obtain the desired Reynolds number.  

Pre-Analysis & Start-Up 

Prior to opening FLUENT, we must answer a couple of questions. We must determine what our solution 

domain is and what the boundary conditions are. 

Solution Domain 

For an external flow problem like this, one needs to determine where to place the outer boundary. A 

circular domain will be used for this simulation. The effects that the cylinder has on the flow extend far. 
Thus, the outer boundary will be set to be 64 times as large as the diameter of the cylinder. That is, the 

outer boundary will be a circle with a diameter of 64 m. The solution domain discussed here is illustrated 

below.  
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Boundary Conditions 

First, we will specify a velocity inlet boundary condition. We will set the left half of the outer boundary 

as a velocity inlet with a velocity of 1 m/s in the x direction. Next, we will use a pressure outlet boundary 

condition for the right half of the outer boundary with a gauge pressure of 0 Pa. Lastly, we will apply a 
no slip boundary condition to the cylinder wall. The aforementioned boundary conditions are illustrated 

below.  

 

 
 

 

Set Up Problem in FLUENT 

 

Launch FLUENT 

 

Start > Programs > Fluent Inc > FLUENT 6.3.26 

 

Select 2ddp from the list of options and click Run. 

 

Import File 

 

Main Menu > File > Read > Case... 

 

Navigate to your working directory and select the cylinder.msh file. Click OK. 

 

Analyze Grid 

 

Grid > Info > Size 

 

Check how many cells and nodes the mesh has. 

Display > Grid 
 

Display the grid information. 

 

Define Properties 
 

Define > Models > Solver... 

 

Under the Solver box, select Pressure Based. 
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Click OK. 

 

Define > Models > Viscous 

 

Select Laminar under Model 

 

Click OK. 

 

Define > Models > Energy 
 

Do not select Energy Equation. 

 

Define > Materials 

 

Make sure air is selected under Fluent Fluid Materials. Set Density to constant and equal to 1 kg/m 3 

and Viscosity to 0.025 kg/m-s. We choose these numbers so that Re = 40. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Click Change/Create. 

 

Define > Operating Conditions 

 

We'll work in terms of gauge pressures in this example. So set Operating Pressure to the ambient value 

of 101,325 Pa. 

 
Click OK. 
 

Define > Boundary Conditions 

 

Set inlet, click Set... and set the Velocity Magnitude to 1 m/s. Click OK. 
 

Set outlet, click Set... and set the Gauge Pressure at this boundary to 0. Click OK. 
 

 

Solve 

 

Solve > Control > Solution 
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Under Discretization, set Momentum to Second-Order Upwind. 
 

Solve > Initialize > Initialize... 

 

Select inlet under Compute From. We'll set these values to be equal to those at the inlet. 

 
Solve > Monitors > Residual... 

 

Now we will set the residual values (the criteria for a good enough solution). Once again, we'll 

set this value to 1e-06. 

 

Select Print and Plot under Options. Click 

OK. 

 
Solve > Monitors > Force... 

 

Under Coefficient, choose Drag. Under Options, select Print and Plot. Then, Choose cylinder under 

Wall Zones. 

 

Set the Force Vector components for the drag. The drag is the force in the direction of the freestream. 

So to get the drag coefficient, set X to 1 and Y to 0. 

 

Record the histories of Cd. Under Options, select Write. Fill in the name in the box under File Name, 

then the text file containing drag coefficients at each iteration will be stored in the file. 

 
 
 
 
 
 

 

 

 
 

 

 
 

 

Click Apply for these changes to take effect. 

 

Similarly, set the Force Monitor options for the Lift force. The lift is defined as the force component 

perpendicular to the direction of the freestream. So under Force Vector, set X to 0 and Y to 1. 

 
Click Apply. 
 

Report > Reference Values 
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Now, set the reference values to set the base cases for our iteration. Select inlet under Compute 

From. 

 
Main Menu > File > Write > Case... 

 

Save the case file before you start the iterations. 

 

Solve > Iterate 

 

Make note of your findings, make sure you include data such as: 

 

What does the convergence plot look like? 
 
How many iterations does it take to converge? 

 

Main Menu > File > Write > Case & Data... 
 

Save case and data after you have obtained a converged solution. 

Analyze Results 

 

Drag / Lift coefficients 

 

Report > Forces > 

 

Under Force Vector, we set X = 1 and Y = 0 to identify the direction of drag force. Click Print to 

see what's displayed in the main window. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Plot convergence of the drag coefficient versus the number of iterations. Report the drag coefficient 

and compare it with the result in literature as shown in Table 1. 

 
Plot>File 

 

Click Add... choose the file with drag or lift coefficient. 
 
 
Before you plot, you can adjust the Axes and Curves to get a better view. 



51 | P a g e  

 

 

Similarly, you can plot the lift coefficient, which should be zero for the symmetric flow. As you can 

see, the drag coefficient is around 2.1, which is significantly higher than the result in the table. Next, we 

will try to increase the domain size and repeat the simulation. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

Plot streamlines. Plot pressure, velocity, vorticity contours. 
 

Streamline 

 

Display > Contours > 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Contour of the dimensionless pressure 
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Contour of the velocity magnitude (normalized by the freestream velocity) 
 
 
 

Vorticity Magnitude (normalized by U/a) 
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EXPERIMENT - 7  

FLOW OVER A WEDGE 

Problem Specification 

A uniform supersonic stream encounters a wedge with a half-angle of 15 degrees as shown in the figure 
below. 

 

The stream is at the following conditions: 

 

Using FLUENT, calculate the Mach Number, static and total pressure behind the oblique shock that will 

be formed. Also, calculate the shock angle, pressure coefficient along the wedge and drag coefficient. 
Compare the FLUENT results with the corresponding analytical results. 

 

Design considerations 
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Mesh  

 

Boundary conditions 

 

 

Physics Setup 

Update the Project and Open FLUENT 

Before we open FLUENT, we need to update the project so we can import the mesh into FLUENT. To do 

this, click Update Project . When the project updates, double click Setup  to open FLUENT. 
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Initial Settings 

(Double Click) Setup in the Workbench Project Page. 

When the FLUENT Launcher appears change options to "Double Precision", and then click OK as 

shown below.The Double Precision option is used to select the double-precision solver. In the double-

precision solver, each floating point number is represented using 64 bits in contrast to the single-precision 

solver which uses 32 bits. The extra bits increase not only the precision, but also the range of magnitudes 
that can be represented. The downside of using double precision is that it requires more memory.  

 

 

Problem Setup - General 

Now, FLUENT should open. We will begin setting up some options for the solver. In the left hand 

window (in what I will call the Outline window), under Problem Setup, select General. The only option 

we need to change here is the type of solver. In the Solver window, select Density-Based. 

Models 

In the outline window, click Models. We will need to utilize the energy equation in order to solve this 

simulation. Under Models highlight Energy - Off and click Edit.... Now, the Energy window will launch. 
Check the box next to Energy Equation and hit OK. Doing this turns on the energy equation. 

We also need to change the type of viscosity model. Select Viscous - Laminar and click Edit.... Choose 

the Inviscid option and press OK. 

https://confluence.cornell.edu/download/attachments/170201588/cyl_fluent_launcher.png?version=1&modificationDate=1393449969000&api=v2
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Materials 

In the Outline window, highlight Materials. In the Materials window, highlight Fluid, and 

click Create/Edit.... this will launch the Create/Edit Materials window; here we can specify the 
properties of the fluid. Set the Density to Ideal Gas, the Specific Heat to 1006.43, the Molecular 

Weight to 28.966. When you have updated these fields, press Change/Create. 

 

Boundary Conditions 

In the Outline window, select Boundary Conditions. We will now specify each boundary condition for 

the simulation. 

Farfield 

In the Boundary Conditions window, select farfield. Use the drop-down menu to change 

the Type to pressure-far-field. You will be asked to confirm the change, and do so by pressing OK. Next, 

https://confluence.cornell.edu/download/attachments/170201588/Materials.png?version=1&modificationDate=1329673467000
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a dialogue box will open with some parameters we need to specify. Change the Gauge Pressure 

(Pascal) to 101325, and Mach Number to 3. 

 

Also, select the Thermal tab, and ensure that the temperature correctly defaulted to 300 K. When you are 

finished, press OK. 

Wedge 

In the Boundary Conditions window, select wedge. Use the drop-down menu to change the Type to wall. 

Symmetry 

In the Boundary Conditions window, select symmetry. Use the drop-down menu to change 

the Type to symmetry. 

Operating Conditions 

In the Boundary Conditions window, select the Operating Conditions button. Change the Gauge 

Pressure to 0. Then press OK 
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It is important to check the operating conditions. When setting the density in materials to ideal gas, 

FLUENT calculates the density using the absolute pressure. However, the pressure we specify is the 

gauge pressure, not the absolute pressure. FLUENT will use the absolute pressure to compute the density 

therefore if we do not set the operating pressure to 0 our density will be incorrect for the flow field.   

 

Numerical Solution 

Solution Methods 

In the Outline window, select Solution Methods to open the Solution Methods window. Under Spatial 

Discretization, ensure that the option under Flow Second Order Upwind is selected. 

Solution Controls 

In the Outline window, select Solution Controls to open the Solution Controls window. Ensure that 

the Courant Number is set to 5.0. 

The Courant number can be considered a non dimensionalized timestep. The density-based solver obtains 

the steady-state solution by starting with the initial guess and marching in pseudo-time until convergence 

is obtained. The Courant number controls the time step the solver uses. The larger it is, the faster the 
solution will converge but it will not be very stable and can diverge. The smaller it is, the slower it is to 

reach convergence but the solution is much more stable. 

Monitors 

In the Outline window, click Monitors to open the Monitors window. In the Monitors window, 

select Residuals - Print,Plot and press Edit.... This will open the Residual Monitors window. We want to 

change the convergence criteria for our solution. Under Equation and to the right of Continuity, change 
the Absolute Criteria to 1e-6. Repeat for x-velocity, y-velocity, and energy, then press OK. 
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Solution Initialization 

In the Outline window, select Solution Initialization. We need to make an "Initial Guess" to the solution 

so FLUENT can iterate to find the final solution. In the Solution Initialization window, select Standard 

Initialization, then under Compute from, select farfield from the drop down box. Check to see that the 
values that generate match our inputted values, then press Initialize 

Run Calculation 

In the Outline window, select Run Calculation. Change the Number of Iterations to 4000. Double 
click Calculate to run the calculation. It should a few minutes to solve. After the calculation is complete, 

save the project. Do not close FLUENT.  

 

Mach Number Contours 

1. Some calculated parameters are not by default carried over into CFD-post. We are interested in such 

quantities (i.e. Mach Number). To manually transfer a customized selection of quantities 

a. Select File > Data File Quantities 
b. Under Additional Quantities, Select Static Pressure, Total Pressure, Mach Number, and Total 

Temperature 

2. Post-processing will be done in CFD-post > Double Click Results in Workbench 

3. We are interested in viewing contours of Mach Number in CFD-post 
a. Select Insert > Contour > Name > Mach No.  

b. Under Details of Mach No, select Locations > symmetry 1.  

c. Variable > Mach Number> No Contours = 101 
4. Turn on the mesh in the graphics pane 

a. Check the box next to symmetry 1 in the Outline tree > Click Render > Show Mesh Lines. 

5. Turn off the mesh by deselecting symmetry 1 in the outline tree 

6. Save a copy of the figure in the graphics pane 

Pressure Contours 

The following video shows how to make a plot of the pressure contours. 

1. Turn off the Mach Number contours in the graphics window 
2. We are interested in viewing contours of pressure in CFD-post 

a. Select Insert > Contour 

b. Name > Pressure Contours 
c. Under Details of Pressure contours, select Locations > symmetry 1.Variable > Pressure. 

3. To increase the number of contours to 101 

4. Under Details of Pressure contours, scroll down to # of Contours. Type “101”. 

Velocity Vectors 

1. We are interested in viewing velocity vectors in CFD-post. 

a. Select Insert > Vector 

b. Type “Velocity vectors” under Name in the Insert Vector dialogue box that appears. 

c. Under Details of Velocity vectors, select Locations > symmetry 1.   
2. To make the velocity vectors more visible, turn off the pressure contours 
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a. Uncheck the box next to Pressure contours in the Outline tree 

 

Now, once again, plot the contours of the mach number. Below is a comparison of the mach number 

results from the original mesh and the refined mesh. 

 
Original Mesh 

 
Refined Mesh 

The most striking difference between the two results is the thickness of the shock. Notice that for the 

refined mesh, the shock is less thick that for the original mesh. This shows that the refined mesh is 

converging towards the real case. 

Comparison to Analytical Solution 

In order to verify our simulation, we need to compare our results to either an analytical solution or an 

experiment. Below is a table comparing the values from the simulation with the calculations from the 
pre-analysis. 

  Mach Number Static Pressure (atm) Shock Angle (degrees) 

Theory Value 2.254 2.824 32.22 

FLUENT Solution 2.243 2.803 34.99 

Percent Difference 0.8% 0.7% 8.2% 
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As we can see from the table, we are getting fairly good matching between the computation and 
analytical approaches. From this we can build our trust in our simulation. 

Save Project 

Save the project using File > Save. Copy wedge.wbpj and the associated wedge_files folder to a flash 

drive. You will need both entities to resume the project. 

Alternately, you can select File > Archive and save the project as one file called wege.wbpz. When 
prompted, select the option to save Result/Solution also. You will then need to save only this file. This is 

also convenient to e-mail the project. Double-clicking on the wedge.wbpz file will resume the project.    
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EXPERIMENT - 8 

FLOW OVER A CAMBERED AIRFOIL 
 

Introduction 
 
This provides a short step by step guide to meshing an aerofoil using the icemcfd package. The aim 

being to introduce you the important features of the program in the shortest possible space of time. The 

mesh that this tutorial produces will require further work to be used as a basis for serious calculations but 

this tutorial contains all the information that you need to do this. 
 
icemcfd is available on the University GNU/Linux service called vega. Once you have logged into vega 

you can start it from the command line using the command icemcfd. 
 
The initial screen looks something like: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1: The icemcfd screen.  
As well as the conventional display area and menus there are three areas of note: 
 

● Tabs: These provide access to broad categories of tools which enable the meshing to take 

place.  
 

● Tools: This area in the bottom left is where the tools are actually operated from  
 

● Tree: In this area a hierarchical list of points, lines and so on will be built up as you work 

with the software.  
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icemcfd is a powerful package but does have something of a learning curve, so if something doesn't 

work the first time review the steps you took carefully and try again. 

 

Importing the Geometry 
 
● Start icemcfd  
 
● Obtain the NACA 4412 coordinates file (this should be on the same page/folder where you 

obtained this document)  
 
● File → Import Geometry → Formatted point data (then select the file you just obtained) A good tip 

at this point is to go to File → Change Working Directory and change the directory to where you 

have stored the NACA data – this saves a lot of navigation through file dialogues later.  
 
● Then click apply in the bottom left corner of the screen  
 
● You should have a screen that looks like  Figure 2:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 2: Point Input to icemcfd 
 
● We then want to create a curve made of those points to describe the surface of aerofoil  
 

● Under the Geometry tab in the top centre of the screen click on the Create/Modify Curve 

button  
 

● This pops a new menu in the bottom left. Click on the top left icon underneath “Inherit Part”, 

This is the “From Points” tool. Click on “Inherit Part” to deselect it and name the part SUCTION.   
● You should then select each point on the top of the curve one after the other with the left mouse 

button. (There ought to be a better way of doing this but I can't seem to find it!) You might need to 

zoom in to get all the points in the trailing edge. The middle mouse button accepts your final 

selection  
 

Hint: Pressing F9 suspends the Selection Mode and allows you to use the mouse to control the 
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view, hitting F9 again puts you back into Selection Mode. 
 

● Repeat the process for the points on the bottom of the curve. Name this PRESSURE. 

● Then we want to create the surface on which we will calculate the fluid flow. To do this we will 

create a domain around 1 chord lengths above and below the aerofoil and 1.5 chord lengths before 

and after. This is slightly arbitrary and we may want to change this after we look at the results!  
 

● Add points at (-1.5,1),(-1.5,-1),(2,1) and (2,-1) Click on the Create Point tool under the geometry 

tab and use the Explicit Locations tool to do this.  
 

● Join these points together with straight lines. Label the left hand one INLET, the right hand line 

EXIT and the upper and lower parts TOP and BOTTOM. Your screen should look like  Figure 3.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3: Aerofoil and Calculation Domain. 
 

● We are going to construct an outer surface called FLUID which will then mesh later.  

● Make a surface from the outer edges into surface (Geometry Tab → Create/Modify Surface → 

Simple Surface)  
 

● Click on the “Inherit Part” button so that it is no longer checked  
 

● Rename the Surface as FLUID  
 

● Select the four curves  
 

● Click on OK or Apply  
 

● This surface might not actually be visible. On the left hand side of the screen is tree menu that 

controls what is and is not visible. If you want to see the surface simply go through the menu 

and ensure that under “Geometry” the “Surfaces” node is ticked.  
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Setting up the Initial Blocking 
 
To do this we need to apply what is known as a “blocking strategy”. In icemcfd for structured meshes 

the geometry is joined to a series of blocks which are then filled with the cells that make up the actual 

volumes on which the calculation will take place on. The process of meshing is therefore somewhat 

different from the CAD programs you will have used up to now as you are not trying to draw the part 

but the surrounding area which the fluid surrounds. 
 
● Go to the Blocking Tab  
 
● Click on “Create Block” and ensure in the “Initalize Blocks” drop down the type is 2D Planar and 

the part selected is “FLUID”. Click OK, A blue message saying “Initialize blocking done” should 

appear in the message window  
 
● This creates a Block which we then need to associate to various edges  
 
● In the Blocking Tab click on “Associate” (fifth tool from the left) then in the left hand menu that 

appears select “Associate Edge to Curve”. This should look a bit like  Figure 4 , note that in  Figure 4 

the points are not displayed.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 4: Setting up the Blocking 

 

● You now need to associate each side of the block one of the parts we made earlier. (INLET, 
OUTLET, TOP and BOTTOM). This must be done separately for each part. To do this: Click 

on the first edge (which is part of the blocking) and then the first curve (which is geometry). This is 
most easily done by left clicking and middle clicking - an on screen prompt guides as to which 

mouse button to press when.  
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Hint: This is a part of the tutorial that confuses people a lot. The edges (part of the blocking) and the 

curves (geometry) are actually on top of each other on the screen. Although they are physically 

coincident on the screen there is no logical connection between them until you make one using the 

associate tool. 
 
● We can now get icemcfd to do a crude initial first mesh. Go to the Mesh Tab → Part Mesh Setup 

and set the max size to be 0.1 on all the parts. Then go to the Blocking Tab → Pre-Mesh Params 
(9th from left) select the “Recalculate Sizes” tool and click ok. It may look like nothing has 
happened but a first mesh has been created!  

 
● To see it you need to make the mesh viewable. On the left hand side of the screen there is a tree 

menu with a white background. Expand the Blocking Menu and click on “Pre-Mesh” a square mesh 

that completely ignores the aerofoil should now appear. Clearly there is work to be done! You 

should now turn the Pre-Mesh view off to make manipulations easier.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 5: The Pre-Mesh View turned on. 

 

We now need to associate the face (the mesh) with the surface (the FLUID part we created earlier. 
 
● On the Blocking Tab select the Associate Vertices icon (fifth from left). In the tool that pops on the 

bottom left select Associate Face → Surface (fourth from left). Then select the face and the FLUID 

part in the pop up window.  
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Meshing the aerofoil 
 
Clearly we need some way to tell icemcfd that we would like the mesh associated with the aerofoil 

shape in the middle of the screen and to organise this mesh so that we end up with the right sort of 

mesh. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 6: Splitting the Original Block  
● First further divide up the Blocks. Blocking Tab → Split Block and then select the Split Block tool. 

Use this tool to split the block upstream and downstream of the aerofoil and above and below the 

trailing edge. Again left and middle clicking is the most efficient method. Your screen should look 

something like  Figure 6  
 
● Now we want to add a special type of block called an “Ogrid” around the aerofoil. Go to the 

Blocking Tab → Split Block (Second from left) and then select the Ogrid Block tool (Second item 

from left in the bottom left panel). After you have selected the tool you need to Click on Select 

Blocks.  
 
● Select the central block and the block on the middle right by using the left mouse then the middle 

mouse and two turquoise squares should appear in the centre of your screen. Now click on the Select 

Edge(s) option within the tool and then select the right hand most edge. A yellow square should 

appear on the right hand side. Click ok or apply to define a new O grid.  
 
● Now we should delete the central block as this is the aerofoil itself and not something that we actually 

want to calculate. Blocking Tab → Delete Block and left click on the central square and use middle 

mouse to get rid of it. Your screen should look something like  Figure 7 whilst you are doing this.  
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Figure 8: Trailing Edge Block Eliminated 
 
● On the left hand side of the screen there is that tree menu with a white background, if you click on 

Pre-Mesh you should be able to view the mesh again.  
 
● The mesh most likely still occupies the centre of the aerofoil, so we add a point to guide the program 

about where we would like the mesh to go. Blocking Tab → Edit Edge, then select the Split Edge 

tool and select Linear from the drop down menu.  
 
● This should look like  Figure 9.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 9: Setting up the Linear 

Point to nap the Mesh to the Outside 
of the Aerofoil 
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● At this point you will want to adjust the position of the vertices on the aerofoil so that it gives a 

more reasonable mesh. Blocking Tab → Move Vertex tool will accomplish this.  
 
● The Pre-Mesh Parameters tool (Blocking Tab → Pre-Mesh Parameters (Ninth from left) then the 

Edge Params Tool (Third from Left) should be used to add more points in various places. Until the 

mesh looks better.  
 
After some work and moving points around, along with changing the number of points, the mesh is 

shown in  Figure 10. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 
 

Figure 10: A First Attempt at the Mesh 
 
● A number of tools allow you to assess the mesh quality. Blocking Tab → Pre-Mesh Quality 

Histograms allow you to look at things like the worst element. A graph appears in the bottom right 

which you can click on to examine the the worst element then adjust the mesh spacing, the position 

of the vertices on the blocks and so on.  
 
● For our mesh this looks like  Figure 11.  
 
This isn't a great mesh and if you wanted to actually trust the results from it you'd need to do more 

work. 
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Figure 11: Finding the Lowest Quality Elements 

 

 

Step 4: Set Up Problem in FLUENT 

 

Launch FLUENT 

 

Start > Programs > Fluent Inc > FLUENT 6.3.26 

 

Select 2ddp from the list of options and click Run. 

 

Import File 
Main Menu > File > Read > Case... 

 

Navigate to your working directory and select the airfoil.msh file. Click OK. The 

following should appear in the FLUENT window: 



71 | P a g e  

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Check that the displayed information is consistent with our expectations of the airfoil grid. 

 

Analyze Grid 

 

Grid > Info > Size 

 

How many cells and nodes does the grid have? 

Display > Grid 

 
Note what the surfaces farfield1, farfield2, etc. correspond to by selecting and plotting them in turn. 

 

Zoom into the airfoil. 

 

Where are the nodes clustered? Why? 

 

Define Properties 

 

Define > Models > Solver... 

Under the Solver box, select Pressure Based. 
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Click OK. 

 

Define > Models > Viscous 

 

Select                                                    Inviscid under Model 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Click OK. 
 
Define > Models > Energy 

 

The speed of sound under SSL conditions is 340 m/s so that our freestream Mach number is around 0.15. 
This is low enough that we'll assume that the flow is incompressible. So the energy equation can be 
turned off. 

 

Make sure there is no check in the box next to Energy Equation and click OK. 

 

Define > Materials 

 

Make sure air is selected under Fluid Materials. Set Density to constant and equal to 1.225 kg/m3. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 



73 | P a g e  

 

 

Click Change/Create. 

 

Define > Operating Conditions 

 
We'll work in terms of gauge pressures in this example. So set Operating Pressure to the ambient value 
of 101,325 Pa. 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

Click OK. 
 

 

Define > Boundary Conditions 

 

Set farfield1 and farfield2 to the velocity-inlet boundary type. 

 

For each, click Set.... Then, choose Components under Velocity Specification Method and set the x- and 
y-components to that for the freestream. For instance, the x-component is 50*cos(1.2)=49.99. (Note that 
1.2° is used as our angle of attack instead of 2° to adjust for the error caused by assuming the airfoil to be 
2D instead of 3D.) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click OK. 

 
Set farfield3 to pressure-outlet boundary type, click Set... and set the Gauge Pressure at this boundary 
to 0. Click OK. 
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Step 5: Solve! 

 

Solve > Control > Solution 

 

Take a look at the options available. 

 

Under Discretization, set Pressure to PRESTO! and Momentum to Second-Order Upwind. 
 
 
 

 

 
 

 

 

 
 

 

 
 

Click OK. 

Solve > Initialize > Initialize... 

 

As you may recall from the previous tutorials, this is where we set the initial guess values (the base case) 
for the iterative solution. Once again, we'll set these values to be equal to those at the inlet. Select 
farfield1 under Compute From. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Click Init. 

 

Solve > Monitors > Residual... 
Now we will set the residual values (the criteria for a good enough solution). Once again, we'll set 
this value to 1e-06. 
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Click OK. 

 

Solve > Monitors > Force... 

 
Under Coefficient, choose Lift. Under Options, select Print and Plot. Then, Choose airfoil under Wall 
Zones. 

 

Lastly, set the Force Vector components for the lift. The lift is the force perpendicular to the direction of 
the freestream. So to get the lift coefficient, set X to -sin(1.2°)=-020942 and Y to cos(1.2°)=0.9998. 
 
 
 

 

 
 

 

 
 

 

 

 
Click Apply for these changes to take effect. 

 

Similarly, set the Force Monitor options for the Drag force. The drag is defined as the force component 

in the direction of the freestream. So under Force Vector, set X to cos(1.2°)=0.9998  

and Y to sin(1.2°)=0.020942 Turn on only Print for it. 
Report > Reference Values 
Now, set the reference values to set the base cases for our iteration. Select farfield1 under 
Compute From. 
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Click OK. 
Note that the reference pressure is zero, indicating that we are measuring gage pressure. 
 

 

Main Menu > File > Write > Case... 

 

Save the case file before you start the iterations. 

 

Solve > Iterate 

 

Make note of your findings, make sure you include data such as; What does 

the convergence plot look like? 

 
How many iterations does it take to converge? 

 

How does the Lift coefficient compared with the experimental data? 

 

Main Menu > File > Write > Case & Data... 

 

Save case and data after you have obtained a converged solution. 

Step 6: Analyze Results 

 

Lift Coefficient 

 

The solution converged after about 480 iterations. 

 

476 1.0131e-06 4.3049e-09 1.5504e-09 6.4674e-01 2.4911e-03 0:00:48 524 
477 solution is converged  

477 9.9334e-07 4.2226e-09 1.5039e-09 6.4674e-01 2.4910e-03 0:00:38 523  

 

From FLUENT main window, we see that the lift coefficient is 0.647. 
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Plot Velocity Vectors 

 

Let's see the velocity vectors along the airfoil. 

 

Display > Vectors 

 

Enter 4 next to Scale. Enter 3 next to Skip. Click Display. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
As can be seen, the velocity of the upper surface is faster than the velocity on the lower surface. 
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EXPERIMENT – 9 

FLOW OVER A SYMMETRIC AEROFOIL 
Introduction 
 
This provides a short step by step guide to meshing an aerofoil using the icemcfd package. The aim 

being to introduce you the important features of the program in the shortest possible space of time. The 

mesh that this tutorial produces will require further work to be used as a basis for serious calculations but 

this tutorial contains all the information that you need to do this. 
 
icemcfd is available on the University GNU/Linux service called vega. Once you have logged into vega 

you can start it from the command line using the command icemcfd. 
 
The initial screen looks something like: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1: The icemcfd screen.  
As well as the conventional display area and menus there are three areas of note: 
 

● Tabs: These provide access to broad categories of tools which enable the meshing to take 

place.  
 

● Tools: This area in the bottom left is where the tools are actually operated from  
 

● Tree: In this area a hierarchical list of points, lines and so on will be built up as you work 

with the software.  
 
icemcfd is a powerful package but does have something of a learning curve, so if something doesn't 
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work the first time review the steps you took carefully and try again. 
 
Importing the Geometry 
 
● Start icemcfd  
 
● Obtain the NACA 2412 coordinates file (this should be on the same page/folder where you 

obtained this document)  
 
● File → Import Geometry → Formatted point data (then select the file you just obtained) A good tip 

at this point is to go to File → Change Working Directory and change the directory to where you 

have stored the NACA data – this saves a lot of navigation through file dialogues later.  
 
● Then click apply in the bottom left corner of the screen  
 
● You should have a screen that looks like  Figure 2:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 2: Point Input to icemcfd 
 
● We then want to create a curve made of those points to describe the surface of aerofoil  
 

● Under the Geometry tab in the top centre of the screen click on the Create/Modify Curve 

button  
 

● This pops a new menu in the bottom left. Click on the top left icon underneath “Inherit Part”, This 

is the “From Points” tool. Click on “Inherit Part” to deselect it and name the part SUCTION.  
 

● You should then select each point on the top of the curve one after the other with the left mouse 

button. (There ought to be a better way of doing this but I can't seem to find it!) You might need 

to zoom in to get all the points in the trailing edge. The middle mouse button accepts your final 

selection  
 

Hint: Pressing F9 suspends the Selection Mode and allows you to use the mouse to control the 

view, hitting F9 again puts you back into Selection Mode. 
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● Repeat the process for the points on the bottom of the curve. Name this PRESSURE. 

 

● Then we want to create the surface on which we will calculate the fluid flow. To do this we will 

create a domain around 1 chord lengths above and below the aerofoil and 1.5 chord lengths before 

and after. This is slightly arbitrary and we may want to change this after we look at the results!  
 
● Add points at (-1.5,1),(-1.5,-1),(2,1) and (2,-1) Click on the Create Point tool under the geometry tab 

and use the Explicit Locations tool to do this.  
 
● Join these points together with straight lines. Label the left hand one INLET, the right hand line EXIT 

and the upper and lower parts TOP and BOTTOM. Your screen should look like  Figure 3.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3: Aerofoil and Calculation Domain. 
 
● We are going to construct an outer surface called FLUID which will then mesh later.  
 
● Make a surface from the outer edges into surface (Geometry Tab → Create/Modify Surface → 

Simple Surface)  
 

● Click on the “Inherit Part” button so that it is no longer checked  
 

● Rename the Surface as FLUID  
 

● Select the four curves  
 

● Click on OK or Apply  
 

● This surface might not actually be visible. On the left hand side of the screen is tree menu that 

controls what is and is not visible. If you want to see the surface simply go through the menu 

and ensure that under “Geometry” the “Surfaces” node is ticked.  
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Setting up the Initial Blocking 
 
To do this we need to apply what is known as a “blocking strategy”. In icemcfd for structured meshes 

the geometry is joined to a series of blocks which are then filled with the cells that make up the actual 

volumes on which the calculation will take place on. The process of meshing is therefore somewhat 

different from the CAD programs you will have used up to now as you are not trying to draw the part 

but the surrounding area which the fluid surrounds. 
 
● Go to the Blocking Tab  
 
● Click on “Create Block” and ensure in the “Initalize Blocks” drop down the type is 2D Planar and 

the part selected is “FLUID”. Click OK, A blue message saying “Initialize blocking done” should 

appear in the message window  
 
● This creates a Block which we then need to associate to various edges  
 
● In the Blocking Tab click on “Associate” (fifth tool from the left) then in the left hand menu that 

appears select “Associate Edge to Curve”. This should look a bit like  Figure 4 , note that in  Figure 4 

the points are not displayed.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 4: Setting up the Blocking 

 

● You now need to associate each side of the block one of the parts we made earlier. (INLET, 
OUTLET, TOP and BOTTOM). This must be done separately for each part. To do this: Click 

on the first edge (which is part of the blocking) and then the first curve (which is geometry). This is 
most easily done by left clicking and middle clicking - an on screen prompt guides as to which 

mouse button to press when.  
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Hint: This is a part of the tutorial that confuses people a lot. The edges (part of the blocking) and the 

curves (geometry) are actually on top of each other on the screen. Although they are physically 

coincident on the screen there is no logical connection between them until you make one using the 

associate tool. 
 
● We can now get icemcfd to do a crude initial first mesh. Go to the Mesh Tab → Part Mesh Setup 

and set the max size to be 0.1 on all the parts. Then go to the Blocking Tab → Pre-Mesh Params 
(9th from left) select the “Recalculate Sizes” tool and click ok. It may look like nothing has 
happened but a first mesh has been created!  

 
● To see it you need to make the mesh viewable. On the left hand side of the screen there is a tree 

menu with a white background. Expand the Blocking Menu and click on “Pre-Mesh” a square mesh 

that completely ignores the aerofoil should now appear. Clearly there is work to be done! You 

should now turn the Pre-Mesh view off to make manipulations easier.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 5: The Pre-Mesh View turned on. 

 

We now need to associate the face (the mesh) with the surface (the FLUID part we created earlier. 
 
● On the Blocking Tab select the Associate Vertices icon (fifth from left). In the tool that pops on the 

bottom left select Associate Face → Surface (fourth from left). Then select the face and the FLUID 

part in the pop up window.  
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Meshing the aerofoil 
 
Clearly we need some way to tell icemcfd that we would like the mesh associated with the aerofoil 

shape in the middle of the screen and to organise this mesh so that we end up with the right sort of 

mesh. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 6: Splitting the Original Block  
● First further divide up the Blocks. Blocking Tab → Split Block and then select the Split Block tool. 

Use this tool to split the block upstream and downstream of the aerofoil and above and below the 

trailing edge. Again left and middle clicking is the most efficient method. Your screen should look 

something like  Figure 6  
 
● Now we want to add a special type of block called an “Ogrid” around the aerofoil. Go to the 

Blocking Tab → Split Block (Second from left) and then select the Ogrid Block tool (Second item 

from left in the bottom left panel). After you have selected the tool you need to Click on Select 

Blocks.  
 
● Select the central block and the block on the middle right by using the left mouse then the middle 

mouse and two turquoise squares should appear in the centre of your screen. Now click on the Select 

Edge(s) option within the tool and then select the right hand most edge. A yellow square should 

appear on the right hand side. Click ok or apply to define a new O grid.  
 
● Now we should delete the central block as this is the aerofoil itself and not something that we actually 

want to calculate. Blocking Tab → Delete Block and left click on the central square and use middle 

mouse to get rid of it. Your screen should look something like  Figure 7 whilst you are doing this.  
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Figure 8: Trailing Edge Block Eliminated 
 
● On the left hand side of the screen there is that tree menu with a white background, if you click on 

Pre-Mesh you should be able to view the mesh again.  
 
● The mesh most likely still occupies the centre of the aerofoil, so we add a point to guide the program 

about where we would like the mesh to go. Blocking Tab → Edit Edge, then select the Split Edge 

tool and select Linear from the drop down menu.  
 
● This should look like  Figure 9.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 9: Setting up the Linear Point to  

nap the Mesh to the Outside of the 

Aerofoil 
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● At this point you will want to adjust the position of the vertices on the aerofoil so that it gives a 

more reasonable mesh. Blocking Tab → Move Vertex tool will accomplish this.  
 
● The Pre-Mesh Parameters tool (Blocking Tab → Pre-Mesh Parameters (Ninth from left) then the 

Edge Params Tool (Third from Left) should be used to add more points in various places. Until the 

mesh looks better.  
 
After some work and moving points around, along with changing the number of points, the mesh is 

shown in  Figure 10. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 
 

Figure 10: A First Attempt at the Mesh 
 

 

 

● A number of tools allow you to assess the mesh quality. Blocking Tab → Pre-Mesh Quality 

Histograms allow you to look at things like the worst element. A graph appears in the bottom right 

which you can click on to examine the the worst element then adjust the mesh spacing, the position 

of the vertices on the blocks and so on.  
 
● For our mesh this looks like  Figure 11.  
 
This isn't a great mesh and if you wanted to actually trust the results from it you'd need to do more work. 
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Figure 11: Finding the Lowest Quality Elements 
 
 
Step 4: Set Up Problem in FLUENT 

 

Launch FLUENT 

 

Start > Programs > Fluent Inc > FLUENT 6.3.26 

 

Select 2ddp from the list of options and click Run. 

 

Import File 

 

Main Menu > File > Read > Case... 

 

Navigate to your working directory and select the airfoil.msh file. Click OK. The following 

should appear in the FLUENT window: 
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Check that the displayed information is consistent with our expectations of the airfoil grid. 

 

Analyze Grid 

 

Grid > Info > Size 

 

How many cells and nodes does the grid have? 

Display > Grid 

 
Note what the surfaces farfield1, farfield2, etc. correspond to by selecting and plotting them in turn. 

 

Zoom into the airfoil. 

 

Where are the nodes clustered? Why? 

 

Define Properties 

 

Define > Models > Solver... 

Under the Solver box, select Pressure Based. 
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Click OK. 

 

Define > Models > Viscous 

 

Select                                                    Inviscid under Model 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Click OK. 
 
Define > Models > Energy 

 

The speed of sound under SSL conditions is 340 m/s so that our freestream Mach number is around 0.15. 
This is low enough that we'll assume that the flow is incompressible. So the energy equation can be 
turned off. 

 

Make sure there is no check in the box next to Energy Equation and click OK. 

 

Define > Materials 

 

Make sure air is selected under Fluid Materials. Set Density to constant and equal to 1.225 kg/m3. 
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Click Change/Create. 

 

Define > Operating Conditions 

 
We'll work in terms of gauge pressures in this example. So set Operating Pressure to the ambient value 
of 101,325 Pa. 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

Click OK. 
 

 

Define > Boundary Conditions 

 

Set farfield1 and farfield2 to the velocity-inlet boundary type. 

 

For each, click Set.... Then, choose Components under Velocity Specification Method and set the x- and 
y-components to that for the freestream. For instance, the x-component is 50*cos(1.2)=49.99. (Note that 
1.2° is used as our angle of attack instead of 2° to adjust for the error caused by assuming the airfoil to be 
2D instead of 3D.) 
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Click OK. 

 

Set farfield3 to pressure-outlet boundary type, click Set... and set the Gauge Pressure at this boundary 
to 0. Click OK. 

 

Step 5: Solve! 
Solve > Control > Solution 

Take a look at the options available. 
Under Discretization, set Pressure to PRESTO! and Momentum to Second-Order Upwind. 
 
 
 

 

 

 
 

 

 
 

 

 
 

Click OK. 

Solve > Initialize > Initialize... 

 

As you may recall from the previous tutorials, this is where we set the initial guess values (the base case) 
for the iterative solution. Once again, we'll set these values to be equal to those at the inlet. Select 
farfield1 under Compute From. 
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Click Init. 

 

Solve > Monitors > Residual... 
Now we will set the residual values (the criteria for a good enough solution). Once again, we'll set 
this value to 1e-06. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 

 

 
Click OK. 

 

Solve > Monitors > Force... 

 
Under Coefficient, choose Lift. Under Options, select Print and Plot. Then, Choose airfoil under Wall 
Zones. 

 

Lastly, set the Force Vector components for the lift. The lift is the force perpendicular to the direction of 
the freestream. So to get the lift coefficient, set X to -sin(1.2°)=-020942 and Y to cos(1.2°)=0.9998. 
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Click Apply for these changes to take effect. 

 

Similarly, set the Force Monitor options for the Drag force. The drag is defined as the force component 

in the direction of the freestream. So under Force Vector, set X to cos(1.2°)=0.9998  

and Y to sin(1.2°)=0.020942 Turn on only Print for it. 
Report > Reference Values 
Now, set the reference values to set the base cases for our iteration. Select farfield1 under 
Compute From. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click OK.Note that the reference pressure is zero, indicating that we are measuring gage pressure. 
 

 

Main Menu > File > Write > Case... 

 

Save the case file before you start the iterations. 

 

Solve > Iterate 
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Make note of your findings, make sure you include data such as; What does 

the convergence plot look like? 

 
How many iterations does it take to converge? 

 

How does the Lift coefficient compared with the experimental data? 

 

Main Menu > File > Write > Case & Data... 

 

Save case and data after you have obtained a converged solution. 

Step 6: Analyze Results 

 

Lift Coefficient 

 

The solution converged after about 480 iterations. 

 

476 1.0131e-06 4.3049e-09 1.5504e-09 6.4674e-01 2.4911e-03 0:00:48 524 
477 solution is converged  

477 9.9334e-07 4.2226e-09 1.5039e-09 6.4674e-01 2.4910e-03 0:00:38 523  

 

From FLUENT main window, we see that the lift coefficient is 0.647. 
 
 
Plot Velocity Vectors 

 

Let's see the velocity vectors along the airfoil. 

 

Display > Vectors 

 

Enter 4 next to Scale. Enter 3 next to Skip. Click Display. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
As can be seen, the velocity of the upper surface is faster than the velocity on the lower surface. 
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EXPERIMENT - 10 

SHOCK WAVE AROUND A CONE 

 
Aim: To observe the shock wave phenomena and change of properties around a cone at supersonic Mach 

number. 
 

We will create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem. 

 

 

➢ Create or import Geometry  

➢ Block the geometry 

➢ Associate entities to the geometry. 

➢ Apply mesh parameters. 

➢ Generate the initial mesh. 

➢ Export mesh  

 

Start ICEM CFD  

 

Create Geometry in ICEM CFD 
 

1) Close any previous files, have blank screen in ICEM. 

2) Create new project file for the pipe in ICEM: 
a) File, New Project. 

b) Select folders in turn: Desktop, CFX Training Files – Copy, Flat plate. 

c) Save project with name “Flat plate” in folder “Flat plate”. 

3) We are going to create some points now: 
a) Select Geometry tab at top of screen. 

b) Select “Create Point” option. 

c) In the bottom left are various options for creating the point. Select the second “XYZ” option. 
d) Input the numbers X=0, Y=0, Z=0. 

e) Press “Apply” to create a point on screen 

f) Note - If the point does not appear, then check that points are displayed in the tree, and use 
the “Fit Window” option in the top left to zoom the screen correctly. 

 

Create points  

Explicit location > specify x and y location and click ok  
Similarly create required  points  

Note that for a 2D problem, the z-coordinate can always be left to the default value of 0. 

 

Create curves  

 

Under “Geometry” tab, select “Create and modify curve”. 
b) Under “Create and modify curve” option panel on bottom left, select 3rd option “ 
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Select two points on the screen and select ok Create remaining curves  
 

Create surface  

 

Simple surface – from 2-4 curves  
To check surface click on solid frame  

 

Label the curves 

 

Give names to the INLET, OUTLET and WALL surfaces: 

a) Under “Geometry” tree, highlight only “Surfaces”. 
b) Right click “Parts”, Create Part. 

c) Part = “INLET”. 

d) Entities: click arrow icon, left click surface (near surface, around origin) to highlight it, middle 

click to save selection, right click to de-select mode. 
e) Note that the INLET part has been created, and can be turned on and off independently 

using the tree view. 

f) Part = “OUTLET”, repeat step to identify an outlet at the far end. 
g) Part = “WALL”, repeat step to identify the wall. 

h) Notes: “GEOM” now contains only 0D and 1D elements; points and lines. 

 
Block the Geometry 

 

The geometry and part information has already been defined for this tutorial. You will create the initial block 

in this step. 
1. Create the initial block. 

Blocking > Create Block > Initialize Blocks 

a. Enter FLUID in the Part field. 
b. Select 2D Planar in the Type drop-down list. 

c. Click Apply. 

 

Associate Entities to the Geometry 

 

You will associate the edges of the blocking to the curves of the CAD geometry in this step. First select the 

edges and then the curves to which you want to associate them. 
1. Associate the inlet, the left-most end of the large flat plate. 

a. Ensure that Project Vertices is disabled. 

b. Click (Select edge(s)) and select edge 13–41. Click the middle-mouse button to accept the selection. 
 

c. Click (Select compcurve(s)) and select CURVES/1 . Click the middle-mouse button to accept the selection. 

d. Click Apply. 

The associated edge will be colored green. 
 

Generate the Initial Mesh 

 

Blocking > Pre-Mesh Params > Update Sizes 

1. Retain the selection of Update All in the Method list. 
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Note 
This will automatically determine the number of nodes on the edges from the mesh 

sizes set on the curves. 

2. Select Run Check/Fix Blocks to check for mesh problems automatically and repair them if possible. 

3. Click Apply. 
4. Enable Pre-Mesh. 

 

Blocking Pre-Mesh 
 

The Mesh dialog will appear, asking if you want to recompute the mesh. 

5. Click Yes in the Mesh dialog to compute the initial mesh. 
6. Disable Vertices and Edges. 

 

Verify and Save the Mesh and Blocking 

 
1. Convert the mesh to unstructured format. 

Blocking Pre-Mesh Convert to Unstruct Mesh 

2. Save the blocking file (2D- Flat plate -geometry-final.blk). 
 

File > Blocking > Save Blocking As... 

 
This block file can be loaded in a future session (File > Blocking > Open Blocking...) for additional 

modification or to mesh a similar geometry. Save each blocking to a separate file instead of overwriting 

a previous one. In more complex models, you may have to back track and load a previous blocking. 

3. Save the project file (2D-flat plate-geometry-final.prj). 
File > Save Project As... 

This will save all the files—tetin, blocking, and unstructured mesh. 

4. Exit the current session. 
File > Exit 

Save your ICEM CFD file in your working directory. 

 

Setting Up the CFD Simulation in ANSYS FLUENT 

Now that you have created a computational mesh for the elbow geometry, you can proceed to setting up a CFD 

analysis using ANSYS FLUENT. 

1.   Start ANSYS FLUENT. 

In the ANSYS Workbench Project Schematic, double-click the Setup cell in the elbow fluid flow analysis 

system. You can also right-click on the Setup cell to display the context menu where you can select 

the Edit option. 

When ANSYS FLUENT is first started, FLUENT Launcher is displayed, allowing you to view and/or set 

certain ANSYS FLUENT start-up options. 

   ANSYS FLUENT Launcher allows you to decide which version of ANSYS FLUENT you will use, based on 

your geometry and on your processing capabilities. 

(a) Ensure that the proper options are enabled. 



97 | P a g e  

 

 

Note that the Dimension setting is already filled in and cannot be changed, since ANSYS 

FLUENT automatically sets it based on the mesh or geometry for the current system. 

i.   Make sure that Serial from the Processing Options list is enabled. 

ii.   Make sure that the Display Mesh After Reading, Embed Graphics Windows, and Workbench 

Color Scheme options are enabled. 

iii.   Make sure that the Double-Precision option is disabled. 

(b)   Click OK to launch ANSYS FLUENT. 

2.   Set some general settings for the CFD analysis. 

  Select General in the navigation pane to perform the mesh-related activities and to choose a solver. 

 General 

 

(a)   Change the units for length. 

Since we want to specify and view values based on a unit of length in inches from within ANSYS FLUENT, 

change the units of length within ANSYS FLUENT from meters (the default) to inches. 

 General  Units... 

This displays the Set Units dialog box. 

 

i.   Select length in the Quantities list. 

ii.   Select in in the Units list. 

iii.   Close the dialog box. 

   Now, all subsequent inputs that require a value based on a unit of length can be specified in inches rather than 

meters. 

(b)   Check the mesh. 

 General  Check 

   ANSYS FLUENT will report the results of the mesh check in the console. 

3.   Set up your models for the CFD simulation. 

 Models 
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(a)   Enable heat transfer by activating the energy equation. 

 Models   Energy  Edit... 

 

   You can also double-click a list item in order to open the corresponding dialog box. 

i.   Enable the Energy Equation option. 

ii.   Click OK to close the Energy dialog box. 

(b)   Enable the -  turbulence model. 

 Models   Viscous  Edit... 

 

i.   Select k-epsilon from the Model list. 

   The Viscous Model dialog box will expand. 

ii.   Select Realizable from the k-epsilon Model list. 

iii.   Click OK to accept the model and close the Viscous Model dialog box. 

4.   Set up your materials for the CFD simulation. 

 Materials 

 

(a) Create a new material called air  using the Create/Edit Materials dialog box. 

(b)  Materials   Fluid  Create/Edit... 

i.   Enter air for Name. 

ii.    specify the properties  

iii.   Click Change/Create. 

 

  5.   Set up the cell zone conditions for the CFD simulation. 

 Cell Zone Conditions 
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(a)   Set the cell zone conditions for the fluid zone. 

i.   Select fluid in the Zones list in the Cell Zone Conditions task page, then click the Edit... button to open 

the Fluid dialog box. 

   You can also double-click a list item in order to open the corresponding dialog box. 

 

ii.   In the Fluid dialog box, select water from the Material Name drop-down list. 

iii.   Click OK to close the Fluid dialog box. 

6.   Set up the boundary conditions for the CFD analysis. 

 Boundary Conditions 

 

(a)   Set the boundary conditions at the cold inlet (velocity-inlet-large). 

 Boundary Conditions   velocity-inlet-large  Edit... 

Hint:   If you are unsure of which inlet zone corresponds to the cold inlet, you can probe the mesh display using 

the right mouse button or the probe toolbar button (  ) as described in a previous step. The information will 
be displayed in the ANSYS FLUENT console, and the zone you probed will be automatically selected from 

the Zone selection list in the Boundary Conditions task page. 

 

i.   Select Components from the Velocity Specification Method drop-down list. 

  The Velocity Inlet dialog box will expand. 

ii.   Enter 0.4 m/s for X-Velocity. 

iii.   Retain the default value of 0 m/s for both Y-Velocity and Z-Velocity. 

7.   Set up solution parameters for the CFD simulation. 

  In the steps that follow, you will set up and run the calculation using the task pages listed under 

the Solution heading in the navigation pane. 

(a)   Change the convergence criteria for the continuity equation residual. 

 Monitors   Residuals  Edit... 

 

i.   Make sure that Plot is enabled in the Options group box. 
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ii.   Enter 1e-05 for the Absolute Criteria of continuity, as shown in the Residual Monitor dialog box. 

iii.   Click OK to close the Residual Monitors dialog box. 

Note:   By default, all variables will be monitored and checked by ANSYS FLUENT as a means to determine 

the convergence of the solution. 

(b)   Initialize the flow field, using the boundary conditions settings at the cold inlet ( velocity-inlet-large) as a 

starting point. 

 Solution Initialization 

 

i.   Select velocity-inlet-large from the Compute From drop-down list. 

ii.   Enter 1.2 m/s  for Y Velocity in the Initial Values group box. 

Note:   While an initial X Velocity is an appropriate guess for the horizontal section, the addition of a Y 

Velocity component will give rise to a better initial guess throughout the entire elbow. 

iii.   Click Initialize. 

(c)   Check to see if the case conforms to best practices. 

 Run Calculation  Check Case 

8.   Calculate a solution. 

(a)   Start the calculation by requesting 250 iterations. 

 Run Calculation 

 

i.   Enter 250 for Number of Iterations. 

ii.   Click Calculate. 

  As the calculation progresses, the residuals will be plotted in the graphics window  
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9.   View the files generated by ANSYS Workbench. 
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EXPERIMENT - 11 

ONE DIMENSIONAL WAVE EQUATION USING EXPLICIT METHOD OF LAX 

The wave equation considered here is an extremely simplified model of the physics of waves. Many facts 

about waves are not modeled by this simple system, including that wave motion in water can depend on 
the depth of the medium, that waves tend to disperse, and that waves of different frequency may travel at 

different speeds. However, as a first model of wave motion, the equation is useful because it captures a 

most interesting feature of waves, that is, their usefulness in transmitting signals. 

This program solves the 1D wave equation of the form: 

        Utt = c^2 Uxx 

% matlab script waveeq1dfd.m 
% finite difference scheme for the 1D wave equation  

% fixed boundary conditions 

% raised cosine initial conditions 
%%%%%% begin global parameters 

 

SR = 44100;                       % sample rate (Hz) 
f0 = 441;                         % fundamental frequency (Hz) 

TF = 1;                           % duration of simulation (s) 

ctr = 0.7; wid = 0.1;             % center location/width of excitation 

u0 = 1; v0 = 0;                   % maximum initial displacement/velocity 
rp = 0.3;                         % position of readout (0-1) 

lambda = 1;                       % Courant number 

gamma = 2*f0;                     % wave equation free parameter 
k = 1/SR;                         % time step 

NF = floor(SR*TF);                % duration of simulation (samples) 

% stability condition/scheme parameters 

 
h = gamma*k/lambda; N = floor(1/h); h = 1/N; lambda = gamma*k/h;          

s0 = 2*(1-lambda^2); s1 = lambda^2;        

rp_int = 1+floor(N*rp);           % rounded grid index for readout 
rp_frac = 1+rp/h-rp_int;          % fractional part of readout location 

xax = [0:N]'*h; 

ind = sign(max(-(xax-ctr-wid/2).*(xax-ctr+wid/2),0)); 
rc = 0.5*ind.*(1+cos(2*pi*(xax-ctr)/wid)); 

 

% initialize grid functions and output 

 
u2 = u0*rc; u1 = (u0+k*v0)*rc; u = zeros(N+1,1); out = zeros(NF,1); 

for n=3:NF 

    u(2:N) = -u2(2:N)+s0*u1(2:N)+s1*(u1(1:N-1)+u1(3:N+1));  % scheme calculation 
    out(n) = (1-rp_frac)*u(rp_int)+rp_frac*u(rp_int+1);     % readout 

    u2 = u1; u1 = u;                                        % update of grid variables 

end 
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EXPERIMENT - 12 

ONE DIMENSIONAL HEAT CONDUCTION EQUATION USING EXPLICIT METHOD 

L=1; 
t=1; 

k=.001; 

n=11; 

nt=500; 
dx=L/n; 

dt=.002; 

alpha=k*dt/dx^2; 
T0(1)=400; 

for j=1:nt 

    for i=2:n 

        T1(i)=T0(i)+alpha*(T0(i+1)-2*T0(i)+T0(i-1)); 
    end 

    T0=T1; 

end 
plot(x,T1) 

 

 

 

 


