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INSTITUTE OF AERONAUTICAL ENGINEERING 
(Autonomous) 

       Dundigal, Hyderabad - 500 043 

 
 

Vision 
To bring forth professionally competent and socially sensitive engineers, capable of working across 

cultures meeting the global standards ethically. 
 

 

Mission 
To provide students with an extensive and exceptional education that prepares them to excel in their 

profession, guided by dynamic intellectual community and be able to face the technically complex 

world with creative leadership qualities. 
 

Further, be instrumental in emanating new knowledge through innovative research that emboldens 

entrepreneurship and economic development for the benefit of wide spread community. 

 

 

Quality Policy 
Our policy is to nurture and build diligent and dedicated community of engineers providing a 

professional and unprejudiced environment, thus justifying the purpose of teaching and satisfying the 

stake holders. 
 

A team of well qualified and experienced professionals ensure quality education with its practical 

application in all areas of the Institute.   

 

 

Philosophy 
The essence of learning lies in pursuing the truth that liberates one from the darkness of ignorance and 

Institute of Aeronautical Engineering firmly believes that education is for liberation. 
 

Contained therein is the notion that engineering education includes all fields of science that plays a 

pivotal role in the development of world-wide community contributing to the progress of civilization. 

This institute, adhering to the above understanding, is committed to the development of science and 

technology in congruence with the natural environs. It lays great emphasis on intensive research and 

education that blends professional skills and high moral standards with a sense of individuality and 

humanity. We thus promote ties with local communities and encourage transnational interactions in 

order to be socially accountable. This accelerates the process of transfiguring the students into 

complete human beings making the learning process relevant to life, instilling in them a sense of 

courtesy and responsibility. 
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INSTITUTE OF AERONAUTICAL ENGINEERING 
(Autonomous) 

Dundigal, Hyderabad - 500 043 

 
 

 
Program Outcomes – (Common for all branches) 

 

PO1 Engineering knowledge: Apply the knowledge of mathematics, science, engineering 

fundamentals, and an engineering specialization to the solution of complex engineering 

problems. 

PO2 Problem analysis: Identify, formulate, review research literature, and analyze complex 

engineering problems reaching substantiated conclusions using first principles of 

mathematics, natural sciences, and engineering sciences. 
PO3 Design/development of solutions: Design solutions for complex engineering problems and 

design system components or processes that meet the specified needs with appropriate 

consideration for the public health and safety, and the cultural, societal, and environmental 

considerations.  
PO4 Conduct investigations of complex problems: Use research-based knowledge and research 

methods including design of experiments, analysis and interpretation of data, and synthesis of 

the information to provide valid conclusions.  

PO5 Modern tool usage: Create, select, and apply appropriate techniques, resources, and modern 

engineering and IT tools including prediction and modeling to complex engineering activities 

with an understanding of the limitations.  

PO6 The engineer and society: Apply reasoning informed by the contextual knowledge to assess 

societal, health, safety, legal and cultural issues and the consequent responsibilities relevant 

to the professional engineering practice.  
PO7 Environment and sustainability: Understand the impact of the professional engineering 

solutions in societal and environmental contexts, and demonstrate the knowledge of, and need 

for sustainable development.  

PO8 Ethics: Apply ethical principles and commit to professional ethics and responsibilities and 

norms of the engineering practice. 

PO9 Individual and team work: Function effectively as an individual, and as a member or leader 

in diverse teams, and in multidisciplinary settings.  

PO10 Communication: Communicate effect tively on complex engineering activities with the 

engineering community and with society at large, such as, being able to comprehend and 

write effective reports and design documentation, make effective presentations, and give and 

receive clear instructions.  

PO11 Project management and finance: Demonstrate knowledge and understanding of the 

engineering and management principles and apply these to one’s own work, as a member and 

leader in a team, to manage projects and in multidisciplinary environments.  

PO12 Life-long learning: Recognize the need for, and have the preparation and ability to engage in 

independent and life-long learning in the broadest context of technological change.  
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INSTITUTE OF AERONAUTICAL ENGINEERING 
 (Autonomous) 

Dundigal, Hyderabad - 500 043 

 

 

 
Program Specific Outcomes - Aeronautical  Engineering 

 

PSO1 Professional skills: Able to utilize the knowledge of aeronautical/aerospace engineering in 

innovative, dynamic and challenging environment for design and development of new products 

PSO2 Problem solving skills: imparted through simulation language skills and general purpose CAE 

packages to solve practical, design and analysis problems of components to complete the 

challenge of airworthiness for flight vehicles 

PSO3 Practical implementation and testing skills: Providing different types of in house and training 

and industry practice to fabricate and test and develop the products with more innovative 

technologies. 
PSO4 Successful career and entrepreneurship: To prepare the students with broad aerospace 

knowledge to design and develop systems and subsystems of aerospace and allied systems and 

become technocrats 

 
Program Specific Outcomes - Computer Science and Engineering 

 

PSO1 Professional Skills: The ability to research, understand and implement computer programs in 

the areas related to algorithms, system software, multimedia, web design, big data analytics, and 

networking for efficient analysis and design of computer-based systems of varying complexity. 

PSO2 Problem-Solving Skills: The ability to apply standard practices and strategies in software 

project development using open-ended programming environments to deliver a quality product 

for business success. 
PSO3 Successful Career and Entrepreneurship: The ability to employ modern computer languages, 

environments, and platforms in creating innovative career paths, to be an entrepreneur, and a 

zest for higher studies. 

 
Program Specific Outcomes - Information Technology 

 

PSO1 Professional Skills: The ability to research, understand and implement computer programs 

in the areas related to algorithms, system software, multimedia, web design, big data 

analytics, and networking for efficient analysis and design of computer-based systems of 

varying complexity. 

PSO2 Problem-Solving Skills: The ability to apply standard practices and strategies in software 

project development using open-ended programming environments to deliver a quality 

product for business success. 

PSO3 Successful Career and Entrepreneurship: The ability to employ modern computer 

languages, environments, and platforms in creating innovative career paths, to be an 

entrepreneur, and a zest for higher studies. 

`  
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Program Specific Outcomes - Electronics and Communication Engineering 

 

PSO1 Professional Skills: An ability to understand the basic concepts in Electronics & 

Communication Engineering and to apply them to various areas, like Electronics, 

Communications, Signal processing, VLSI, Embedded systems etc.,  in the design and 

implementation of complex systems. 

PSO2 Problem-solving Skills: An ability to solve complex Electronics and communication 

Engineering problems,  using latest hardware and software tools, along with analytical skills to 

arrive  cost effective and appropriate solutions. 

PSO3 Successful Career and Entrepreneurship: An understanding of social-awareness & 

environmental-wisdom along with ethical responsibility to have a successful career and to 

sustain passion and zeal for real-world applications using optimal resources as an Entrepreneur 

 
Program Specific Outcomes - Electrical and Electronics Engineering 

 

PSO1 Professional Skills:Able to utilize the knowledge of high voltage engineering in collaboration 

with power systems in innovative, dynamic and challenging environment, for the research based 

team work. 
PSO2 Problem-Solving Skills: Can explore the scientific theories, ideas, methodologies and the new 

cutting edge technologies in renewable energy engineering, and use this erudition in their 

professional development and gain sufficient competence to solve the current and future energy 

problems universally. 

PSO3 Successful Career and Entrepreneurship: The understanding of technologies like PLC, PMC, 

process controllers, transducers and  HMI one can  analyze, design  electrical and electronics 

principles to install, test , maintain power system and applications. 

 
Program Specific Outcomes - Mechanical  Engineering 

 

PSO1 To produce engineering professional capable of analyzing and synthesizing mechanical systems 

including allied engineering streams. 
PSO2 An ability to adopt and integrate current technologies in the design and manufacturing domain 

to enhance the employability. 
PSO3 To build the nation, by imparting technological inputs and managerial skills to become 

technocrats. 

 
Program Specific Outcomes - Civil Engineering 

 

PSO1 Understanding: Graduates will have an ability to understand, analyze and solve problems using 

basic mathematics and apply the techniques related to irrigation, structural design, etc. 

PSO2 Analytical Skills: Graduates will have an ability to design civil structures, using construction 

components and to meet desired needs within realistic constraints such as economic, 

environmental, social, political, ethical, health and safety manufacturability and reliability and 

learn to work with multidisciplinary teams. 
PSO3 Broadness: Graduates will have an exposure to various fields of engineering necessary to 

understand the impact of other disciplines on civil engineering blueprints in a global, economic, 

and societal context and to have necessary focus for postgraduate education and research 

opportunities at global level. 
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WEEK: 1    DISASSEMBLING AND ASSEMBLING 

Introduction to Computer Hardware: A COMPUTER is an electronic device that has the ability to 

store, retrieve process data and can be programmed with instructions that it remembers. In other words, 

the computer is a machine that processes data according to a set of instructions that are stored internally 

either temporarily or permanently. Hardware is the physical appearance of the devices or tools. It is what 

which we can touch and feel.  

 

Block Diagram of Computer 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Areas of Applications  

 Education  

 Banking  

 Multimedia  

 Transport  

 Industries  

 Communications  

 Space Technologies  

 Medical & Research  

 Science & Engineering  
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Data: Data is a collection of numbers, alphabets or some facts and numbers. Information: Information is 

obtained from data after a program processes it. Generations of Computers 1st generation :( 1946-

1954) computers were based on vacuum tubes. 2nd generation :( 1955-1964) computers were based on 

transistors. 3rd generation: (1965-1974) computers were based on Integrated circuits(IC‘s). 4th 

generation: (1975- till date) computers are microprocessors based. 

 5th generation computers are artificial intelligence (AI) based.  

Computer Hardware consists of the monitor, CPU, Keyboard, Mouse and all other devices connected to 

the computer either externally or internally.  

 

A typical computer (personal computer, PC) consists of a desktop or tower case (chassis) and the 

following parts:  
1.     CPU-The central processing unit contains the heart of any computer, the processor. The 

processor is fitted on to a Mother Board. The Mother Board contains various components,    

which support the functioning of a PC.  

 

2. System board/Motherboard which holds the Processor, Random Access 

Memory and other parts, and has slots for expansion cards  

 

 

 

3. RAM (Random Access Memory) - for program execution and short term data-storage, so the 

computer doesn't have to take the time to access the hard drive to find something. More RAM 

can contribute to a faster PC.  

 

 

 

 

4. 3.Buses: PCI bus, PCI-E bus, ISA bus (outdated), USB, AGP  

5. Power Supply - a case that holds a transformer, voltage control and fan  

 

 

 

 

6. Storage controllers, of IDE, SCSI or other type, that control hard disk, floppy disk, CD-ROM 

and other drives; the controllers sit directly on the motherboard (on-board) or on expansion 

cards  

7. Video display controller that produces the output for the computer display  

8. Computer bus controllers (parallel, serial, USB, Fire wire) to connect the computer to external 

peripheral devices such as printers or scanners  

9. Some type of a removable media writer:  

10. CD - the most common type of removable media, cheap but fragile.  
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11. Floppy disk 

 

 

 

12. Tape Drive - mainly for backup and long-term storage  

13. Internal storage - keeps data inside the computer for later use.  

14. Hard disk - for medium-term storage of data. 

 

 

 

15. Disk array controller 

 

 

16. Sound card - translates signals from the system board into analog voltage levels, and has 

terminals to plug in speakers.  

17. Networking - to connect the computer to the Internet and/or other computers  

18. Modem - for dial-up connections  

19. Network card - for DSL/Cable internet, and/or connecting to other computers. 

20. Other peripherals: In addition, hardware can include external components of a computer 

system. The following are either standard or very common.  

      Input, Keyboard, Pointing devices, Mouse, Trackball, Joystick, Game pad 

 

 

 

 
On most computers, a keyboard is the primary text input device. 

Types of Key boards: 

 101-key Enhanced keyboard 

 104-key Windows keyboard 

 82-key Apple standard keyboard 108-key Apple Extended keyboard. 

 

Basic types of Keys: 

Typing keys, Numeric keypad, Function keys and Control keys. 

21. Output: The output devices are: Printer, Speakers, Monitor, Networking, Modem, Network card. 

 

ASSEMBLING AND DISASSEMBLING OF PC 

 

PROCEDURE: Assembling a P – IV PC In this section you will learn how to assemble a Pentium – IV 

PC with Requirements:  

• P – IV 1.6 GHz 478 pin CPU  

• KOB P4M266 NDFSMX Mother Board  

• 1 GB DDR-1 RAM  

• Sony FDD  
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• LG/SAMSUNG 52X DVD R/W  

• Seagate 40 GB HDD  

• 10 /100 Realtek Ethernet Card  

• Data cables  

• Three types of screws (Inner, Outer & Mother board)  

• ATX cabinet  

• Screw driver  

 

Disassembling the computer system 

Detach the power cable:     Remove the Cover: 

 

Remove the adapter cards:     Remove the Drivers: 

 

 

Remove the memory module:      Remove the power supply: 

 

Remove the motherboard: 

 

 

Assembling a Computer: 

 
Materials Required 

 
Make sure that you have all the below materials before starting. 
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1. All the necessary components (Although the all the below components are preferable, not all 

are necessary. Then necessary ones are marked with a *) 

 Processors 

 Motherboard 

 Hard disk 

 RAM 

 Cabinet 

 Floppy Drive 

 CD Drive 

 Cards 

 Display Card (Not needed if On-board display is available on Motherboard) 

 Sound Card (Not needed if On-board sound is available on Motherboard) 

 Modem 

 Other Cards (If Any) 

 Monitors 

 Keyboard 

 Mouse 

 Speaker 

 UPS 

 Other Components (If Any) 

 Also keep the cables that came with the components close by 

2. Philips head Screwdriver (also known as Star Screwdriver) 

3. Flat head Screwdriver 

4. Forceps (for pulling out jumpers and screws) 

5. Magnetized Screwdriver 

6. Multi meter (Testing) 

 

    Installing Motherboard 
 

 

Placing the main board in the case                               Raising the lift lever on the CPU Socket    
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 The socket lever is fully raised                                         Placing the CPU into the socket    
 

                                                                                                        

  

 

 

 

 

CPU sits in its socket           installing the Heat sink/Fan: 

                                         
      
Placing the heat sink    plugging the heat sink fan into the main board  

Installing RAM: 

RAM module notch 

 
 

 

Opening the lever at the sides of the memory slot                     Inserting the memory chip into its slot 
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Placing the main board in the case                                         Holding the PCI card properly by the     

                                                                                               metal and the edges   

Installing Hard disk 

Ensure that the hard drive is set up to be the master drive on its IDE cable. Each IDE cable can support 

up to two IDE devices, such as hard-drives, CD-drives, Zip Drives, etc., but in order for this to work, 

one IDE device must be designated as a master 

device, and one must be designated as a slave device. You   cannot have two master devices or two slave 

devices on a single cable. This must be later configured in the BIOS. 

 

 

 

 

 

 

 

 

Installing Optical Drive (DVD/CDROM) 

Ensure that at least one full sized 5.25" bay is open in the case. Examine the jumper settings on the top 

of the drive, as you did with the hard-drive. Ensure that the drive is set to 'master'. If your case came 

with rails, screw them to the sides of the CD drive and insert it into the front   of   the   case   until   it   

clicks   into   place.   Otherwise, slide the drive into the front of the computer until the faceplate of the 

drive is flush with the front bezel of the case and the screw holes along the side of the drive line up with 

the case. Then, screw it in securely on both sides. Attach the power cable (same as the hard-drive power 

cable) to the drive. Attach your secondary IDE cable to the drive. Note that generally this should be a 

regular 40-wire IDE cable, not the 80- wire UDMA IDE cable that is used for the hard-drive. Some 

DVD drives will use the 80- wire cable, however. 

Set the jumper on the CD-ROM drive. Here you have a choice. You can either: 

 Attach the CD-ROM to IDE connector 1 and make the CD-ROM a slave. In this case, you will 

set the jumper on the CD-ROM to "Slave" and attach the CD-ROM drive to the same IDE 

cable as the hard drive. Or, 

 Attach the CD-ROM to IDE connector 2 and make the CD-ROM a master. In this case you will 

set the jumper on the CD-ROM to "Master" and attach the CD-ROM drive with a separate 

cable to IDE slot 2. In order to use this method, you will need a second IDE cable. 

 Connect the Sound Cable of the CDROM to the Sound Card so that the Audio CDs can work 

Properly. 
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Power Cables 

After all these connections, connect the power cable of the Monitor to its place. Then plug in the power 

cable into its jack. Give the other end to a plug nearby. If a UPS is available, plug the power cable to 

the UPS and the power cable of the UPS to the Power plug. 

Powering the System 

Plug in the power cord and switch the power supply switch to the on position. Press the power button. 

If everything is connected as it should be, all system fans should start spinning, you should hear a 

single beep, and after about 2-5 seconds the computer start to boot. 

Depending on the manufacturer of the Motherboard, you may get a splash screen, or just a memory 

check. The system will then halt with an error because we have yet to install an operation system. Now 

check the front LEDs to see if you plugged them in correctly. Also test the reset button. Power off and 

fix the LEDS if there are any problems. 

 

I/O, I/O (In or Out of the Computer) 

When placing the main board inside the case, it will be necessary to push the main board toward what’s 

called the I/O shield (input/output shield) of the case. 

The I/O shield usually has several metal fins sticking out toward the main board. Various connectors 

that are permanently attached to the main board will protrude from the I/O shield. 

 The serial ports 

 Parallel port 

 PS/2 keyboard connector and 

 PS/2 mouse connector 

 USB ports and Fire wire IEEE 1394 connectors are other connectors 

 If you’re big into video editing, you might want to select a main board with a Fire wire 

port. Otherwise, you can purchase a PCI card that gives your system a Fire wire 

connection. 

The main board sits behind the I/O shield 

The keyboard and other devices will attach through this I/O shield at the back of the case. 

Closing the Cabinet 

After all the connections are made inside the Cabinet, double-check all the wiring. Make sure all 

connections are firmly attached, and ensure that no wires are running close to the top of the CPU heat 

sink fan. Then close the cabinet and screw it tight. Set it in an upright position(assuming it is a tower 

type cabinet). 

Configurations 

At the first screen press the Delete key to enter the BIOS setup. Review the BIOS settings. Here 

are a few that you may want to pay attention to: 

 Time and date. 

 IDE devices – Hard disk and Floppy Drive. 

 Boot Order 
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Finished 

 

 

 

 

 

If there are no troubles, the system is ready. The operating system can be installed now. If some 

problems have appeared, read the troubleshooting guide for instructions to solve the problem. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



13 

 

WEEK: 2 INSTALLATIONS OF OPERATING SYSTEMS 

 

PROCEDURE: Start the computer and insert your Windows XP CD. After a few seconds, the screen 

will clear and you will see a 'press any key to boot from CD' prompt. Press the any key..... Press any key 

to start the install. The prompt allowing you to install will time out after about 4 seconds, so if you don't 

hit any of the keyboard keys you will have to reboot to install. The installer program will begin copying 

files from the CD. Insert the Windows XP CD into your computer and restart your computer. 

  

 

Note: If you are installing WinXP onto a hard-drive that is not connected to a standard IDE port, for 

example a SCSI drive, or an IDE drive connected to a hardware RAID controller, you will need to press 

F6 when prompted at the bottom of the screen, immediately after the blue 'windows setup' screen appears. 

After about 2 minutes, this will bring up a dialog which allows you to install drivers for your SCSI or 

RAID device from a floppy disk. Many computer motherboards have RAID controllers built into them, so 

be aware that this may be a required step.  

The 'welcome to setup' screen appears. Press enter to continue. View the licensing agreement and hit F8 

to continue. 

 

The installation program will then search your drives for any prior installation of XP. If it finds one, you 

will be given the option to repair it, which essentially reinstalls most system files while leaving the 

registry and installed programs intact. Otherwise, move forward to the partitioning and formatting section 

of the install. 

 

 

The initial screen shows the hard disks connected to your system, and any partitions that may already be 

created. 
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Formatting NTFS/FAT32:  

 

Formatting creates a file-system on the drive, so that an operating system can write information to it. The 

XP setup utility performs both partitioning and formatting. If you are starting with a blank hard-drive, you 

will see the disk and the un partitioned space available. Highlight the 'un partitioned space' using the 

arrow keys and press 'c' to create a partition. You will be shown the minimum and maximum amount of 

space you can allocate to the new partition, and prompted for an amount in MB. Keep in mind that 

1000MB = 1 GB. Next you must specify a name for your computer, or accept the pre-generated one 

presented to you. The computer name is relevant for networking purposes. 

 

 

A partition is simply a section of the free space on your hard-drive. Operating systems use partitions to 

logically assign drive letters. For example, if you have a single 40GB drive, you can allocate all the space 

to a single partition, but then you could only have a single drive (C:) visible in Windows. 
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Entering Regional, Language and Personal Settings 

 

After the system reboots, you are prompted to provide some information for Windows. You’ll be 

asked for your regional and language settings. And, you’ll be asked to enter your name to personalize 

your computer. 

 

Regional and Language Options Just hit “Next” to choose English as your language. 

 

 Enter your name and your organization 

 

You can enter your full name. You’ll be able to create user accounts later, where you can enter your 

username. 

Entering the Windows XP Product Key 

 
You’ll need to enter your Windows XP key code. Be sure to write this number down in case you need 

it later. I find writing this number in the Windows manual is handy. If your CD comes in a cheap 

floppy paper holder and you transfer the CD to a jewel case, be sure to copy the number onto a paper 

inside the jewel case. It’s also a good idea to keep the original CD holder. (Keep all the stuff that’s left 

over after the build in its own box, in case you need it later.) 

 

If your key code number is rejected, it probably means you misentered it. Try again. And, again. And, 

possibly, again. Be alert for tricky letters like “I” which could be mistaken for a “1.” Or a “B” for an 

“8.” 

 

Naming the Computer and Setting the Date and Time 

 
You’ll be asked to name your computer. Computer names are useful if your computer is on a 

network. We named our PC “ASUS.” Another screen appears asking for date and time settings. 
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Naming the PC 

Like a proud new parent, you can name your PC. The name will identify the PC on a network. 

 

          Date and time settings 

Copying Remaining Files to Hard Drive 

 

Windows will then copy some more files to your hard drive. You can see the progress of the install by 

the status bar at the left of the screen. Depending upon your point of view, either useful information or 

Microsoft propaganda appears at the right of the screen. Don’t worry about reading this. It’s not 

important. 

Next, you’ll be asked if you wish to “activate Windows.” You can choose to activate Windows now or 

you can do it later. I’d probably do it later, after you’re fully satisfied with the install. Just select to 

activate later and continue. We’ll discuss activation in more detail later. 

Adjusting Monitor Settings 

 
The computer might ask you if it can adjust the settings of your monitor. If it does, you’ll have only an 

“OK” box to select. Then, another screen will test whether or not the screen is readable with the new 

settings. If the screen isn’t readable, don’t worry. The settings should revert to the previous settings. 

We discuss the importance of having the correct monitor identified and how to install video drivers 

later. 
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When “OK” is your only choice...hit OK 

Adjusting display settings 

 

After adjusting your display settings, you’re asked to hit OK to confirm that you can read the 

display. If the display is unreadable, the settings should revert. 

 

Adding Users 

 

Next, we add users to the computer (Figure 148). Users allow several people to use the same PC, and 

each user can have his or her own files and settings. I added a user for “Charlie.” I also added a user for 

“Ducker.” A username should not be the same as the computer name. 

  Adding users to the computer 

Completing Installation and Booting Windows XP from the Hard Drive 

When the computer is finished copying files, you can remove the Windows XP CD and click the little 

arrow on the “Thank you” screen to restart the computer. 

 

 

Installation complete 

Hit the little arrow to finish. 
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LINUX INSTALLATION 

 

PROCEDURE: Fedora 14 Linux Installation Process: 

  

Screenshots with explanation:  

 

Linux Boot options: Actually Linux can be installed in two different modes, based on the requirement of 

the user Graphical Mode & Text Mode. Graphical Mode - In this you can work with Graphical Interface 

(i.e., it supports mouse and Icons). By clicking the icon with the mouse, you can perform related action.  

To install Linux in Graphical Mode Press Enter. Text Mode - In this mode you have to interact with 

character based interface (i.e., Command prompt).To install Linux in Text Mode Type: Linux text and 

Press Enter. After selecting the mode of installation, it goes on detecting the basic input output devices 

and file systems. And at last it displays a screen asking whether to test the DVD inserted to install or to 

Skip the test process. Otherwise we can test total installation DVD. On completion of testing the DVD, it 

goes on loading an installation program ―ANACONDA‖ which helps us in the installation of the 

remaining part. 

  

 

Select the 'Skip' option when you're asked if you want to check the media before installation and press the 

Enter key on your keyboard...  

 

Welcome to installation process It starts with the display of the welcome screen containing the 

online help , and four buttons to help us in the different activities in the installation process. Hide 

Help/Show Help - Which helps you in guiding the installation process, which can be activated or 

hidden? Release Notes - Which contain the Basic Hardware Requirements that are necessary for 

the installation of the Red Linux 9.0 and some other post-installation issues. Next - This button 

allows you to go to next step of the installation process by the current step. Back - This button 

allows you to move back of the installation process to make any changes that previously 

mentioned. 
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Selecting a language It displays a screen containing various languages, to select a language you would 

like to use during this installation process.  

 

Configuring keyboard and mouse Here we need to select our own keyboard and mouse layouts which 

will help you to interactively proceed in the installation process. At this point of time it displays you the 

different types of keyboard layouts. So that you can select your desired one that you would like to use for 

the system. And also choose the appropriate Mouse for the system, based on the following:  

 

 

Network Configuration With this option you can set your Network devices manually or using DHCP 

(Dynamic Host Configuration Protocol) which will automatically takes default IP address, and Net mask 

addresses. The DHCP also set your Hostname.  
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Selecting a Time Zone To set our time zone we can do it either by selecting computers physical 

location or by your time zone‘s offset from Universal Time, Coordinated. This screen shows two 

tabs namely location and UTC Offset. First tab offers you the ability to configure by location. 

Second tab allows setting UTC Offset. 

 

Hardware Trouble Shooting: 

S. No. Symptom Problem Source Solution 

1 PC does not start a. Power cord or cable  

 

 

b. SMPS  

 

 

c. Processor not installed 

properly 

Check power cable for loose 

contact or breakage 

 

Check the SMPS fuse or replace 

SMPS 

 

Install the processor properly 

2 System started but no 

display  

a. Monitor cable loose 

contact or faulty 

 

 

b. VGA card loose contact on 

Motherboard. 

 

 

 

c. Monitor 

Check monitor cable for loose 

contact and put it properly If it 

breaks replace with new one. 

 

Properly inset the VGA card in 

PCI slot if it not solves the 

problem then replace the VGA 

card. 

 

Adjust the settings on the 

monitor otherwise problem with 

monitor 

3 Continuous beep as 

you start PC 

a. RAM 

 

 

 
 

 

 

 
 

b. System bus speed 

mismatch 

a. Insert RAM properly on 

motherboard. 
 

b. Clear the CMOS     settings 

by shorting the pin 1 and 2 or 

JP1. 

c. Faulty RAM replaces it with 

working one. 
 

Configure correct bus speed in 

BIOS. If you don’t know values 

then configure it to Optimized 

Defaults. 
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4 HDD not found  a. IDE cable or Power 

connection 

 

 

b. BIOS settings  

 

 

 

c. Partition failure 

 

 

 

d. Operating System boot 

files damaged in the HDD 

Check IDE cables or power 

connector for Proper 

connectivity. 

 

Use IDE Auto Detection option 

in BIOS for detecting the HDD. 

 

Repartition the HDD using 

bootable disk or any third party 

tools 

 

Restore the bootable files by 

starting the computer with boot 

disk and type the following 

command prompt a:\>sys c:\ 

5 FDD not found  FDD cable or power 

connector  

Connect data cable & power 

cable to FDD. Replace the FDD.  

6 Keyboard not found  a. Keyboard connection 

 

 

b. Keyboard Port failure 

Check the Keyboard cable for 

proper connection or damage 

 

Give it for repair at authorized 

service center. 

7 Mouse not detecting  a. Mouse cable Faulty 

 

 

 

b. Mouse drivers corrupted 

or not loaded 

 

 

c. Mouse is dead 

Check it for proper connection 

and replace it with working one. 

 

Load the mouse drivers from 

vendors diskettes replace it with 

working one. 

 

Replace it with working one. 

8. When we connect both 

HDD & CD-ROM, 

HDD is not detecting 

a. Jumper settings on a 

device 

 

 

 

 

 

b. BIOS settings 

Check for master & slave setting 

on backside of the devices. The 

device, which contains 

Operating System, must set to 

master and other to slave. 

 

Properly detect the devices using 

the Ide Auto Detection option in 

BIOS. 

9 System booting slowly a.  Insufficient disk space on      

default drives   

 

 

 

b. Virus Problem 
 

Free the disk space by removing 

all unnecessary files and run the 

disk defragmentation utility. 

 

Remove virus by running 

antivirus application. 

10 Unable to remove 

BIOS password 

Jumper settings Remove all power connector 

from motherboard and start pin 

2 & 3 of JP1 and set back to Pin 

1 & 2. 
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11 CD auto play not 

working  

Device manager Go to control panel then system 

device manger select CD Drive 

right click properties and then 

enable auto insertion. 

12 No clarity Display resolution  Load display drivers properly & 

set correct resolution (no. of 

bits/clarity) 

13. PC Speaker, HDD led, 

power led & other 

LEDs not working 

Front panel port Check indicator connectors for 

proper connectivity on 

motherboard front panel port. 

14. Check sum error CMOS Battery  CMOS battery weak. Replace it 

with working  

      

     Software Trouble Shooting: 

S.No Symptom Solution 

1 Computer is running slowly a. Hard disk drive is short on available disk space: 

If you have a hard disk drive that is 2GB or smaller, 

ensure that there is at least 200MB of hard disk drive 

space free. If you have a hard drive larger than this size, 

verify that there is at least 500MB of free hard disk space 

2 Unable to install a software 

program 

a. Verify the diskettes or CD is readable by reading the 

files on the drive. 

 

b. Computer does not have enough disk drive space or 

does not meet the requirements, the program will not 

install. 

 

c. Program or utility you are installing is compatible with 

the version of Operating System you have on your 

computer 

d. If you are running Microsoft Windows 95 or higher 

try installing the program from safe mode.  

3 CD-ROM not working in 

Windows 9x.                                                 

 

a. Ensure that you have tested more than one CD in the 

CD-ROM drive; it is possible for one CD to be bad or 

dirty and not be read properly. Bad or dirty CD.  

b. Click Start / Settings / Control Panel / double click 

System / click the Device Manager tab. Within Device 

Manager verify that the CD-ROM has no exclamation 

marks. If listed with a yellow exclamation mark or red 

X, remove the CD-ROM with the error and reboot the 

computer to reinstall the CD-ROM.  

4 Getting no sound from audio 

CDs. 

a. Sound settings not properly setup. Verify that a Sound 

Icon is on the bottom right hand side of the screen and 

that your sound is working properly elsewhere. Verify 

http://www.computerhope.com/jargon/o/os.htm
http://www.computerhope.com/jargon/s/safemode.htm
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 that the CD-ROM or CD Audio option is turned up mid 

way or more and that it is not checked on Mute.   

b.  Check Multimedia properties by following the below 

steps: 

1. Click Start / Settings / Control Panel Double click the 

Multimedia icon. Click the CD Music tab Verify that 

CD Music Volume. Verify that the volume is turned up 

mid-way or more.  

5 MS-DOS errors. a. Bad command or file name - Usually, this is when 

you miss type a command or if DOS does not know the 

command. 

Access denied - Usually meaning the file has an 

attribute on it. TIP: if you need to delete the file, just 

deltree FILE 

File cannot be copied onto itself - An attempt to copy a 

file could not be completed because the file already 

exists or same source and destination. 

File not found - Meaning that, in the directory that you 

searched, it does not have that certain file or there are no 

files in the directory. 

Not ready, reading drive X - Attempted to read a disk 

that is not readable or there is no disk in that drive 

Invalid Switch - The wrong slash was typed, such as 

cd/ when it is supposed to be cd\. 

Invalid media, track 0 bad or unusable - Format 

command cannot format the specified disk or the disk 

capacity is invalid, or bad disk.  

Invalid directory - Directory is invalid or does not exist 

in the directory you are currently in. 
 

File creation error - Directory could be full because of 

the DOS limitation of files in one directory; the file 

could also already exist or the file was not copied 

correctly 

 

 Divide overflow - Program has attempted to divide 

something by 0. 

6 Error loading Operating System 

after Windows XP setup 

a. The computers BIOS does not support the computer 
hard disk drives size or settings This issue is often 
caused when the BIOS does not properly detect the hard 
disk drive. To resolve this issue update the computer 

http://www.computerhope.com/attribhl.htm
http://www.computerhope.com/deltree.htm
http://www.computerhope.com/formathl.htm
http://www.computerhope.com/copyhlp.htm
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motherboards BIOS. 

b. Computer Hard disk drive is not properly setup in 
CMOS Verify that the computer’s hard disk drive is 
properly setup in CMOS setup. Once in CMOS verify 
the below hard disk drive settings. 

1. Verify the hard disk drive is detected.  

2. Try changing the "Access mode" on the hard disk 
drive to "Large" or "LBA". This setting may vary 
depending on the type of BIOS.   

c. Issue with drives partitions This issue can be cause if 
the disk drives are not properly setup or have been 
changed by another program such as a utility that comes 
with a Linux distribution. To resolve this issue delete all 
and recreate all the partitions before running the 
Windows XP setup. 

7 Computer turns off without 

warning. 

a. Heat related issue: a fan may be failing in your 

computer. You can first start by verifying the fan on the 

power supply is working by examining the back of the 

computer. 

b. Computer virus: It's possible for your computer to be 

infected with a virus that is designed to shut down your 

computer or turn it off. If computer is infected with a 

virus, make sure your virus scanner definitions are up to 

date. 

8. When booting the computer, 

the error message "Missing 

command interpreter" 

appears 

a. Non bootable CD or diskette in drive: It is possible 

that the computer may be attempting to boot from a 

device other than your hard drive. Verify that no floppy 

diskette or CD is in the computer. 

b. Bad hard drive: It is possible that the hard drive may 

be going or already is bad. If, after following the above 

steps, you are still receiving errors about the command 

interpreter or the command.com being missing or bad, 

we recommend that you follow the below instructions. 

Boot the computer with a bootable floppy diskette.  
1. At the prompt type fdisk /mbr and press enter. 
2. This will return to a prompt with no message.   
3. Once back at the prompt attempt to reboot the  
    Computer. 
4. If the same issue occurs we recommend that you 
    delete and recreate the partition, and reinstall the    
    operating system back onto the computer.      

http://www.computerhope.com/jargon/p/ps.htm
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PC diagnostic tools: 

PC diagnostic tools are tools to be used in the process of identifying the nature and cause of a problem. 

Through various scans, these tools are able to quickly and accurately diagnose hardware issues. 

Windows Memory Diagnostic: 

Windows actually has a built-in tool that can physically test your RAM modules to check if they’re free 

of errors. It’s an app called the Windows Memory Diagnostic. 

 
 

Using it will restart your computer. On boot up, the tool will run several tests on your RAM, and 

if it encounters any errors or failures, it will do its best to let you know which module is the 

culprit. 

 

Windows Task Manager:   

 

Windows Task Manager enables you to monitor the applications, processes, and services currently 

running on your PC. You can use Task Manager to start and stop programs and to stop processes, but in 

addition Task Manager will show you informative statistics about your computer's performance and 

about your network. 

 

 
 

http://www.makeuseof.com/tag/4-vital-system-tools-every-windows-users-should-know-about/
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Disk Cleanup: 

 
Windows’ Disk Cleanup utility isn’t quite as hidden as some of the other utilities here, but not enough 

people know about it. It will scan your computer for files that can be deleted, from temporary files and 

memory dumps to old system restore points and leftover files from Windows upgrades. It does the same 

job a PC cleaning utility does, but it’s free and doesn’t try to extract any money from you. Advanced 

users may prefer CCleaner, but Disk Cleanup does a decent job. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.howtogeek.com/162683/pc-cleaning-apps-are-a-scam-heres-why-and-how-to-speed-up-your-pc/
http://www.howtogeek.com/113382/how-to-use-ccleaner-like-a-pro-9-tips-tricks/
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WEEK: 3    NETWORKING 

 

Network: A network consists of two or more computers that are linked in order to share resources (such 

as printers and CDs), exchange files, or allow electronic communications.  

Common types of networks are: 

LAN (Local Area Network) 

WAN (Wide Area Network) 

MAN (Metropolitan Area Network) 

 

Local Area Network: 

A Local Area Network (LAN) is a network that is confined to a relatively small area. It is generally 

limited to a geographic area such as a writing lab, school, or building. 

 

Wide Area Network: 

Wide Area Networks (WANs) connect networks in larger geographic areas.  

 

Metropolitan Area Network: 

Metropolitan Area Network connects town or a city. 

 

Types of Network Topologies: 

 

Network Topology is the schematic description of a network arrangement, connecting various 

nodes(sender and receiver) through lines of connection. 

 

Bus topology: 

 

Bus topology is a network type in which every computer and network device is connected to single cable. 

When it has exactly two endpoints, then it is called Linear Bus topology. 

 

 
Ring Topology: 

 

It is called ring topology because it forms a ring as each computer is connected to another computer, with 

the last one connected to the first. Exactly two neighbors’ for each device. 
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Star Topology: 

In this type of topology all the computers are connected to a single hub through a cable. This hub is the 

central node and all others nodes are connected to the central node. 

 
 

Mesh Topology: 

 

It is a point-to-point connection to other nodes or devices. All the network nodes are connected to each 

other.  

 

 
Tree Topology: 

 

It has a root node and all other nodes are connected to it forming a hierarchy. It is also called hierarchical 

topology. It should at least have three levels to the hierarchy. 

 
 

Network Protocol is a set of rules that governs the communications between computers on a network. 

What is a Network Protocol? 

Rules of Network Protocol include guidelines that regulate the following characteristics of a network: 

access method, allowed physical topologies, types of cabling, and speed of data transfer. 
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Types of Network Protocols 

The most common network protocols are: 

 Ethernet 

 Local Talk 

 Token Ring 

 FDDI 

 ATM 

 

The followings are some commonly used network symbols to draw different kinds of network protocols. 

 

Internet Connection Settings: 

 Open Network Connections.  

 Under Network Tasks, click Create a new connection, and then click next.  

 Click Connect to the Internet, and then click next.  

 Choose one of the following:  

 If you already have an account with an Internet service provider (ISP), click Set up my       

         If you have a CD from an ISP, click Use the CD I got from an ISP and then click Next. 

 If you do not have an Internet account, click Choose from a list of Internet service  

         Providers (ISPs) and then click next. 

 From your choice above, click one of the following:  

To Configure Tcp/Ip Settings: 

1. Open Network Connections.  

2. Click the connection you want to configure, and then, under Network Tasks, click Change 

settings of this connection.  

3. Do one of the following:  

o If the connection is a local area connection, on the General tab, under This connection 

uses the following items, click Internet Protocol (TCP/IP), and then click Properties.  

o If this is a dial-up, VPN, or incoming connection, click the Networking tab. In This 

connection uses the following items, click Internet Protocol (TCP/IP), and then click 

Properties.  

4. Do one of the following:  

o If you want IP settings to be assigned automatically, click Obtain an IP address 

automatically, and then click OK.  

o If you want to specify an IP address or a DNS server address, do the following:  

 Click Use the following IP address, and in IP address, type the IP address.  

ms-its:C:/WINDOWS/Help/netcfg.chm::/Howto_Enable_DHCP.htmEXEC=,control.exe,%20netconnections%20CHM=ntshared.chm%20FILE=alt_url_windows_component.htm
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 Click Use the following DNS server addresses, and in Preferred DNS server and 

Alternate DNS server, type the addresses of the primary and secondary DNS 

servers.  

5. To configure DNS, WINS, and IP Settings, click Advanced. 
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Bridge: A bridge is a device that connects between two or more networks. 

 

There are different types of bridges. 

 

Transparent Bridge: As the name signifies, it appears to be transparent for the other devices on the 

network. The other devices are ignorant of its existence.  

 

Source Route Bridge: It derives its name from the fact that the path which packet takes through the 

network is implanted within the packet. It is mainly used in token ring networks. 

 

Translational Bridge: The process of conversion takes place via Translational Bridge. It converts the 

data format of one networking to another. For instance Token ring to Ethernet and vice versa. 

HUB 

 

Hub is one of the networking devices used to connect devices. They are used to transmit the data from 

source and destination. 

 

Hub falls in two categories: 

 

1. Active Hub(repeaters): They are smarter than the passive hubs. They not only provide 

the path for the data signals they regenerate, concentrate and strengthen the signals before 

sending them to their destinations.  

 

2. Passive Hub: They are more like point contact for the wires to built in the physical 

network. They do not modify the signals. 

 

 

 

 

 

 

http://www.certiology.com/wp-content/uploads/2014/03/Ethernet-Hubs.jpg
http://www.certiology.com/wp-content/uploads/2014/03/Hub.jpg
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Switches 

Switch is also one of the connecting device but the difference between hub and switch is working that hub 

works by sending the data to all the ports on the device whereas a switch transfers it only to that port 

which is connected to the destination device. Switches operate in full-duplex mode where devices can 

send and receive data from the switch. 

 

 

Wireless Technology: WiFi, LiFi, Bluetooth 

Wifi:  
Wi-Fi or WiFi is a local area wireless computer networking technology that allows electronic devices to 

connect to the network, mainly using the 2.4 gigahertz (12 cm) UHF and 5 gigahertz (6 cm) SHF ISM 

radio bands. 

 

Wi-Fi is simply a trademarked term meaning IEEE 802.11x. The false notion that the brand name "Wi-Fi" 

is short for "wireless fidelity" has spread to such an extent that even industry leaders have included the 

phrase wireless fidelity in a press release. 

 

In 1991, NCR Corporation with AT&T Corporation invented the precursor to 802.11, intended for use in 

cashier systems. The first wireless products were under the name Wave LAN. 

 

If you have a friend or a neighbor who has broadband internet within line of sight from your home, then 

you may be able to get free WiFi Internet access. You will need to ask permission to use their internet 

before proceeding. If all is ok, then your task will be to make a WiFi connection to their router. 

 

Lifi: 

LiFi is a wireless optical networking technology that uses light-emitting diodes (LEDs) for data 

transmission. LiFi is designed to use LED light bulbs similar to those currently in use in many energy-

conscious homes and offices. 

Li-Fi (Light Fidelity) is a bidirectional, high speed and fully networked wireless communication 

technology similar to Wi-Fi. 

 

Harald Haas, who teaches at the University of Edinburgh in the UK, coined the term "Li-Fi" at his TED 

Global Talk where he introduced the idea of "Wireless data from every light". He is Chair of Mobile 

Communications at the University of Edinburgh and co-founder of pureLiFi. 

 

A 224Gbps speed would technically allow for 18 movies of 1.5GB each to be downloaded in a single 

second CC.Researchers at the University of Oxford have reached a new milestone in networking by using 

light fidelity (Li-Fi) to achieve bi-directional speeds of 224 gigabits per second(Gbps). 

 

How it works! 

Li-Fi and Wi-Fi are quite similar as both transmit data electromagnetically. However, Wi-Fi uses radio 

waves while Li-Fi runs on visible light. 

 

http://www.certiology.com/wp-content/uploads/2014/03/switches.jpg
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As we now know, Li-Fi is a Visible Light Communications (VLC) system. This means that it 

accommodates a photo-detector to receive light signals and a signal processing element to convert the 

data into 'stream-able' content. 

 

An LED light bulb is a semi-conductor light source meaning that the constant current of electricity 

supplied to an LED light bulb can be dipped and dimmed, up and down at extremely high speeds, without 

being visible to the human eye.For example, data is fed into an LED light bulb (with signal processing 

technology), it then sends data (embedded in its beam) at rapid speeds to the photo-detector (photodiode). 

 

The tiny changes in the rapid dimming of LED bulbs is then converted by the 'receiver' into electrical 

signal. 

 

The signal is then converted back into a binary data stream that we would recognise as web, video and 

audio applications that run on internet enables devices 

 

 

Feature LiFi WiFi 

Full form Light Fidelity Wireless Fidelity 

Operation LiFi transmits data using light with 

the help of LED bulbs. 

WiFi transmits data using radio 

waves with the help of WiFi router. 

Interference Do not have any intereference 

issues similar to radio frequency 

waves. 

Will have intereference issues from 

nearby access points(routers) 

Technology Present IrDA compliant devices WLAN 802.11a/b/g/n/ac/ad 

standard compliant devices 

Applications Used in airlines, undersea 

explorations, operation theaters in 

the hospitals, office and home 

premises for data transfer and 

internet browsing 

Used for internet browsing with the 

help of wifi kiosks or wifi hotspots 

Merits(advantages) Interference is less, can pass 

through salty sea water, works in 

densy region 

Interference is more, can not pass 

through sea water, works in less 

densy region 

Privacy In LiFi, light is blocked by the 

walls and hence will provide more 

secure data transfer 

In WiFi, RF signal can not be 

blocked by the walls and hence 

need to employ techniques to 

achieve secure data transfer. 

Data transfer speed About 1 Gbps WLAN-11n offers 150Mbps, 

About 1-2 Gbps can be achieved 
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using WiGig/Giga-IR 

Frequency of 

operation 

10 thousand times frequency 

spectrum of the radio 

2.4GHz, 4.9GHz and 5GHz 

Data density Works in high dense environment Works in less dense environment 

due to interference related issues 

Coverage distance About 10 meters About 32 meters (WLAN 

802.11b/11g), vary based on 

transmit power and antenna type 

System 

components 

Lamp driver, LED bulb(lamp) and 

photo detector will make up 

complete LiFi system. 

requires routers to be installed, 

subscriber devices(laptops, PDAs, 

desktops) are referred as stations 

 

Bluetooth: 

 

Bluetooth is a wireless technology standard for exchanging data over short distances (using short-

wavelength UHF radio waves in the ISM band from 2.4 to 2.485 GHz) from fixed and mobile devices, 

and building personal area networks (PANs). 

 

In 1994 a group of engineers at Ericsson, a Swedish company, invented a wireless communication 

technology, later called Bluetooth. In 1998, the original group of Promoter companies—Ericsson, Intel, 

Nokia, Toshiba and IBM—came together to form the Bluetooth Special Interest Group (SIG). 

 

Most Mac computers come with Bluetooth technology built-in. To determine whether your computer 

supports Bluetooth do one of the following: Look for the Bluetooth Icon in the menu bar. If 

the Bluetooth icon is present, your computer has Bluetooth. 

 

Before you can use a Bluetooth keyboard, mouse, track pad, or audio device, you need to “pair” 

your Mac with the device. You need to pair your Mac with the device only once. The device remains 

paired until you un pair it.  

 

Crimping, crossover, straight over: 

 

A crimping tool is a device used to conjoin two pieces of metal by deforming one or both of them in a 

way that causes them to hold each other. The result of the tool's work is called a crimp. A good example 

of crimping is the process of affixing a connector to the end of a cable. For instance, network cables and 

phone cables are created using a crimping tool (shown below) to join the RJ-45 and RJ-11 connectors to 

the both ends of either phone or CAT5 cable. 

 

http://www.computerhope.com/jargon/r/rj45.htm
http://www.computerhope.com/jargon/r/rj11.htm
http://www.computerhope.com/jargon/c/cat5.htm
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How does it work? 

 

To use this crimping tool, each wire is first placed into the connector. Once all the wires are in the jack, 

the connectors with wires are placed into the crimping tool, and the handles are squeezed together. 

Crimping punctures the plastic connector and holds each of the wires, allowing for data to be transmitted 

through the connector. 

 

Straight Cable 

You usually use straight cable to connect different type of devices. This type of cable will be used most of 

the time and can be used to: 

1) Connect a computer to a switch/hub's normal port.  

2) Connect a computer to a cable/DSL modem's LAN port.  

3) Connect a router's WAN port to a cable/DSL modem's LAN port.  

4) Connect a router's LAN port to a switch/hub's uplink port. (normally used for expanding network)  

5) Connect 2 switches/hubs with one of the switch/hub using an uplink port and the other one using 

normal port. 

 

Crossover Cable 

Sometimes you will use crossover cable, it's usually used to connect same type of devices. A crossover 

cable can be used to: 

1) Connect 2 computers directly.  

2) Connect a router's LAN port to a switch/hub's normal port. (normally used for expanding network)  

3) Connect 2 switches/hubs by using normal port in both switches/hubs. 
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WEEK-4    BLOG CREATION, SKYPE INSTALLATION AND CYBER HYGIENE 

 

Blog Creation 

 

A blog (short for weblog) is a personal online journal that is frequently updated and intended for general 

public consumption. Blogs are defined by their format: a series of entries posted to a single page in 

reverse-chronological order. Blogs generally represent the personality of the author or reflect the purpose 

of the Web site that hosts the blog.  

 

Creating the blogs: 

 

STEP 1: Know WHY you want to start a blog 

When you know your destination, getting your direction becomes easier, right? 

People start blogs for different reasons. Today, blogging is a great way to: 

 

 Become a better person. Blogging helps you think clearer, communicate with intentionality and build 

your creative flair. 

 Improve your writing. Writing proficiency comes with regular practice and starting a blog helps you 

write regularly 

 Make your voice heard. Gone are the days when only powerful politicians and wealthy businessmen 

could air their views. Now, you, too, can! 

 Make a difference. You want to help people take control of their personal finance? Start your own blog. 

You wish people would exercise more, take healthier meals and rest better? Start a blog. 

 Get published. The world is changing, and traditional publishers are falling into irrelevance. Smart 

authors now make a blog, build a loyal audience and publish their works. This approach works always. 

 Make money. It takes time and commitment but people make real money from blogs. I’ve made tens of 

thousands of dollars myself from blogging. And many folks I’ve taught how to create a blog are doing 

fine too. 

 

STEP 2: Decide WHAT your blog will focus on?  

Travel blogs. Vegetarian blogs. Romance blogs. Writing blogs. Marketing blogs. Political blogs. Religion 

blogs. Fashion blogs. Photography blogs. 

So… what type of blog should you start? 

What will be the focus or theme of your blog? This theme is called a niche –– and you should have one. 

The best is to choose a niche you’re passionate about. Blogging is to be enjoyed. You know, there’s 

fulfillment in connecting with others and providing helpful information. You’ll experience this joy, and 

be able to do it for long, if you’re passionate about what you blog about. 

What are your hobbies? 

What do you feel happy doing? What are you always excited to talk about to your friends? 

Is it fashion, technology, entrepreneurship, leadership, food, traveling, relationship, movies or fiction? 

That’s probably what you should be blogging about. If you’re passionate about it, you can keep sharing 

useful information about it. 

Create a blog today, and talk about what you love, what you know, and what you’re learning. It’s easy, 

and you CAN do it. 

 

STEP 3: Decide WHICH of the blogging platforms you’ll use 

The question, “How do you start a blog?” has many alternative answers. You can do it on blogging 

platforms like: 

 Blogger: e.g. yourfashionguy.blogspot.com 

 Hosted WordPress: e.g. yourfashionguy.wordpress.com 

 Self-Hosted WordPress: e.g. yourfashionguy.com 
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If your interest is to start a blog for business, a self-hosted WordPress blog is more professional. If it’s to 

do it for a cause or as a hobby, a self-hosted WordPress blog is more elegant. 

The free blogging platforms aren’t really free. 

 
They come with TONS of annoying limitations that just enslave you. Here’s 5 of them: 

Limit #1: if you think the companies allowing you to create a blog on their blogging platforms for free do 

so because they love you, you’re wrong. They only do so to make money off of you. That’s why they put 

up adverts on your blog and ask you to pay to enjoy upgrades. Go for a self-hosted blog so you won’t be a 

wheel in a car working to make another company rich. 

Limit #2: you’re not allowed to do affiliate marketing on free blogs. Some of them further prohibit 

Google Adsense and other cool ways to make money blogging. That’s not how to start a blog rightly. 

Limit #3: you can’t use any of the thousands of amazing plugins and themes available to a self-hosted 

blog. After making a blog, plugins help you extend the functionality of the blog, the same way apps 

extend the functionality of a phone. Imagine having a phone without being able to install and use apps. Is 

it cool to live in a house you’re prohibited from painting and designing? If it’s not, then it sucks to have a 

blog without being able to use a theme on it. 

Limit #4: you can’t use a custom email like John@YourFashionGuy.com. That’s not cool. You deserve 

something better. 

Limit #5: on free blogging platforms, your blog can be deleted at anytime if the company’s server 

mistakes your blog for a spam, or if you accidentally violate their rules. And guess what – you have no 

remedy if that happens. 

 

STEP 4: Decide which web host to use 

#1: which provide 24/7 customer support through chat, phone, or email and in my experience, their 

customer service reps are helpful, polite and professional. 

#2: which guarantee and provide an amazing server uptime of 99.9%. Very few web hosts can match that 

feat. 

#3: which give you a free domain name – some web hosts sell a domain name for $15 per year. 

#4: their service is extremely easy to use, and specifically tailored for Word Press blogs. Whether you’re 

an expert or a non-geek, they’ll make your experience memorable. 

#5: they offer unlimited disk space, unlimited bandwidth, and unlimited email accounts. 

#6: they’re inexpensive. When you use the discount link on this page, you’ll SAVE some extra money 

and pay less than $72 for the first year. 

#7: they have a “one-click WordPress blog” installation, so you can install WordPress with few clicks. 

#8: they offer a 90-day money-back guarantee. So if you start a blog today and decide later that blogging 

is not something you want to do again, you can cancel your account and get a refund. 

 

STEP 5: How to create a blog using WebHostingHub 

First, go to Webhosting Hub and     choose your hosting plan.   

click “Order Now.” 

       

http://howtostartablogonline.net/go/webhostinghub
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On the next page, enter the domain name you want to register for free, choose the domain extension (I’d 

go with “.com“) and click “Search Domain”. If you already have a domain name, enter it on the tab to 

the right. 

 
 

If the domain name you’ve chosen is already taken, you’ll be prompted to choose another domain name. 

If it’s available, you’ll see the page below. WHOIS Privacy is optional. Unless you absolutely want to be 

anonymous, I’d uncheck it and save $9.99. Click “Continue“. 

 
On the next page, enter your personal details. 

 
Still on the same page, scroll down and you’ll see the optional “Automated Secure Backups“. I’d 

choose “No Thanks” to save $12 annually but it’s up to you. 

 
Scroll down and check “Install WordPress“. This saves you some time. 
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Scroll down and choose the duration of your hosting plan. If you’re just starting out, I’d go with Spark for 

12 months. Enter your payment information: 

 
Agree to the terms and conditions, check that all your information is correct and click “Purchase“. 

 
The next page shows that your order is successful. And within few minutes, WebHostingHub would 

email you a username and password for your Word Press installation. 

Congratulations! That’s all it takes to create a hosting account with WebHostingHub. 

STEP 6: Login to your new blog and start blogging 

Open a new browser tab and go to “http://YourNewBlog.com/wp-admin” (replace “YourNewBlog.com” 

with your blog domain name). Login with the username and password you’d have received by email in 

step 5 above. 

 
You’ll see your blog dashboard. This is the “back side” of your website from where you set everything 

that your readers see on the “front side”. 

Look to the left of your dashboard and you’ll see menus. 

If you want to publish a new post on your blog right away, that’s totally fine. The post doesn’t have to be 

perfect; it just has to be published, to get you started. So go ahead and do it. 

Hover the mouse on “Posts” and click “Add New” from the sub-menus that pop out. 

 
Add the title of your post in the first tab and the content in the second tab. 
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Hit “Publish”. 

When the next page loads, click “View post” to see how your new post appears to your readers. 

 
Woo-hoo! That’s all there is to creating a blog. 20 minutes is all you need. 

 

Import data into bogs 

WordPress is an open source blogging platform that is used both privately and on the WordPress.com 

website. Most blogs are hosted on the WordPress.com site, but many businesses and organizations 

download the software from WordPress.org for their business or personal blogs, or to use as a content 

management system (CMS). Blogs often change addresses. For example, you may decide you want your 

WordPress.com blog to go on your professional website, or you may want to move a self-hosted blog to 

WordPress.com, while you change domain names. You can do this with the WordPress import and export 

functions.  

 

Step1: 

Sign into your existing WordPress blog. Click on your blog name, and select "Dashboard" from the 

menu. You should see a list of options on left hand side of your screen. 

 

 
Step 2: 

Find the "Tools" menu on the left hand side, near the bottom of the dashboard. Choose the "Export" 

box from the list of options. You will most likely want to export your content first, so you can import it 

somewhere else. 

 
Step 3: 

Decide how much of your content you want to export. The top option is "All Content," and it is the 

most popular choice. Click "Download Export File" to create an "XML" file of your entire blog on your 

computer. 
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 You may see the option "Guided Transfer" on your Export page. This is a service, provided by 

WordPress.com, for approximately $119. They will export your website and import it onto the site of 

your choice. If you choose to download the Extensible Markup Language (XML), or website, file, it is 

always completely free of charge. 

 Some uploads, photos and links may not be exported into your file. You may need to re-upload some of 

this content onto your new website. 

 
Step 4 

Place the file in an easy to access folder, or on your desktop. You will need this file in order to import 

it later. 

 
 

Go to your WordPress.com or WordPress.org website. Go to the blog page. Find the Tools section of 

the Dashboard and select the "Import" option. 

 You can try to transfer your WordPress.com or .org blog to a non-WordPress platform. Some content that 

does not match the website format may be lost. WordPress is free, and open-source, so if a web 

programmer can install the WordPress.org software on your new website, it may be the easiest option. 

You will already have familiarity with how the blog can be changed, leading to fewer problems. 

 
 

Choose the Wordpress option, and then choose the XML file on your computer. Click "Upload" to 

upload the XML file to the new blog. Select "Download & import file attachments" to move your media 

along with the rest of your blog. 
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Skype Installation 

 

Skype is the biggest VoIP (Voice over Internet Protocol) service in the world, and it’s probably the easiest 

way to talk to your friends for free over the internet – through text, voice (just like a phone call) or even 

video. 

 Downloading and installing Skype on to your computer can be a little complicated, but luckily we’re here 

to take you through it step by step. 

 You’ll need: 

  

 A computer with a broadband internet connection (a dial-up connection is too slow for  Skype). 

 Speakers and a microphone. Many computers will have these built in (especially    laptops), and many 

webcams (see below) also have microphones built in. You can also use a headphones-and-microphone 

headset that can be bought quite cheaply. 

 A webcam. This is a small camera that connects to your computer through a USB port, if  it isn’t already 

built into your screen. A webcam isn’t compulsory, but video calls are a  key function of Skype, and you 

can’t make them without one. 

Our guide is specifically for Windows computers, but Skype is also available for Apple Macs. 

  

Follow these step-by-step instructions to download Skype now 
  

Step 1: Go to the Skype.com home page. 

  

 
 

 Step 2: Click on Download Skype on the page. 

  

 Step 3: A page will appear where you can either sign in (if you’ve registered already) or input your 

information to create an account. 

 You can skip the registration if you sign in using a Microsoft Account (Messenger, Hotmail or    

  outlook.com) or a Facebook account. 

  If not, there are also a number of boxes to fill in to create an account: 

  

  To begin, fill in your first name and last name and your email address (and repeat it).                     

          These are all required. No one will be able to see your email address. 

 
  

http://www.skype.com/
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 Profile information. All this will be available for anyone to see on Skype, except for  your mobile 

number, which will be restricted to your own contacts. However, you do not have to fill in all the boxes 

with personal information, only those with a star next to them. 

  

 
 

Step 4: You can choose to tell Skype how you intend to use its service by clicking one of the options in 

the drop-down menu. 

  

 'Skype Name' - Enter the name that you want your Skype friends to see and which you’ll use to log in to 

Skype. Whether you use your real name is up to you. None of the 650 million users of Skype can have the 

same Skype name, so if your own name is a common one, you might want to change it a little – for 

instance, by adding your year of birth. The system will automatically check to see if your name has been 

claimed by anyone else and, if it has, will suggest alternatives. Don’t worry if your name isn’t available – 

you can easily modify it until you come up with a unique moniker. 

 'Password' - Enter (and repeat) the password you’d like to use. It must consist of six to 20 characters and 

contain both letters and numbers. 

 If you don’t want promotional emails from Skype, untick the two boxes towards the bottom. 

 The ‘captcha’ box: This is designed to make sure that you are you and not a naughty computer.   

  Look at the text in the first box and then type it into the box below – in this case, ‘deouotThere’. If you 

can’t read the text, click theRefresh button and you’ll be given another bit   

  of text to copy. 

 Finally click on I agree – Continue. 

 

 
  

Step 5: You’ll be taken to a page headed ‘Your account is ready’. Click onDownload Skype for 

Windows. If you have a different version of Windows or if you have Linux, click on ‘download a 

different version’.  

  

 
  

http://digitalunite.com/guides/using-internet-0/searching-browsing/what-captcha
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 Step 6: Another box will open up asking you to Run or Save to your computer. Click Run. 

 Another window will open saying that there isn’t far to go now. Tick Run Skype when the computer 

starts to enable Skype whenever you turn your computer on. It will also ask which language you wish to 

proceed in. Click I agree – next. 

  

Step 7: When the next window appears it will ask whether you want to have Skype Click to call which 

enables you to call instant numbers shown on websites. Tick Install Skype Click to call. Click 

on Continue. 

 
  

 You may also get another window pop up asking if you wish to make MSN your homepage. Tick or 

untick as you wish. Click Continue.  

  

 
  

Step 8: A new window will open. This contains a progress bar that will fill up while the Skype program 

downloads and installs. Once it’s done, Skype will automatically start. 

  

 
  

Step 9: Skype will now open up and you will be able to find contacts and start making calls. 

 

Usage of Skype 

How do I call someone in Skype for Windows Desktop? 

You can make a voice or video call to anyone on Skype, anywhere in the world, for free. Simply find 

your family, friends and colleagues who are using Skype and add them to your contact list. When you’ve 

added them, it’s easy to make a call. And now you can translate voice and video calls in 6 languages (for 

users on Windows 7 and above). 

 

Watch this short video to find out how, or follow the steps below. 

  

1. In Skype, click Contacts. 
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2. Find the person you want to call from your contact list. If you have lots of contacts, you can type a name 

in the search box to find the contact you’re looking for. 

 
3. Click the contact. You’ll see their details in the main window. 

       If the contact has one of these status icons displayed next to their name 

 It means they’re on Skype and you can call them for free. 

 It means they’re on a mobile or landline so you’ll need a little Skype Creditor a subscription to call 

them. 

 

 It means that the person hasn’t yet accepted your contact request. 

4.   Click the Call button  to make a video call. 

 

 
 

The screen changes color and you’ll hear ringing until the other person answers. 

5. If you don’t see or hear the other person, or they can’t see or hear you, click the call quality    

  icon(you may need to move your mouse to make it appear). Check the tabs to look for potential   

  problems. 

 

 
 

If problems persist, take a look at our call quality guide. 

6. At the end of the call, click the End call button  to hang up. 

Invite anyone to your call 

We've launched a new way to invite anyone to your call. You don't need to know their Skype name, and 

they don't even need to have a Skype account to enjoy free voice, video and instant message 

conversations with you. Learn more. 

 Useful things you can do on a call 

 
 

 Show or hide your Contacts or Recent lists. 

 If you have a webcam, turn your video on and off. 

http://www.skype.com/go/skypecredit/?intcmp=CS-Upsell-FA3681
http://www.skype.com/go/subscriptions/?intcmp=CS-Upsell-FA3681
https://support.skype.com/faq/FA12097/
https://support.skype.com/faq/FA34569/
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 Mute your microphone so the other person can’t hear you. 

 Send files, send contacts, share your screen, add people to the conversation and show      

         the dial pad. 

  End the call. 

 Check your call settings and connection speed, and adjust your microphone, speaker and webcam. 

 Show the IM window so you can instant message the person you’re talking to. 

  Turn on/off Skype translator during your call.  

 

Cyber Hygiene 

Today we focus on cyber hygiene. 

"Cyber hygiene refers to steps that computer users can take to improve their cyber security and better 

protect themselves online." 

 
 

Installing and running cyber hygiene step-by-step 

Cyber hygiene is installed and run separately from IBM® Intelligent Operations Center and must be 

installed and run after all other IBM Intelligent Operations Center components are installed, configured, 

and are operational. Cyber hygiene changes the default operating system configuration to a more secure 

set of options that help to assure a more secure foundation for the IBM Intelligent Operations Center 

system. 

 

Before you begin 

Note: Cyber hygiene is installed and run in the same step. If you are installing IBM Intelligent Operations 

Center using IBM Installation Manager, do not use these steps. The IBM Installation Manager installation 

provides an option to install and run cyber hygiene. 

To reduce the time cyber hygiene runs scans and remediation, unmount any file system not required to be 

assessed for security. For example, the install_media directories on each server can be deleted after all 

installation steps are complete. These directories can be deleted or unmounted before running cyber 

hygiene. 

On the installation server, go to the directory where the IBM Intelligent Operations Center installation 

package was copied. In these steps, this directory is referred to as install_home. 

 

About this task 

Cyber hygiene should be the last step after installation of the IBM Intelligent Operations Center. The scan 

and remediation’s address configuration security exposures that exist after default operating system and 

the IBM Intelligent Operations Center product are installed. The remediations applied have been tested to 

confirm that IBM Intelligent Operations Center services will operate correctly. 

Changes applied to the system by cyber hygiene can cause problem with other applications and solutions. 

For example, other applications and solutions might have requirements on the Linux environment that are 

https://support.skype.com/faq/FA3091/
https://support.skype.com/faq/FA10220/
https://support.skype.com/faq/FA10215/
http://images.huffingtonpost.com/2015-10-01-1443716890-4500032-NCSAM01OCT2015.png
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not in accord with good security practices. An application or solution might require for the system to be 

logged on as the root user to be installed or run. In this case some of the cyber hygiene changes might 

need to be temporarily or permanently changed or another solution found from the supplier of the 

application or solution. 

Once cyber hygiene changes are made, there is no automated method to change them. Any changes must 

be made by manual updates to the Linux operating system or by changing file or directory permissions. 

 

Procedure 

1. On the installation server open a terminal window and log on as root. If not logged on as root, switch to 

the root account by running the su - command. 

2. Run the export JAVA_HOME=/opt/ibm/java-x86_64-  60/jre command. The JAVA_HOME variable 

is set to the Java runtime environment (JRE). 

3. Change to the install_home/ch/install directory. 

4. Edit the iop-ch-install.xml file using a text editor. 

5. Replace the parameters in the iop-ch-install.xml file with the values appropriate for you installation. 

6. Save the file. 

7. Change to the install_home/ch directory. 

8. Run the install__home/ch/install/iop-ch-install.sh -r iop-ch-install- messages.properties -f 

’com.ibm.iop.cyber.hygiene.scripts.lite_1.5.0.zip’ –dinstall_media/ioc/image -

p GRUB_password command where GRUB_password is  the password to the GRUB boot loader on the 

servers. The GRUB_password will beapplied to all target servers. Normally when servers are restarted, no 

password is required however, once cyber hygiene is installed, if you start a server with any Linux option, 

such as starting in single-user mode, theGRUB_password will have to be entered on the server console. 

 

Results 

The processing time is determined by the speed of the hardware and if extra, unnecessary files are on the 

target servers. Processing can run up to 1.5 hours. During that time target servers will be scanned and the 

appropriate remediation applied. 

 

What to do next 

Check the cyber hygiene log for any error. The logs will also show the applied remediation and optional 

manual steps. 

 

Changes to the Linux operating system 

 Cyber hygiene scans the Linux operating system for well-known security exposures and makes 

appropriate changes. Logs describe the scanned exposures and the changes made to Linux OS policies 

and settings. 

 

Reviewing the cyber hygiene log 
after cyber hygiene is installed and run, review the log to understand the changes that were made to the 

system and any remaining exposures. 

 

Re-enabling remote root log on 
Cyber hygiene disables remote log on to the root account through the ssh command. 

The telnet and rsh commands are completely disabled in the Linux operating system.    

If needed, remote log on can be re-enabled. 
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Symantec Antivirus software Installation Procedure 

 

Installation instructions: 

 

Before you install Symantec Antivirus software: 

Installing Symantec Antivirus 

 

Close your web browser and double -click on the Symantec Antivirus installer that should be 

located on your computer desktop. The icon you double click will look like this:  
 

Symantec Antivirus Client Setup will open. 

 

1.  Click Next.  
 
 
 
 
 
 1 
 

 
 
 
 
 
 
 
 
 
 
 

 

Read the license agreement screen. If you agree to it (which you must do to continue 

installation): 

 
2. Click the button to select "I accept the terms of the license agreement"  
3. Click Next.  

 
 
 
 
 
 
 
 
 2 
 

 3 
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Symantec will ask if you want to have e-mail checked. 

 

4) If you use Microsoft Exchange / Outlook or Lotus Notes, select one of these clients  and then 

click Next. 
 

5) If not, simply click next. 

 
 
 
 

4)  Optional   
 
 

  
 
 
 5 
  
 

 
 
 
 
 

 

Symantec will prompt you to install the program in a default location. 

 

6.  Click Next to accept the default installation path.  
 
 
 
 
 
 
 

 

6 

 

 

 

 

 

 

 

 

 

In the Network Setup Type window: 

 

7. Select Unmanaged  
8. Click Next. 
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7 
 

 

8 
 
 
 
 
 
 
 
 
The Initial Settings window will open. Keep the default settings selected so that Symantec will 

watch for viruses. 

 
9.  Click Next.  
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Live Update 

 

Ensure your Internet connection is active: 

 

1. Click Live Update to acquire the latest version of the software and update your virus 

definition files during installation. 
 
 
 
 
 
 
 
 
 
 
 
 

 

1 
 
 
 
 
 
 

2. Click Next  
 
 
 
 
 
 
 
 
 
 
 

 

2 
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3. Click Install  
 
 
 
 
 
 
 
 
 
 
 
 

 

3 
 
 
 
 
 
 
If you ran Live Update, drag the Symantec installation window out of the way. In the 

underlying Live Update window, click next. 

 
When the update is complete, click Finished. If you receive an "Old Virus Definition File" 

message, disregard it and click Close. 

 
Read the license agreement screen, and if you agree to it, select “I accept the terms of the license 

agreement” and click next. 

 
The installation wizard will appear. Click Install. 

 

A technical support window will appear. In the Technical Support window, click Next, then click 

Finish to complete the installation proces



 

 

WEEK: 5    MS WORD-I 

 

Microsoft Word (simply referred to as Word) is a sophisticated word processing application 

program/package specially designed for performing various word processing tasks, such as typing, editing 

and printing out of textual information. It allows adequate control over the creation and presentation of 

the typographic work. Microsoft Word also offers facilities for basic graphic design, statistical report of 

a document, spelling and grammar checking tasks, etc. These and numerous other features and facilities 

Word offers make it stand out among word processing programs, as well as make the difference between 

it and other mechanical devices for word processing (e.g. typewriter). 

 

Importance of Microsoft Word 

 Microsoft Word is an effective tool for creating all kinds of documents like letters, memos, 

reports, term papers, and typesetting novels and magazines, etc. 

 Microsoft  Word offers you specialized tools for formatting your document in various ways; 

perform spelling and grammar check to produce standard and error-free documents; in-built 

thesaurus for finding appropriate synonyms to replace repetitive words/phrases; word count 

feature for a statistical report of your document; drawing and graphics editing tools to add a touch 

of graphics or images to go with your documents; sounds and video handling tools to add 

multimedia feature to a document; numerous wizards and tools for creating and distributing 

merged faxes, form letters, labels and envelopes, etc. 

 Microsoft Word is highly useful for creating text of large volume. 

 You can easily create and maintain mailing lists, create personalized documents and create 

newsletters in Word. 

 It also helps you send documents to a group of people for feedback. 

 Word provides customized assistance in many ways. 

 With Word, you can import files or objects from other programs and use them in your 

documents. 

 Word also offers facilities for exporting documents to other packages, e.g. Lotus Notes, 

WordPerfect, etc. 

 Microsoft office is a set of inter related desk top applications, servers and services, collectively 

refers to 

 As an office suit for the micro soft windows and MAC OSX operating systems. 

 

 

 

 

  

MS WORD: 

 
Microsoft Word is a word processing software package. we can use it to type letters, reports, and 

other documents. In Word 2007, how a window displays depends on the size of your window, the 

size of your monitor and the resolution to which your monitor is set. Resolution determines how 

much information your computer monitor can display. 

 

 
 



 

 

 

 

 

 

 

 

 

 

 

 

STARTING MS WORD:- 
 
Two ways of starting MSWORD:- 
 
Double click on Microsoft word icon on the desk top. 
 
Click on start -> programs-> ms office -> ms word.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Microsoft Office Button 
 
 
In the upper-left corner of the Word 2007 window is the Microsoft Office button. When you click the 

button, a menu appears. You can use the menu to create a new file, open an existing file, save a file, and 

perform many other tasks. 
 
 
 
 
 
 
 



 

 

The Quick Access Toolbar 
 
 
The Quick Access toolbar provides you with access to commands you frequently use. By default Save, 

Undo, and Redo appear on the Quick Access toolbar. You can use Saves your file, Undo to rollback an 

action you have taken, and Redo to reapply an action you have rolled back. 

 

 

 

 

The Ribbon 
 

 
We use the Ribbon to issue commands. The Ribbon is located near the top of the screen, below the 

Quick Access toolbar. At the top of the Ribbon are several tabs; clicking a tab displays several related 

command groups. Within each group are related command buttons. You click buttons to issue 

commands or to access menus and dialog boxes. 

 

 

 

 

 

The Ruler 

 

We can use the ruler to change the format of your document quickly  
 
 
 

 

The Text Area 

 

You type your document in the text area. The blinking vertical line in the upper-left corner of the text 

area is the cursor. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

The Status Bar 

 

The Status bar appears at the very bottom of your window and provides such information as the current 

page and the number of words in your document. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Using Word to create project certificate. Features to be covered:-Formatting Fonts in word, Drop Cap in 

word, Applying Text effects, Using Character Spacing, Borders and Colors, Inserting Header and Footer, 

Using Date and Time option in both LaTeX and Word. 

The graphical user interface (GUI) provides ways to apply the various font formatting options (or 

character formatting options) to your text. In Word 2010 and Word 2007, many of these options are 

displayed directly in the Font group on the Home tab of the Ribbon and on the contextual toolbar that 

appears when you right-click within text. Additional options are available in the Font dialog box, which 

you can open by clicking the Font dialog box launcher ( ) in the lower right-hand corner of the Font 

group on the Home tab. In Word 2003, many of these options are displayed directly on the Formatting 

toolbar, and additional options are available in the Font dialog box, which you can open by right-clicking 

and then clicking Font ( ) on the context-sensitive menu that opens or by clicking Font on the Format 

menu. The Font dialog box has two tabs. 

 

Font 

 

Character Spacing 

 

The font formatting options that you can configure on the Font tab in the Font dialog box influence the 

appearance of the individual characters in your text. 



 

 

 

 

A drop cap is a specially formatted letter that appears at the beginning of a paragraph. Word 2007 offers 

two styles of drop caps. The first, and more common, begins the paragraph with a large letter that spills 

down into the text. Thus, the drop cap displaces the first few lines of the paragraph. The second style 

places the large first letter in the margin adjacent to the paragraph. 

 
Add an effect to text 

 

Select the text that you want to add an effect to. 

On the Home tab, in the Font group, click Text Effect.  
 
 
 
 
 
 
 
 
 

 

Click the effect that you want. 
 
For more choices, point to Outline, Shadow, Reflection, or Glow, and then click the effect that you want 
to add. 

 
Remove an effect from text 

 
Select the text that you want to remove an effect from. 

 
On the Home tab, in the Font group, click Clear Formatting.  

 
 
 
 
 
 
 
 
 
 



 

 

 

If you want to add a graphic or text at the top or the bottom of your document, you need to add a header 

or footer. You can quickly add a header or a footer from the galleries, or you can add a custom header or 

footer. 

 
You can use these same steps to add a header or footer without page numbers. 

 

Add a header or footer from the gallery 

 

On the Insert tab, in the Header & Footer group, click Header or Footer. 

Click the header or footer that you want to add to your document. 
 
 
To return to the body of your document, click Close Header and Footer on the Design tab (under Header 

& Footer Tools). 
 
 
 
 
 
 
 
 
 

 

 

Click where you want to insert the date or time. 

 

On the Insert tab, in the Text group, click Quick Parts.  
 
 
 
 
 
 
 
 

 

Click Field. 

 

In the Categories box, click Date and Time. 

 

In the Field names box, click Create Date, Print Date, or Save Date. 

 

Formatting A Text 

Formatting refers to changing the font style, size, italics and other related parameters. A good formatted 

text can help in creating a nice impression. Further, formatting is required to highlight certain important 

factors and points. The main steps to consider while formatting are as follows. 

 Select the text that you want to format. If it is the entire document, click Control + A or select the 

specific portion. 

 After you have selected the part, you want to format, click on the Home tab in the top row. 

 You can see a dropdown list with font name and adjacent to it you have another drop down list 

displaying font size. 



 

 

 

 
As you can see, there are various fonts and you may select the one you want. 

 

 
 

As you can see in the above screenshot, you may alter font size with the drop box. 

 You can change either of them if you want another font or different size. 

 
You can adjust more with advanced font settings. 

 Just below the font name and size, you have another row with options like 

 Bold: if you want to bold some points, click on the icon. To remove bold, click again. 

 Italics: for italicizing a portion, click “I”. For removing the italics, click it again. 

 Underline: if you wish to underline a part, click on the “U” button. Clicking on the same button 

again will remove the underline. 

 

 
 

As you can see, the different options like Bold, Italics, and Underline are present in the home tab itself. 

There are other options as well, like make a strikethrough, use subscript, change case from lowercase to 

uppercase or vice versa. You can even capitalize the first letter of each word or highlight a certain part 

using different colors. 

Thus, this was all about basic editing in a word file. 

 

 

 



 

 

 

Paragraph Formatting 

 

A paragraph is a unit of text or other content that starts at the beginning of a document, immediately after 

a hard return (a carriage return), a page break, or a section break, or at the beginning of a table cell, 

header, footer, or list of footnotes and ends with a hard return (carriage return) or at the end of a table cell. 

Word documents generally contain paragraphs with different formatting.  

 

Even a very simple document with a centered heading and a justified body contains paragraphs with two 

different types of formatting. 

Word's graphical user interface (GUI) provides ways to apply numerous formatting options to your 

paragraphs. However, these options are not available in a single location, and some of these locations 

differ in different versions of Word. For this reason, this page is divided into the following sections, and 

the applicable options are described in each section. 

 The Paragraph Group 

 The Paragraph Dialog Box 

 The Tabs Dialog Box 

 Keyboard Shortcuts 

 More Information 

 

The Paragraph Group 

Many options are available directly in the Paragraph group on the Home tab of the Ribbon, in the 

Paragraph group on the Page Layout tab, and on the contextual toolbar and menu that appear when you 

right-click within text. 

 

Alignment: 

Alignment or justification refers to the way in which the lines of a paragraph are aligned. There are four 

types of alignment, and the type of alignment of the paragraph where your cursor is located is indicated 

by the highlighted button in the Paragraph group on the Home tab. 

 

 
 

 With left alignment ( ) (the default), the left-hand ends of all the lines in the paragraph are 

aligned along the left-hand margin of the text area. 

 With center alignment ( ), the mid-points (centers) of all the lines in the paragraph are aligned 

along the same imaginary vertical line at the center of the text area between the margins. 

 With right alignment ( ), the right-hand ends of all the lines in the paragraph are aligned along 

the right-hand margin of the text area. 

 With justified alignment or full justification ( ), all the lines in the paragraph, except the last 

line, are extended so that the left-hand end of each line is aligned along the left-hand margin of 

the text area, the right-hand end of each line is aligned along the right-hand margin of the text 

area, and the lines are all of the same length. This is achieved by inserting additional space 

between words. 

You can change the type of alignment of the paragraph where your cursor is located or of a group of 

selected paragraphs by clicking the applicable button in the Paragraph group on the Home tab. There are 

also shortcut keys (see the table in Keyboard Shortcuts below) for setting the type of alignment. 

 

http://makeofficework.com/paragraph_formatting.htm#tabs
http://makeofficework.com/paragraph_formatting.htm#shortcuts


 

 

Note. When you apply justified alignment to a paragraph, the last line does not extend across the full 

width of the text area. You can make all the lines in a paragraph extend across the full width of the text 

area by placing your cursor within the paragraph and pressing Ctrl+Shift+J, but it should be mentioned 

that in this case Word also adds space between letters within words to extend the lines. 

 

Line Spacing: 

Line spacing refers to the vertical distance between the lines within a paragraph and determines the 

location of each line relative to the line above it. Line spacing can be specified by name (single, 1.5 lines, 

double), by a number that indicates a multiple of single spacing (for example, 2.0 is equivalent to double 

spacing), and by an exact distance in points, where a point (pt) is equal to 1/72 of an inch. You can 

quickly view and change the line spacing to several common standard values by clicking the Line Spacing 

button ( ) in the Paragraph group on the Home tab. More line spacing options become available when 

you click Line Spacing Options to open the Paragraph dialog box (see below). 

 

Indents: 

The indent before text refers to the width of the additional empty space that is inserted between the 

margin and the text on the left-hand side of a paragraph of left-to-right text, and the indent after text refers 

to the width of the additional empty space that is inserted between the text and the margin on the right-

hand side of a paragraph of left-to-right text. You can quickly increase the indent before text to the next 

tab stop by clicking the Increase Indent button ( ) in the Paragraph group on the Home tab, and you can 

quickly decrease the indent before text to the preceding tab stop by clicking the Decrease Indent button (

) in the Paragraph group on the Home tab. 

You can set the indent before text (the left indent for left-to-right text) to values that do not correspond to 

tab stops, and you can also set the indent after text (the rights indent for left-to-right text) in the Paragraph 

group on the Page Layout tab. 

 

 
 

 

Paragraph Spacing: 

The spacing between your paragraphs is determined by the spacing before it and the spacing after it that 

are set for each paragraph. You can modify the spacing before a paragraph and the spacing after it by 

changing the values in the applicable boxes in the Paragraph group on the Page Layout tab. 

 

Note. When the first of two consecutive paragraphs has non-zero spacing after it and the second 

paragraph has non-zero spacing before it, only the larger of the two spaces will be inserted between the 

paragraphs. 

 

Borders: 

If you want to add borders around the paragraph where your cursor is located, click the Borders button (

) to add the current default borders (the original default or the last border style that you selected). If 

you want to select a border style that differs from the current default border style, click the small arrow on 

the Borders button, and select one of the border styles displayed or click Borders and Shading to define 

your own custom borders. If you want to add borders around multiple paragraphs, select the applicable 

paragraphs before you click the Borders button or the small arrow on it. 

 

 



 

 

Shading (Colored Background): 

If you want to add shading with the current default background color to the entire text area of the 

paragraph where your cursor is located, click the Shading button ( ) in the Paragraph group on the 

Home tab. If you want to select a background color other than the current default color, click the small 

arrow on the Shading button and then click one of the colors displayed or define your own custom color. 

If you want to apply the same shading to multiple paragraphs, select the applicable paragraphs before you 

click the Shading button or the small arrow on it. 

If you choose a very dark background color, Word will automatically change the text color to white to 

maintain good contrast and keep your text visible. 

 

The Paragraph Dialog Box: 

Many of the paragraph formatting options described in the previous sections and additional paragraph 

formatting options are available in the Paragraph dialog box, which has two tabs. 

 Indents and Spacing 

 Line and Page Breaks 

 

Before opening the Paragraph dialog box, place your cursor anywhere within a single paragraph that you 

want to format or select the multiple paragraphs that you want to format. To  open the Paragraph dialog 

box, on the Home tab or on the Page Layout tab, at the bottom of the Paragraph group, click the 

Paragraph dialog box launcher ( ). 

When you click OK in the Paragraph dialog box or press Enter, any changes that you have made on either 

tab will be applied to the single paragraph where you cursor was located or to the paragraphs that you 

selected. 

The paragraph formatting options that are available on the Indents and Spacing tab of the Paragraph 

dialog box are divided among the General, Indentation, and Spacing groups. 

 

 
 

These paragraph formatting options are described in the next subsections.  

 

 

 

 

 

 

 



 

 

 

Keyboard Shortcuts: 

The keyboard shortcuts (or shortcut keys or shortcut key combinations) that you can use to quickly apply 

paragraph formatting are listed in the following table. 

Keyboard shortcuts for use in paragraph formatting 

 

Key Action 

Ctrl+E Applies center alignment. 

Ctrl+J Applies justified alignment. 

Ctrl+Shift+J Spreads the current paragraph across the entire width between the margins. 

Ctrl+M 
Increases the indentation of the current paragraph or selected paragraphs to the next 

tab stop. 

Ctrl+Shift+M Decreases the indentation to the preceding tab stop. 

Ctrl+Q 
Resets the paragraph formatting to the default paragraph formatting of the applied 

style. 

Ctrl+R Applies right alignment. 

Ctrl+Shift+S 

Opens the Apply Styles task pane for applying, creating, or modifying styles and 

formatting (use Alt+Ctrl+Shift+S to modify a style without applying it to the 

selection). 

Alt+Ctrl+Shift+S Opens the Styles pane. 

Ctrl+1 Applies single line spacing to the current paragraph or selected paragraphs. 

Ctrl+2 Applies double spacing to the current paragraph or selected paragraphs. 

Ctrl+5 Applies 1.5 line spacing to the current paragraph or selected paragraphs. 

Ctrl+0 Adds or removes additional space before the current paragraph or selected paragraphs. 

Shift+F1 Shows or hides the formatting properties in the task pane. 

F4 Redoes the last action performed. 

 

 Inserting Tables: 

 

Introduction 

A table is a grid of cells arranged in rows and columns. Tables can be customized and are useful for 

various tasks such as presenting text information and numerical data.  

In this lesson, you will learn how to convert text to a table, apply table styles, format tables, and create 

blank tables. 

 
 

Inserting and modifying tables 

In Word, tables are useful for organizing and presenting data. You can create a blank table, convert text to 

a table, and apply a variety of styles and formats to existing tables. 



 

 

Optional: You can download this example for extra practice. 

To insert a blank table: 

1. Place your insertion point in the document where you want the table to appear. 

2. Select the Insert tab. 

3. Click the Table command. 

4. However your mouse over the diagram squares to select the number of columns and rows in the 

table. 

 
5. Click your mouse, and the table appears in the document. 

6. You can now place the insertion point anywhere in the table to add text. 

 

To convert existing text to a table: 

1. Select the text you want to convert. 

2. Select the Insert tab. 

3. Click the Table command. 

4. Select Convert Text to Table from the menu. A dialog box will appear. 

 

 
 

5. Choose one of the options in the Separate text at: section. This is how Word knows what text to 

put in each column. 

 
 

 

 

 

 

 

http://media.gcflearnfree.org/ctassets/topics/174/Word2010_Tables_Practice.docx


 

 

6. Click OK. The text appears in a table. 

 
To add a row above an existing row: 

1. Place the insertion point in a row below the location where you want to add a row. 

 
2. Right-click the mouse. A menu appears. 

3. Select Insert Insert Rows Above. 

 

 
 

4. A new row appears above the insertion point. 

 
You can also add rows below the insertion point. Follow the same steps, but select Insert Rows Below 

from the menu. 

To add a column: 

1. Place the insertion point in a column adjacent to the location where you want the new column to 

appear. 

2. Right-click the mouse. A menu will appear. 

 
 

 

 

 

 

 



 

 

3. Select Insert Insert Columns to the Left or Insert Columns to the Right. A new column 

appears. 

 
To delete a row or column: 

1. Select the row or column. 

2. Right-click your mouse. A menu will appear. 

3. Select Delete Cells. 

 
 

4. Select Delete entire row or Delete entire column, then click OK. 

 
 

Bullets and Numbering: 
 

In Microsoft word we can easily create bulleted or numbered list of items. 

 

Changing text direction: 

 

You can change the text orientation in drawing objects, such as text boxes, shapes, and callouts, or in 

table cells so that the text is displayed vertically or horizontally. 

 

Track changes: 

 

Track changes is an excellent feature of Microsoft word as it enables a user or reviewer to keep track of 

the changes that have taken a period. Changes like insertion, deletion or formatting changes can be kept 

track of. 

 

Procedure: 

 

Changing Text direction: 

 

1. Click the drawing object or table cell that contains the text you want to change. 



 

 

 

2. On the Format menu, click Text Direction. 

 

3. Click the orientation you want. 

 

Cell Alignment: 
 
 

1. Click the cell that contains text you want to align. 
 

On the Tables and Borders toolbar, select the option for the horizontal and vertical alignment you 

want— for example, Align Bottom Center or Align Top Right. 

To change table style options: 

Once you've chosen a table style, you can turn various options on or off to change the appearance of the 

table. There are six options: Header Row, Total Row, Banded Rows, First Column, Last Column, and 

Banded Columns. 

 

1. Click anywhere on the table. The Design tab will appear. 

2. From the Design tab, check or uncheck the desired options in the Table Style Options group. 

 

 
 

Depending on which table style you're using, certain table style options may have a somewhat different 

effect. You may need to experiment to get the exact look you want. 

To add borders to a table: 

1. Select the cells you want to add a border to. 

 
2. From the Design tab, select the desired Line Style, Line Weight, and Pen Color. 

 
3. Click the Borders drop-down arrow. 

4. From the drop-down menu, select the desired border type. 

 



 

 

 
 

5. The border will be added to the selected cells. 

 
Modifying a table using the Layout tab 

When you select a table in Word 2010, Design and Layout tabs appear under Table Tools on the Ribbon. 

Using commands on the Layout tab, you can make a variety of modifications to the table. 

Click the buttons in the interactive below to learn about the different ways you can modify a table with 

the Layout tab. 

 
Foot Note: 
 

1. In print layout view, click where you want to insert the note reference mark. 
 

2. On the Insert menu, point to Reference, and then click Footnote. 
 

3. Click Footnotes or Endnotes. 
 

 

By default, Word places footnotes at the end of each page and endnotes at the end of the 

document. You can change the placement of footnotes and endnotes by making a selection in the 

Footnotes or Endnotes box. 

 

4. In the Number format box, click the format you want. 
 

5. Click Insert. 
 

Word inserts the note number and places the insertion point next to the note number. 
 

6. Type the note text. 
 

7. Scroll to your place in the document and continue typing. 



 

 

 

As you insert additional footnotes or endnotes in the document, Word automatically applies the 

correct number format. 

 

Hyper link: 

 

Select the text or picture you want to display as the hyperlink, and then click Insert Hyperlink on the 

Standard toolbar 

 

Do one of the following: 

 

1. Link to an existing file or web page: 

 

1. Under Link to, click Existing File or Web Page. 

 

2. In the Address box, type the address you want to link to or, in the Look in box, click the 

down arrow, and navigate to and select the file 

 

2. Link to a file you haven’t created yet Under Link to, click Create New Document. 

 

3. In the Name of new document box, type the name of the new file. 

 

4. Under When to edit, click either Edit the new document later or Edit the new document 

now 

Symbol: 
 

1. Click where you want to insert the symbol. 
 

2. On the Insert menu, click Symbol, and then click the Symbols tab. 
 

3. In the Font box, click the font that you want. 
 

4. Double-click the symbol that you want to insert. 
 

5. Click Close 

 

Spell check: On the Standard toolbar, click Spelling and Grammar 
1. When Word finds a possible spelling or grammatical problem, make your changes in the Spelling 

and Grammar dialog box. 

Inserting clip art and pictures 

Adding clip art and pictures to your document can be a great way to illustrate important information or 

add decorative accents to existing text. You can insert images from your computer or search Microsoft's 

extensive selection of clip art to find the image you need. Once an image has been inserted, you can 

format text to wrap around the image. 

To locate clip art: 

1. Select the Insert tab. 

2. Click the Clip Art command in the Illustrations group. 



 

 

 
 

3. The clip art options appear in the task pane to the right of the document. 

4. Enter keywords in the Search for : field that are related to the image you want to insert. 

5. Click the drop-down arrow in the Results should be: field. 

6. Deselect any types of media you do not want to see. 

 
7. If you also want to search for clip art on Office.com, place a check mark next to Include 

Office.com content. Otherwise, it will just search for clip art on your computer. 

 

 
8. Click Go. 

 

To insert clip art: 

1. Review the results from a clip art search. 

2. Place your insertion point in the document where you want to insert the clip art. 

3. Click an image in the Clip Art pane. It will appear in the document. 

 
 

You can also click the drop-down arrow next to the image in the Clip Art pane to view more options. 

To insert a picture from a file: 

 



 

 

1. Place your insertion point where you want the image to appear. 

2. Select the Insert tab. 

3. Click the Picture command in the Illustrations group. The Insert Picture dialog box appears. 

 
4. Select the desired image file, then click Insert to add it to your document. 

 

 
 

To resize an image, click and drag one of the corner sizings handles. The image will change size while 

keeping the same proportions. If you want to stretch it horizontally or vertically, you can use the side 

sizing handles. 

 
Drawing Toolbar and Word Art: 
 
1. Click in your document where you want to create the drawing. 
2. On the Insert menu, point to Picture, and then click New Drawing. A drawing canvas is inserted     
      into your document. 
3. Use the Drawing toolbar to add any shapes or pictures that you want. 
 

Word Art:  
1.On the Drawing toolbar, click Insert WordArt 
2. Click the WordArt effect you want, and then click OK. 
3. In the Edit WordArt Text dialog box, type the text you want. 
4. Do any of the following: 
 

o To change the font type, in the Font list, select a font. 
 

o To change the font size, in the Size list, select a size. 
 

o To make text bold, click the Bold button. 
 

o To make text italic, click the Italic button. 
 
Formatting Images: 
 
1. Formatting of the images can be achieved by selecting the image and double click on the 
picture, format picture dialog box appears. 
 
2. The same can be achieved by selecting the tools menu > customize>tool bars tab>picture 
and click close.  



 

 

 
Basic formatting features of an image 
 
Text Box: 
 
1.  On the Drawing toolbar, click Text Box . 
2. Click or drag in your document where you want to insert the text box 
 
You can use the options on the Drawing toolbar to enhance a text box— for example, to 
change the fill color— just as you can with any other drawing object 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  



 

 

WEEK: 6    MS WORD-II 

 

PROCEDURE: 

Prepare Resume 

Creating a Resume from a Template (Word 2003, 2007, 2010, 2013) 

Step 1: 

To create a resume, open Microsoft Word and locate the File tab. Select New from the drop-down menu. 

 

Step 2: 

A new word document is opened. 

 

  

 

Step 3: 

Fill in with your details needed in a resume. 

 

https://cdn.papercheck.com/wp-content/uploads/2015/08/25040925/office-2010-resume-template-step-1.png


 

 

WEEK: 7    EXCEL-I 

Spreadsheet basics: 

 

Step:1: Go to 

 

 

 

Step2: 

 

Notice there is rows and columns. 

 Each column has a capital letter on the top to show what column it is. 

 Each row has a number to the immediate left of the first column, to show what row it is. 

 Each cell is identified by a unique address consisting of the column letter followed by  

 the row number. For example, the address of the cell in the first column, first row is A1.  

 The address of the cell in the second column, third row is B3. 

 If you click a cell, the cell address appears just above column A. 

 

 

Step 3: 

Click cell A1 and type: Item. 

 

 



 

 

Step 4 :       Step 5: 

Click cell B1 and type: Cost.     Click cell A2 and type: Printing. 

 

 

Step:6      STEP: 7 

Click in cell B2 and type 80.00.    Click cell A3 and type: Postage. 

 After you click outside of cell B2,  

80 will show in cell B2. 

 

STEP:8      STEP:9  

Click cell B3 and type: 75.55.    Click cell A4 and type: Envelopes. 

 After you click outside of cell B3,  

75.55 will show in cell B3. 

 

 

 

 

 

 



 

 

10 Click cell B4 and type: 6.00.    STEP: 11 

 After you click outside of the cell B4,     Click cell A5 and type: Total. 

6 will show in cell B4. 

 

STEP: 12 

Click cell B5 and type: =SUM(B2:B4). 

 

 

STEP: 13 

Click in another cell. A total of 161.55 will show in cell B5. 

 SUM(B2:B4) is a formula. Formulas are used to perform math functions in Excel. It is essential to put 

equals sign (=) just before a formula, so that Excel knows that it is a formula. 

 

 

 



 

 

STEP: 14 

Click Save. 

 

 

Modifying worksheets: 

Creating New Worksheet 

Three new, blank sheets always open when you start Microsoft Excel. But suppose that you want start 

another new worksheet while you are working on another worksheet, or you closed already opened 

worksheet and want to start a new worksheet. Here are the steps to create a new worksheet: 

Step (1) : Right Click the Sheet Name and select Insert option. 

 

 

Step (2) : Now you'll see the Insert dialog with select Worksheet option as selected from the general 

tab. Click Ok button 

 

Now you should have your blank sheet as shown below ready to start typing your text. 



 

 

 

You can use a short cut to create a blank sheet anytime. Try using Shift+F11keys and you will see a new 

blank sheet similar to above sheet is opened. 

Formatting cells: 

 

Knowing how to format your spreadsheet in Excel, the cells in particular, can really help you improve not 

just the aesthetic perspective of your document, but also its effectiveness in providing relevant 

information to the viewers of the files. Each cell in Microsoft Excel can be modified and formatted to 

follow your specific preferences. 

 

STEP 1: 

Open your Microsoft Excel. Click the “Start” button on the lower-left corner of your screen and select 

“All Programs” from the menu. Inside, you’ll find the “Microsoft Office” folder where Excel is listed. 

Click on Excel. 

 

 

STEP 2: 

Select the specific cell or group of cells that you want to format. Highlight it using your mouse cursor. 

 

SETP 3: 

Open the Format Cells window. Right-click on the cells you’ve selected and select “Format Cells” from 

the popup menu to access the “Format Cells” window. 



 

 

 

STEP 4: 

Set the desired formatting options you want for the cell. There are six formatting options that you can 

use to customize a cell or group of cells: 

 Number – Defines the format of numerical data entered on the cells such as dates, currency, time, 

percentage, fraction and more. 

 Alignment – Sets how the data will be visually aligned inside each cells (left, right or centered). 

 Font – Sets all the options related to text fonts such as styles, sizes and colors. 

 Border – Improves the visual appearance of each cell by adding definite lines (borders) around a cell or 

group of cells. 

 Fill – Sets the background color and pattern formats of each cell on the spreadsheet. 

 Protection – Adds security to cells and data contained inside it by hiding or locking the selected cells or 

group of cells. 

 

 

STEP 5: 

Save. Click on the “OK” button at the lower right corner of the “Format Cells” window to save any 

changes you’ve made and apply the formats you’ve set to the selected cells. 

 
 

Formulas and Functions: 

A formula is an expression which calculates the value of a cell. Functions are predefined formulas and are 

already available in Excel. 

For example, cell A3 below contains a formula which adds the value of cell A2 to the value of cell A1. 

 



 

 

 

For example, cell A3 below contains the SUM function which calculates the sum of the range A1:A2. 

 

Enter a Formula 

To enter a formula, execute the following steps. 

1. Select a cell. 

2. To let Excel know that you want to enter a formula, type an equal sign (=). 

3. For example, type the formula A1+A2. 

 

 

Tip: instead of typing A1 and A2, simply select cell A1 and cell A2. 

4. Change the value of cell A1 to 3. 

 

Excel automatically recalculates the value of cell A3. This is one of Excel's most powerful features! 

 

 

 

 

 

 

 



 

 

Edit a Formula 

 

When you select a cell, Excel shows the value   1. To edit a formula, click in the formula bar and 

or formula of the cell in the formula bar.                       change the formula. 

 

 

2. Press Enter. 

 

 

Operator Precedence 

Excel uses a default order in which calculations occur. If a part of the formula is in parentheses, that part 

will be calculated first. It then performs multiplication or division calculations. Once this is complete, 

Excel will add and subtract the remainder of your formula. See the example below. 

 

 

First, Excel performs multiplication (A1 * A2). Next, Excel adds the value of cell A3 to this result. 

Another example, 

 

 



 

 

First, Excel calculates the part in parentheses (A2+A3). Next, it multiplies this result by the value of cell 

A1. 

Copy/Paste a Formula 

 

When you copy a formula, Excel automatically adjusts the cell references for each new cell the formula is 

copied to. To understand this, execute the following steps. 

 

1. Enter the formula shown below into cell A4.              2a. Select cell A4, right click, and then click Copy      

                                                                                        (or press CTRL + c)... 

 

 

...next, select cell B4, right click, and then click Paste under 'Paste Options:' (or press CTRL + v). 

 

2b. You can also drag the formula to cell B4. Select cell A4, click on the lower right corner of cell A4 and 

drag it across to cell B4. This is much easier and gives the exact same result! 

 

 

Result. The formula in cell B4 references the values in column B. 

 

 

 

 



 

 

Insert a Function 

Every function has the same structure. For example, SUM(A1:A4). The name of this function is SUM. 

The part between the brackets (arguments) means we give Excel the range A1:A4 as input. This function 

adds the values in cells A1, A2, A3 and A4. It's not easy to remember which function and which 

arguments to use for each task. Fortunately, the Insert Function feature in Excel helps you with this. 

To insert a function, execute the following steps. 

1. Select a cell. 

2. Click the Insert Function button. 

 

 

The 'Insert Function' dialog box appears. 

 

3. Search for a function or select a function from a category. For example, choose COUNTIF from the 

Statistical category. 

 

 

4. Click OK. 

The 'Function Arguments' dialog box appears. 

5. Click in the Range box and select the range A1:C2. 

6. Click in the Criteria box and type >5. 

7. Click OK. 

 

 

Result. Excel counts the number of cells that are higher than 5. 



 

 

 

Note: instead of using the Insert Function feature, simply type =COUNTIF(A1:C2,">5"). When you 

arrive at: =COUNTIF( instead of typing A1:C2, simply select the range A1:C2. 

Percent Change 

 The percent change formula is used very often in Excel. For example, to calculate the Monthly Change 

and Total Change. 

 

1a. Select cell C3 and enter the formula                  1b. Select cell C3 and apply a Percentage format. 

shown below. 

 

 

We don't need to repeat step 1a and step 1b ten more times. 

 

1c. Select cell C3, click on the lower right               1d. Check if everything went alright. 

corner of cell C3 and drag it down to cell C13. 

 

 

1d. Check if everything went alright. 

2a. In a similar way, we can calculate the Total Change. This time we fix the reference to cell B2. Select 

cell D3 and enter the formula shown below. 

 



 

 

 

2b. Select cell D3 and apply a Percentage format. 
 

2c. Select cell D3, click on the lower right corner of cell D3 and drag it down to cell D13. 
 

2d. Check if everything went alright. 

 

Explanation: when we drag the formula down, the absolute reference ($B$2) stays the same, while the 

relative reference (B3) changes to B4, B5, B6, etc. Maybe this is one step too far for you at this stage, but 

it shows you one of the many other powerful features Excel has to offer. 

Names in Formulas 

 Create a named range or a named constant and use these names in your formulas. This way you can make 

your formulas easier to understand. 

Named Range 

To create a named range, execute the following steps. 

1. Select the range A1:A4. 

2. On the Formulas tab, click Define Name. 

 

 

 

 

 

 

http://www.excel-easy.com/functions/cell-references.html#absolute-reference


 

 

3. Enter a name and click OK.             4. Select the range, type the name in the    

                                                                                                 Name box and press Enter. 

 

 

There's an even quicker way of doing this. 

 

4. Select the range, type the name in the Name box and press Enter. 

5. Now you can use this named range in your formulas. For example, sum Prices. 

 

Named Constant 

 

To create a named constant, execute the following steps. 

1. On the Formulas tab, click Define Name. 

2. Enter a name, type a value, and click OK. 

 

3. Now you can use this named constant in your formulas. 

 

Note: if the tax rate changes, use the Name Manager to edit the name and Excel automatically updates all 

the formulas that use TaxRate. 



 

 

Name Manager 

To edit and delete defined names, execute the following steps. 

1. On the Formulas tab, click Name Manager.                      2. For example, select TaxRate and click Edit. 

 

 

 

A dynamic named range expands automatically when you add a value to the range. 

1. For example, select the range A1:A4 and name it Prices. 

 

2. Calculate the sum.                                                         3. When you add a value to the range, Excel does  

                                                                                         not update the sum. 

 

 

 

To expand the named range automatically when you add a value to the range, execute the following the 

following steps. 

 

4. On the Formulas tab, click Name Manager.                  5. Click Edit. 

 

 

 



 

 

6. Click in the "Refers to" box and enter the formula =OFFSET($A$1,0,0,COUNTA($A:$A),1) 

 

 

Explanation: The Offset function takes 5 arguments. Reference: $A$1, rows to offset: 0, columns to 

offset: 0, height: COUNTA($A:$A), width: 1. COUNTA($A:$A) counts the number of values in column 

A that are not empty. When you add a value to the range, COUNTA($A:$A) increases. As a result, the 

named range expands. 

 

7. Click OK and Close. 

8. Now, when you add a value to the range, Excel updates the sum automatically. 

 

Paste Options 

 This example illustrates the various paste options in Excel. Cell B5 below contains the SUM function 

which calculates the sum of the range B2:B4. Furthermore, we changed the background color of this cell 

to yellow and added borders. 

 

 

 

Paste 

 

The Paste option pastes everything. 

1. Select cell B5, right click, and then click Copy (or press CTRL + c). 

2. Next, select cell F5, right click, and then click Paste under 'Paste Options:' (or press CTRL + v). 
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Result. 

 

Values 

The Values option pastes the result of the formula. 

1. Select cell B5, right click, and then click Copy (or press CTRL + c). 

2. Next, select cell D5, right click, and then click Values under 'Paste Options:' 

 

Result. 

 

Note: to quickly replace the formula in cell B5 with its own result, select cell B5, press F2 (to edit the 

formula) and press F9. 

Formulas 

The Formulas option only pastes the formula. 

1. Select cell B5, right click, and then click Copy (or press CTRL + c). 

2. Next, select cell F5, right click, and then click Formulas under 'Paste Options:' 

 

Result. 

 

 



 

 

Formatting 

The Formatting option only pastes the formatting. 

1. Select cell B5, right click, and then click Copy (or press CTRL + c). 

2. Next, select cell D5, right click, and then click Formatting under 'Paste Options:' 

 

Result. 

 

Note: the Format Painter copy/pastes formatting even quicker. 

 

Paste Special 

 

The Paste Special dialog box offers many more paste options. To launch the Paste Special dialog box, 

execute the following steps. 

1. Select cell B5, right click, and then click Copy (or press CTRL + c). 

2. Next, select cell D5, right click, and then click Paste Special. 

 

 

The Paste Special dialog box appears. 

 



 

 

Note: here you can also find the paste options described above. You can also paste comments only, 

validation criteria only, use the source theme, all except borders, column widths, formulas and number 

formats, values and number formats. You can also use the Paste Special dialog box to perform quick 

operations, skip blanks and transpose data. 

Status Bar 

The quickest way to see the average, count, numerical count, minimum, maximum or sum of selected 

cells is by taking a look at the status bar. 

1. Select a range of cells.                                                    2. Look at the status bar at the bottom of your  

                                                                                       window to see the sum of these cells. 

 

 

 

3. Right click the status bar to add the     Result: 

average, count, numerical count,  

minimum or maximum. 

 

Quick Operations 

 Use the 'Paste Special Operations' to quickly perform operations on a range of cells in Excel. 

1. Select cell D3. 

2. Right click, and then click Copy. 

 

3. Select the range A1:B8. 

4. Right click, and then click Paste Special... 

 

 



 

 

5. Click Multiply.      6. Click OK. 

 

 

Note: you can also Divide, Add or Subtract a value. 

 

Note: all values are increased by 10 percent. Without this feature, you would have to create a temporary 

range (with formulas that multiply the values in the range A1:B8 by 1.1) and then replace the range 

A1:B8 by copy and pasting the temporary range as values. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

WEEK: 8    MS EXCEL - II 

Sorting and Filtering: 

Filter 

 Filter your Excel data if you only want to display records that meet certain criteria. 

1. Click any single cell inside a data set. 

2. On the Data tab, click Filter.                                  Arrows in the column headers appear. 

 

3. Click the arrow next to Country. 

4. Click on Select All to clear all the check              5. Click OK.Result. Excel only displays the sales in 

the USA. 

boxes, and click the check box next to USA. 

 

 

 

6. Click the arrow next to Quarter. 
 

7. Click on Select All to clear all the check           8. Click OK. 

boxes, and click the check box next to Qtr 4.             Result. Excel only displays the sales in the USA in    

                                                                             Qtr 4. 

 

 



 

 

9. To remove the filter, on the Data tab, click Clear. To remove the filter and the arrows, click Filter. 

 

 

Number and Text Filters 

 This example teaches you how to apply a number filter and a text filter to only display records that meet 

certain criteria. 

1. Click any single cell inside a data set. 

2. On the Data tab, click Filter.           Arrows in the column headers appear. 

 

 

Number Filter 

 

To apply a number filter, execute the following steps. 

3. Click the arrow next to Sales. 

4. Click Number Filters (this option is available because the Sales column contains numeric data) and 

select Greater Than from the list. 

 

 

5. Enter 10,000 and click OK. 

 

 

 



 

 

Result. Excel only displays the records where Sales is greater than $10,000. 

 

Note: you can also display records equal to a value, less than a value, between two values, the top x 

records, records that are above average, etc. The sky is the limit! 

Text Filter 

To apply a text filter, execute the following steps. 

3. Click the arrow next to Last Name. 

4. Click Text Filters (this option is available because the Last Name column contains text data) and select 

Equals from the list. 

 

 

5. Enter ?m* and click OK. 

 

Note: A question mark (?) matches exactly one character. An asterisk (*) matches a series of zero or more 

characters. 

Result. Excel only displays the records where the second character of Last Name equals m. 

 

Note: you can also display records that begin with a specific character, end with a specific character, 

contain or do not contain a specific character, etc. The sky is the limit! 

Date Filters 



 

 

 This example teaches you how to apply a date filter to only display records that meet certain criteria. 

1. Click any single cell inside a data set. 

2. On the Data tab, click Filter.                                 Arrows in the column headers appear. 

 

 

 

 

3. Click the arrow next to Date. 

4. Click on Select All to clear all the check          5. Click OK. 

boxes, click the + sign next to 2012,                                        Result. Excel only displays the sales in     

  and click the check box next to January.                               2012, in January. 

 

 
 

6. Click the arrow next to Date. 

7. Click on Select All to select all the check boxes. 

8. Click Date Filters (this option is available because the Date column contains dates) and select Last 

Month from the list. 

 

 

 

 

 

 



 

 

Result. Excel only displays the sales of last month. 

 

 
 

Note: this date filter and many other date filters depend on today's date. 

 

Sort 

 You can sort your Excel data on one column or multiple columns. You can sort in ascending or 

descending order. 

One Column 

To sort on one column, execute the following steps. 

1. Click any cell in the column you want to sort.                          2. To sort in ascending order, on the Data  

                                                                                                  tab, click AZ. 

 

 
 

Result: 

 

Note: to sort in descending order, click ZA. 

Multiple Columns 

To sort on multiple columns, execute the following steps. 

1. On the Data tab, click Sort. 

 

 



 

 

The Sort dialog box appears. 

2. Select Last Name from the 'Sort by' drop-down list. 

 

 

3. Click on Add Level. 

4. Select Sales from the 'Then by' drop-down list. 

 

5. Click OK. 

Result. Records are sorted by Last Name first and Sales second. 

 

 
Sort by Color 

Excel 2007 makes it possible to sort data by color. 

 

 
 

To sort data by color, execute the following steps. 

1. Click any single cell inside a data set. 

2. On the Data tab, click Sort. 



 

 

 

The Sort dialog box appears. 

3. Sort by Last Name (or any other column), sort on Cell Color (you can also sort on Font Color and Cell 

Icon), and select the green color for the first level. 

 

 
 

4. Click 'Copy Level' two times and select the other colors. 

5. Click OK. 

 

 
 

Result. 

 

 
 

 

Charts: 

A simple chart in Excel can say more than a sheet full of numbers. As you'll see, creating charts is very 

easy. 



 

 

Create a Chart 

To create a line chart, execute the following steps. 

1. Select the range A1:D7. 

2. On the Insert tab, in the Charts group, choose Line, and select Line with Markers. 

 

 

Result: 

 

 

Change Chart Type 

You can easily change to a different type of chart at any time. 

1. Select the chart. 

2. On the Insert tab, in the Charts group, choose Column, and select Clustered Column. 

 

 

Result: 

 

 



 

 

Switch Row/Column 

If you want the animals, displayed on the vertical axis, to be displayed on the horizontal axis instead, 

execute the following steps. 

1. Select the chart. The Chart Tools contextual tab activates. 

2. On the Design tab, click Switch Row/Column. 

 

 

Result: 

 

Chart Title 

 

To add a chart title, execute the following steps. 

1. Select the chart. The Chart Tools contextual tab activates. 

2. On the Layout tab, click Chart Title, Above Chart. 

 

 

3. Enter a title. For example, Population. 

Result: 

 
 
 

 

 

 



 

 

Column Chart 

Column charts are used to compare values across categories by using vertical bars. 

To create a column chart, execute the following steps. 

1. Select the range A1:A7, hold down CTRL, and select the range C1:D7. 

2. On the Insert tab, in the Charts group, choose Column, and select Clustered Column. 

 

 
 

Result: 

 

Note: only if you have numeric labels, empty cell A1 before you create the column chart. By doing 

this, Excel does not recognize the numbers in column A as a data series and automatically places these 

numbers on the horizontal (category) axis. After creating the chart, you can enter the text Year into cell 

A1 if you like. 

 

 

Line Chart 

Line charts are used to display trends over time. Use a line chart if you have text labels, dates or a few 

numeric labels on the horizontal axis. Use a scatter chart (XY chart) to show scientific XY data. 

To create a line chart, execute the following steps. 

1. Select the range A1:D7. 

2. On the Insert tab, in the Charts group, choose Line, and select Line with Markers. 
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Result: 

 

 

Note: only if you have numeric labels, empty cell A1 before you create the line chart. By doing 

this, Excel does not recognize the numbers in column A as a data series and automatically places these 

numbers on the horizontal (category) axis. After creating the chart, you can enter the text Year into cell 

A1 if you like. 

 

Pie Chart 

Pie charts are used to display the contribution of each value (slice) to a total (pie). Pie charts always use 

one data series. 

To create a pie chart of the 2009 data series, execute the following steps. 

1. Select the range A1:D2. 

2. On the Insert tab, in the Charts group, choose Pie, and select Pie. 

 

 
 

 

 

 

Result: 

 

 
 

4. Click on the pie to select the whole pie. Click on a slice to drag it away from the center. 
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Result: 

 

 

Note: only if you have numeric labels, empty cell A1 before you create the pie chart. By doing 

this, Excel does not recognize the numbers in column A as a data series and automatically creates the 

correct chart. After creating the chart, you can enter the text Year into cell A1 if you like. 

 

Bar Chart 

 A bar chart is the horizontal version of a column chart. Use a bar chart if you have large text labels. 

To create a bar chart, execute the following steps. 

1. Select the range A1:B6. 

2. On the Insert tab, in the Charts group, choose Bar, and select Clustered Bar. 

 

 
 

Result: 

 

 
 

Area Chart 

An area chart is a line chart with the areas below the lines filled with colors. Use a stacked area chart to 

display the contribution of each value to a total over time. 

To create an area chart, execute the following steps. 

1. Select the range A1:D7. 

2. On the Insert tab, in the Charts group, choose Area, and select Area as subtype. 
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Result. In this example, some areas overlap.                            Below you can find the corresponding  

                                                                                                line chart to clearly see this. 

 

3. Change the chart's subtype to Stacked  

Area (the one next to Area). 

Result: 

 

 
 

Note: only if you have numeric labels, empty cell A1 before you create the area chart. By doing 

this, Excel does not recognize the numbers in column A as a data series and automatically places these 

numbers on the horizontal (category) axis. After creating the chart, you can enter the text Year into cell 

A1 if you like. 

 

Scatter Chart 

Use a scatter chart (XY chart) to show scientific XY data. Scatter charts are often used to find out if 

there's a relationship between variable X and Y. 

Straight Lines 

To create a scatter chart, execute the following steps. 

1. Select the range A1:D22. 

2. On the Insert tab, in the Charts group, choose Scatter, and select Scatter with Straight Lines. 
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Note: also see the subtype Scatter with Smooth Lines above Scatter with Straight Lines. 

Result: 

 

 
 

Note: we added a horizontal and vertical axis title. The horizontal axis of a scatter chart is a value axis, so 

you have more axis scaling options (the same as a vertical axis which always is a value axis). 

Only Markers 

To find out if there is a relationship between X (a person's salary) and Y (his/her car price), execute the 

following steps. 

1. Select the range A1:B10. 

2. On the Insert tab, in the Charts group, choose Scatter, and select Scatter with only Markers. 

 

 
 

Result: 

 

Note: we added a trend line to clearly see the relationship between these two variables. 

Data Series 

A row or column of numbers that are plotted in a chart is called a data series. You can plot one or more 

data series in a chart. 

To create a column chart, execute the following steps. 

1. Select the range A1:D7. 
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2. On the Insert tab, in the Charts group, choose Column, and select Clustered Column. 

 

 

Chart Sheet 

So far we have only seen charts on the same worksheet as the source data (embedded charts). However, 

you can also move a chart to a separate sheet that only contains a chart (chart sheet). 

To move a chart to a chart sheet, execute the following steps. 

1. Select the chart. The Chart Tools contextual tab activates. 

2. On the Design tab, click Move Chart. 

 

 
The Move Chart dialog box appears. 

3. Click New sheet and enter a name. 

4. Click OK. 

 

 
 

Result: 

 

Note: repeat these steps, but instead of New sheet at step 3, click Object in, to move the chart back to the 

same worksheet as the source data. 

 

 



 

 

Hyper Linking: 

 

1. Create a worksheet: On the file menu, click new, and then click blank workbook task pane. 

2. Insert a worksheet: C lick worksheet on the insert menu. Right click on sheet tab and then click   

3.  Insert double clicks the template for the type of sheet you want. 

      Hyperlink: Using hyperlink we can insert one more sheet in the present sheet 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

WEEK: 9   MS POWER POINT 

 

PROCEDURE:  

 

1. Choose Start | All Programs | Accessories | Run, as shown in Figure 3 (highlighted in red). 

You can also skip this step by pressing Windows + R shortcut keys together on your keyboard. 

 

 
Figure 1: Run command within the Start menu of Windows 7 

 

2. This opens the Run dialog box, as shown in Figure 2. 

 

 
Figure 2: Run dialog box in Windows 7 

3. Type powerpnt.exe without the quotes in the dialog box, as shown in Figure 5 -- and click OK. 

 

 
Figure 3: PowerPoint being summoned through the Run Window 

 

4. If you have PowerPoint installed, it should launch now -- otherwise you'll see an error message.  

 

Power Point Screen: 

You use PowerPoint to create effective slide show presentations. The PowerPoint screen has 

many elements.  



 

 

 
 

Title Bar 

The Title bar generally appears at the top of the screen. The Title bar displays the title of the current 

presentation.  

 

Menu Bar 
The Menu bar displays the menu. You use the menu to give instructions to PowerPoint. 

 

Standard and Formatting Toolbars 
PowerPoint has several toolbars. Toolbars provide shortcuts to menu commands. The most commonly 

used toolbars are the Standard and Formatting toolbars. You use the Standard toolbar to do such things as 

open a file; save a file; print a file; check spelling; cut, copy, and paste; undo and redo; or insert a chart or 

table. You use the Formatting toolbar to change the font, font size or font color; bold, underline, or 

italicize text; left align, right align, center, or justify; bullet or number lists; highlight; or decrease or 

increase the indent. 

 

Rulers 
Rulers are vertical and horizontal guides. You use them to determine where you want to place an object. 

They are marked in inches. 

 

Placeholders 
Placeholders hold the objects in your slide. You use placeholders to hold text, clip art, and charts. 

 

Status Bar 
The Status bar generally appears at the bottom the screen. The Status bar displays the number of the slide 

that is currently displayed, the total number of slides, and the name of the design template in use or the 

name of the background. 

 

Outline Tab 
The Outline displays the text contained in your presentation.  

 

Slides Tab 
The Slides tab displays a thumbnail of all your slides. You click the thumbnail to view the slide in the 

Slide pane. 

 

View Buttons 
The View buttons appear near the bottom of the screen. You use the view buttons to change between 

Normal view, Slider Sorter view, and the Slide Show. 

 

Normal View 

Normal view splits you screen into three major sections: the Outline and Slides tabs, the Slide 

pane, and the Task pane. The Outline and Slides tabs are on the left side of your screen. They 

enable you to shift between two different ways of viewing your slides. The Slides tab shows 

thumbnails of your slides. The Outline tab shows the text on your slides. The Slide pane is 



 

 

located in the center of your screen. The Slide pane shows a large view of the slide on which you 

are currently working. The Task pane is located on the right side of your screen. The Tasks pane 

enables you to select the task you want to perform. 

 

 Slide Sorter View 

Slide Sorter view enables you to view thumbnails of all your slides. In Slide Sorter view you can 

easily add, delete, or change the order of your slides. When you are in Slide Sorter view, a special 

Formatting toolbar appears. It has options that allow you to make changes to your slides 

 

Slide Show 

Use the Slide Show view when you want to view your slides, as they will look in your final 

presentation. When in Slide Show view: 

 

Drawing Toolbar 
The Drawing toolbar generally appears near the bottom of the screen. It contains tools for creating and 

editing graphics. 

 

Common Tasks Buttons 
Using the common tasks buttons, you can select the type of tasks you want to perform. 

 

Task Pane 
The Task pane enables you to select the specific task you want to perform. 

 

Vertical Splitter Bar 
You can click and drag the vertical splitter bar to change the size of your panes. 

 

Minimize Button 
You use the Minimize button to remove a window from view. While a window is minimized, its title 

appears on the taskbar. 

 

Maximize/Restore Button 
You use the Maximize button to cause a window to fill the screen. After you maximize a window, if you 

click the Restore button, the window returns to its former size. 

Close Button 

You use the Close button to exit the window and close the program. 

 

Working with slides: 

When you start PowerPoint, PowerPoint displays the Title Slide in the Slide pane. You can type the title 

of your presentation and a subtitle on this side. To enter text on the Title Slide: 

 Click and type the title of your presentation in the "Click to add title" area. 

 Click and type a subtitle in the "Click to add subtitle" area.  

If you do not wish to use the Title Slide, choose Edit > Delete slide from the menu to delete it. 

Create New Slides 

After completing your title slide, you can create additional slides. To create a new slide: 

1. Do one of the following:  

o Choose Insert > New Slide from the menu. 

o Click the New Slide button . 

o Press Ctrl-M.  

The Apply Slide Layout pane will appear on the right side of the screen. The Apply Slide Layout pane 

provides you with slide templates you can use when creating your PowerPoint presentation. There are 

four types of Text Layout templates.  



 

 

Title Slide - The Title Slide contains two text placeholders that you can use to display a title and a subtitle 

of your presentation. 

Title Only - The Title Only slide contains a single placeholder. You can use it to display a title. 

Title and Text - The Title and Text template provides a placeholder for a title and a placeholder for text. 

Title and 2 Column Text - The Title and Text template provides a placeholder for a title and two 

placeholders for text. 

2. To select a layout, click the layout you want in the Apply Slide Layout pane. The layout will then 

appear in the Slide pane. 

 
3. To add text, click inside the placeholder and type. 

4. To add an additional slide to your presentation do one of the following: 

o Right-click on the slide layout. A menu will appear. Choose Insert New Slide. 

o Click the down arrow next to the slide layout. A menu will appear). Choose Insert New 

Slide. 

 
Change Your Slides 

After creating a slide, if you want to add text: 

1. Place the cursor at the point at which you would like to add text. 

2. Type the information you want to add. 

If you would like to change text: 

1. Highlight the text you want to change. 

2. Type the new text. 

You can use the backspace key to delete text. You can also delete text by highlighting the text and 

pressing the Delete key. 

Apply a Design Template 

Design templates provide attractive backgrounds for your PowerPoint slides. To apply a design template: 

1. Do one of the following:  

o Choose Format > Slide Design from the menu. 

o Click the Slide Design icon . 

Design templates will appear on the right side of the screen.  

2. To apply a design template to all of the slides in your presentation do one of the following:  

o Click on the design template. 

o Right-click on the template. A menu will appear. Choose Apply to All Slides. 

o Click on the down arrow next to the template. A menu will appear. Choose Apply to All 

Slides. 

 
Correct Spelling 

Using the PowerPoint spell checker, you can check the spelling in you PowerPoint documents. 

1. To start spell check, do one of the following:  

o Choose Tools > Spelling from the menu. 

o Press F7. 

o Click the Spell Check icon. 



 

 

If there are possible spelling errors, the Spelling dialog box will open. 

Task Procedure 

Do not change spelling.  Click Ignore. 

Correct spelling. 1. Click the correct spelling in the 

Suggestions box. 

2. Click Change.  

Add to Dictionary. Click Add. 

Word is Correct. Do not change 

document. 

Click Ignore All. 

Word is incorrect. Change entire 

document.  

Click Change All. 

 

Sorter View 
After you have created your PowerPoint slides, you can move, cut, copy, paste, duplicate, navigate, and 

view them in Sorter view. To view the slides in Sorter view, do one of the following: 

o Choose View > Slide Sorter from the menu. 

o Click the Slide Sorter View icon. 

 
 

Slide Sorter View 

Task Procedure 

Move to first slide. Ctrl-Home 

Move to last slide.  Ctrl-End  

Move to next slide. Right arrow 

Move to previous slide. Left arrow 

Select a slide. Single-click 

Open slide in Normal view. Double-click slide. 

Select slides. Select a single slide:  

1. Click the slide you want to 

select.  

Select multiple slides: 

1. Hold down Ctrl key. 

2. Click the slides you want to 

select. 



 

 

Slide Sorter View 

Task Procedure 

Delete a slide. 1. Select the slide or slides you 

want to delete. 

2. Press the Delete key. 

1. Select the slide or slides you 

want to delete. 

2. Choose Edit > Delete Slide 

from the menu. 

Copy a slide. 1. Select the slide.  

2. Choose Edit > Copy from the 

menu. 

1. Select the slide. 

2. Click the copy icon. 

1. Select the slide. 

2. Press Ctrl-C. 

Paste a slide 1. Select the slide after which 

you want the new slide or 

slides to appear. 

2. Choose Edit > Paste from the 

menu. 

1. Select the slide after which 

you want the new slide or 

slides to appear. 

2. Click the paste icon. 

1. Select the slide after which 

you want the new slide or 

slides to appear. 

2. Press Ctrl-V. 

Cut a slide 1. Select the slide or slides you 

want to cut. 

2. Choose Edit > Cut from the 

menu. 

1. Select the slide or slides you 

want to cut. 

2. Click the Cut icon. 

1. Select the slide or slides you 

want to cut. 

2. Press Ctrl-X. 

Move a slide 1. Select the slide or slides you 

want to move. 

2. Drag to the new location. 



 

 

Slide Sorter View 

Task Procedure 

Duplicate a slide  1. Select the slide or slides you 

want to       duplicate. 

2. Choose Edit > Duplicate from 

the menu. 

1. Select the slide or slides you 

want to duplicate. 

2. Press Ctrl- D. 

Run Your PowerPoint Slide Show 

Once you have created your slides, you can run your Slide Show: 

1. Do any one of the following:  

o Press F5. 

o Choose Slide Show > View Show from the menu. 

o Click the Slide Show icon , which is located in the bottom left corner of your screen.  

Your slideshow will appear on your screen. 

Navigating the Slideshow 

Task Procedure 

Go to the next slide. Do one of the following: 

 Press the Right Arrow key. 

 Press the Enter key. 

 Press the Page Down key. 

 Left-click 

Go to the previous slide. Do one of the following: 

 Press the Left Arrow key. 

 Press the Backspace key. 

 Press the Page Up key. 

 

 

Add content: 

Add text to a slide 

Applies To: PowerPoint 2007 

You can add text to the following areas of a slide: 

 Text Placeholders 

 Text boxes 

 Shapes 

 

NOTES: It's important to note that there is a difference with how you use a text placeholder versus a text 

box in Slide Master view. Here's the difference: 

o Add a text placeholder from within Slide Master view when you want to prompt users of your  

template to replace the prompt text with text that is pertenent to their own project. Normal behavior of 

custom prompt text in a text placeholder is that it disappears when you begin typing. For procedures on 

how to do this, see Add a text placeholder with custom prompt text. 

o Add a text box from within Slide Master view when you want it to contain permanent,     



 

 

   Un editable text. 

   When you add a text box in Normal view, the text is editable by anyone. 

Add text to a placeholder 

Below, the dotted border represents the placeholder that contains the title text for the slide. 

 
To add text to a text placeholder on a slide, do the following: 

 Click inside the placeholder and then type or paste the text. 

NOTE: If your text exceeds the size of the placeholder, Microsoft Office PowerPoint 2007 reduces the font 

size and line spacing incrementally as you type to make the text fit. 

Add text to a text box 

Use text boxes to place text anywhere on a slide, such as outside a text placeholder. For example, to add a 

caption to a picture, create a text box and position it near the picture. 

NOTE: When you add a text box in Normal view, the text is editable by anyone. When you add a text 

box in Slide Master view, the text you add to it will become permanent and uneditable outside the Slide 

Master. 

 To add text to a text box that anyone can edit, in Normal view, click inside the text box, and     

 then type or paste the text. 

 To add text to a text box that is contain permanent and uneditable, in Slide Master view,  

      click click inside the text box, and then type or paste the text. 

Add text that is part of a shape 

Shapes such as squares, circles, callout balloons, and block arrows can contain text. When you type text 

into a shape, the text attaches to the shape and moves and rotates with it. 

 To add text that becomes part of a shape, select the shape, and then type or paste the text. 

      Add text that is independent of a shape 

A text box is handy if you want to add text to a shape, but you don't want the text to attach to the shape. 

You can add a border, fill, shadow, or three-dimensional (3-D) effect to text in a text box. 

 To add text that moves independently of a shape, add a text box, and then type or paste the  

     text. 

       Add a text box 

a.     On the Insert tab, in the Text group, click Text Box. 

NOTE: If you are using an East Asian language, from the Text Box drop-down menu, click 

either Horizontal or Vertical alignment. 

b.    Click the slide, and then drag the pointer to draw the text box. 

 

WORKING WITH TABLES: 

PowerPoint is a great way to present data to groups, and if you create slideshows it’s important to know 

how to present information. Today we’ll briefly go over the use of tables in a presentation. 

On The Ribbon Click the Insert tab and click Table.  

 
 

 

http://www.howtogeek.com/wp-content/uploads/2007/12/17.png


 

 

 

You will get a menu which allows you to select how many rows and columns to include with the table. 

 
Choose the design and theme by choosing the Design tab and select Themes. 

 
Also in Design you can choose from a plethora of table designs.  Just hovering over the different designs 

will show what that design looks like in the document. 

 
You can really mix and match designs, colors, and themes to create a quality presentation.  

 
1. Open your presentation and navigate to a slide containing the table you need to edit. Select the 

table, as shown in Figure 1. Then, select the Table Tools Layout tab of the Ribbon (highlighted 

in red within Figure 1). 

 

 
Figure 1: Table Tools Layout tab of the Ribbon 

 

http://www.howtogeek.com/wp-content/uploads/2007/12/2.png
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2. Within the Table Tools Layout tab, locate the Rows & Columns group as shown in Figure 2. 

This group includes four buttons named Insert Above,Insert Below, Insert Left, and Insert 

Right (highlighted in red within Figure 2). These buttons will help you add and remove table rows 

and columns.  

 

 
Figure 2: Rows & Columns group within the Table Tools Layout tab 

 
Now, follow these guidelines to add or remove rows/columns within the table: 

 

Add Table Rows and Columns 

1. To add a row above a particular row, select that row first. Then click the Insert 

Above button (highlighted in red within Figure 3).  

 

 

 
Figure 3: Table row selected 

 

2. This will add a new row above the selected row as shown in Figure 4. 

 
Figure 4: New row inserted above the selected row 

 

3. Similarly, clicking the Insert Below button (highlighted in blue withinFigure 3) with a row 

selected, will add a new row below the selected row as shown in Figure 5. 

 
Figure 5: New row inserted below the selected row 

 

4. To add a column before a particular column, select that column first. Then click the Insert 

Left button (highlighted in red within Figure 6.  

 

http://www.indezine.com/products/powerpoint/learn/tables/2013/select-table-rows-columns-ppt.html


 

 

 
Figure 6: Table column selected 

5. This will add a new column before the selected column, as shown in Figure 7.  

 
Figure 7: New column added before the selected column 

 

6. Similarly, clicking the Insert Right button (highlighted in blue withinFigure 6) with a 

column selected, will add a new column next to the selected column as shown in Figure 8.  

 

 
Figure 8: New column added after the selected column 

 

Delete Table Rows and Columns 

Follow these steps to delete a row or a column: 

7. To delete a particular row(s) select the corresponding row(s) and click the Delete button, as 

shown highlighted in red within Figure 9. From the resultant drop-down gallery, select 

the Delete Rows option (refer to Figure 9 again). 

 

 
Figure 9: Delete a row within a table 

8. To delete a particular column(s) select the corresponding column(s) and click 

the Delete button, as shown highlighted in red within Figure 10. From the resultant drop-

down gallery, select the Delete Columns option (refer to Figure 10 again). 

 

 
Figure 10: Delete a column within a table 

3. Add or remove table rows and columns as required. 

4. Save your presentation often. 



 

 

 

ANIMATION: 

Click on the image or the text you would like to animate. To select a whole text box, click on the 

border of the text box. It will automatically send in the text by paragraphs unless you highlight all 

the text in the box, in which case it all comes in at the same time. 

 

 
 

Go to the "Animations" tab. In the 2007 and 2010 versions of PowerPoint, this tab is located at the top 

of the page, next to "Transitions". You can either open the "Animation pane" in 2010, or use the drop 

down list. In 2007, use "Custom animation". 

 
Select the animation you would like. There are entrances, exits, emphasis, and paths. 

 
Specify whether you want your animation to start "On mouse click", "After previous" or "With 

previous". 

 

 
Preview the effect by either going to slideshow mode. Click "preview", "play" or the F5 key on your 

keyboard. It's now ready to go, or you can add as many more as you'd like to your PowerPoint 

presentation. 

 

http://www.wikihow.com/Insert-a-PowerPoint-to-Google-Page


 

 

How to Add Audio to PowerPoint  

Microsoft PowerPoint provides numerous options for adding audio to a presentation. Music, sounds and 

audio effects can be imported into PowerPoint and adjusted to fit the timing of a presentation. Audio 

narrations also can be recorded and timed to meet user specifications. This article provides detailed 

instructions for adding audio clips and recording a narration in PowerPoint. 

 

Method:1 Method an audio file in PowerPoint: 

 

Import an audio file saved to the computer. Open the presentation and select a slide to add an audio 

file. Click the Insert tab on the menu bar and click the Audio File button in the far right corner of the 

menu bar. Select the Audio From File option from the pull-down menu. Locate the audio file you wish to 

add to the presentation and double-click to insert it into the current slide. The audio file has been inserted 

into the presentation. 

 

 
Format the audio file for playback. Click the Playback tab in the Audio Tools menu to open the 

Playback menu. Under Audio Options, click the Start menu and select the On Click, Automatic or Play 

Across Slides options as desired. Apply a fade effect, adjust the volume levels, trim the audio clip or 

adjust other settings as needed in the Playback menu. The audio file has been formatted. 

 

 
 

Procedure for adding sound to presentation: 
 

1. On the slide show menu, click setup show. Under performance check box. If your computer 

has their capability, office PowerPoint will attempt to use it. 

2. Animation performance will be much better with a video card that has Microsoft direct 3D. 
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Importance of latex: 

LaTeX is a TeX format written by a computer scientist named Leslie Lamport. LaTeX is based 

on the principle that authors should concentrate on logical design rather than visual design when 

writing their documents. Thus instead of writing 

 

 \vspace{1.5cm} 

  \begin{centering} 

  \Large \bf 

  2. Section Title 

  \end{centering} 

 

LaTeX provides infrastructure that makes it possible for authors to write 

 

  \section{Section Title} 

and have not only the visual appearance but even the numbering be done automatically. LaTeX 

also has certain features designed to be used in conjunction with auxiliary programs such as 

make index and BibTeX that help automate the tasks of making indexes and bibliographies. 

LaTeX is a typesetting system that is extremely useful for typing and formatting scientific 

documents. Typing in math equations is very intuitive and easy in LaTeX. One of the biggest 

advantages in using this software is that the user need not concentrate on the layout of the 

document because LaTeX takes care of all that by itself, resulting in really good looking and 

cleanly professional documents.  

LaTeX is for science, Word for general use (and even for that...) 

LaTeX makes it very simple to handle equations, figures, bibliographies, indexes, etc. With 

LateX you focus on the content of the document and let the program handle how the output is 

formatted.  

If you want to write a paper with LaTeX you can start from a template like this: 

--- 

\section{Introduction} 

Write the introduction here..... 

\section{Title of first section} 

Write the first section of the paper here.... 

\section{Title of second section} 

Write the second section of the paper here.... 

\subsection{Title of the subsection} 

This is a subsection of the second section.... 

\subsection{Title of the subsection} 

This is another subsection of the second section.... 

\section{Conclusions} 

The conclusions are here... 

\end{document} 

--- 

and that is all. 

 

 

 



 

 

Feature of LATEX: 

Portability 
LaTeX portability comes in multiple ways: 

1. An actual LaTeX file is merely a text file, which is just about the most portable format in 

computing. 

2. The LaTeX system that processes the text file and produces the finished document has been 

implemented on just about every mainstream platform you care to mention. 

3. The default output file format for LaTeX is DVI (which stands for device independent). This was 

around well before PDF was dreamed up and the high quality files can be viewed via software 

viewers or printed out. DVI is an open standard, so once again, readers are extremely portable 

and exist on most operating systems. Admittedly, DVI is hardly ubiquitous and nowadays it's 

often bypassed in favour for PDF (or it's very simple to convert to other formats like PS or 

HTML) 
 

Flexibility 

You can get LaTeX to do just about anything you can think of! Over the years, an overwhelming 

selection of packages to extend its potential and macros that can simplify complex tasks have 

come into being, most of which are freely available on CTAN. For example, LaTeX's main users 

are within academia and research institutions and they benefit hugely thanks to the Bibtex 

package that provides bibliography management - I pity my Word-using colleagues who suffer 

by actually manually word-processing their bibliographies (unless they've shelled out for a 

program like Endnote).  

 

Control 

Whilst LaTeX makes decent typesetting decisions for you, if you want to, you can have total 

control over the presentation of your document. 

 

Quality 

It's difficult to disagree that the output from LaTeX is far superior to what Word can produce. 

This is emphasised greatest when it comes to documents with high mathematical content, which 

is a major strength for LaTeX. It also has much better kerning, hyphenation and justification 

algorithms that simply make the output far more professional than what any word processor. Its 

algorithms for laying out text are more sophisticated and extremely fine-grained.  

 

Output 

As mentioned, the default output is a DVI file. DVI was a clever little standard but unfortunately 

didn't take-off. It takes little effort to convert your document into a Postscript or PDF file (in fact, 

you can just use the 'pdflatex' command instead of normal 'latex' if you only ever want to create 

PDFs). There's no need to buy additional software such as Adobe Acrobat like you need to do to 

convert a Word document into PDF. (At least OpenOffice has its 'Export to PDF' functionality!) 

 

Scalability 

In my personal experience, using Word for documents with more than 20 pages has not been a 

pleasant experience. Obviously, that could be my own bad luck, but that is also the impression 

I've got from other users too. 

With LaTeX, I've never found such problems. Additionally, you are free to split up large 

documents into smaller chunks and then let LaTeX combine them altogether later (like one 

http://en.wikipedia.org/wiki/DVI_%28TeX%29


 

 

chapter per file). It can also create tables of content, indexes and bibliographies easily, even on 

multi-file projects. 

 

Stability 

One of the reasons why perhaps so many people struggle with Word when creating large 

documents, is because it is prone to crashes. 'Document recovery' is now a high 

ranking feature of Word.  

 

Cost 

Well, this is one area where LaTeX wins hands down, since it is free! As with most open source 

software, the phrase "you get what you pay for" doesn't hold true. You get an extremely mature 

system, that is still years ahead of its competition. 

 

What about spell checking? 
It's a good point. This is not a deficiency of LaTeX, because it just processes the words you give 

it. However, within your text-editor, you do not get fancy lines highlighting your spelling errors 

or bad grammar as you type, like you get with Word, yet it's a feature users have come to expect 

when writing documents. 

 

Overview of toolbars, saving files and using help and resources: 

 

Latex Toolbar with menu bar: 

 

 
 

Latex toolbar contains the following options: 

 New 

 Open 

 Save 

 Undo 

 Redo 

 Cut 

 Copy 

 Find 

 Replace 

 

 

 

 

 

 

 

 

 

 



 

 

File Menu bar:       Edit Menu bar: 

 

 
 

File menu is used for creating the new file and for opening and saving the document. We close or 

print the documents. 

Edit Menu bar:       Search menu bar: 

 

 
 

 

 

 

 

 

 

 

 

 



 

 

Format menu bar:     

  Typeset Menu bar: 

 
 

Scripts Menu bar:    Window menu bar:   Help Menu bar: 
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Prepare the project Document 

Creating a document in LaTeX 

LaTeX is a great tool to create documents, it's based on the wysiwym (what you see is what you 

mean) idea, meaning you only have focus on the contents of your document and the computer 

will take care of the formatting. With LaTeX is very easy to create professional-looking material. 

This article presents the basics to create a document. 

Introduction  

Let's start with the simplest working example:  

\documentclass{article} 

  

\begin{document} 

First document. This is a simple example, with no  

extra parameters or packages included. 

\end{document} 

 
The first line of code declares the type of document, in this case is a article. Then enclosed in the 

\begin{document} \end{document} tags you must write the text of your document.  

The preamble of a document  

In the previous example the text was entered after the \begin{document} command. The part of 

your .tex file before this point is called the preamble. In the preamble you define the type of 

document you are writing, the language and several other elements. For instance, a normal 

document preamble would look like this:  

\documentclass[12pt, letterpaper]{article} 

\usepackage[utf8]{inputenc} 

  

\title{First document} 

\author{Hubert Farnsworth \thanks{funded by the ShareLaTeX team}} 

\date{February 2014} 

Below a detailed description of each line:  

\documentclass[12pt, letterpaper]{article}  

As said before, this defines the type of document. Some additional parameters inside 

brackets and comma-separated can be passed to the command. In the example, the extra 

parameters set the font size (12pt) and the paper size (letterpaper). Of course other font 

sizes (9pt, 11pt, 12pt) can be used, the default size is 10pt. As for the paper size other 

possible values are a4papper and legalpaper; see the article about Page size and margins 

for more details about this.  

 

https://www.sharelatex.com/learn/Page_size_and_margins
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    \usepackage[utf8]{inputenc}  

 

This is the encoding for the document. Can be omitted or changed to another encoding 

but utf-8 is recommended. Unless you specifically need another encoding, or if you are 

unsure about it, add this line to the preamble.  

The next three lines are self-descriptive. Anyway, you can see a description about what they 

actually do in the next section.  

Another important parameter that can be passed to the \documentclass command is twocolumn if 

you want your text in a two-column format and twoside for two-side paper sheet printing.  

Displaying the title of your document  

To display the title of your document you have to declare its components in the preamble and 

then use some additional code:  

 

\documentclass[12pt, letterpaper, twoside]{article} 

\usepackage[utf8]{inputenc} 

  

\title{First document} 

\author{Hubert Farnsworth \thanks{funded by the ShareLaTeX team}} 

\date{February 2014} 

  

\begin{document} 

  

\begin{titlepage} 

\maketitle 

\end{titlepage} 

  

In this document some extra packages and parameters were added. There is a encoding package 

an a pagesize and fontsize parameters. 

  

\end{document} 

 
There is a block with three lines in the preamble that define what information is going to be 

included in the title page.  

\title{First document}  

This is the title.  

\author{Hubert Farnsworth}  

https://www.sharelatex.com/learn/Creating_a_document_in_LaTeX#The_preamble_of_a_document
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Here you put the name of the Author(s) and, as a optional parameter, you can add the 

next command:  

\thanks{funded by the ShareLaTeX team}  

This can be added after the name of the autor, inside the braces of the title command. It 

will add a superscript and a footnote with the text inside the braces. Useful if you need to 

thank an institution in your article.  

\date{February 2014}  

You can enter the date manually or use the command \today so the date will be updated 

automatically at the time you compile your document.  

Once you have that in the preamble now in the body of your document you can use the next 

commands for the information to be printed.  

\begin{titlepage} \end{titlepage}  

This declares an environment, a block of code with a specific behaviour depending on its 

type. In this case whatever you include in this titlepage environment will appear in the 

first page of your document.  

\maketitle  

This command will print the title, the author and the date in the format shown in the 

example. If it's not enclosed in a titlepage environment, it will be shown at the beginning 

of the document, above the first line.  

Basic formatting: abstract, paragraphs and newlines  

Everything included inside the \begin{document} \end{document} commands will be rendered 

in the final document.  

\begin{document} 

  

\begin{abstract} 

This is a simple paragraph at the beginning of the document. A brief introduction about the main 

subject. 

\end{abstract} 

  

In this document some extra packages and parameters were added. There is a encoding package 

an a pagesize and fontsize parameters. 

  

This line will start a second Paragraph. And I can  brake\\ the lines \\and continue in a new line. 

  

\end{document} 

 
In scientific documents it's a common practice to include a brief overview of the main subject of 

the paper. In LaTeX there's the abstract environment for this. The abstract environment will put 

the text in a special format at the top of your document.  

https://www.sharelatex.com/learn/File:BasicsEx3.png


 

 

When writing the contents of your document, if you need to start a new paragraph you must hit 

the "Enter" key twice (to insert a double blank line). Notice that paragraphs have a white space 

before the first line.  

To start a new line without actually starting a new paragraph insert a break line point, this can be 

done by \\ (a double backslash as in the example) or the \newline command  

You can find more information in the Paragraphs and new lines article.  

For a more complete discussion about the document structure see the article about sections and 

chapters.  

Comments  

Sometimes it's necessary to add comments to your LaTeX code for readability. This is 

straightforward, put a % before the comment and LaTeX will ignore that text.  

\documentclass{article} 

\usepackage[utf8]{inputenc} %codification of the document 

  

\usepackage{comment} 

  

%Here begins the body of the document 

\begin{document} 

This documents contains a lot of comments, non of them will appear here, only this text.  

This documents contains a lot of comments, non of them will appear here, only this text. 

  

\begin{comment} 

This text won't show up in the compiled pdf this is just a multi-line comment. Useful 

to, for instance, comment out slow-rendering while working on the draft. 

\end{comment} 

  

\end{document} 

 
 

In the last part of the example you can see a comment environment, this helps in multi-line 

comments instead of putting a % at the beginning of each line. For this to work you must add the 

next line to your preamble:  

\usepackage{comment} 

The % symbols is a reserved character, if you actually need this symbol to be printed in your 

document, use \%. See the reference guide for a full list of reserved characters.  

Reserved characters  

The following symbol characters are reserved by LaTeX because they introduce a command and 

have a special meaning.  

# $ % ^ & _ { } ~ \  

https://www.sharelatex.com/learn/Creating_a_document_in_LaTeX#Reference_guide
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Choosing a LaTeX Compiler 

The styles, contents and layout in a LaTeX document are defined by means of tags or commands 

in a plain .tex file, this file can be used to generate several types of "human-readable" versions of 

the document. The easiest way to generate this final output is to use ShareLaTeX, ShareLaTeX 

has a ready-to-use LaTeX distribution and final documents can be generated by simply clicking 

the "Recompile" button; if this is your case you can skip this article. Otherwise, if you need to 

learn how to compile documents in your computer, this article describes how to generate PS, 

DVI and PDF output from a LaTeX file. 

 

Introduction  

LaTeX documents are plain documents with a .tex extension (see the Creating a document in 

LaTeX article for examples), this plain text file has some markup commands that are meant to 

format the document but, how do you actually generate the final output?. It depends on the type 

of document you want to generate.  

Suppose you saved your document and named the file "mydocument.tex". To create a .PDF file 

just run this command in the system terminal.  

pdflatex mydocument.tex  

And a file named "mydocument.pdf" will appear.  

TeX distributions  

The set of programs that make possible to compile TeX and LaTeX documents is called a TeX 

typesetting or a TeX distribution. There are many TeX distributions available for different 

operating systems:  

 MiKTeX for Windows  

 TeX Live for Linux and other UNIX-like systems  

 MacTeX redistribution of TeX Live for Mac OS X  

 teTeX for Linux and other UNIX-like systems, now is no longer actively maintained  

 proTeXt is based on MiKTeX  

Of course, if you don't want to go through the process of installing a TeX distribution, you can 

use an on-line ready to use option like ShareLaTeX.  

LaTeX editors  

There are many advanced text editors specifically dedicated to LaTeX for the most popular 

operating systems, some of them can be downloaded for free while others are proprietary 

software:  

 Open source: AUCTEX, GNU TeXmacs, Gummi, Kile, LaTeXila, MeWa, TeXShop, 

TeXnicCenter, Texmaker, TeXstudio, TeXworks  

 Freeware: LEd, WinShell  

 Proprietary/Shareware: Inlage, Scientific WorkPlace, WinEdt  

There are also general-purpose editors that add LaTeX-friendly options by means of plugins. For 

example the well known editors emacs and vim have both a LaTeX extension.  

It's worth to mention that the editor in ShareLaTeX can be customized to emulate the emacs or 

vim behaviour. It is also themeable, so you can choose the same syntax highlighting of some of 

the aforementioned editors.  

Output formats  

There are three output formats available in all TeX distributions. To generate a specific output 

the document has to be compiled by running a command in a terminal (linux and osx) or the 

command prompt (windows).  

http://www.sharelatex.com/
https://www.sharelatex.com/learn/Creating_a_document_in_LaTeX
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For example, if you want to compile a file named "mydocument.tex" you can use one of the next 

commands:  

latex mydocument.tex  

This will create "mydocument.dvi", a DVI document  

pdflatex mydocument.tex  

This will generate "mydocument.pdf", a PDF document  

There are some additional commands that allow conversion between formats, PS images are also 

supported. See the reference guide for a schematic description of commands and output formats.  

A description of each output format is provided below:  

 (DVI) Device independent file format consists of binary data describing the visual layout 

of a document in a manner not reliant on any specific image format, display hardware or 

printer.  

 (PS) PostScript file format describes text and graphics on page and it is based on vector 

graphics. PostScript is, until now, a standard in desktop publishing areas.  

 (PDF) Portable Document Format is a file format, based on PostScript, used to represent 

documents in a manner independent of application software, hardware, and operating 

systems. It is now widely used as a file format for printing and for distribution on the 

Web.  

Note: Most of the editors nowadays include quick-access icons to compile to different output 

formats so you don't have to actually run the commands in a system prompt.  

Compiling documents with cross-references  

In some cases, when your document includes cross-references, you must compile the source 

twice. It is necessary to include the correct numbers in the table of contents, list of images, 

reference numbers to theorems and so on.  

During the first compilation the LaTeX compiler writes the .aux file for information about 

different numbering and during the second one the compiler reads these information in order to 

properly generate a table of contents, bibliography, etc.  

This process can be automatized by the command latexmk. For example, to create a pdf out of 

the "mydocument.tex" file, run  

latexmk -pdf mydocument.tex  

only once, even if the document has referenced images and bibliography. You can change -pdf to 

-dvi to set a different file type.  
Paragraphs and new lines 

Even tough the default formatting in LaTeX is fine, sometimes we need to change some elements. In this 

article is explained how to format paragraphs, change the text alignment and insert blank spaces.  

Introduction  

Let's start with an example:  

\begin{center} 

Example 1: The following paragraph (given in quotes) is an  

example of Center Alignment using the center environment.  

  

``LaTeX is a document preparation system and document markup  

language. LaTeX uses the TeX typesetting program for formatting  

its output, and is itself written in the TeX macro language.  

LaTeX is not the name of a particular editing program, but  

refers to the encoding or tagging conventions that are used  

in LaTeX documents". 

\end{center} 

https://www.sharelatex.com/learn/Choosing_a_LaTeX_Compiler#Reference_guide


 

 

 
This two paragraphs are written inside a center environment, which causes them to be centred. Notice that 

to start a new paragraph you have to insert a blank line in between them. This is quite natural, but not the 

only way declare a new paragraph.  

 

New Paragraph  

To start a new paragraph in LaTeX, as said before, you must leave a blank line in between. There's 

another way to start a new paragraph, look at the following code snippet.  

 

This is the text in first paragraph. This is the text in first  paragraph. This is the text in first paragraph. \par 

This is the text in second paragraph. This is the text in second  paragraph. This is the text in second 

paragraph. 

 

 
As you can see, the \par command also starts a new paragraph.  

By default, the paragraphs are indented by 1.5 times the point size of the current font. Also, there is no 

extra blank space inserted between the paragraphs. In the sections below is described how to change that.  

 

Paragraph Alignment (Text Justification)  

Paragraphs in LaTeX are fully justified, i.e. flush with both the left and right margins. If you would like to 

change the justification of a paragraph, LaTeX has the following three environments: center, flushleft and 

flushright (see an example of center at the introduction).  

\begin{flushleft} 

``LaTeX is a document preparation system and document markup  language. LaTeX uses the TeX 

typesetting program for formatting  its output, and is itself written in the TeX macro language.  LaTeX is 

not the name of a particular editing program, but refers  to the encoding or tagging conventions that are 

used in LaTeX documents". 

\end{flushleft} 

 
 

The flushleft environment left-justifies the paragraph. To right-justify use flushright instead.  

 

Paragraph Indentation  

By default, LaTeX does not indent the first paragraph of a section. The size of the subsequent paragraph 

indents is determined by the parameter. \parindent  

\setlength{\parindent}{10ex} 

This is the text in first paragraph. This is the text in first paragraph. This is the text in first paragraph. \par 

\noindent %The next paragraph is not indented This is the text in second paragraph. This is the text in 

second paragraph. This is the text in second paragraph. 

https://www.sharelatex.com/learn/File:ParagraphsEx1.png
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The default length of this parameter is set by the document class used. It is possible to change the indent 

size of the paragraph by using the command \setlength. In the example the paragraphs below 

\setlength{\parindent}{10ex} will be indented 10ex (an "ex" equals the lenght of the "x" in the current 

font)  

If you want to create a non-indented paragraph, like the second one in the example, you can use the 

command \noindent at the beginning of the paragraph.  

If you want to indent a paragraph that is not indented you can use \indent above it. It should be noted that 

this command will only have an effect when \parindent is not set to zero.  

Detailed information and further examples can be found at Paragraph formatting.  

 

Bold, italics and underlining 

Simple text formatting helps to highlight important concepts within a document and make it 

more readable. Using italics, bold or underlined words can change the perception of the reader. 

Introduction  

In this article three basic text formatting tools will be explained: italics, bold and underline. Let's begin 

with an example:  

Some of the \textbf{greatest}  

discoveries in \underline{science}  

were made by \textbf{\textit{accident}}. 

 
As you can see, there are three basic commands and they can be nested to get combined effects.  

Note: The commands \it and \bf also work to italicize and boldface text, but it's not recommended to use 

them since they don't preserve previous styles. With these you can't, for instance, italicize and make a text 

bold at the same time.  

Italicized text 

To make a text italic is straightforward, use the \textit command:  

Some of the greatest discoveries in science  

were made by \textit{accident}. 

 

Bold text  

To make a text bold use \textbf command:  

Some of the \textbf{greatest}  

discoveries in science were made by accident. 
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Underlined text  

Underlining text is very simple too, use the \underline command:  

Some of the greatest discoveries in \underline{science}  

were made by accident. 

 

Emphasising text  

  

\textit{Some of the greatest \emph{discoveries}  

in science were made by accident.} 

  

\textbf{Some of the greatest \emph{discoveries}  

in science were made by accident.} 

 
What the \emph command actually does with its argument depends on the context - inside normal text the 

emphasized text is italicized, but this behaviour is reversed if used inside an italicized text- see example 

above:  

Moreover, some packages, e.g. Beamer, change the behaviour of \emph command.  

 

Lists 

List are basic elements in a document, when used correctly they keep concepts organized and 

structured. This article explains how to create and modify numbered and unnumbered lists in 

LaTeX. 

 
Introduction  

Lists are actually very simple to create. List are really easy to create 

  

\begin{itemize} 

  \item One entry in the list 

  \item Another entry in the list 

\end{itemize} 

 
To create a (unordered) list you have to declare the itemize environment and then put the entries inside.   

 



 

 

Unordered lists  

The unordered (unnumbered) lists are produced by the itemize environment. Each entry must be preceded 

by the control sequence \item.  

\begin{itemize} 

  \item The individual entries are indicated with a black dot, a so-called bullet. 

  \item The text in the entries may be of any length. 

\end{itemize} 

 
By default the individual entries are indicated with a black dot, so-called bullet. The text in the entries 

may be of any length.  

Ordered lists  

Ordered list have the same syntax inside a different environment:  

\begin{enumerate} 

  \item The labels consists of sequential numbers. 

  \item The numbers starts at 1 with every call to the enumerate environment. 

\end{enumerate} 

 
 

The ordered lists are generated by a \enumerate environment and each entry must be preceded by the 

control sequence \item, which will automatically generate the number labelling the item. The enumerate 

labels consists of sequential numbers, these numbers starts at 1 with every call to the enumerate 

environment.  

 

Nested Lists  

In LaTeX you can insert a list inside another list. The above lists may be included within one another, 

either mixed or of one type, to a depth of four levels.  

\begin{enumerate} 

   \item The labels consists of sequential numbers. 

   \begin{itemize} 

     \item The individual entries are indicated with a black dot, a so-called bullet. 

     \item The text in the entries may be of any length. 

   \end{itemize} 

   \item The numbers starts at 1 with every call to the enumerate environment. 

\end{enumerate} 

 
 

List styles  

As many other LaTeX elements, unordered and ordered list styles can be personalized.  

 

 

The default numbering scheme is:  

 Arabic number (1, 2, 3, ...) for Level 1  

 Lowercase letter (a, b, c, ...) for Level 2  

 Lowercase Roman numeral (i, ii, iii, ...) for Level 3  

 Uppercase letter (A, B, C, ...) for Level 4.  



 

 

These numbers can be changed by redefining the commands that typeset the numbers of various list 

levels.  

 \end{enumerate} 

 

The command \renewcommand{\labelenumii}{\Roman{enumii}} changes the second level to upper case 

Roman numeral. It is possible to change the labels of any level, replace labelenumii for one of the listed 

below.  

 \theenumi for Level 1  

 \theenumii for Level 2  

 \theenumiii for Level 3  

 \theenumiv for Level 4  
The command must be placed in the preamble to change the labels globally or right before 

\begin{enumerate} to change labels only in this list. There are some other styles, see the reference guide 

for a complete list.  

In numbered lists the counter is incremented by \item before it is printed, and starts from 1,a,i,A,I. This 

can be changed:  

 \renewcommand{\labelenumii}{\Roman{enumii}} 

 \begin{enumerate} 

   \item First level item 

   \item First level item 

   \begin{enumerate} 

     \setcounter{enumii}{4} 

     \item Second level item 

     \item Second level item 

       \begin{enumerate} 

       \item Third level item 

       \item Third level item 

         \begin{enumerate} 

         \item Fourth level item 

         \item Fourth level item 

       \end{enumerate} 

     \end{enumerate} 

   \end{enumerate} 

 \end{enumerate} 

 

 

The label scheme of unordered lists also changes depending on the depth of the nested list:  

  

 \begin{itemize} 

   \item  First Level 

   \begin{itemize} 

     \item  Second Level 

     \begin{itemize} 

       \item  Third Level 

       \begin{itemize} 

         \item  Fourth Level 

       \end{itemize} 

     \end{itemize} 

   \end{itemize} 

 \end{itemize} 

 

All you have to do is pass the desired mark as a parameter inside brackets to the item line.  



 

 

Mathematical expressions 

The feature that makes LaTeX the right edition tool for scientific documents is the ability to 

render complex mathematical expressions. This article explains the basic commands to display 

equations. 

Introduction  

Basic equations in LaTeX can be easily "programmed", for example:  

The well known Pythagorean theorem \(x^2 + y^2 = z^2\) was  

proved to be invalid for other exponents.  

Meaning the next equation has no integer solutions: 

  

\[ x^n + y^n = z^n \] 

 
As you see, the way the equations are displayed depends on the delimiter, in this case \[ \] and \( 

\).  

Mathematical modes. LaTeX allows two writing modes for mathematical expressions: the inline 

mode and the display mode. The first one is used to write formulas that are part of a text. The 

second one is used to write expressions that are not part of a text or paragraph, and are therefore 

put on separate lines.  

Let's see an example of the inline mode:  

In physics, the mass-energy equivalence is stated by the equation $E=mc^2$, discovered in 1905 

by Albert Einstein. 

 
To put your equations in inline mode use one of these delimiters: \( \), $ $ or \begin{math} 

\end{math}. They all work and the choice is a matter of taste.  

The displayed mode has two versions: numbered and unnumbered.  

The mass-energy equivalence is described by the famous equation 

  

$$E=mc^2$$ 

  

discovered in 1905 by Albert Einstein.  

In natural units ($c$ = 1), the formula expresses the identity 

  

\begin{equation} 

E=m 

\end{equation} 

 
To print your equations in display mode use one of these delimiters: \[ \], $$ $$, 

\begin{displaymath} \end{displaymath} or \begin{equation} \end{equation}  

Important Note: equation* environment is provided by an external package, consult the amsmath 

article.  

Reference guide 



 

 

Below is a table with some common maths symbols. For a more complete list see the List of 

Greek letters and math symbols:  

description  code  examples  

Greek letters  \alpha \beta \gamma \rho \sigma \delta \epsilon  
 

Binary operators  \times \otimes \oplus \cup \cap  
 

Relation operators  < > \subset \supset \subseteq \supseteq  
 

Others  \int \oint \sum \prod  
 

Different classes of mathematical symbols are characterized by different formatting (for 

example, variables are itzlized, but operators are not) and different spacing.  

 
Subscripts and superscripts 

The use of superscripts and subscripts is very common in mathematical expressions involving 

exponents, indexes, and in some special operators. This article explains how to write superscripts 

and subscripts in simple expressions, integrals, summations, etcetera. 

Introduction  

Definite integrals are some of the most common mathematical expressions, let's see an example:  

\[ \int\limits_0^1 x^2 + y^2 \ dx \] 

 
In LaTeX, subscripts and superscripts are written using the symbols ^ and _, in this case the x 

and y exponents where written using these codes. The codes can also be used in some types of 

mathematical symbols, in the integral included in the example the _ is used to set the lower 

bound and the ^ for the upper bound. The command \limits changes the way the limits are 

displayed in the integral, if not present the limits would be next to the integral symbol instead of 

being on top and bottom. (see the reference guide)  

More detailed examples  

The symbols _ and ^ can also be combined in the same expression, for example:  

\[ a_1^2 + a_2^2 = a_3^2 \] 

 
There are also a bigcup and bigcap commands similar to cup and cap but larger for larger 

expressions.  

 
Inserting Images 

Images are essential elements in most of the scientific documents. LaTeX provides several 

options to handle images and make them look exactly what you need. In this article is explained 

how to include images in the most common formats, how to shrink, enlarge and rotate them, and 

how to reference them within your document. 

 



 

 

Introduction  

Below is a example on how to import a picture.  

\documentclass{article} 

\usepackage{graphicx} 

\graphicspath{ {images/} } 

 \begin{document} 

The universe is immense and it seems to be homogeneous,  

in a large scale, everywhere we look at. 

 \includegraphics{universe} 

  

There's a picture of a galaxy above 

\end{document} 

 
Latex can not manage images by itself, so we need to use the graphicx package. To use it, we include the 

following line in the preamble: \usepackage{graphicx}  

The command \graphicspath{ {images/} } tells LaTeX that the images are kept in a folder named images 

under the current directory.  

The \includegraphics{universe} command is the one that actually included the image in the document. 

Here universe is the name of the file containing the image without the extension, then universe.PNG 

becomes universe. The file name of the image should not contain white spaces nor multiple dots.  

 

Note: The file extension is allowed to be included, but it's a good idea to omit it. If the file extension is 

omitted it will prompt LaTeX to search for all the supported formats. For more details see the section 

about generating high resolution and low resolution images.  

 

The folder path to images  

When working on a document which includes several images it's possible to keep those images in one or 

more separated folders so that your project is more organised.  

In the example at the introduction the command \graphicspath{ {images/} } tells LaTeX to look in the 

images folder. The path is relative to the current working directory.  

The path to the folder can be relative (recommended) if it is in the same location as the main .tex file or in 

one of the sub-folders, or absolute if you have to specify the exact path. For example:  

%Path in Windows format: 

\graphicspath{ {c:/user/images/} } 

  

%Path in Unix-like (Linux, OsX) format 

\graphicspath{ {/home/user/images/} } 

Notice that this command requires a trailing slash / and that the path is in between double braces.  

You can also set multiple paths if the images are saved in more than one folder. For instance, if there are 

two folders named images1 and images2, use the command.  

\graphicspath{ {images1/}{images2/} }</code> 

If no path is set LaTeX will look for pictures in the folder where the .tex file is saved.  

 

Changing the image size and rotating the picture  

If we want to further specify how LaTeX should include our image in the document (length, height, etc), 

we can pass those settings in the following format:  



 

 

ShareLaTeX is a great professional tool to edit online,  

share and backup your \LaTeX projects. Also offers a  

rather large help documentation. 

  

\includegraphics[scale=1.5]{lion-logo} 

 
 

The command \includegraphics[scale=1.5]{lion-logo} will include the image lion-logo in the document, 

the extra parameter scale=1.5 will do exactly that, scale the image 1.5 of its real size.  

You can also scale the image to a some specific width and height.  

The parameter angle=45 rotates the picture 45 degrees counter-clockwise. To rotate the picture clockwise 

use a negative number.  

 

Positioning  

In the previous section was explained how to include images in your document, but the combination of 

text and images may not look as we expected. To change this we need to introduce a new environment.  

In the next example the figure will be positioned  

right below this sentence. 

  

\begin{figure}[h] 

\includegraphics[width=8cm]{Plot} 

\end{figure} 

 
The figure environment is used to display pictures as floating elements within the document. This means 

you include the picture inside the figure environment and you don't have to worry about it's placement, 

LaTeX will position it in a such way that it fits the flow of the document.  

Anyway, sometimes we need to have more control on the way the figures are displayed. An additional 

parameter can be passed to determine the figure positioning. In the example, begin{figure}[h], the 

parameter inside the brackets set the position of the figure to here. Below a table to list the possible 

positioning values.  



 

 

Parameter  Position  

h  
Place the float here, i.e., approximately at the same point it occurs in the source text 

(however, not exactly at the spot)  

t  Position at the top of the page.  

b  Position at the bottom of the page.  

p  Put on a special page for floats only.  

!  Override internal parameters LaTeX uses for determining "good" float positions.  

H  
Places the float at precisely the location in the LaTeX code. Requires the float 

package. This is somewhat equivalent to h!.  

 
The additional command \centering will centre the picture. The default alignment is left.  

It's also possible to wrap the text around a figure. When the document contains small pictures this makes 

it look better.  

\begin{wrapfigure}{r}{0.25\textwidth} %this figure will be at the right 

    \centering 

    \includegraphics[width=0.25\textwidth]{mesh} 

\end{wrapfigure} 

  

There are several ways to plot a function of two variables, depending on the information you are 

interested in. For instance, if you want to see the mesh of a function so it easier to see the derivative you 

can use a plot like the one on the left. 

   

\begin{wrapfigure}{l}{0.25\textwidth} 

    \centering 

    \includegraphics[width=0.25\textwidth]{contour} 

\end{wrapfigure} 

  

On the other side, if you are only interested on certain values you can use the contour plot, you can use 

the contour plot, you can use the contour plot, you can use the contour plot, you can use the contour plot, 

you can use the contour plot, you can use the contour plot, like the one on the left. 

  

For the commands in the example to work, you have to import the package wrapfig. Add to the preamble 

the line \usepackage{wrapfig}.  

Now you can define the wrapfigure environment by means of the commands 

\begin{wrapfigure}{l}{0.25\textwidth} \end{wrapfigure}. Notice that the environment has two additional 

parameters enclosed in braces. Below the code is explained with more detail:  

{l}  



 

 

This defines the alignment of the figure. Set l for left and r for right. Furthermore, if you 

are using a book or any similar format, use instead o for the outer edge and i for the inner 

edge of the page.  

{0.25\textwidth}  

This is the width of figure box. It's not the width of the image itself, that must be set in 

the includegraphics command. Notice that the length is relative to the text width, but 

normal units can also be used (cm, in, mm, etc). See the reference guide for a list of units.  

\centering  

This was already explained, but in this example the image will be centred by using its 

container as reference, instead of the whole text.  
For a more complete article about image positioning see Positioning images and tables  

 

Captioning, labelling and referencing  

Captioning images to add a brief description and labelling them for further reference are two important 

tools when working on a lengthy text.  

Captions  

Let's start with a caption example:  

\begin{figure}[h] 

\caption{Example of a parametric plot ($\sin (x), \cos(x), x$)} 

\centering 

\includegraphics[width=0.5\textwidth]{spiral} 

\end{figure} 

 
It's really easy, just add the \caption{Some caption} and inside the braces write the text to be shown. The 

placement of the caption depends on where you place the command; if it'a above the includegraphics then 

the caption will be on top of it, if it's below then the caption will also be set below the figure.  

Captions can also be placed right after the figures. The sidecap package uses similar code to the one in the 

previous example to accomplish this.  

\documentclass{article} 

\usepackage[rightcaption]{sidecap} 

  

\usepackage{graphicx} %package to manage images 

\graphicspath{ {images/} } 

  

\begin{SCfigure}[0.5][h] 

\caption{Example of a parametric plot.  

         This caption will be on the right} 

\includegraphics[width=0.6\textwidth]{spiral} 

\end{SCfigure} 



 

 

 
There are two new commands  

\usepackage[rightcaption]{sidecap}  

As you may expect this line will import a package named sidecap, but there is an 

additional parameter: rightcaption. This parameter establishes the placement of the 

caption at the right of the picture, you can also use leftcaption. In book-like documents 

outercaption and innercaption are also available. The names of these are self-descriptive.  

\begin{SCfigure}[0.5][h] \end{SCfigure}  

Defines an environment similar to figure. The first parameter is the width of the caption 

relative to the size of the image, as declared in includes graphics. The second parameter h 

works exactly as in the figure environment. See the placement section for more 

information.  
You can do a more advanced management of the caption formatting. Check the further reading section for 

references. 

Labels and cross-references  

Figures, just as many other elements in a LaTeX document (equations, tables, plots, etc) can be 

referenced within the text. This is very easy, just add a label to the figure or SCfigure environment, then 

later use that label to refer the picture.  

 

\begin{figure}[h] 

    \centering 

    \includegraphics[width=0.25\textwidth]{mesh} 

    \caption{a nice plot} 

    \label{fig:mesh1} 

\end{figure} 

  

As you can see in the figure \ref{fig:mesh1}, the  

function grows near 0. Also, in the page \pageref{fig:mesh1}  

is the same example. 

 
There are three commands that generate cross-references in this example.  

\label{fig:mesh1}  



 

 

This will set a label for this figure. Since labels can be used in several types of elements 

within the document, it's a good practice to use a prefix, such as fig: in the example.  

\ref{fig:mesh1}  

This command will insert the number assigned to the figure. It's automatically generated 

and will be updated if insert some other figure before the referenced one.  

\pageref{fig:mesh1}  

This prints out the page number where the referenced image appears.  
The \caption is mandatory to reference a figure.  

Another great characteristic in a LaTeX document is the ability to automatically generate a list of figures. 

This is straightforward.  

\listoffigures 

 
This command only works on captioned figures, since it uses the caption in the table. The example above 

lists the images in this article.  

Important Note: When using cross-references your LaTeX project must be compiled twice, otherwise the 

references, the page references and the table of figures won't work.  

 

Generating high-res and low-res images  

So far while specifying the image file name in the \includegraphics command we have omitted file 

extensions. However, that is not necessary, though it is often useful. If the file extension is omitted, 

LaTeX will search for any supported image format in that directory, and will search for various 

extensions in the default order (which can be modified).  

This is useful in switching between development and production environments. In a development 

environment (when the article/report/book is still in progress), it is desirable to use low-resolution 

versions of images (typically in .png format) for fast compilation of the preview. In the production 

environment (when the final version of the article/report/book is produced), it is desirable to include the 

high-resolution version of the images.  

This is accomplished by  

 Not specifying the file extension in the \includegraphics command, and  

 Specifying the desired extension in the preamble.  
Thus, if we have two versions of an image, venndiagram.pdf (high-resolution) and venndiagram.png 

(low-resolution), then we can include the following line in the preamble to use the .png version while 

developing the report -  

  \DeclareGraphicsExtensions{.png,.pdf} 

The command above will ensure that if two files are encountered with the same base name but different 

extensions (for example venndiagram.pdf and venndiagram.png), then the .png version will be used first, 

and in its absence the .pdf version will be used, this is also a good ideas if some low-resolution versions 

are not available.  

Once the report has been developed, to use the high-resolution .pdf version, we can change the line in the 

preamble specifying the extension search order to  

  \DeclareGraphicsExtensions{.pdf,.png} 

Improving on the technique described in the previous paragraphs, we can also instruct LaTeX to generate 

low-resolution .png versions of images on the fly while compiling the document if there is a PDF that has 



 

 

not been converted to PNG yet. To achieve that, we can include the following in the preamble after 

\usepackage{graphicx}  

  \usepackage{epstopdf} 

  \epstopdfDeclareGraphicsRule{.pdf}{png}{.png}{convert #1 \OutputFile} 

  \DeclareGraphicsExtensions{.png,.pdf} 

If venndiagram2.pdf exists but not venndiagram2.png, the file venndiagram2-pdf-converted-to.png will 

be created and loaded in its place. The command convert #1 is responsible for the conversion and 

additional parameters may be passed between convert and #1. For example - convert -density 100 #1.  

There are some important things to have in mind though:  

 For the automatic conversion to work, we need to call pdflatex with the --shell-escape 

option.  

 For the final production version, we must comment out the 

\epstopdfDeclareGraphicsRule, so that only high-resolution PDF files are loaded. We'll 

also need to change the order of precedence.  

 
Tables 

Tables are common elements in most scientific documents, LaTeX provides a large set of tools 

to customize tables, change the size, combine cells, change the colour of cells and so on. This 

article explains how. 
Introduction 

Below you can see the simplest working example of a table  

\begin{center} 

\begin{tabular}{ c c c } 

 cell1 & cell2 & cell3 \\  

 cell4 & cell5 & cell6 \\   

 cell7 & cell8 & cell9     

\end{tabular} 

\end{center} 

 
The tabular environment is the default LaTeX method to create tables. You must specify a parameter to 

this environment, {c c c} tells LaTeX that there will be three columns and that the text inside each one of 

them must be centred.  

 

Creating a simple table in LaTeX 

The tabular environment is more flexible, you can put separator lines in between each column.  

\begin{center} 

\begin{tabular}{ |c|c|c| }  

 \hline 

 cell1 & cell2 & cell3 \\  

 cell4 & cell5 & cell6 \\  

 cell7 & cell8 & cell9 \\  

 \hline 

\end{tabular} 

\end{center} 



 

 

 
Tables with fixed length 

When formatting a table you might require a fixed length either for each column or for the entire table. In 

the example below a fixed column width is established.  

\begin{center} 

\begin{tabular}{ | m{5em} | m{1cm}| m{1cm} | }  

\hline 

cell1 dummy text dummy text dummy text& cell2 & cell3 \\  

\hline 

cell1 dummy text dummy text dummy text & cell5 & cell6 \\  

\hline 

cell7 & cell8 & cell9 \\  

\hline 

\end{tabular} 

\end{center} 

 
First, to use the parameters shown in the example, you must import the package array in the preamble of 

your LaTeX file with the next command  

\usepackage{array} 

In the tabular environment, the parameter m{5em} sets a length of 5em for first column (1cm for the 

other two) and centres the text in the middle of the cell. The aligning options are m for middle, p for top 

and b for bottom. In standard tables new lines must be inserted manually so the table won't stretch out of 

the text area, when using this parameters the text is automatically formatted to fit inside each cell.  

The environment tabu is similar to tabular but more flexible, it's available after adding the line 

\usepackage{tabu} to the preamble. Notice that the environment opening statement is different, in the 

example the table width is set to 0.8 the width of the text. You can use any of the LaTeX units for such 

length.  

The parameter inside braces | X[l] | X[c] | X[r] | sets the alignment of each column: the first one to left, the 

second one to center and the third one to right.  

https://www.sharelatex.com/learn/Lengths_in_LaTeX


 

 

 

Combining rows and columns 

Rows and columns can be combined in a bigger cell. The example below is an example of the 

\multicolumn command to combine columns.  

\begin{tabular}{ |p{3cm}||p{3cm}|p{3cm}|p{3cm}|  } 

 \hline 

 \multicolumn{4}{|c|}{Country List} \\ 

 \hline 

 Country Name     or Area Name& ISO ALPHA 2 Code &ISO ALPHA 3 Code&ISO numeric Code\\ 

 \hline 

 Afghanistan   & AF    &AFG&   004\\ 

 Aland Islands&   AX  & ALA   &248\\ 

 Albania &AL & ALB&  008\\ 

 Algeria    &DZ & DZA&  012\\ 

 American Samoa&   AS  & ASM&016\\ 

 Andorra& AD  & AND   &020\\ 

 Angola& AO  & AGO&024\\ 

 \hline 

\end{tabular} 

 
The command multirow takes three parameters. The first one is the number of rows to be combined, 3 in 

the example. The second parameter is the width of the column, 4em in the example. Finally, the third 

parameter is the content of the cell.  

 

Multi-page tables 

If you have to insert a very long table, which takes up two or more pages in your document, use the 

longtable package. First, add to the preamble the line  

\usepackage{longtable} 

This will make the command longtable available.  

\documentclass{article} 

\usepackage[utf8]{inputenc} 

\usepackage{longtable} 

 \begin{document} 

  \begin{longtable}[c]{| c | c |} 

 \caption{Long table caption.\label{long}}\\ 

  \hline 

 \multicolumn{2}{| c |}{Begin of Table}\\ 

 \hline 

 Something & something else\\ 

 \hline 

 \endfirsthead 

  \hline 

 \multicolumn{2}{|c|}{Continuation of Table \ref{long}}\\ 

 \hline 

 Something & something else\\ 



 

 

 \hline 

 \endhead 

  \hline 

 \endfoot 

  \hline 

 \multicolumn{2}{| c |}{End of Table}\\ 

 \hline\hline 

 \endlastfoot 

  Lots of lines & like this\\ 

 Lots of lines & like this\\ 

 Lots of lines & like this\\ 

 Lots of lines & like this\\ 

 Lots of lines & like this\\ 

 Lots of lines & like this\\ 

 Lots of lines & like this\\ 

 Lots of lines & like this\\ 

 ... 

 Lots of lines & like this\\ 

 \end{longtable} 

 
longtable behaviour is similar to the default tabular, but generates tables that can be broken by the 

standard LaTeX page-breaking algorithm. There are four elements long-table specific.  

\endfirsthead  
 

Positioning tables 

Positioning a table is easy if they're inside a float table environment.  

\begin{table}[h!] 

\centering 

 \begin{tabular}{||c c c c||}  

 \hline 

 Col1 & Col2 & Col2 & Col3 \\ [0.5ex]  

 \hline\hline 

 1 & 6 & 87837 & 787 \\  

 2 & 7 & 78 & 5415 \\ 

 3 & 545 & 778 & 7507 \\ 

 4 & 545 & 18744 & 7560 \\ 

 5 & 88 & 788 & 6344 \\ [1ex]  

 \hline 

 \end{tabular} 



 

 

\end{table} 

 
The parameter h! passed to the table environment declaration establishes that this table must be placed 

here, and override LaTeX defaults. Other positioning parameters can be passed also:  

h  Will place the table here approximately.  

t  Position the table at the top of the page.  

b  Position the table at the bottom of the page.  

p  Put the table in a special page, for tables only.  

!  Override internal LaTeX parameters.  

H  Place the table at this precise location, pretty much like h!. 

  
For further examples on table positioning see the Positioning images and tables article.  

In this example there are a few more commands.:  

\centering  

Centres the table relative to the float container element.  

\[1ex]  

This adds extra space to the cell.  

 
Captions, labels and references 

Tables can be captioned, labelled and referenced by means of the table environment.  

The table \ref{table:1} is an example of referenced \LaTeX elements. 

  

\begin{table}[h!] 

\centering 

\begin{tabular}{||c c c c||}  

 \hline 

 Col1 & Col2 & Col2 & Col3 \\ [0.5ex]  

 \hline\hline 

 1 & 6 & 87837 & 787 \\  

 2 & 7 & 78 & 5415 \\ 

 3 & 545 & 778 & 7507 \\ 

 4 & 545 & 18744 & 7560 \\ 

 5 & 88 & 788 & 6344 \\ [1ex]  

 \hline 

\end{tabular} 

\caption{Table to test captions and labels} 

\label{table:1} 

\end{table} 

https://www.sharelatex.com/learn/Positioning_images_and_tables


 

 

 
There are three important commands in the example:  

\caption{Table to test captions and labels}  

As you may expect this command sets the caption for the table, if you create a list of 

tables this caption will be used there. You can place it above or below the table.  

\label{table:1}  

If you need to refer the table within your document, set a label with this command. The 

label will number the table, and combined with the next command will allow you to 

reference it.  

\ref{table:1}  

This code will be substituted by the number corresponding to the referenced table.  
Note: The document may need to be compiled more than once for the labels to work.  

List of tables 

To create a list of tables is straightforward.  

\documentclass{article} 

\usepackage[utf8]{inputenc} 

 \begin{document} 

 \listoftables 

 ... 

\end{document} 

 
The caption of each table will be used to generate this list. For languages supported by the babel package, 

the title "List of tables" will be translated accordingly. See the article about International language support 

for more info.  

 

Changing the appearance of a table 

Several table elements can be modified to achieve a good-looking document. Below you will learn how to 

modify the line thickness, the line colour and the background colour of the cells in your table.  

Line width and cell padding 

The readability of the table sometimes is improved by incrementing the column spacing and row stretch.  

\documentclass{article} 

https://www.sharelatex.com/learn/International_language_support


 

 

\usepackage[utf8]{inputenc} 

\setlength{\arrayrulewidth}{1mm} 

\setlength{\tabcolsep}{18pt} 

\renewcommand{\arraystretch}{1.5} 

\begin{document} 

\begin{tabular}{ |p{3cm}|p{3cm}|p{3cm}|  } 

\hline 

\multicolumn{3}{|c|}{Country List} \\ 

\hline 

Country Name     or Area Name& ISO ALPHA 2 Code &ISO ALPHA 3 \\ 

\hline 

Afghanistan & AF &AFG \\ 

Aland Islands & AX   & ALA \\ 

Albania &AL & ALB \\ 

Algeria    &DZ & DZA \\ 

American Samoa & AS & ASM \\ 

Andorra & AD & AND   \\ 

Angola & AO & AGO \\ 

\hline 

\end{tabular} 

\end{document} 

 
A description of the commands is provided below:  

\setlegth{\arrayrulewidth}{1mm}  

This sets the thickness of the borders of the table. In the example is 1mm but you can use 

other units, see the article Lengths in LaTeX for a complete list.  

\setlength{\tabcolsep}{18pt}  

The space between the text and the left/right border of its containing cell is set to 18pt 

with this command. Again, you may use other units if needed.  

\renewcommand{\arraystretch}{1.5}  

The height of each row is set to 1.5 relative to its default height.  

Colour alternating rows 

It is a common practice to use two colours for alternating rows in a tables to improve readability. This can 

be achieved in LaTeX with the package xcolor and the table parameter.  

\documentclass{article} 

\usepackage[table]{xcolor} 

\setlength{\arrayrulewidth}{1mm} 

\setlength{\tabcolsep}{18pt} 

\renewcommand{\arraystretch}{2.5} 

{\rowcolors{3}{green!80!yellow!50}{green!70!yellow!40} 

https://www.sharelatex.com/learn/Lengths_in_LaTeX


 

 

\begin{tabular}{ |p{3cm}|p{3cm}|p{3cm}|  } 

\hline 

\multicolumn{3}{|c|}{Country List} \\ 

\hline 

Country Name     or Area Name& ISO ALPHA 2 Code &ISO ALPHA 3 \\ 

\hline 

Afghanistan & AF &AFG \\ 

Aland Islands & AX   & ALA \\ 

Albania &AL & ALB \\ 

Algeria    &DZ & DZA \\ 

American Samoa & AS & ASM \\ 

Andorra & AD & AND   \\ 

Angola & AO & AGO \\ 

\hline 

\end{tabular} 

} 

 
Notice the braces right before the command  

\rowcolors{3}{green!80!yellow!50}{green!70!yellow!40} 

and after the tabular environment. The command \rowcolors takes three parameters each passed inside 

braces:  

 the row to start,  

 the colour for odd rows and  

 the colour for even rows.  
See the xcolor package documentation (at the further reading section) for a list of available colours and 

how to create your own. In the example the colours green and yellow are mixed in different proportions.  

For the command to work make sure to add  

\usepackage[table]{xcolor} 

to the preamble of your LaTeX file.  

Colouring a table (cells, rows, columns and lines) 

All elements in a table can be customized to use a specific colour. Again, this functionality is provided by 

xcolor so you must add  

\usepackage[table]{xcolor} 

to the preamble. Below you can see an example.  

\documentclass{article} 

\usepackage[utf8]{inputenc} 

\usepackage[table]{xcolor} 

\setlength{\arrayrulewidth}{1mm} 

\setlength{\tabcolsep}{18pt} 

\renewcommand{\arraystretch}{2.5} 

\newcolumntype{s}{>{\columncolor[HTML]{AAACED}} p{3cm}} 

https://www.sharelatex.com/learn/Tables#Further_reading


 

 

  

\arrayrulecolor[HTML]{DB5800} 

\begin{tabular}{ |s|p{3cm}|p{3cm}|  } 

\hline 

\rowcolor{lightgray} \multicolumn{3}{|c|}{Country List} \\ 

\hline 

Country Name    or Area Name& ISO ALPHA 2 Code &ISO ALPHA 3 \\ 

\hline 

Afghanistan & AF &AFG \\ 

\rowcolor{gray} 

Aland Islands & AX & ALA \\ 

Albania   &AL & ALB \\ 

Algeria  &DZ & DZA \\ 

American Samoa & AS & ASM \\ 

Andorra & AD & \cellcolor[HTML]{AA0044} AND    \\ 

Angola & AO & AGO \\ 

\hline 

\end{tabular} 

 
You can put more than one value in the parameter, for instance, if you write [ht] LaTeX will try to 

position the figure here, but if it's not possible (the space may be insufficient) then the figure will appear 

at the top of the page. It is recommended to use more than one positioning parameter to prevent 

unexpected results. 

Multiple images in one figure 

It is possible to insert several images in one figure, each one with its own reference and label  

Praesent in sapien. Lorem ipsum dolor sit amet, consectetuer  

adipiscing elit. Duis fringilla tristique neque...  

\begin{figure}[h] 

\begin{subfigure}{0.5\textwidth} 

\includegraphics[width=0.9\linewidth, height=5cm]{lion-logo}  

\caption{Caption1} 

\label{fig:subim1} 

\end{subfigure} 

\begin{subfigure}{0.5\textwidth} 

\includegraphics[width=0.9\linewidth, height=5cm]{mesh} 

\caption{Caption 2} 

\label{fig:subim2} 

\end{subfigure} 

\caption{Caption for this figure with two images} 

\label{fig:image2} 

\end{figure} 



 

 

Praesent blandit blandit mauris. Praesent lectus tellus, aliquet aliquam, luctus a, egestas a, turpis. Mauris 

lacinia loremsit amet ipsum. Nunc quis urna dictum turpis accumsan semper. 

 
 

First, you must import the package subcaption by adding to the preamble  

\usepackage{subcaption} 

then you can use the environment \subfigure that takes one parameter, the width of the figure. This 

environment must be used inside a figure environment, captions and labels can be set to each subfigure.  

Note:The \subfigure</cont> command doesn't work with Beamer nor Beamerposter  

  Open an example in ShareLaTeX  

Wrapping text around a figure 

The package wrapfig provides a useful feature, text can be floated around the images.  

Praesent in sapien. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Duis fringilla tristique neque. 

Sed interdum libero ut metus. Pellentesque placerat.  

\begin{wrapfigure}{l}{0.25\textwidth} 

\includegraphics[width=0.9\linewidth]{lion-logo}  

\caption{Caption1} 

\label{fig:subim1} 

\end{wrapfigure} 

  

Praesent in sapien. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Duis fringilla tristique neque. 

Sed interdum 

 
First import the package wrapfig by adding  

\usepackage{wrapfig} 

to the preamble.  

After that you can use the environment <code>wrapfig, it takes two parameters that are passed inside 

braces: the alignement that can be l, r, c, i or o; this letters stand for left, right, centre, inner and outer (the 

https://www.sharelatex.com/learn/Beamer
https://www.sharelatex.com/learn/Posters#Beamerposter
https://www.sharelatex.com/project/new/template?zipUrl=/project/532cda2653f42c100f002b56/download/zip&templateName=PositioningTablesandFigures&compiler=pdflatex


 

 

last two intended for two-sided documents). The second parameter is the width of the figure, in the 

example is 0.25 the width of the text. See the reference guide for a list of possible length units.  

You can set more than one value in the parameter, for instance, if you write [ht] LaTeX will try to 

position the table here, but if it's not possible (the space may be insufficient) then the table will appear at 

the top of the page. It is recommended to use more than one positioning parameter to prevent unexpected 

results.  

Notice also the command \centering. This changes the alignment of the table within its container to centre 

instead of the default left.  

Wrapping text around a table 

If your table don't take all available space and you want to put text next or before it, is possible with the 

package wraptable.  

Praesent in sapien. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Duis fringilla tristique neque. 

Sed interdum libero ut metus. Pellentesque placerat. Nam rutrum augue a leo.  

Morbi sed elit sit amet ante lobortis sollicitudin. 

  

\begin{wraptable}{r}{8cm} 

\arrayrulecolor[HTML]{DB5800} 

\centering 

\begin{tabular}{ |s|p{2cm}|  } 

\hline 

\rowcolor{lightgray} \multicolumn{2}{|c|}{Country List} \\ 

\hline 

Country Name     or Area Name& ISO ALPHA 2 Code \\ 

\hline 

Afghanistan & AF \\ 

\rowcolor{gray} 

Aland Islands & AX \\ 

Albania    &AL  \\ 

Algeria   &DZ \\ 

American Samoa & AS \\ 

Andorra & \cellcolor[HTML]{AA0044} AD   \\ 

Angola & AO \\ 

\hline 

\end{tabular} 

\caption{Table inside a floating element} 

\label{table:ta} 

\end{wraptable} 

  

Praesent in sapien. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Duis fringilla tristique neque. 

Sed interdum libero ut metus. Pellentesque placerat. Nam rutrum augue a leo.  

Morbi sed elit sit amet ante lobortis sollicitudin... 



 

 

 
 

First, import the package  

\usepackage{wraptable} 

then you can use the environment wraptable which takes two parameters: The first one is the alignment 

that can be l, r, c, i or o for left, right, centre, inner and outer respectively. The second one is the width of 

the table container, keep in mind that this latter parameter must be the same as the width of the table, 

otherwise things may not be properly aligned.  

 

Bibliography management in LaTeX 

When it comes to bibliography management packages, there are three main options in LaTeX: 

bibtex, natbib and biblatex. Biblatex is a modern program to process bibliography information, 

provides an easier and more flexible interface and a better language localization that the other 

two options. This article explains how to use biblatex to manage and format the bibliography in a 

LaTeX document. 

Introduction 

A minimal working example of the biblatex package is shown below:  

\documentclass{article} 

\usepackage[utf8]{inputenc} 

\usepackage[english]{babel} 

 \usepackage{biblatex} 

\addbibresource{sample.bib} 

 \begin{document} 

Let's cite! The Einstein's journal paper \cite{einstein} and the Dirac's  

book \cite{dirac} are physics related items.  

 \printbibliography 

 \end{document} 



 

 

 
There are four bibliography-related commands in this example:  

\usepackage{biblatex}  

Imports the package biblatex.  

\addbibresource{sample.bib}  

Imports the bibtex data file sample.bib, this file is the one that includes information about 

each referenced book, article, etc. See the bibliography file section for more information.  

\cite{einstein}  

This command inserts a reference within the document, [1] in this case, that corresponds 

to an element in the bibliography, "einstein" is a keyword corresponding to an entry in 

sample.bib.  

\printbibliography  

Prints the list of cited references, the default title is "References" for the article document 

class and "Bibliography" for books and reports.  
ShareLaTeX provides several templates with pre-defined styles to manage bibliography. See this link  

Customizing the bibliography 

Biblatex allows high customization of the bibliography section with little effort. It was mentioned that 

several citation styles and bibliography styles are available, and you can also create new ones. Another 

customization option is to change the default title of the bibliography section.  

\documentclass{article} 

\usepackage[utf8]{inputenc} 

\usepackage[english]{babel} 

\usepackage{comment} 

\usepackage[ 

backend=biber, 

style=alphabetic, 

sorting=ynt 

]{biblatex} 

\addbibresource{sample.bib} 

\title{Bibliography management: \texttt{biblatex} package} 

\author{Share\LaTeX} 

\date{ } 

\begin{document} 

\maketitle 

Using \texttt{biblatex} you can display bibliography divided into sections,  

depending of citation type.  

Let's cite! The Einstein's journal paper \cite{einstein} and the Dirac's  

book \cite{dirac} are physics related items.  

Next, \textit{The \LaTeX\ Companion} book \cite{latexcompanion}, the Donald  

Knuth's website \cite{knuthwebsite}, \textit{The Comprehensive Tex Archive  

https://www.sharelatex.com/learn/Bibliography_management_in_LaTeX#The_bibliography_file
https://www.sharelatex.com/templates/bibliographies
https://www.sharelatex.com/learn/Biblatex_citation_styles
https://www.sharelatex.com/learn/Biblatex_bibliography_styles


 

 

Network} (CTAN) \cite{ctan} are \LaTeX\ related items; but the others Donald  

Knuth's items \cite{knuth-fa,knuth-acp} are dedicated to programming.  

  

\medskip 

\printbibliography[title={Whole bibliography}] 

 
The additional parameter title={Whole bibliography} passed inside brackets to the command 

\printbibliography is the one that changes the title.  

The bibliography can also be subdivided into sections based on different filters, for instance: print only 

references from the same author, the same journal or similar title. Below an example.  

\printbibliography[type=article,title={Articles only}] 

\printbibliography[type=book,title={Books only}] 

\printbibliography[keyword={physics},title={Physics-related only}] 

\printbibliography[keyword={latex},title={\LaTeX-related only}] 

 
Here, the bibliography is divided in 4 sections. The syntax of the commands used here is explained 

below:  

\printbibliography[type=article,title={Articles only}]  

Only prints entries whose type is "article", and sets the title "Articles only" for this 

section. The same syntax works for any other entry type.  

\printbibliography[keyword={physics},title={Physics-related only}]  



 

 

Filters bibliography entries that include the word "physics" in any of the fields. Sets the 

title "Physics-related only" for said section.  

Adding the bibliography in the table of contents 

For the bibliography the be printed in the table of contents an extra option must be passed to 

\printbibliography  

\printbibliography[ 

heading=bibintoc, 

title={Whole bibliography} 

] 

  

\printbibliography[heading=subbibintoc,type=article,title={Articles only}] 

 
A section and a subsection are added to the table of contents:  

 In the first case, adding heading=bibintoc adds the title to the table of contents as an 

unnumbered chapter if possible or as an unnumbered section otherwise.  

 The second case is heading=subbibintoc that adds the title as a second level entry in the 

table of contents, in this example as a subsection nested in "Whole bibliography".  
 

 


