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DEPARTMENT OF AERONAUTICAL ENGINEERING 

 

PROGRAM OUTCOMES 

PO1 
Identify, formulate, and solve complex aerospace engineering problems by applying advanced 

principles of engineering. 

PO2 
Apply aerospace engineering design to produce solutions that meet specified needs with 
frontier technologies 

PO3 
Formulate and solve complex engineering problems related to aerospace materials, propulsion, 

aerodynamics, structures, avionics, stability and control. 

PO4 Write and present a substantial technical report / document.  

PO5 
Independently carry out research / investigation and development work to solve practical 

problems 

PO6 

Function effectively on a team whose members together provide leadership, create a 

collaborative and inclusive environment, establish goals, plan tasks, and meet objectives in 

aerospace engineering. 

PO7 

Recognize ethical and professional responsibilities in aerospace engineering situations and 

make informed judgments, which must consider the impact of engineering solutions in global, 

economic, environmental, and societal contexts. 
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ADVANCED COMPUTATIONAL AERODYNAMICS LABORATORY 

SYLLABUS 

 

S.NO LIST OF EXPERIMENTS 
PAGE 

NO 

1 Introduction   

2 Introduction to ICEM CFD  

3 Introduction to fluent  

4 Shock wave boundary layer intersection over a flat plate    

5 Subsonic flow in a convergent divergent nozzle  

6 Circulation of the lift over a circular cylinder  

7 Pressure distribution over a symmetric aerofoil  

8 Pressure distribution over a cambered aerofoil  

9 Shock wave supersonic flow over wedge  

10 Shock wave around a cone  

11 Flow through diffuser  

12 Flow through supersonic intake  
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ADVANCED COMPUTATIONAL AERODYNAMICS LABORATORY 

 

OBJECTIVE: 

The objective of this lab is to teach students and give knowledge about the computational techniques of 

aerodynamic problems with the flow visualization and usage of the flow properties for different 

geometries with different boundary conditions. This lab also enables the students to learn the tools of 

ICEM CFD and Fluent This laboratory also enhances experimental skills to the students to assess the 

simulation and visualization of flow around the aerodynamic bodies under different flow streams . 

 

OUTCOMES: 

The course should enable the students to: 

 

I. Implement the computational fluid dynamic and computational aerodynamic fundamentals by using 

advanced solvers. 

II. Understand the flow properties of flat plate, nozzle and cylinder to demonstrate Reynolds number. 

III. Differentiate the flow properties around symmetrical and cambered airfoil. 

IV. Analyse the coefficient of pressure, lift, drag and moment for different bodies for different   flow 

conditions. 

V. Visualize the flow around the different bodies under supersonic conditions. 
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ATTAINMENT OF PROGRAM OUTCOMES  

Experiment 

No 

Program Outcomes 

Attained 

1 PO1 

2 PO1,PO2 

3 PO1,PO2,PO5 

4 PO2, PO5 

5 PO2, PO5 

6 PO2, PO5 

7 PO2, PO5 

8 PO2, PO5 

9 PO2, PO5 

10 PO2, PO5 

11 PO2, PO5 

12 PO2, PO5 

 



8 
 
 

EXPERIMENT-1 

 

INTRODUCTION  

 

Computational fluid dynamics (CFD) is a branch of fluid mechanics that uses numerical analysis and data 

structures to analyze and solve problems that involve fluid flows. Computers are used to perform the calculations 

required to simulate the free-stream flow of the fluid, and the interaction of the fluid (liquids and gases) with 

surfaces defined by boundary conditions. With high-speed supercomputers, better solutions can be achieved, and 

are often required to solve the largest and most complex problems. Ongoing research yields software that 

improves the accuracy and speed of complex simulation scenarios such as transonic or turbulent flows. Initial 

validation of such software is typically performed using experimental apparatus such as wind tunnels.  

In addition, previously performed analytical or empirical analysis of a particular problem can be used for 

comparison. A final validation is often performed using full-scale testing, such as flight tests. 

CFD is applied to a wide range of research and engineering problems in many fields of study and industries, 

including aerodynamics and aerospace analysis, weather simulation, natural science and environmental 

engineering, industrial system design and analysis, biological engineering and fluid flows, 

and engine and combustion analysis. 

 

Methodology 

In all of these approaches the same basic procedure is followed. 

 

During preprocessing 

 The geometry and physical bounds of the problem can be defined using computer aided design (CAD). 

From there, data can be suitably processed (cleaned-up) and the fluid volume (or fluid domain) is 

extracted. 

 The volume occupied by the fluid is divided into discrete cells (the mesh). The mesh may be uniform or 

non-uniform, structured or unstructured, consisting of a combination of hexahedral, tetrahedral, 

prismatic, pyramidal or polyhedral elements. 

 The physical modeling is defined – for example, the equations of fluid motion + enthalpy + radiation + 

species conservation 

 Boundary conditions are defined. This involves specifying the fluid behavior and properties at all 

bounding surfaces of the fluid domain. For transient problems, the initial conditions are also defined. 

 The simulation is started and the equations are solved iteratively as a steady-state or transient. 

 Finally a postprocessor is used for the analysis and visualization of the resulting solution. 

 

 

Concept of Computational Fluid Dynamics 

 

Computational Fluid Dynamics (CFD) is the simulation of fluids engineering systems using modeling 

(mathematical physical problem formulation) and numerical methods (discretization methods, solvers, numerical 

parameters, and grid generations, etc.).  

 

Process of Computational Fluid Dynamics 

 

Firstly, we have a fluid problem. To solve this problem, we should know the physical properties of fluid by using 

Fluid Mechanics. Then we can use mathematical equations to describe these physical properties. This is Navier-

https://en.wikipedia.org/wiki/Fluid_mechanics
https://en.wikipedia.org/wiki/Numerical_analysis
https://en.wikipedia.org/wiki/Data_structure
https://en.wikipedia.org/wiki/Data_structure
https://en.wikipedia.org/wiki/Data_structure
https://en.wikipedia.org/wiki/Fluid_dynamics
https://en.wikipedia.org/wiki/Liquid
https://en.wikipedia.org/wiki/Gas
https://en.wikipedia.org/wiki/Boundary_value_problem#Boundary_value_conditions
https://en.wikipedia.org/wiki/Supercomputer
https://en.wikipedia.org/wiki/Transonic
https://en.wikipedia.org/wiki/Turbulence
https://en.wikipedia.org/wiki/Wind_tunnel
https://en.wikipedia.org/wiki/Closed-form_solution
https://en.wikipedia.org/wiki/Empirical_research
https://en.wikipedia.org/wiki/Flight_test
https://en.wikipedia.org/wiki/Aerodynamics
https://en.wikipedia.org/wiki/Numerical_weather_prediction
https://en.wikipedia.org/wiki/Environmental_engineering
https://en.wikipedia.org/wiki/Environmental_engineering
https://en.wikipedia.org/wiki/Environmental_engineering
https://en.wikipedia.org/wiki/Biological_engineering
https://en.wikipedia.org/wiki/Engine
https://en.wikipedia.org/wiki/Preprocessor_(CAE)
https://en.wikipedia.org/wiki/Geometry
https://en.wikipedia.org/wiki/Computer-aided_design
https://en.wikipedia.org/wiki/Volume
https://en.wikipedia.org/wiki/Enthalpy
https://en.wikipedia.org/wiki/Computer_simulation
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Stokes Equation and it is the governing equation of CFD. As the Navier-Stokes Equation is analytical, human 

can understand it and solve them on a piece of paper. But if we want to solve this equation by computer, we have 

to translate it to the discretized form. The translators are numerical discretization methods, such as Finite 

Difference, Finite Element, Finite Volume methods. Consequently, we also need to divide our whole problem 

domain into many small parts because our discretization is based on them. Then, we can write programs to solve 

them.  

The typical languages are Fortran and C. Normally the programs are run on workstations or supercomputers. At 

the end, we can get our simulation results. We can compare and analyze the simulation results with experiments 

and the real problem. If the results are not sufficient to solve the problem, we have to repeat the process until find 

satisfied solution. This is the process of CFD. 

 

Importance of Computational Fluid Dynamics 

There are three methods in study of Fluid: theory analysis, experiment and simulation (CFD). As a new method, 

CFD has many advantages compared to experiments. 

 

 Simulation (CFD) Experiment 

 Cost Cheap Expensive 

 Time Short Long 

 Scale Any Small/Middle 

 Information All Measured Point 

 Repeatable Yes Some 

 Safety Yes Some Dangerous 

 

Application of Computational Fluid Dynamics 

 

As CFD has so many advantages, it is already generally used in industry such as 

 Aerospace, 

 Automotive,  

 Biomedicine,  

 Chemical processing,  

 Heat ventilation air condition, 

 Hydraulics,  

 Power generation,  

 Sports and  

 Marine etc. 

 

Viva questions: 

1. What is computational Aerodynamics? 

2. What is topology? 

3. List the properties of fluid dynamics. 

4. Define discretization. 

5. What are governing equations? 
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EXPERIMENT - 2 

INTRODUCTION TO ICEM CFD 
 

ANSYS ICEM CFD is a popular proprietary software package which provides advanced geometry/mesh 

generation as well as mesh diagnostics and repair functions useful for in-depth analysis. Its design is centered 

around aerospace, automotive and electrical engineering applications with a specific focus on computational 

fluid dynamics and structural analysis. The ability to accurately create computational grids about geometrically 

complex configurations is becoming increasingly important in the analysis world.  

 

ANSYS ICEM CFD offers mesh generation with the capacity to compute meshes with various different 

structures depending on the user’s requirements. It is powerful and highly manipulative software which allows 

the user to generate grids of high resolution. This is a requirement as mesh generation is an inherently geometry 

dependent problem meaning there is no singular meshing method which can be used for every problem. ICEM 

CFD allows the following different types of grid structures to be created  

 

Multi-block structured meshes, Unstructured meshes, Hybrid meshes. A simplified overview of the meshing 

methodology provides an indication of how to begin the meshing procedure with the different stages shown. 

 

 
Geometry Modelling 

 

ICEM CFD allows for its geometry to either be made using its own geometry topology package or to import 

geometry via external CAD software. For simple geometries the former tends to be used and for more complex 

geometries the latter is often used. Regardless of this, the geometry should be checked using the geometry 

analysis to ensure the model contains a closed volume, meaning there are no holes or gaps within the geometry, 

so that further down the line, no negative volume elements are present.  

 

Negative volume elements are not permitted in external solvers. These maybe present due to differences in 

geometrical and meshing tolerances. There is hence an emphasis in ICEM CFD to create a mesh that has a 
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'water-tight' geometry. It means if there is a source of water inside a region, the water should be contained and 

not leak out of the BODY. 

 

Apart from the regular points, curves, surface creation and editing tools, ICEM CFD especially has the capability 

to do BUILD TOPOLOGY which removes unwanted surfaces and then you can view if there are any 'holes' in 

the region of interest for meshing. Existence of holes would mean that the algorithm which generates the mesh 

would cause the mesh to 'leak out' of the domain. Holes are typically identified through the colour of the curves. 

The following is the colour coding in ICEM CFD, after the BUILD TOPOLOGY option has been implemented: 

 

YELLOW: curve attached to a single surface 

RED: curve shared by two surfaces 

BLUE: curve shared by more than two surfaces. 

Green: curve not attached to any surface 

An analysis post building the topology is then required, whereby if it is clear a curve is supposed to share two 

surfaces yet is being displayed as yellow, a hole exists and it is likely there will be meshing problems. 

 

Geometrical entities which may include points, curves and surfaces must also be associated to a given part. Each 

part can then be controlled for meshing, visualization or various other purposes and is stored within the 

aforementioned tetin file. 

 

The unstructured mesh generation procedure will now be considered: 

1. Create/Import geometry 

2. Repair geometry ensuring a closed volume 

3. Determine global meshing parameter 

4. Specify part mesh setup 

5. Specify curves and surface mesh size 

6. Compute mesh 

 

The structured mesh generation procedure will now be considered: 

 

1. Create/Import geometry. 

2. Initialize blocking with respect to geometry dimension 

3. Generate block structure using the split, merge, Ogrid definition. 

4. Associate vertices to points, edges to curve and block faces to geometry face. 

5. Check block structure quality to ensure the block model meets specified quality threshold. 

6. Determine edge meshing parameters and using spacing 1 or spacing 2 for increasing mesh density in 

specific zone. 

7. Using pre-mesh to update mesh 

8. Check the cell quality of the mesh once its generated. 

9. Convert structure mesh to substructure mesh by right click on the re-compute mesh 

10. Write output files to desired solver like ANSYS fluent or Star CCM 
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Exporting Mesh 
ICEM CFD allows the user to export their mesh into various different formats for compatibility with other 

external solvers. The meshing topology, associated parts, boundary conditions and loads should all be predefined 

before this stage. Some of the possible supported output solvers are: 

 

 ANSYS CFX 

 ANSYS Fluent 

 CGNS 

 Plot3D 

 STAR-CCM 

 

Viva questions: 

1. What is topology? 

2. What is geometry? 

3. Differentiate the structured and unstructured mesh. 

4. What is full form ICEM CFD? 
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EXPERIMENT – 3 

 

INTRODUCTION TO ANSYS FLUENT 
 

ANSYS Fluent is a state-of-the-art computer program for modeling fluid flow, heat transfer, and chemical 

reactions in complex geometries. ANSYS Fluent is written in the C computer language and makes full use of the 

flexibility and power offered by the language. Consequently, true dynamic memory allocation, efficient data 

structures, and flexible solver control are all possible. In addition, ANSYS Fluent uses a client/server 

architecture, which enables it to run as separate simultaneous processes on client desktop workstations and 

powerful computer servers. This architecture allows for efficient execution, interactive control, and complete 

flexibility between different types of machines or operating systems. 

 

ANSYS Fluent provides complete mesh flexibility, including the ability to solve your flow problems using 

unstructured meshes that can be generated about complex geometries with relative ease. Supported mesh types 

include 2D triangular/quadrilateral, 3D tetrahedral/hexahedral/pyramid/wedge/polyhedral, and mixed (hybrid) 

meshes. ANSYS Fluent also enables you to refine or coarsen your mesh based on the flow solution. 

 

You can read your mesh into ANSYS Fluent, or, for 3D geometries, create your mesh using the meshing mode 

of Fluent (see the Fluent Meshing User’s Guide for further details). All remaining operations are performed 

within the solution mode of Fluent, including setting boundary conditions, defining fluid properties, executing 

the solution, refining the mesh, and post processing and viewing the results. 

 

The ANSYS Fluent serial solver manages file input and output, data storage, and flow field calculations using a 

single solver process on a single computer. ANSYS Fluent also uses a utility called cortex that manages ANSYS 

Fluent’s user interface and basic graphical functions. ANSYS Fluent’s parallel solver enables you to compute a 

solution using multiple processes that may be executing on the same computer, or on different computers in a 

network. 

 

Parallel processing in ANSYS Fluent involves an interaction between ANSYS Fluent, a host process, and a set 

of compute-node processes. ANSYS Fluent interacts with the host process and the collection of compute nodes 

using the cortex user interface utility. 

  

 
 

Figure 3.1:  Parallel ANSYS Fluent Architecture 
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For more information about ANSYS Fluent’s parallel processing capabilities, message passing interfaces (MPI), 

and so on, refer to Parallel Processing in the User's Guide. 

 

All functions required to compute a solution and display the results are accessible in ANSYS Fluent through an 

interactive interface. 

 

Viva questions: 

1. What are the solver software’s? 

2. Differentiate the triangular and tetrahedral elements  

3. Define cell and node. 
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EXPERIMENT – 4 

 

SHOCK WAVE BOUNDARY LAYER INTERSECTION OVER A FLAT PLATE   
  

Aim: To visualize the shock wave boundary layer intersection over a flat plate and  plot the velocity profile at x 

= 1m. Compare the accuracy of your results from FLUENT with empirical correlations. 

 

Software Used: ICEM CFD and FLUENT  

 

Preliminary Analysis 
 

We expect the turbulent boundary layer to grow along the plate. As the boundary layer grows in thickness, the 

rate of heat transfer (q'') and thus the heat transfer coefficient (h) will decrease. 

 

 

 
 

Fig 4.1: Boundary layer 

 

We will compare the numerical results with experimentally-derived heat transfer correlations. We will create the 

geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem. 

 

 Create or import Geometry  

 Block the geometry 

 Associate entities to the geometry. 

 Apply mesh parameters. 

 Generate the initial mesh. 

 Export mesh  

 

Start ICEM CFD  

 

Create Geometry in ICEM CFD 
 

1) Close any previous files, have blank screen in ICEM. 

2) Create new project file for the pipe in ICEM: 

a) File, New Project. 

b) Select folders in turn: Desktop, CFX Training Files – Copy, Flat plate. 

c) Save project with name ―Flat plate‖ in folder ―Flat plate‖. 
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3) We are going to create some points now: 

a) Select Geometry tab at top of screen. 

b) Select ―Create Point‖ option. 

c) In the bottom left are various options for creating the point. Select the second ―XYZ‖ option. 

d) Input the numbers X=0, Y=0, Z=0. 

e) Press ―Apply‖ to create a point on screen 

 

Create points  

x y 

0 0 

1 0 

1 1 

0 1 

 

Explicit location > specify x and y location and click ok  

Similarly create 4 points  

 

Create curves  

 

a) Under ―Geometry‖ tab, select ―Create and modify curve‖. 

b) Under ―Create and modify curve‖ option panel on bottom left, select 3rd option ― 

Select two points on the screen and select ok Create remaining curves  

 

Create surface  

 

Simple surface – from 2-4 curves, to check surface click on solid frame  

 

Label the curves 

 

Give names to the INLET, OUTLET and WALL surfaces: 

a) Under ―Geometry‖ tree, highlight only ―Surfaces‖. 

b) Right click ―Parts‖, Create Part. 

c) Part = ―INLET‖. 

d) Entities: click arrow icon, left click surface (near surface, around origin) to highlight it, middle 

click to save selection, right click to de-select mode. 

e) Note that the INLET part has been created, and can be turned on and off independently using the tree 

view. 

f) Part = ―OUTLET‖, repeat step to identify an outlet at the far end. 

g) Part = ―WALL‖, repeat step to identify the wall. 

h) Notes: ―GEOM‖ now contains only 0D and 1D elements; points and lines. 

 

Block the Geometry 

 

The geometry and part information has already been defined for this tutorial. You will create the initial 

blockin this step. 

1. Create the initial block. 

 Blocking > Create Block > Initialize Blocks 

a. Enter FLUID in the Part field. 

b. Select 2D Planar in the Type drop-down list and click apply. 
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Associate Entities to the Geometry 

 

You will associate the edges of the blocking to the curves of the CAD geometry in this step. First select the 

edges and then the curves to which you want to associate them. 

 

1. Associate the inlet, the left-most end of the large flat plate. 

a. Ensure that Project Vertices is disabled. 

b. Click (Select edge(s)) and select edge 13–41. Click the middle-mouse button to accept the selection. 

c. Click (Select compcurve(s)) and select CURVES/1. Click the middle-mouse button to accept the 

selection. Click Apply. 

The associated edge will be colored green. 

 

Generate the Initial Mesh 

 

Blocking > Pre-Mesh Params > Update Sizes 

 

Retain the selection of Update All in the Method list. 

 

Blocking Pre-Mesh 

 

The Mesh dialog will appear, asking if you want to recompute the mesh. 

Click Yes in the Mesh dialog to compute the initial mesh. 

Disable Vertices and Edges. 

 

Verify and Save the Mesh and Blocking 

 

1. Convert the mesh to unstructured format. 

Blocking Pre-Mesh Convert to Unstruct Mesh 

2. Save the blocking file (2D-Flat plate -geometry-final.blk). 

File > Blocking > Save Blocking As... 

This block file can be loaded in a future session (File > Blocking > Open Blocking...) for additional 

modification or to mesh a similar geometry. Save each blocking to a separate file instead of overwritinga 

previous one. In more complex models, you may have to back track and load a previous blocking. 

3. Save the project file (2D-flat plate-geometry-final.prj). 

File > Save Project As... 

This will save all the files—tetin, blocking, and unstructured mesh. 

4. Exit the current session. 

File > Exit 

Save your ICEM CFD file in your working directory. 

 

Setting Up the CFD Simulation in ANSYS FLUENT 

 

Now that you have created a computational mesh for the elbow geometry, you can proceed to setting up a 

CFD analysis using ANSYS FLUENT. 

 

1.   Start ANSYS FLUENT. 

In the ANSYS Workbench Project Schematic, double-click the Setup cell in the elbow fluid flow analysis 

system. You can also right-click on the Setup cell to display the context menu where you can select 

the Edit option. 
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When ANSYS FLUENT is first started, FLUENT Launcher is displayed, allowing you to view and/or set 

certain ANSYS FLUENT start-up options. 

 

 ANSYS FLUENT Launcher allows you to decide which version of ANSYS FLUENT you will use, based on 

your geometry and on your processing capabilities. 

 

Ensure that the proper options are enabled. 

Note that the Dimension setting is already filled in and cannot be changed, since ANSYS  

 

FLUENT automatically sets it based on the mesh or geometry for the current system. 

i.   Make sure that Serial from the Processing Options list is enabled. 

ii.   Make sure that the Display Mesh After Reading, Embed Graphics Windows, and Workbench 

Color Scheme options are enabled. 

iii.   Make sure that the Double-Precision option is disabled. 

(b)   Click OK to launch ANSYS FLUENT. 

2.   Set some general settings for the CFD analysis. 

  Select General in the navigation pane to perform the mesh-related activities and to choose a solver. 

 

General 
(a)   Change the units for length. 

Since we want to specify and view values based on a unit of length in inches from within ANSYS FLUENT, 

change the units of length within ANSYS FLUENT from meters (the default) to inches. 

  

General  Units... 

This displays the Set Units dialog box. 

i.   Select length in the Quantities list. 

ii.   Select in in the Units list. 

iii.   Close the dialog box. 

   Now, all subsequent inputs that require a value based on a unit of length can be specified in inches rather 

than meters. 

 

(b)   Check the mesh. 

 

General  Check 

   ANSYS FLUENT will report the results of the mesh check in the console. 

 

3.   Set up your models for the CFD simulation. 

 

 Models 

(a)   Enable heat transfer by activating the energy equation. 

 

 Models   Energy  Edit... 

   You can also double-click a list item in order to open the corresponding dialog box. 

i.   Enable the Energy Equation option. 

ii.   Click OK to close the Energy dialog box. 

(b)   Enable the -  turbulence model. 

 Models   Viscous  Edit... 

i.   Select k-epsilon from the Model list. 
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   The Viscous Model dialog box will expand. 

ii.   Select Realizable from the k-epsilon Model list. 

iii.   Click OK to accept the model and close the Viscous Model dialog box. 

 

4.   Set up your materials for the CFD simulation. 

 

Materials 
(a) Create a new material called air using the Create/Edit Materials dialog box. 

(b)  Materials   Fluid  Create/Edit... 

i.   Enter air for Name. 

ii.    specify the properties  

iii.   Click Change/Create. 

 

5.   Set up the cell zone conditions for the CFD simulation. 

 

Cell Zone Conditions 
(a)   Set the cell zone conditions for the fluid zone. 

i.   Select fluid in the Zones list in the Cell Zone Conditions task page, then click the Edit... button to open 

the Fluid dialog box. 

    

You can also double-click a list item in order to open the corresponding dialog box. 

ii.   In the Fluid dialog box, select water from the Material Name drop-down list. 

iii.   Click OK to close the Fluid dialog box. 

 

6.   Set up the boundary conditions for the CFD analysis. 

 

Boundary Conditions 
(a)   Set the boundary conditions at the cold inlet (velocity-inlet-large). 

 

Boundary Conditions   velocity-inlet-large  Edit... 

i.   Select Components from the Velocity Specification Method drop-down list. 

  The Velocity Inlet dialog box will expand. 

ii.   Enter 0.4 m/s for X-Velocity. 

iii.   Retain the default value of 0 m/s for both Y-Velocity and Z-Velocity. 

 

7.   Set up solution parameters for the CFD simulation. 

   

In the steps that follow, you will set up and run the calculation using the task pages listed under 

the Solution heading in the navigation pane. 

Change the convergence criteria for the continuity equation residual. 

 

Monitors   Residuals  Edit... 

i.   Make sure that Plot is enabled in the Options group box. 

ii.   Enter 1e-05 for the Absolute Criteria of continuity, as shown in the Residual Monitor dialog box. 

iii.   Click OK to close the Residual Monitors dialog box. 

Initialize the flow field, using the boundary conditions settings at the cold inlet (velocity-inlet-large) as a 

starting point. 
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Solution Initialization 

 

i.   Select velocity-inlet-large from the Compute From drop-down list. 

ii.   Enter 1.2 m/s  for Y Velocity in the Initial Values group box. 

Note:   While an initial X Velocity is an appropriate guess for the horizontal section, the addition of a Y 

Velocity component will give rise to a better initial guess throughout the entire elbow. 

iii.   Click Initialize. 

 

Check to see if the case conforms to best practices. 

 Run Calculation  Check Case 

 

8.   Calculate a solution. 

Start the calculation by requesting 250 iterations. 

 

Run Calculation 
i.   Enter 250 for Number of Iterations. 

ii.   Click Calculate. 

  

As the calculation progresses, the residuals will be plotted in the graphics window  

 

9.   View the files generated by ANSYS Workbench. 

 

Result: 

 

Viva questions: 

1. What is boundary layer thickness? 

2. Calculate the displacement thickness and momentum thickness at a given set of points? 

3. Was the transition point identified? 

 

 

 

 

 

 

 

 

 

 

 



21 
 
 

EXPERIMENT – 5 

 

SUBSONIC FLOW IN A CONVERGENT DIVERGENT NOZZLE 
  

AIM: To visualize the flow through convergent divergent nozzle and calculate the flow properties ate different 

velocities. 

 

Software Used:ICEM CFD and FLUENT  

 

We will create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem 

 

 Create or import Geometry  

 Block the geometry 

 Associate entities to the geometry. 

 Apply mesh parameters. 

 Generate the initial mesh. 

 Export mesh  

 

Start ICEM CFD  

 

Create Geometry in ICEM CFD 
 

1) Close any previous files, have blank screen in ICEM. 

2) Create new project file for the pipe in ICEM: 

a) File, New Project. 

b) Select folders in turn: Desktop, CFX Training Files – Copy, Flat plate. 

c) Save project with name ―Flat plate‖ in folder ―Flat plate‖. 

3) We are going to create some points now: 

a) Select Geometry tab at top of screen. 

b) Select ―Create Point‖ option. 

c) In the bottom left are various options for creating the point. Select the second ―XYZ‖ option. 

d) Input the numbers X=0, Y=0, Z=0. 

e) Press ―Apply‖ to create a point on screen 

f) Note - If the point does not appear, then check that points are displayed in the tree, and usethe ―Fit 

Window‖ option in the top left to zoom the screen correctly. 

 

Create points  

 

Explicit location > specify x and y location and click ok  

Similarly create 4 points  

 

Create curves  

 

a) Under ―Geometry‖ tab, select ―Create and modify curve‖. 

b) Under ―Create and modify curve‖ option panel on bottom left, select 3rd option ― 
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Select two points on the screen and select ok Create remaining curves  

 

Create surface  

 

Simple surface – from 2-4 curves  

To check surface click on solid frame  

 

Label the curves 

 

Give names to the INLET, OUTLET and WALL surfaces: 

a) Under ―Geometry‖ tree, highlight only ―Surfaces‖. 

b) Right click ―Parts‖, Create Part. 

c) Part = ―INLET‖. 

d) Entities: click arrow icon, left click surface (near surface, around origin) to highlight it, middle 

click to save selection, right click to de-select mode. 

e) Note that the INLET part has been created, and can be turned on and off independently using the tree 

view. 

f) Part = ―OUTLET‖, repeat step to identify an outlet at the far end. 

g) Part = ―WALL‖, repeat step to identify the wall. 

h) Notes: ―GEOM‖ now contains only 0D and 1D elements; points and lines. 

 

Block the Geometry 

 

The geometry and part information has already been defined for this tutorial. You will create the initial 

blockin this step. 

1. Create the initial block. 

 Blocking > Create Block > Initialize Blocks 

a. Enter FLUID in the Part field. 

b. Select 2D Planar in the Type drop-down list. 

c. Click Apply. 

 

Associate Entities to the Geometry 

 

You will associate the edges of the blocking to the curves of the CAD geometry in this step. First select the 

edges and then the curves to which you want to associate them. 

 

1. Associate the inlet, the left-most end of the large flat plate. 

a. Ensure that Project Vertices is disabled. 

b. Click (Select edge(s)) and select edge 13–41. Click the middle-mouse button to accept the selection. 

c. Click (Select compcurve(s)) and select CURVES/1. Click the middle-mouse button to accept the 

selection. 

d. Click Apply. 

The associated edge will be colored green. 

 

Generate the Initial Mesh 

 

Blocking > Pre-Mesh Params > Update Sizes 

 

Retain the selection of Update All in the Method list. 
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Blocking Pre-Mesh 

The Mesh dialog will appear, asking if you want to recompute the mesh. 

Click Yes in the Mesh dialog to compute the initial mesh. 

Disable Vertices and Edges. 

 

Verify and Save the Mesh and Blocking 

 

1. Convert the mesh to unstructured format. 

Blocking Pre-Mesh Convert to Unstruct Mesh 

2. Save the blocking file (2D-Flat plate -geometry-final.blk). 

File > Blocking > Save Blocking As... 

This block file can be loaded in a future session (File > Blocking > Open Blocking...) for additional 

modification or to mesh a similar geometry. Save each blocking to a separate file instead of overwriting a 

previous one. In more complex models, you may have to back track and load a previous blocking. 

3. Save the project file (2D-flat plate-geometry-final.prj). 

File > Save Project As... 

This will save all the files—tetin, blocking, and unstructured mesh. 

4. Exit the current session. 

File > Exit 

Save your ICEM CFD file in your working directory. 

 

Setting Up the CFD Simulation in ANSYS FLUENT 

Now that you have created a computational mesh for the elbow geometry, you can proceed to setting up a 

CFD analysis using ANSYS FLUENT. 

1.   Start ANSYS FLUENT. 

In the ANSYS Workbench Project Schematic, double-click the Setup cell in the elbow fluid flow analysis 

system. You can also right-click on the Setup cell to display the context menu where you can select 

the Edit option. 

When ANSYS FLUENT is first started, FLUENT Launcher is displayed, allowing you to view and/or set 

certain ANSYS FLUENT start-up options. 

 Ensure that the proper options are enabled. 

Note that the Dimension setting is already filled in and cannot be changed, since ANSYS 

FLUENT automatically sets it based on the mesh or geometry for the current system. 

i.   Make sure that Serial from the Processing Options list is enabled. 

ii.   Make sure that the Display Mesh After Reading, Embed Graphics Windows, and Workbench 

Color Scheme options are enabled. 

iii.   Make sure that the Double-Precision option is disabled. 

(b)   Click OK to launch ANSYS FLUENT. 

2.   Set some general settings for the CFD analysis. 
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  Select General in the navigation pane to perform the mesh-related activities and to choose a solver. 

 General 

(a)   Change the units for length. 

Since we want to specify and view values based on a unit of length in inches from within ANSYS FLUENT, 

change the units of length within ANSYS FLUENT from meters (the default) to inches. 

 General  Units... 

This displays the Set Units dialog box. 

i.   Select length in the Quantities list. 

ii.   Select in in the Units list. 

iii.   Close the dialog box. 

   Now, all subsequent inputs that require a value based on a unit of length can be specified in inches rather 

than meters. 

(b)   Check the mesh. 

 General  Check 

   ANSYS FLUENT will report the results of the mesh check in the console. 

3.   Set up your models for the CFD simulation. 

 Models 

(a)   Enable heat transfer by activating the energy equation. 

 Models   Energy  Edit... 

   You can also double-click a list item in order to open the corresponding dialog box. 

i.   Enable the Energy Equation option. 

ii.   Click OK to close the Energy dialog box. 

(b)   Enable the -  turbulence model. 

 Models   Viscous  Edit... 

i.   Select k-epsilon from the Model list. 

   The Viscous Model dialog box will expand. 

ii.   Select Realizable from the k-epsilon Model list. 

iii.   Click OK to accept the model and close the Viscous Model dialog box. 
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4.   Set up your materials for the CFD simulation. 

 Materials 

(c) Create a new material called air using the Create/Edit Materials dialog box. 

(d)  Materials   Fluid  Create/Edit... 

i.   Enter air for Name. 

ii.    specify the properties  

iii.   Click Change/Create. 

  5.   Set up the cell zone conditions for the CFD simulation. 

Cell Zone Conditions 

(a)   Set the cell zone conditions for the fluid zone. 

i.   Select fluid in the Zones list in the Cell Zone Conditions task page, then click the Edit... button to open 

the Fluid dialog box. 

   You can also double-click a list item in order to open the corresponding dialog box. 

ii.   In the Fluid dialog box, select water from the Material Name drop-down list. 

iii.   Click OK to close the Fluid dialog box. 

6.   Set up the boundary conditions for the CFD analysis. 

 Boundary Conditions 

(a)   Set the boundary conditions at the cold inlet (velocity-inlet-large). 

 Boundary Conditions   velocity-inlet-large  Edit... 

i.   Select Components from the Velocity Specification Method drop-down list. 

  The Velocity Inlet dialog box will expand. 

ii.   Enter 0.4 m/s for X-Velocity. 

iii.   Retain the default value of 0 m/s for both Y-Velocity and Z-Velocity. 

7.   Set up solution parameters for the CFD simulation. 

  In the steps that follow, you will set up and run the calculation using the task pages listed under 

the Solution heading in the navigation pane. 

Change the convergence criteria for the continuity equation residual. 
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 Monitors   Residuals  Edit... 

i.   Make sure that Plot is enabled in the Options group box. 

ii.   Enter 1e-05 for the Absolute Criteria of continuity, as shown in the Residual Monitor dialog box. 

iii.   Click OK to close the Residual Monitors dialog box. 

Note:   By default, all variables will be monitored and checked by ANSYS FLUENT as a means to 

determine the convergence of the solution. 

Initialize the flow field, using the boundary conditions settings at the cold inlet ( velocity-inlet-large) as a 

starting point. 

 Solution Initialization 

i.   Select velocity-inlet-large from the Compute From drop-down list. 

ii.   Enter 1.2 m/s  for Y Velocity in the Initial Values group box. 

Note:   While an initial X Velocity is an appropriate guess for the horizontal section, the addition of a Y 

Velocity component will give rise to a better initial guess throughout the entire elbow. 

iii.   Click Initialize. 

   Check to see if the case conforms to best practices. 

 Run Calculation  Check Case 

8.   Calculate a solution. 

 Start the calculation by requesting 250 iterations. 

 Run Calculation 

i.   Enter 250 for Number of Iterations. 

ii.   Click Calculate. 

 As the calculation progresses, the residuals will be plotted in the graphics window  

9.   View the files generated by ANSYS Workbench. 

 

Result: 

Viva questions: 

1. Define the pressure contour? 

2. What is normal shock wave? 

3. What is gauge pressure? 
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EXPERIMENT – 6 

 

CIRCULATION OF THE LIFT OVER A CIRCULAR CYLINDER 

 
Aim: To visualize the circulation of the lift over a circular cylinder. 

 

Software Used: ICEM CFD and FLUENT  

 

 

 

 
 

We will create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow 

problem. 

 Create or import Geometry  

 Block the geometry 

 Associate entities to the geometry. 

 Apply mesh parameters. 

 Generate the initial mesh. 

 Export mesh  
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Consider the steady state case of a fluid flowing past a cylinder, as illustrated above. Obtain the velocity 

and pressure distributions when the Reynolds number is chosen to be 20. In order to simplify the 

computation, the diameter of the cylinder is set to 1 m, the x component of the velocity is set to 1 m/s and 

the density of the fluid is set to 1 kg/m^3. Thus, the dynamic viscosity must be set to 0.05 kg/m*s in order 

to obtain the desired Reynolds number.  

Pre-Analysis & Start-Up 

Prior to opening FLUENT, we must answer a couple of questions. We must determine what our solution 

domain is and what the boundary conditions are. 

Solution Domain 

For an external flow problem like this, one needs to determine where to place the outer boundary. A 

circular domain will be used for this simulation. The effects that the cylinder has on the flow extend far. 

Thus, the outer boundary will be set to be 64 times as large as the diameter of the cylinder. That is, the 

outer boundary will be a circle with a diameter of 64 m. The solution domain discussed here is illustrated 

below.  

 

Boundary Conditions 

First, we will specify a velocity inlet boundary condition. We will set the left half of the outer boundary 

as a velocity inlet with a velocity of 1 m/s in the x direction. Next, we will use a pressure outlet boundary 

condition for the right half of the outer boundary with a gauge pressure of 0 Pa. Lastly, we will apply a no 

slip boundary condition to the cylinder wall. The aforementioned boundary conditions are illustrated 

below.  
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Set Up Problem in FLUENT 
 

Launch FLUENT 

 

Start > Programs > Fluent> FLUENT 6.3.26 

Select 2ddp from the list of options and click Run. 

 

Import File 

 

Main Menu > File > Read > Case... 

Navigate to your working directory and select the cylinder.msh file. Click OK. 

 

Analyze Grid 

 

Grid > Info > Size 

Check how many cells and nodes the mesh has. 

 

Display > Grid 
Display the grid information. 

 

Define Properties 

 

Define > Models > Solver... 
Under the Solver box, select Pressure Based. 

Click OK. 

 

Define > Models > Viscous 
Select Laminar under Model 

Click OK. 

 

Define > Models > Energy 
Do not select Energy Equation. 

Define > Materials 
 

Make sure air is selected under Fluent Fluid Materials.  

Set Density to constant and equal to 1 kg/m 
3
 and Viscosity to 0.025 kg/m-s. We choose these numbers 

so that Re = 40. 

Click Change/Create. 

 

Define > Operating Conditions 
We'll work in terms of gauge pressures in this example. So set Operating Pressure to the ambient value 

of 101,325 Pa. 

Click OK. 

 

Define > Boundary Conditions 
Set inlet, click Set... and set the Velocity Magnitude to 1 m/s. Click OK. 

Set outlet, click Set... and set the Gauge Pressure at this boundary to 0. Click OK. 
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Solve 

Solve > Control > Solution 
Under Discretization, set Momentum to Second-Order Upwind. 

 

Solve > Initialize > Initialize... 
Select inlet under Compute From. We'll set these values to be equal to those at the inlet. 

 

Solve > Monitors > Residual... 
Now we will set the residual values (the criteria for a good enough solution). Once again, we'll set 

this value to 1e-06. 

Select Print and Plot under Options. Click 

OK 

 

Solve > Monitors > Force... 
Under Coefficient, choose Drag. Under Options, select Print and Plot. Then, Choose cylinder under  

Wall Zones. 

 

Set the Force Vector components for the drag. The drag is the force in the direction of the freestream. 

So to get the drag coefficient, set X to 1 and Y to 0. 

 

Record the histories of Cd. Under Options, select Write. Fill in the name in the box under File Name, 

then the text file containing drag coefficients at each iteration will be stored in the file. 

 

Click Apply for these changes to take effect. 

Similarly, set the Force Monitor options for the Lift force. The lift is defined as the force component 

perpendicular to the direction of the free stream. So under Force Vector, set X to 0 and Y to 1. 

Click Apply. 

Report > Reference Values 
Now, set the reference values to set the base cases for our iteration. Select inlet under Compute From. 

 

Main Menu > File > Write > Case... 
Save the case file before you start the iterations. 

 

Solve > Iterate 
Make note of your findings, make sure you include data such as: 
What does the convergence plot look like? 
 
How many iterations does it take to converge? 

 

Main Menu > File > Write > Case & Data... 
Save case and data after you have obtained a converged solution. 

 

Analyze Results 

 

Drag / Lift coefficients 

Report > Forces > 
Under Force Vector, we set X = 1 and Y = 0 to identify the direction of drag force. Click Print to 
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see what's displayed in the main window. 

 

Plot convergence of the drag coefficient versus the number of iterations. Report the drag coefficient 

and compare it with the result in literature as shown in Table 1. 

 

Plot>File 
Click Add... choose the file with drag or lift coefficient. 

Before you plot, you can adjust the Axes and Curves to get a better view. 

 

Similarly, you can plot the lift coefficient, which should be zero for the symmetric flow. As you can see, 

the drag coefficient is around 2.1, which is significantly higher than the result in the table. Next, we will 

try to increase the domain size and repeat the simulation. 

 

Plot streamlines. Plot pressure, velocity, vorticity contours. 

 

Display > Contours > 
 
Results: 
 
 
Viva questions: 
 

1. Define boundary conditions around the cylinder? 

2. What is iteration? 

3. What is center of pressure? 

 
 

 

 

 

 

 

 

 

 

 

 

 

 



32 
 
 

EXPERIMENT – 7 

 

PRESSURE DISTRIBUTION OVER A SYMMETRIC AEROFOIL 

 
Aim: To visualize the pressure distribution over a symmetric aerofoil at different velocities. 

 

We will create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem. 

 

 

 Create or import Geometry  

 Block the geometry 

 Associate entities to the geometry. 

 Apply mesh parameters. 

 Generate the initial mesh. 

 Export mesh  

 

Introduction 
 
This provides a short step by step guide to meshing an aerofoil using the icemcfd package. The aim being 

to introduce you the important features of the program in the shortest possible space of time. The mesh 

that this tutorial produces will require further work to be used as a basis for serious calculations but this 

tutorial contains all the information that you need to do this. 
 
icemcfd is available on the University GNU/Linux service called vega. Once you have logged into vega 

you can start it from the command line using the command icemcfd. 

 
 
Importing the Geometry 
 
● Start icemcfd 
 
● Obtain the NACA5012 coordinates file (this should be on the same page/folder where you 

obtained this document)  
 
● File → Import Geometry → Formatted point data (then select the file you just obtained) A good tip 

at this point is to go to File → Change Working Directory and change the directory to where you 

have stored the NACA data – this saves a lot of navigation through file dialogues later.  
 
● Then click apply in the bottom left corner of the screen  
 
● We then want to create a curve made of those points to describe the surface of aerofoil  
 
 Under the Geometry tab in the top centre of the screen click on the Create/Modify Curve 

button  
 
 This pops a new menu in the bottom left. Click on the top left icon underneath ―Inherit Part‖, 

This is the ―From Points‖ tool. Click on ―Inherit Part‖ to deselect it and name the part 

SUCTION.  
 
 You should then select each point on the top of the curve one after the other with the left mouse 

button. (There ought to be a better way of doing this but I can't seem to find it!) You might 



33 
 
 

need to zoom in to get all the points in the trailing edge. The middle mouse button accepts your 

final selection  

 Repeat the process for the points on the bottom of the curve. Name this PRESSURE. 

 

● Then we want to create the surface on which we will calculate the fluid flow. To do this we will 

create a domain around 1 chord lengths above and below the aerofoil and 1.5 chord lengths before 

and after. This is slightly arbitrary and we may want to change this after we look at the results!  
 
● Add points at (-1.5,1),(-1.5,-1),(2,1) and (2,-1) Click on the Create Point tool under the geometry tab 

and use the Explicit Locations tool to do this.  
 
Join these points together with straight lines. Label the left hand one INLET, the right hand line EXIT and 
the upper and lower parts TOP and BOTTOM. 
 
 
● We are going to construct an outer surface called FLUID which will then mesh later.  
 
● Make a surface from the outer edges into surface (Geometry Tab → Create/Modify Surface → 

Simple Surface)  
 
 Click on the ―Inherit Part‖ button so that it is no longer checked  

 
 Rename the Surface as FLUID  

 
 Select the four curves  

 
 Click on OK or Apply  

 
 This surface might not actually be visible. On the left hand side of the screen is tree menu that 

controls what is and is not visible. If you want to see the surface simply go through the menu 

and ensure that under ―Geometry‖ the ―Surfaces‖ node is ticked.  

 

Setting up the Initial Blocking 
 
To do this we need to apply what is known as a ―blocking strategy‖. In icemcfd for structured meshes the 

geometry is joined to a series of blocks which are then filled with the cells that make up the actual 

volumes on which the calculation will take place on. The process of meshing is therefore somewhat 

different from the CAD programs you will have used up to now as you are not trying to draw the part but 

the surrounding area which the fluid surrounds. 
 
● Go to the Blocking Tab  
 
● Click on ―Create Block‖ and ensure in the ―Initalize Blocks‖ drop down the type is 2D Planar and 

the part selected is ―FLUID‖. Click OK, A blue message saying ―Initialize blocking done‖ should 

appear in the message window  
 
● This creates a Block which we then need to associate to various edges  
 
● In the Blocking Tab click on ―Associate‖ (fifth tool from the left) then in the left hand menu that 

appears select ―Associate Edge to Curve‖. This should look a bit like  Figure 4 , note that in  Figure 4 

the points are not displayed.  
 
● You now need to associate each side of the block one of the parts we made earlier. (INLET, 

OUTLET, TOP and BOTTOM). This must be done separately for each part. To do this: Click on 

the first edge (which is part of the blocking) and then the first curve (which is geometry). This is 

most easily done by left clicking and middle clicking - an on screen prompt guides as to which 

mouse button to press when.  
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● We can now get icemcfd to do a crude initial first mesh. Go to the Mesh Tab → Part Mesh Setup 
and set the max size to be 0.1 on all the parts. Then go to the Blocking Tab → Pre-Mesh Params (9

th
 

from left) select the ―Recalculate Sizes‖ tool and click ok. It may look like nothing has happened 
but a first mesh has been created!  

 
● To see it you need to make the mesh viewable. On the left hand side of the screen there is a tree 

menu with a white background. Expand the Blocking Menu and click on ―Pre-Mesh‖ a square mesh 

that completely ignores the aerofoil should now appear. Clearly there is work to be done! You should 

now turn the Pre-Mesh view off to make manipulations easier. We now need to associate the face 

(the mesh) with the surface (the FLUID part we created earlier. 
 
● On the Blocking Tab select the Associate Vertices icon (fifth from left). In the tool that pops on the 

bottom left select Associate Face → Surface (fourth from left). Then select the face and the FLUID 

part in the pop up window.  
 
Meshing the aerofoil 
 
Clearly we need some way to tell icemcfd that we would like the mesh associated with the aerofoil 

shape in the middle of the screen and to organise this mesh so that we end up with the right sort of 

mesh. 
  
● First further divide up the Blocks. Blocking Tab → Split Block and then select the Split Block tool. 

Use this tool to split the block upstream and downstream of the aerofoil and above and below the 

trailing edge. Again left and middle clicking is the most efficient method. Your screen should look 

something like  Figure 6  
 
● Now we want to add a special type of block called an ―O grid‖ around the aerofoil. Go to the 

Blocking Tab → Split Block (Second from left) and then select the O grid Block tool (Second 

item from left in the bottom left panel). After you have selected the tool you need to Click on 

Select Blocks.  
 
● Select the central block and the block on the middle right by using the left mouse then the middle 

mouse and two turquoise squares should appear in the centre of your screen. Now click on the Select 

Edge(s) option within the tool and then select the right hand most edge. A yellow square should 

appear on the right hand side. Click ok or apply to define a new O grid.  
 
● Now we should delete the central block as this is the aerofoil itself and not something that we actually 

want to calculate. Blocking Tab → Delete Block and left click on the central square and use middle 

mouse to get rid of it.  

● On the left hand side of the screen there is that tree menu with a white background, if you click on 

Pre-Mesh you should be able to view the mesh again.  
 
● The mesh most likely still occupies the centre of the aerofoil, so we add a point to guide the program 

about where we would like the mesh to go. Blocking Tab → Edit Edge, then select the Split Edge 

tool and select Linear from the drop down menu.  
 
 
● At this point you will want to adjust the position of the vertices on the aerofoil so that it gives a 

more reasonable mesh. Blocking Tab → Move Vertex tool will accomplish this.  
 
● The Pre-Mesh Parameters tool (Blocking Tab → Pre-Mesh Parameters (Ninth from left) then the 

Edge Params Tool (Third from Left) should be used to add more points in various places. Until the 

mesh looks better.  
 
● A number of tools allow you to assess the mesh quality. Blocking Tab → Pre-Mesh Quality 

Histograms allow you to look at things like the worst element. A graph appears in the bottom right 
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which you can click on to examine the the worst element then adjust the mesh spacing, the position 
of the vertices on the blocks and so on.  
 

Set Up Problem in FLUENT 
 

Launch FLUENT 
 

Start > Programs > Fluent Inc > FLUENT 6.3.26 
 

Select 2ddp from the list of options and click Run. 

Import File 

Main Menu > File > Read > Case... 
 

Navigate to your working directory and select the airfoil.msh file. Click OK. Check that the displayed 

information is consistent with our expectations of the airfoil grid. 

 

Analyze Grid 
 

Grid > Info > Size 
 

How many cells and nodes does the grid have? 

 

Display > Grid 
 

Note what the surfaces farfield1, farfield2, etc. correspond to by selecting and plotting them in turn. 

 

Zoom into the airfoil. 

 

Where are the nodes clustered? Why? 

 

Define Properties 
 

Define > Models > Solver... 
Under the Solver box, select Pressure Based. 

 

Click OK. 

 

Define > Models > Viscous 
 

Select Inviscid under Model 

 

Click OK. 

Define > Models > Energy 
 

The speed of sound under SSL conditions is 340 m/s so that our freestream Mach number is around 0.15. 

This is low enough that we'll assume that the flow is incompressible. So the energy equation can be 

turned off. 

 

Make sure there is no check in the box next to Energy Equation and click OK. 
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Define > Materials 
 

Make sure air is selected under Fluid Materials. Set Density to constant and equal to 1.225 kg/m
3
. 

 

Click Change/Create. 

 

Define > Operating Conditions 
 

We'll work in terms of gauge pressures in this example. So set Operating Pressure to the ambient value 

of 101,325 Pa. 

 

Click OK. 

 

Define > Boundary Conditions 
 

Set farfield1 and farfield2 to the velocity-inlet boundary type. 

 

For each, click Set.... Then, choose Components under Velocity Specification Method and set the x- and 

y-components to that for the freestream. For instance, the x-component is50*cos(1.2)=49.99. Click OK. 

 

Set farfield3 to pressure-outlet boundary type, click Set... and set the Gauge Pressure at this boundary to 

0. Click OK. 

 

Step 5: Solve! 
 

Solve > Control > Solution 
 

Take a look at the options available. 

 

Under Discretization, set Pressure to PRESTO! and Momentum to Second-Order Upwind. 

 

 

Click OK. 

Solve > Initialize > Initialize... 
 

As you may recall from the previous tutorials, this is where we set the initial guess values (the base case) 

for the iterative solution. Once again, we'll set these values to be equal to those at the inlet. Select 

farfield1 under Compute From. 

 

Click Init. 

 

Solve > Monitors > Residual... 
 

Now we will set the residual values (the criteria for a good enough solution). Once again, we'll set this 

value to 1e-06.Click OK. 

 

Solve > Monitors > Force... 
Under Coefficient, choose Lift. Under Options, select Print and Plot. Then, Choose airfoil under Wall 

Zones. 
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Lastly, set the Force Vector components for the lift. The lift is the force perpendicular to the direction of 

the freestream. So to get the lift coefficient, set X to -sin(1.2°)=-020942 and Y to cos(1.2°)=0.9998. 

Click Apply for these changes to take effect. 

 

Similarly, set the Force Monitor options for the Drag force. The drag is defined as the force component 

in the direction of the freestream. So under Force Vector, set X to cos(1.2°)=0.9998 and Y to 

sin(1.2°)=0.020942 Turn on only Print for it. 

Report > Reference Values 
Now, set the reference values to set the base cases for our iteration. Select farfield1 under Compute 

From. 

 

Click OK.Note that the reference pressure is zero, indicatingthat we are measuring gage pressure. 

 

Main Menu > File > Write > Case... 
 

Save the case file before you start the iterations. 

 

Solve > Iterate 
 

Make note of your findings, make sure you include data such as; What does the convergence plot look 

like? 

 

How many iterations does it take to converge? 

 

How does the Lift coefficient compared with the experimental data? 

 

Main Menu > File > Write > Case & Data... 
 

Save case and data after you have obtained a converged solution. 

 

Step 6: Analyze Results 
 

Lift Coefficient 
 

The solution converged after about 480 iterations. 

 

476 1.0131e-06 4.3049e-09 1.5504e-09 6.4674e-01 2.4911e-03 0:00:48 524 

● 477 solution is converged  

477 9.9334e-07 4.2226e-09 1.5039e-09 6.4674e-01 2.4910e-03 0:00:38 523  

 

From FLUENT main window, we see that the lift coefficient is 0.647. 

 

 

Plot Velocity Vectors 
 

Let's see the velocity vectors along the airfoil. 

 

Display > Vectors 
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Enter 4 next to Scale. Enter 3 next to Skip. Click Display. 

 

As can be seen, the velocity of the upper surface is faster than the velocity on the lower surface. 

 

 

Main Menu > File > Hardcopy 
 

Make sure that Reverse Foreground/Background is checked and select Color in 

 

Coloring section. Click Preview. Click No when prompted "Reset graphics window?" 

 

 

On the leading edge, we see a stagnation point where the velocity of the flow is nearly zero. The fluid 

accelerates on the upper surface as can be seen from the change in colors of the vectors. 

 

 

On the trailing edge, the flow on the upper surface decelerates and converge with the flow on the lower 

surface. 

 

Plot Pressure Coefficient 

 

Pressure Coefficient is a dimensionless parameter defined by the equation where pisthe static pressure, 

 

Pref is the reference pressure, and 

 

qref is the reference dynamic pressure defined by 

 

Plot > XY Plot... 
 

Change the Y Axis Function to Pressure..., followed by Pressure Coefficient. Then, select airfoil under 

Surfaces. 

 

Click Plot. 

The lower curve is the upper surface of the airfoil and has a negative pressure coefficient as the pressure 

is lower than the reference pressure. 

Plot Pressure Contours 
 

Plot static pressure contours. 

 

Display > Contours... 
 

Select Pressure... and Pressure Coefficient from under Contours Of. Check the Filled and Draw Grid 

under Options menu. Set Levels to 50.Click Display. 

 

From the contour of pressure coefficient, we see that there is a region of high pressure at the leading edge 

(stagnation point) and region of low pressure on the upper surface of airfoil. This is of what we expected 

from analysis of velocity vector plot. From Bernoulli equation, we know that whenever there is high 

velocity, we have low pressure and vice versa. 
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Result: 

 

Viva Questions: 

1. What is vega in terms of ICEM CFD? 

2. What is presto under the discretization? 

3. List the types of airfoils? 

4. What is nomenclature of Airfoil? 
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EXPERIMENT –8 

 

PRESSURE DISTRIBUTION OVER A CAMBEREDAEROFOIL 

 
Aim: To visualize the pressure distribution over a cambered aerofoil at different velocities. 

 

Software Used: ICEM CFD and FLUENT  

 

We will create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem. 

 

 Create or import Geometry  

 Block the geometry 

 Associate entities to the geometry. 

 Apply mesh parameters. 

 Generate the initial mesh. 

 Export mesh  

 

Introduction 
 
This provides a short step by step guide to meshing an aerofoil using the icemcfd package. The aim being 

to introduce you the important features of the program in the shortest possible space of time. The mesh 

that this tutorial produces will require further work to be used as a basis for serious calculations but this 

tutorial contains all the information that you need to do this. 
 
icemcfd is available on the University GNU/Linux service called vega. Once you have logged into vega 

you can start it from the command line using the command icemcfd. 
 
Importing the Geometry 
 
● Start icemcfd 
 
● Obtain the NACA5012 coordinates file (this should be on the same page/folder where you 

obtained this document)  
 
● File → Import Geometry → Formatted point data (then select the file you just obtained) A good tip 

at this point is to go to File → Change Working Directory and change the directory to where you 

have stored the NACA data – this saves a lot of navigation through file dialogues later.  
 
● Then click apply in the bottom left corner of the screen  
 
● We then want to create a curve made of those points to describe the surface of aerofoil  
 

● Under the Geometry tab in the top centre of the screen click on the Create/Modify Curve 

button  
 

● This pops a new menu in the bottom left. Click on the top left icon underneath ―Inherit Part‖, This 

is the ―From Points‖ tool. Click on ―Inherit Part‖ to deselect it and name the part SUCTION.  
 

● You should then select each point on the top of the curve one after the other with the left mouse 

button. (There ought to be a better way of doing this but I can't seem to find it!) You might need 
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to zoom in to get all the points in the trailing edge. The middle mouse button accepts your final 

selection  

● Repeat the process for the points on the bottom of the curve. Name this PRESSURE. 

 

● Then we want to create the surface on which we will calculate the fluid flow. To do this we will 

create a domain around 1 chord lengths above and below the aerofoil and 1.5 chord lengths before 

and after. This is slightly arbitrary and we may want to change this after we look at the results!  
 
● Add points at (-1.5,1),(-1.5,-1),(2,1) and (2,-1) Click on the Create Point tool under the geometry tab 

and use the Explicit Locations tool to do this.  
 
Join these points together with straight lines. Label the left hand one INLET, the right hand line EXIT and 
the upper and lower parts TOP and BOTTOM. 
 
 
● We are going to construct an outer surface called FLUID which will then mesh later.  
 
● Make a surface from the outer edges into surface (Geometry Tab → Create/Modify Surface → 

Simple Surface)  
 
 Click on the ―Inherit Part‖ button so that it is no longer checked  

 
 Rename the Surface as FLUID  

 
 Select the four curves  

 
 Click on OK or Apply  

 
 This surface might not actually be visible. On the left hand side of the screen is tree menu that 

controls what is and is not visible. If you want to see the surface simply go through the menu 

and ensure that under ―Geometry‖ the ―Surfaces‖ node is ticked.  

 

Setting up the Initial Blocking 
 
To do this we need to apply what is known as a ―blocking strategy‖. In icemcfd for structured meshes the 

geometry is joined to a series of blocks which are then filled with the cells that make up the actual 

volumes on which the calculation will take place on. The process of meshing is therefore somewhat 

different from the CAD programs you will have used up to now as you are not trying to draw the part but 

the surrounding area which the fluid surrounds. 
 
● Go to the Blocking Tab  
 
● Click on ―Create Block‖ and ensure in the ―Initalize Blocks‖ drop down the type is 2D Planar and the 

part selected is ―FLUID‖. Click OK, A blue message saying ―Initialize blocking done‖ should appear 

in the message window  
 
● This creates a Block which we then need to associate to various edges  
 
● In the Blocking Tab click on ―Associate‖ (fifth tool from the left) then in the left hand menu that 

appears select ―Associate Edge to Curve‖. This should look a bit like  Figure 4 , note that in  Figure 4 

the points are not displayed.  
 
● You now need to associate each side of the block one of the parts we made earlier. (INLET, OUTLET, 

TOP and BOTTOM). This must be done separately for each part. To do this: Click on the first edge 
(which is part of the blocking) and then the first curve (which is geometry). This is most easily done 

by left clicking and middle clicking - an on screen prompt guides as to which mouse button to press 

when.  
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● We can now get icemcfd to do a crude initial first mesh. Go to the Mesh Tab → Part Mesh Setup and 
set the max size to be 0.1 on all the parts. Then go to the Blocking Tab → Pre-Mesh Params (9

th
 from 

left) select the ―Recalculate Sizes‖ tool and click ok. It may look like nothing has happened but a first 
mesh has been created!  

 
● To see it you need to make the mesh viewable. On the left hand side of the screen there is a tree menu 

with a white background. Expand the Blocking Menu and click on ―Pre-Mesh‖ a square mesh that 

completely ignores the aerofoil should now appear. Clearly there is work to be done! You should now 

turn the Pre-Mesh view off to make manipulations easier. We now need to associate the face (the 

mesh) with the surface (the FLUID part we created earlier. 
 
● On the Blocking Tab select the Associate Vertices icon (fifth from left). In the tool that pops on the 

bottom left select Associate Face → Surface (fourth from left). Then select the face and the FLUID 

part in the pop up window.  

 

Meshing the aerofoil 
 
Clearly we need some way to tell icemcfd that we would like the mesh associated with the aerofoil 

shape in the middle of the screen and to organize this mesh so that we end up with the right sort of 

mesh. 
  
● First further divide up the Blocks. Blocking Tab → Split Block and then select the Split Block tool. 

Use this tool to split the block upstream and downstream of the aerofoil and above and below the 

trailing edge. Again left and middle clicking is the most efficient method. Your screen should look 

something like  Figure 6  
 
● Now we want to add a special type of block called an ―O grid‖ around the aerofoil. Go to the Blocking 

Tab → Split Block (Second from left) and then select the O grid Block tool (Second item from left in 

the bottom left panel). After you have selected the tool you need to Click on Select Blocks.  
 
● Select the central block and the block on the middle right by using the left mouse then the middle 

mouse and two turquoise squares should appear in the centre of your screen. Now click on the Select 

Edge(s) option within the tool and then select the right hand most edge. A yellow square should 

appear on the right hand side. Click ok or apply to define a new O grid.  
 
● Now we should delete the central block as this is the aerofoil itself and not something that we actually 

want to calculate. Blocking Tab → Delete Block and left click on the central square and use middle 

mouse to get rid of it.  

● On the left hand side of the screen there is that tree menu with a white background, if you click on 

Pre-Mesh you should be able to view the mesh again.  
 
● The mesh most likely still occupies the centre of the aerofoil, so we add a point to guide the program 

about where we would like the mesh to go. Blocking Tab → Edit Edge, then select the Split Edge tool 

and select Linear from the drop down menu.  
 
 
● At this point you will want to adjust the position of the vertices on the aerofoil so that it gives a more 

reasonable mesh. Blocking Tab → Move Vertex tool will accomplish this.  
 
● The Pre-Mesh Parameters tool (Blocking Tab → Pre-Mesh Parameters (Ninth from left) then the Edge 

Params Tool (Third from Left) should be used to add more points in various places. Until the mesh 

looks better.  
 
● A number of tools allow you to assess the mesh quality. Blocking Tab → Pre-Mesh Quality 

Histograms allow you to look at things like the worst element. A graph appears in the bottom right 
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which you can click on to examine the the worst element then adjust the mesh spacing, the position of 

the vertices on the blocks and so on.  
 
Set Up Problem in FLUENT 
 

Launch FLUENT 
 

Start > Programs > Fluent Inc > FLUENT 6.3.26 
 

Select 2ddp from the list of options and click Run. 

Import File 

Main Menu > File > Read > Case... 
 

Navigate to your working directory and select the airfoil.msh file. Click OK. Check that the displayed 

information is consistent with our expectations of the airfoil grid. 

 

Analyze Grid 
 

Grid > Info > Size 
 

How many cells and nodes does the grid have? 

 

Display > Grid 
 

Note what the surfaces farfield1, farfield2, etc. correspond to by selecting and plotting them in turn. 

 

Zoom into the airfoil. 

 

Where are the nodes clustered? Why? 

 

Define Properties 
 

Define > Models > Solver... 
Under the Solver box, select Pressure Based. 

 

Click OK. 

 

Define > Models > Viscous 
 

Select  Inviscid  under Model 

 

Click OK. 

Define > Models > Energy 
 

The speed of sound under SSL conditions is 340 m/s so that our freestream Mach number is around 0.15. 

This is low enough that we'll assume that the flow is incompressible. So the energy equation can be 

turned off. 

 

Make sure there is no check in the box next to Energy Equation and click OK. 
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Define > Materials 
 

Make sure air is selected under Fluid Materials. Set Density to constant and equal to 1.225 kg/m
3
. 

 

Click Change/Create. 

 

Define > Operating Conditions 
 

We'll work in terms of gauge pressures in this example. So set Operating Pressure to the ambient value 

of 101,325 Pa. 

 

Click OK. 

 

Define > Boundary Conditions 
 

Set farfield1 and farfield2 to the velocity-inlet boundary type. 

 

For each, click Set.... Then, choose Components under Velocity Specification Method and set the x- and 

y-components to that for the freestream. For instance, the x-component is50*cos(1.2)=49.99. (Note that 

1.2° is used as our angle of attack instead of 2° to adjust for the error caused by assuming the airfoil to be 

2D instead of 3D.) 

Click OK. 

 

Set farfield3 to pressure-outlet boundary type, click Set... and set the Gauge Pressure at this boundary to 

0. Click OK. 

 

Solve! 
 

Solve > Control > Solution 
 

Take a look at the options available. 

 

Under Discretization, set Pressure to PRESTO! and Momentum to Second-OrderUpwind. 

 

Click OK. 

 

Solve > Initialize > Initialize... 
Click Init. 

 

Solve > Monitors > Residual... 
 

Now we will set the residual values (the criteria for a good enough solution). Once again, we'll set this 

value to 1e-06. 

 

Click OK. 

 

Solve > Monitors > Force... 

Under Coefficient, choose Lift. Under Options, select Print and Plot. Then, Choose airfoil under Wall 

Zones. 
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Lastly, set the Force Vector components for the lift. The lift is the force perpendicular to the direction of 

the freestream. So to get the lift coefficient, set X to -sin(1.2°)=-020942 and Y to cos(1.2°)=0.9998. 

Click Apply for these changes to take effect. 

 

Similarly, set the Force Monitor options for the Drag force. The drag is defined as the force component 

in the direction of the freestream. So under Force Vector, set X to cos(1.2°)=0.9998 and Y to 

sin(1.2°)=0.020942 Turn on only Print for it. 

Report > Reference Values 
Now, set the reference values to set the base cases for our iteration. Select farfield1 under Compute 

From. 

 

Click OK.Note that the reference pressure is zero, indicatingthat we are measuring gage pressure. 

 

Main Menu > File > Write > Case... 
 

Save the case file before you start the iterations. 

 

Solve > Iterate 
 

Make note of your findings, make sure you include data such as; What does the convergence plot look 

like? 

 

How many iterations does it take to converge? 

 

How does the Lift coefficient compared with the experimental data? 

 

Main Menu > File > Write > Case & Data... 
 

Save case and data after you have obtained a converged solution. 

 

Step 6: Analyze Results 
 

Lift Coefficient 
 

The solution converged after about 480 iterations. 

 

476 1.0131e-06 4.3049e-09 1.5504e-09 6.4674e-01 2.4911e-03 0:00:48 524 

● 477 solution is converged  

477 9.9334e-07 4.2226e-09 1.5039e-09 6.4674e-01 2.4910e-03 0:00:38 523  

 

From FLUENT main window, we see that the lift coefficient is 0.647. 

 

Plot Velocity Vectors 
 

Let's see the velocity vectors along the airfoil. 

 

Display > Vectors 
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Enter 4 next to Scale. Enter 3 next to Skip. Click Display. 

 

As can be seen, the velocity of the upper surface is faster than the velocity on the lower surface. 

 

Plot Pressure Coefficient 

 

Pressure Coefficient is a dimensionless parameter defined by the equation where pisthe static pressure, 

 

Pref is the reference pressure, and 

 

qref is the reference dynamic pressure defined by 

 

Plot > XY Plot... 
 

Change the Y Axis Function to Pressure..., followed by Pressure Coefficient. Then, select airfoil under 

Surfaces. 

 

Click Plot. 

The lower curve is the upper surface of the airfoil and has a negative pressure coefficient as the pressure 

is lower than the reference pressure. 

Plot Pressure Contours 
 

Plot static pressure contours. 

 

Display > Contours... 
 

Select Pressure... and Pressure Coefficient from under Contours Of. Check the Filled and Draw Grid 

under Options menu. Set Levels to 50. 

 

Click Display. 

 

Result: 

Viva Questions: 

1. Differentiate the symmentrical and cambered airfoil  

2. What is Lift coefficient and Drag coefficient? 

3. What is camber? 
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EXPERIMENT –9 

 

SHOCK WAVE SUPERSONIC FLOW OVER WEDGE 

 
Aim: To observe the shock wave phenomena around a wedge at supersonic flow. 

Software Used: ICEM CFD and FLUENT. 

 

 

 

 

 
We will create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem. 

 

 

 Create or import Geometry  

 Block the geometry 

 Associate entities to the geometry. 

 Apply mesh parameters. 

 Generate the initial mesh. 

 Export mesh  
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Start ICEM CFD  

 

Create Geometry in ICEM CFD 
 

1) Close any previous files, have blank screen in ICEM. 

2) Create new project file for the pipe in ICEM: 

a) File, New Project. 

b) Select folders in turn: Desktop, CFX Training Files – Copy, Flat plate. 

c) Save project with name ―Flat plate‖ in folder ―Flat plate‖. 

3) We are going to create some points now: 

a) Select Geometry tab at top of screen. 

b) Select ―Create Point‖ option. 

c) In the bottom left are various options for creating the point. Select the second ―XYZ‖ option. 

d) Input the numbers X=0, Y=0, Z=0. 

e) Press ―Apply‖ to create a point on screen 

f) Note - If the point does not appear, then check that points are displayed in the tree, and use the ―Fit 

Window‖ option in the top left to zoom the screen correctly. 

 

Create points  

Explicit location > specify x and y location and click ok  

Similarly create required points 

Note that for a 2D problem, the z-coordinate can always be left to the default value of 0. 

 

Create curves  

 

Under ―Geometry‖ tab, select ―Create and modify curve‖. 

b) Under ―Create and modify curve‖ option panel on bottom left, select 3rd option ― 

Select two points on the screen and select ok Create remaining curves  

 

Create surface  

 

Simple surface – from 2-4 curves  

To check surface click on solid frame  

 

Label the curves 

 

Give names to the INLET, OUTLET and WALL surfaces: 

a) Under ―Geometry‖ tree, highlight only ―Surfaces‖. 

b) Right click ―Parts‖, Create Part. 

c) Part = ―INLET‖. 

d) Entities: click arrow icon, left click surface (near surface, around origin) to highlight it, middle 

    click to save selection, right click to de-select mode. 

e) Note that the INLET part has been created, and can be turned on and off independently 

     using the tree view. 

f) Part = ―OUTLET‖, repeat step to identify an outlet at the far end. 

g) Part = ―WALL‖, repeat step to identify the wall. 

h) Notes: ―GEOM‖ now contains only 0D and 1D elements; points and lines. 
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Block the Geometry 

 

The geometry and part information has already been defined for this tutorial. You will create the initial block 

in this step. 

 

1. Create the initial block. 

 

Blocking > Create Block > Initialize Blocks 

a. Enter FLUID in the Part field. 

b. Select 2D Planar in the Type drop-down list. 

c. Click Apply. 

 

Associate Entities to the Geometry 

 

You will associate the edges of the blocking to the curves of the CAD geometry in this step. First select the 

edges and then the curves to which you want to associate them. 

 

1. Associate the inlet, the left-most end of the large flat plate. 

a. Ensure that Project Vertices is disabled. 

b. Click (Select edge(s)) and select edge 13–41. Click the middle-mouse button to accept the selection. 

 

c. Click (Select compcurve(s)) and select CURVES/1 . Click the middle-mouse button to acceptthe selection. 

d. Click Apply. 

The associated edge will be colored green. 

 

Generate the Initial Mesh 

 

Blocking > Pre-Mesh Params > Update Sizes 

1. Retain the selection of Update All in the Method list. 

2. Select Run Check/Fix Blocks to check for mesh problems automatically and repair them if possible. 

3. Click Apply. 

4. Enable Pre-Mesh. 

 

Blocking Pre-Mesh 

 

The Mesh dialog will appear, asking if you want to recompute the mesh. 

5. Click Yes in the Mesh dialog to compute the initial mesh. 

6. Disable Vertices and Edges. 
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Verify and Save the Mesh and Blocking 

 

1. Convert the mesh to unstructured format. 

Blocking Pre-Mesh Convert to Unstruct Mesh 

2. Save the blocking file (2D-Flat plate -geometry-final.blk). 

 

File > Blocking > Save Blocking As... 

 

This block file can be loaded in a future session (File > Blocking > Open Blocking...) for additional modification 

or to mesh a similar geometry. Save each blocking to a separate file instead of overwriting previous one. In more 

complex models, you may have to back track and load a previous blocking. 

 

3. Save the project file (2D-flat plate-geometry-final.prj). 

File > Save Project As... 

This will save all the files—tetin, blocking, and unstructured mesh. 

4. Exit the current session. 

File > Exit 

Save your ICEM CFD file in your working directory. 

 

Setting Up the CFD Simulation in ANSYS FLUENT 

Problem Setup - General 

Now, FLUENT should open. We will begin setting up some options for the solver. In the left hand window 

(in what I will call the Outline window), under Problem Setup, select General. The only option we need to 

change here is the type of solver. In the Solver window, select Density-Based. 

 

Models 

In the outline window, click Models. We will need to utilize the energy equation in order to solve this 

simulation. Under Models highlight Energy - Off and click Edit.... Now, the Energy window will launch. 

Check the box next to Energy Equation and hit OK. Doing this turns on the energy equation. 

We also need to change the type of viscosity model. Select Viscous - Laminar and click Edit.... Choose 

the Inviscid option and press OK. 

Materials 

In the Outline window, highlight Materials. In the Materials window, highlight Fluid, and 

click Create/Edit.... this will launch the Create/Edit Materials window; here we can specify the properties of 

the fluid. Set the Density to Ideal Gas, the Specific Heat to 1006.43, the Molecular Weight to 28.966. When 

you have updated these fields, press Change/Create. 

 

Boundary Conditions 

In the Outline window, select Boundary Conditions. We will now specify each boundary condition for the 

simulation. 

Farfield 

In the Boundary Conditions window, select farfield. Use the drop-down menu to change 

the Type to pressure-far-field. You will be asked to confirm the change, and do so by pressing OK. Next, a 
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dialogue box will open with some parameters we need to specify. Change the Gauge Pressure 

(Pascal) to 101325, and Mach Number to 3. 

Also, select the Thermal tab, and ensure that the temperature correctly defaulted to 300 K. When you are 

finished, press OK. 

Wedge 

 

In the Boundary Conditions window, select wedge. Use the drop-down menu to change the Type to wall. 

Symmetry 

 

In the Boundary Conditions window, select symmetry. Use the drop-down menu to change 

the Type to symmetry. 

 

Operating Conditions 

 

In the Boundary Conditions window, select the Operating Conditions button. Change the Gauge 

Pressure to 0. Then press OK 

 

It is important to check the operating conditions. When setting the density in materials to ideal gas, FLUENT 

calculates the density using the absolute pressure. However, the pressure we specify is the gauge pressure, 

not the absolute pressure. FLUENT will use the absolute pressure to compute the density therefore if we do 

not set the operating pressure to 0 our density will be incorrect for the flow field.   

 

Numerical Solution 

 

Solution Methods 

 

In the Outline window, select Solution Methods to open the Solution Methods window. Under Spatial 

Discretization, ensure that the option under Flow Second Order Upwind is selected. 

 

Solution Controls 

 

In the Outline window, select Solution Controls to open the Solution Controls window. Ensure that 

the Courant Number is set to 5.0. 

The Courant number can be considered a non dimensionalized time step. The density-based solver obtains 

the steady-state solution by starting with the initial guess and marching in pseudo-time until convergence is 

obtained. The Courant number controls the time step the solver uses. The larger it is, the faster the solution 

will converge but it will not be very stable and can diverge. The smaller it is, the slower it is to reach 

convergence but the solution is much more stable. 

 

Monitors 

In the Outline window, click Monitors to open the Monitors window. In the Monitors window, 

select Residuals - Print,Plot and press Edit.... This will open the Residual Monitors window. We want to 

change the convergence criteria for our solution. Under Equation and to the right of Continuity, change 

the Absolute Criteria to 1e-6. Repeat for x-velocity, y-velocity, and energy, then press OK. 

 

Solution Initialization 

 

In the Outline window, select Solution Initialization. We need to make an "Initial Guess" to the solution so 

FLUENT can iterate to find the final solution. In the Solution Initialization window, select Standard 
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Initialization, then under Compute from, select farfield from the drop down box. Check to see that the 

values that generate match our inputted values, then press Initialize 

Run Calculation 

 

In the Outline window, select Run Calculation. Change the Number of Iterations to 4000. Double 

click Calculate to run the calculation. It should a few minutes to solve. After the calculation is complete, 

save the project. Do not close FLUENT.  

 

Result: 

Viva Questions: 

1. List the types of flow field under Mach number. 

2. Define the Mach number and Reynolds number. 

3. What do you understand by expansion waves? 
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EXPERIMENT – 10 

SHOCK WAVE AROUND A CONE 

 
Aim: To observe the shock wave phenomena and change of properties around a cone at supersonic Mach 

number. 

 

Software Used :ICEM CFD  and FLUENT  

 

We will create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem. 

 

 Create or import Geometry  

 Block the geometry 

 Associate entities to the geometry. 

 Apply mesh parameters. 

 Generate the initial mesh. 

 Export mesh  

Start ICEM CFD  

 

Create Geometry in ICEM CFD 
 

1) Close any previous files, have blank screen in ICEM. 

2) Create new project file for the pipe in ICEM: 

a) File, New Project. 

b) Select folders in turn: Desktop, CFX Training Files – Copy, Flat plate. 

c) Save project with name ―Flat plate‖ in folder ―Flat plate‖. 

3) We are going to create some points now: 

a) Select Geometry tab at top of screen. 

b) Select ―Create Point‖ option. 

c) In the bottom left are various options for creating the point. Select the second ―XYZ‖ option. 

d) Input the numbers X=0, Y=0, Z=0. 

e) Press ―Apply‖ to create a point on screen 

f) Note - If the point does not appear, then check that points are displayed in the tree, and use 

   the ―Fit Window‖ option in the top left to zoom the screen correctly. 

 

Create points  

Explicit location > specify x and y location and click ok  

Similarly create required points 

Note that for a 2D problem, the z-coordinate can always be left to the default value of 0. 

 

Create curves  

 

Under ―Geometry‖ tab, select ―Create and modify curve‖. 

b) Under ―Create and modify curve‖ option panel on bottom left, select 3rd option ― 

Select two points on the screen and select ok Create remaining curves  
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Create surface  

 

Simple surface – from 2-4 curves  

To check surface click on solid frame  

 

Label the curves 

 

Give names to the INLET, OUTLET and WALL surfaces: 

a) Under ―Geometry‖ tree, highlight only ―Surfaces‖. 

b) Right click ―Parts‖, Create Part. 

c) Part = ―INLET‖. 

d) Entities: click arrow icon, left click surface (near surface, around origin) to highlight it, middle 

    click to save selection, right click to de-select mode. 

e) Note that the INLET part has been created, and can be turned on and off independently 

    using the tree view. 

f) Part = ―OUTLET‖, repeat step to identify an outlet at the far end. 

g) Part = ―WALL‖, repeat step to identify the wall. 

h) Notes: ―GEOM‖ now contains only 0D and 1D elements; points and lines. 

 

Block the Geometry 

 

The geometry and part information has already been defined for this tutorial. You will create the initial block 

in this step. 

1. Create the initial block. 

     Blocking > Create Block > Initialize Blocks 

a. Enter FLUID in the Part field. 

b. Select 2D Planar in the Type drop-down list. 

c. Click Apply. 

 

Associate Entities to the Geometry 

 

You will associate the edges of the blocking to the curves of the CAD geometry in this step. First select the 

edges and then the curves to which you want to associate them. 

1. Associate the inlet, the left-most end of the large flat plate. 

a. Ensure that Project Vertices is disabled. 

b. Click (Select edge(s)) and select edge 13–41. Click the middle-mouse button to accept the selection. 

c. Click (Select compcurve(s)) and select CURVES/1 . Click the middle-mouse button to accept the selection. 

d. Click Apply. 

The associated edge will be colored green. 

 

Generate the Initial Mesh 

 

Blocking > Pre-Mesh Params > Update Sizes 

1. Retain the selection of Update All in the Method list. 

2. Select Run Check/Fix Blocks to check for mesh problems automatically and repair them if possible. 

3. Click Apply.  

4. Enable Pre-Mesh. 

Blocking Pre-Mesh 
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The Mesh dialog will appear, asking if you want to recompute the mesh. 

5. Click Yes in the Mesh dialog to compute the initial mesh. 

6. Disable Vertices and Edges. 

 

Verify and Save the Mesh and Blocking 

 

1. Convert the mesh to unstructured format. 

    Blocking Pre-Mesh Convert to Unstruct Mesh 

 

2. Save the blocking file (2D-Flat plate -geometry-final.blk). 

 

File > Blocking > Save Blocking As... 

 

This block file can be loaded in a future session (File > Blocking > Open Blocking...) for additional 

modification or to mesh a similar geometry. Save each blocking to a separate file instead of overwriting 

a previous one. In more complex models, you may have to back track and load a previous blocking. 

 

3. Save the project file (2D-flat plate-geometry-final.prj). 

    File > Save Project As... 

   This will save all the files—tetin, blocking, and unstructured mesh. 

 

4. Exit the current session. 

    File > Exit 

   Save your ICEM CFD file in your working directory. 

 

Setting Up the CFD Simulation in ANSYS FLUENT 

Now that you have created a computational mesh for the elbow geometry, you can proceed to setting up a CFD 

analysis using ANSYS FLUENT. 

1.   Start ANSYS FLUENT. 

In the ANSYS Workbench Project Schematic, double-click the Setup cell in the elbow fluid flow analysis 

system. You can also right-click on the Setup cell to display the context menu where you can select 

the Edit option. 

When ANSYS FLUENT is first started, FLUENT Launcher is displayed, allowing you to view and/or set 

certain ANSYS FLUENT start-up options. 

   ANSYS FLUENT Launcher allows you to decide which version of ANSYS FLUENT you will use, based on 

your geometry and on your processing capabilities. 

(a) Ensure that the proper options are enabled. 

Note that the Dimension setting is already filled in and cannot be changed, since ANSYS 

FLUENT automatically sets it based on the mesh or geometry for the current system. 

i.   Make sure that Serial from the Processing Options list is enabled. 

ii.   Make sure that the Display Mesh After Reading, Embed Graphics Windows, and Workbench 

Color Scheme options are enabled. 
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(b)   Click OK to launch ANSYS FLUENT. 

2.   Set some general settings for the CFD analysis. 

  Select General in the navigation pane to perform the mesh-related activities and to choose a solver. 

 General 

(a)   Change the units for length. 

Since we want to specify and view values based on a unit of length in inches from within ANSYS FLUENT, 

change the units of length within ANSYS FLUENT from meters (the default) to inches. 

 General  Units... 

This displays the Set Units dialog box. 

i.   Select length in the Quantities list. 

ii.   Select in in the Units list. 

iii.   Close the dialog box. 

   Now, all subsequent inputs that require a value based on a unit of length can be specified in inches rather than 

meters. 

(b)   Check the mesh. 

 General  Check 

   ANSYS FLUENT will report the results of the mesh check in the console. 

3.   Set up your models for the CFD simulation. 

 Models 

(a)   Enable heat transfer by activating the energy equation. 

 Models   Energy  Edit... 

   You can also double-click a list item in order to open the corresponding dialog box. 

i.   Enable the Energy Equation option. 

ii.   Click OK to close the Energy dialog box. 

(b)   Enable the -  turbulence model. 

 Models   Viscous  Edit... 

i.   Select k-epsilon from the Model list. 

   The Viscous Model dialog box will expand. 
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ii.   Select Realizable from the k-epsilon Model list. 

iii.   Click OK to accept the model and close the Viscous Model dialog box. 

4.   Set up your materials for the CFD simulation. 

 Materials 

(e) Create a new material called air  using the Create/Edit Materials dialog box. 

(f)  Materials   Fluid  Create/Edit... 

i.   Enter air for Name. 

ii.    specify the properties  

iii.   Click Change/Create. 

  5.   Set up the cell zone conditions for the CFD simulation. 

 Cell Zone Conditions 

(a)   Set the cell zone conditions for the fluid zone. 

i.   Select fluid in the Zones list in the Cell Zone Conditions task page, then click the Edit... button to open 

the Fluid dialog box. 

   You can also double-click a list item in order to open the corresponding dialog box. 

ii.   In the Fluid dialog box, select water from the Material Name drop-down list. 

iii.   Click OK to close the Fluid dialog box. 

6.   Set up the boundary conditions for the CFD analysis. 

 Boundary Conditions 

(a)   Set the boundary conditions at the cold inlet (velocity-inlet-large). 

 Boundary Conditions   velocity-inlet-large  Edit... 

i.   Select Components from the Velocity Specification Method drop-down list. 

  The Velocity Inlet dialog box will expand. 

ii.   Enter 0.4 m/s for X-Velocity. 

iii.   Retain the default value of 0 m/s for both Y-Velocity and Z-Velocity. 

7.   Set up solution parameters for the CFD simulation. 

  In the steps that follow, you will set up and run the calculation using the task pages listed under 

the Solution heading in the navigation pane. 

(a)   Change the convergence criteria for the continuity equation residual. 
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 Monitors   Residuals  Edit... 

i.   Make sure that Plot is enabled in the Options group box. 

ii.   Enter 1e-05 for the Absolute Criteria of continuity, as shown in the Residual Monitor dialog box. 

iii.   Click OK to close the Residual Monitors dialog box. 

 (b)   Initialize the flow field, using the boundary conditions settings at the cold inlet (velocity-inlet-large) as a 

starting point. 

 Solution Initialization 

i.   Select velocity-inlet-large from the Compute From drop-down list. 

ii.   Enter 1.2 m/s for Y Velocity in the Initial Values group box. 

iii.   Click Initialize. 

(c)   Check to see if the case conforms to best practices. 

 Run Calculation  Check Case 

8.   Calculate a solution. 

(a)   Start the calculation by requesting 250 iterations. 

 Run Calculation 

i.   Enter 250 for Number of Iterations. 

ii.   Click Calculate. 

  As the calculation progresses, the residuals will be plotted in the graphics window  

9.   View the files generated by ANSYS Workbench. 

Result: 

Viva Questions: 

1. Differentiate the cone and wedge? 

2. What is the Mach reflection? 

3. How the pressure and velocity changes in cone?  
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EXPERIMENT – 11 

FLOW THROUGH DIFFUSER 

 
Aim: To visualize the flow through diffuser at different velocities. 

 

Software used: ICEM CFD AND FLUENT  

 

We will create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem. 

 

 Create or import Geometry  

 Block the geometry 

 Associate entities to the geometry. 

 Apply mesh parameters. 

 Generate the initial mesh. 

 Export mesh  

 

Start ICEM CFD  

 

Create Geometry in ICEM CFD 
 

1) Close any previous files, have blank screen in ICEM. 

2) Create new project file for the pipe in ICEM: 

a) File, New Project. 

b) Select folders in turn: Desktop, CFX Training Files – Copy, Flat plate. 

c) Save project with name ―Flat plate‖ in folder ―Flat plate‖. 

3) We are going to create some points now: 

a) Select Geometry tab at top of screen. 

b) Select ―Create Point‖ option. 

c) In the bottom left are various options for creating the point. Select the second ―XYZ‖ option. 

d) Input the numbers X=0, Y=0, Z=0. 

e) Press ―Apply‖ to create a point on screen 

f) Note - If the point does not appear, then check that points are displayed in the tree, and usethe ―Fit Window‖      

    option in the top left to zoom the screen correctly. 

 

Create points  

Explicit location > specify x and y location and click ok  

Similarly create required  points  

Note that for a 2D problem, the z-coordinate can always be left to the default value of 0. 

 

Create curves  

 

Under ―Geometry‖ tab, select ―Create and modify curve‖. 

b) Under ―Create and modify curve‖ option panel on bottom left, select 3rd option ― 

Select two points on the screen and select ok Create remaining curves  
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Create surface  

 

Simple surface – from 2-4 curves  

To check surface click on solid frame  

 

Label the curves 

 

Give names to the INLET, OUTLET and WALL surfaces: 

a) Under ―Geometry‖ tree, highlight only ―Surfaces‖. 

b) Right click ―Parts‖, Create Part. 

c) Part = ―INLET‖. 

d) Entities: click arrow icon, left click surface (near surface, around origin) to highlight it, middle click to save      

     selection, right click to de-select mode. 

e) Note that the INLET part has been created, and can be turned on and off independently using the tree view. 

f) Part = ―OUTLET‖, repeat step to identify an outlet at the far end. 

g) Part = ―WALL‖, repeat step to identify the wall. 

h) Notes: ―GEOM‖ now contains only 0D and 1D elements; points and lines. 

 

Block the Geometry 

 

The geometry and part information has already been defined for this tutorial. You will create the initial block 

in this step. 

1. Create the initial block. 

Blocking > Create Block > Initialize Blocks 

a. Enter FLUID in the Part field. 

b. Select 2D Planar in the Type drop-down list. 

c. Click Apply. 

 

Associate Entities to the Geometry 

 

You will associate the edges of the blocking to the curves of the CAD geometry in this step. First select the 

edges and then the curves to which you want to associate them. 

1. Associate the inlet, the left-most end of the large flat plate. 

a. Ensure that Project Vertices is disabled. 

b. Click (Select edge(s)) and select edge 13–41. Click the middle-mouse button to accept the selection. 

 

c. Click (Select compcurve(s)) and select CURVES/1 . Click the middle-mouse button to accept the selection. 

d. Click Apply. 

The associated edge will be colored green. 

 

Generate the Initial Mesh 

 

Blocking > Pre-Mesh Params > Update Sizes 

1. Retain the selection of Update All in the Method list. 

Note 

This will automatically determine the number of nodes on the edges from the mesh sizes set on the curves. 

2. Select Run Check/Fix Blocks to check for mesh problems automatically and repair them if possible. 

3. Click Apply. 

4. Enable Pre-Mesh. 
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Blocking Pre-Mesh 

 

The Mesh dialog will appear, asking if you want to recompute the mesh. 

5. Click Yes in the Mesh dialog to compute the initial mesh. 

6. Disable Vertices and Edges. 

 

Verify and Save the Mesh and Blocking 

 

1. Convert the mesh to unstructured format. 

Blocking Pre-Mesh Convert to Unstruct Mesh 

2. Save the blocking file (2D-Flat plate -geometry-final.blk). 

 

File > Blocking > Save Blocking As... 

 

This block file can be loaded in a future session (File > Blocking > Open Blocking...) for additional modification 

or to mesh a similar geometry. Save each blocking to a separate file instead of overwriting previous one. In more 

complex models, you may have to back track and load a previous blocking. 

3. Save the project file (2D-flat plate-geometry-final.prj). 

File > Save Project As... 

This will save all the files—tetin, blocking, and unstructured mesh. 

4. Exit the current session. 

File > Exit 

Save your ICEM CFD file in your working directory. 

 

Setting Up the CFD Simulation in ANSYS FLUENT 

Now that you have created a computational mesh for the elbow geometry, you can proceed to setting up a CFD 

analysis using ANSYS FLUENT. 

1.   Start ANSYS FLUENT. 

In the ANSYS Workbench Project Schematic, double-click the Setup cell in the elbow fluid flow analysis 

system. You can also right-click on the Setup cell to display the context menu where you can select 

the Edit option. 

When ANSYS FLUENT is first started, FLUENT Launcher is displayed, allowing you to view and/or set 

certain ANSYS FLUENT start-up options. 

  ANSYS FLUENT Launcher allows you to decide which version of ANSYS FLUENT you will use, based on 

your geometry and on your processing capabilities. 

Ensure that the proper options are enabled. 

Note that the Dimension setting is already filled in and cannot be changed, since ANSYS 

FLUENT automatically sets it based on the mesh or geometry for the current system 

Make sure that serial from the processing options list is enabled it. Make sure that the display Mesh after reading, 

Embed Graphics windows, and work bench color Scheme options are enabled . 

Click OK to launch ANSYS FLUENT. 

2.   Set some general settings for the CFD analysis. 
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  Select General in the navigation pane to perform the mesh-related activities and to choose a solver. 

 General 

(a)   Change the units for length. 

Since we want to specify and view values based on a unit of length in inches from within ANSYS FLUENT, 

change the units of length within ANSYS FLUENT from meters (the default) to inches. 

 General  Units... 

This displays the Set Units dialog box. 

i.   Select length in the Quantities list. 

ii.   Select in in the Units list. 

iii.   Close the dialog box. 

   (b)   Check the mesh. 

 General  Check 

   ANSYS FLUENT will report the results of the mesh check in the console. 

3.   Set up your models for the CFD simulation. 

 Models 

(a)   Enable heat transfer by activating the energy equation. 

 Models   Energy  Edit... 

   You can also double-click a list item in order to open the corresponding dialog box. 

i.   Enable the Energy Equation option. 

ii.   Click OK to close the Energy dialog box. 

(b)   Enable the -  turbulence model. 

 Models   Viscous  Edit... 

i.   Select k-epsilon from the Model list. 

   The Viscous Model dialog box will expand. 

ii.   Select Realizable from the k-epsilon Model list. 

iii.   Click OK to accept the model and close the Viscous Model dialog box. 

4.   Set up your materials for the CFD simulation. 
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 Materials 

(g) Create a new material called air  using the Create/Edit Materials dialog box. 

(h)  Materials   Fluid  Create/Edit... 

i.   Enter air for Name. 

ii.    specify the properties  

iii.   Click Change/Create. 

  5.   Set up the cell zone conditions for the CFD simulation. 

 Cell Zone Conditions 

(a)   Set the cell zone conditions for the fluid zone. 

i.   Select fluid in the Zones list in the Cell Zone Conditions task page, then click the Edit... button to open 

the Fluid dialog box. 

   You can also double-click a list item in order to open the corresponding dialog box. 

ii.   In the Fluid dialog box, select water from the Material Name drop-down list. 

iii.   Click OK to close the Fluid dialog box. 

6.   Set up the boundary conditions for the CFD analysis. 

 Boundary Conditions 

(a)   Set the boundary conditions at the cold inlet (velocity-inlet-large). 

 Boundary Conditions   velocity-inlet-large  Edit... 

i.   Select Components from the Velocity Specification Method drop-down list. 

  The Velocity Inlet dialog box will expand. 

ii.   Enter 0.4 m/s for X-Velocity. 

iii.   Retain the default value of 0 m/s for both Y-Velocity and Z-Velocity. 

7.   Set up solution parameters for the CFD simulation. 

  In the steps that follow, you will set up and run the calculation using the task pages listed under 

the Solution heading in the navigation pane. 

(a)   Change the convergence criteria for the continuity equation residual. 

 Monitors   Residuals  Edit... 

i.   Make sure that Plot is enabled in the Options group box. 

ii.   Enter 1e-05 for the Absolute Criteria of continuity, as shown in the Residual Monitor dialog box. 
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iii.   Click OK to close the Residual Monitors dialog box. 

Note:   By default, all variables will be monitored and checked by ANSYS FLUENT as a means to determine 

the convergence of the solution. 

(b)   Initialize the flow field, using the boundary conditions settings at the cold inlet (velocity-inlet-large) as a 

starting point. 

 Solution Initialization 

i.   Select velocity-inlet-large from the Compute From drop-down list. 

ii.   Enter 1.2 m/s  for Y Velocity in the Initial Values group box. 

Note:   While an initial X Velocity is an appropriate guess for the horizontal section, the addition of a Y 

Velocity component will give rise to a better initial guess throughout the entire elbow. 

iii.   Click Initialize. 

(c)   Check to see if the case conforms to best practices. 

 Run Calculation  Check Case 

8.   Calculate a solution. 

(a)   Start the calculation by requesting 250 iterations. 

 Run Calculation 

i.   Enter 250 for Number of Iterations. 

ii.   Click Calculate. 

  As the calculation progresses, the residuals will be plotted in the graphics window  

9.   View the files generated by ANSYS Workbench. 

Results: 

Viva Questions: 

1. Differentiate the nozzle and diffuser? 

2. List the types of diffuser. 

3. How the pressure and velocity changes in diffuser?  
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EXPERIMENT – 12 

FLOW THROUGH SUPERSONIC INTAKE 

 
Aim: To visualize the low through Supersonic intake at different velocities and observe the velocity changes for 

laminar and turbulent flows. 

 

Software used: ICEM CFD AND FLUENT  

 

We will create the geometry and mesh in ICEM CFD, read the mesh into FLUENT, and solve the flow problem. 

 

 Create or import Geometry  

 Block the geometry 

 Associate entities to the geometry. 

 Apply mesh parameters. 

 Generate the initial mesh. 

 Export mesh  

 

Start ICEM CFD  

 

Create Geometry in ICEM CFD 
 

1) Close any previous files, have blank screen in ICEM. 

2) Create new project file for the pipe in ICEM: 

a) File, New Project. 

b) Select folders in turn: Desktop, CFX Training Files – Copy, Flat plate. 

c) Save project with name ―Flat plate‖ in folder ―Flat plate‖. 

3) We are going to create some points now: 

a) Select Geometry tab at top of screen. 

b) Select ―Create Point‖ option. 

c) In the bottom left are various options for creating the point. Select the second ―XYZ‖ option. 

d) Input the numbers X=0, Y=0, Z=0. 

e) Press ―Apply‖ to create a point on screen 

f) Note - If the point does not appear, then check that points are displayed in the tree, and use 

    the ―Fit Window‖ option in the top left to zoom the screen correctly. 

 

Create points  

Explicit location > specify x and y location and click ok  

Similarly create required  points  

Note that for a 2D problem, the z-coordinate can always be left to the default value of 0. 

 

Create curves  

 

Under ―Geometry‖ tab, select ―Create and modify curve‖. 

b) Under ―Create and modify curve‖ option panel on bottom left, select 3rd option ― Select two points on the 

screen and select ok Create remaining curves  



66 
 
 

 

Create surface  

 

Simple surface – from 2-4 curves  

To check surface click on solid frame  

 

Label the curves 

 

Give names to the INLET, OUTLET and WALL surfaces: 

a) Under ―Geometry‖ tree, highlight only ―Surfaces‖. 

b) Right click ―Parts‖, Create Part. 

c) Part = ―INLET‖. 

d) Entities: click arrow icon, left click surface (near surface, around origin) to highlight it, middle click to save       

     selection, right click to de-select mode. 

e) Note that the INLET part has been created, and can be turned on and off independently using the tree view. 

f) Part = ―OUTLET‖, repeat step to identify an outlet at the far end. 

g) Part = ―WALL‖, repeat step to identify the wall. 

h) Notes: ―GEOM‖ now contains only 0D and 1D elements; points and lines. 

 

Block the Geometry 

 

The geometry and part information has already been defined for this tutorial. You will create the initial block 

in this step. 

1. Create the initial block. 

Blocking > Create Block > Initialize Blocks 

a. Enter FLUID in the Part field. 

b. Select 2D Planar in the Type drop-down list. 

c. Click Apply. 

 

Associate Entities to the Geometry 

 

You will associate the edges of the blocking to the curves of the CAD geometry in this step. First select the 

edges and then the curves to which you want to associate them. 

1. Associate the inlet, the left-most end of the large flat plate. 

a. Ensure that Project Vertices is disabled. 

b. Click (Select edge(s)) and select edge 13–41. Click the middle-mouse button to accept the selection. 

c. Click (Select compcurve(s)) and select CURVES/1 . Click the middle-mouse button to accept the selection. 

d. Click Apply. 

The associated edge will be colored green. 

 

Generate the Initial Mesh 

 

Blocking > Pre-Mesh Params > Update Sizes 

1. Retain the selection of Update All in the Method list. 

2. Select Run Check/Fix Blocks to check for mesh problems automatically and repair them if possible. 

3. Click Apply. 

4. Enable Pre-Mesh. 
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Blocking Pre-Mesh 

 

The Mesh dialog will appear, asking if you want to recompute the mesh. 

5. Click Yes in the Mesh dialog to compute the initial mesh. 

6. Disable Vertices and Edges. 

 

Verify and Save the Mesh and Blocking 

 

1. Convert the mesh to unstructured format. 

    Blocking Pre-Mesh Convert to Unstruct Mesh 

 

2. Save the blocking file (2D-Flat plate -geometry-final.blk). 

 

    File > Blocking > Save Blocking As... 

 

3. Save the project file (2D-flat plate-geometry-final.prj). 

    File > Save Project As... 

    This will save all the files—tetin, blocking, and unstructured mesh. 

 

4. Exit the current session. 

    File > Exit 

    Save your ICEM CFD file in your working directory. 

 

Setting Up the CFD Simulation in ANSYS FLUENT 

Now that you have created a computational mesh for the elbow geometry, you can proceed to setting up a CFD 

analysis using ANSYS FLUENT. 

1.   Start ANSYS FLUENT. 

In the ANSYS Workbench Project Schematic, double-click the Setup cell in the elbow fluid flow analysis 

system. You can also right-click on the Setup cell to display the context menu where you can select 

the Edit option. 

When ANSYS FLUENT is first started, FLUENT Launcher is displayed, allowing you to view and/or set 

certain ANSYS FLUENT start-up options. 

   FLUENT automatically sets it based on the mesh or geometry for the current system. 

i.   Make sure that Serial from the Processing Options list is enabled. 

ii.   Make sure that the Display Mesh After Reading, Embed Graphics Windows, and Workbench 

Color Scheme options are enabled. 

(b)   Click OK to launch ANSYS FLUENT. 

2.   Set some general settings for the CFD analysis. 

  Select General in the navigation pane to perform the mesh-related activities and to choose a solver. 
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General 

(a)   Change the units for length. 

Since we want to specify and view values based on a unit of length in inches from within ANSYS FLUENT, 

change the units of length within ANSYS FLUENT from meters (the default) to inches. 

 General  Units... 

This displays the Set Units dialog box. 

i.   Select length in the Quantities list. 

ii.   Select in in the Units list. 

iii.   Close the dialog box. 

   Now, all subsequent inputs that require a value based on a unit of length can be specified in inches rather than 

meters. 

(b)   Check the mesh. 

 General  Check 

   ANSYS FLUENT will report the results of the mesh check in the console. 

3.   Set up your models for the CFD simulation. 

 Models 

(a)   Enable heat transfer by activating the energy equation. 

 Models   Energy  Edit... 

   You can also double-click a list item in order to open the corresponding dialog box. 

i.   Enable the Energy Equation option. 

ii.   Click OK to close the Energy dialog box. 

(b)   Enable the -  turbulence model. 

 Models   Viscous  Edit... 

i.   Select k-epsilon from the Model list. 

   The Viscous Model dialog box will expand. 

ii.   Select Realizable from the k-epsilon Model list. 

iii.   Click OK to accept the model and close the Viscous Model dialog box. 

4.   Set up your materials for the CFD simulation. 
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 Materials 

(i) Create a new material called air using the Create/Edit Materials dialog box. 

(j)  Materials   Fluid  Create/Edit... 

i.   Enter air for Name. 

ii.    Specify the properties  

iii.   Click Change/Create. 

  5.   Set up the cell zone conditions for the CFD simulation. 

 Cell Zone Conditions 

(a)   Set the cell zone conditions for the fluid zone. 

i.   Select fluid in the Zones list in the Cell Zone Conditions task page, then click the Edit... button to open 

the Fluid dialog box. 

   You can also double-click a list item in order to open the corresponding dialog box. 

ii.   In the Fluid dialog box, select water from the Material Name drop-down list. 

iii.   Click OK to close the Fluid dialog box. 

6.   Set up the boundary conditions for the CFD analysis. 

 Boundary Conditions 

(a)   Set the boundary conditions at the cold inlet (velocity-inlet-large). 

 Boundary Conditions   velocity-inlet-large  Edit... 

i.   Select Components from the Velocity Specification Method drop-down list. 

  The Velocity Inlet dialog box will expand. 

ii.   Enter 0.4 m/s for X-Velocity. 

iii.   Retain the default value of 0 m/s for both Y-Velocity and Z-Velocity. 

7.   Set up solution parameters for the CFD simulation. 

(a)   Change the convergence criteria for the continuity equation residual. 

 Monitors   Residuals  Edit... 

i.   Make sure that Plot is enabled in the Options group box. 

ii.   Enter 1e-05 for the Absolute Criteria of continuity, as shown in the Residual Monitor dialog box. 

iii.   Click OK to close the Residual Monitors dialog box. 
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(b) Initialize the flow field, using the boundary conditions settings at the cold inlet (velocity-inlet-large) as a     

       starting point. 

 Solution Initialization 

i.   Select velocity-inlet-large from the Compute From drop-down list. 

ii.   Enter 1.2 m/s for Y Velocity in the Initial Values group box. 

iii.   Click Initialize. 

(c)   Check to see if the case conforms to best practices. 

 Run Calculation  Check Case 

8.   Calculate a solution. 

(a)   Start the calculation by requesting 250 iterations. 

 Run Calculation 

i.   Enter 250 for Number of Iterations. 

ii.   Click Calculate. 

9.   View the files generated by ANSYS Workbench. 

 

Results: 

 

Viva Questions: 

 
1. What is supersonic intake? 

2. List the types of intake. 

3. How the pressure and velocity changes in supersonic intake? 

 


