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Vision 

To produce professionally competent Electronics and Communication Engineers capable of effectively and 

efficiently addressing the technical challenges with social responsibility. 

 

 
Mission 

The mission of the Department is to provide an academic environment that will ensure high quality education, 

training and research by keeping the students abreast of latest developments in the field of Electronics and 

Communication Engineering aimed at promoting employability, leadership qualities with humanity, ethics, 

research aptitude and team spirit. 

 

 

Quality Policy 
Our policy is to nurture and build diligent and dedicated community of engineers providing a professional and 

unprejudiced environment, thus justifying the purpose of teaching and satisfying the stake holders. 
 

A team of well qualified and experienced professionals ensure quality education with its practical application in 

all areas of the Institute. 

 

 

Philosophy 
The essence of learning lies in pursuing the truth that liberates one from the darkness of ignorance and Institute 

of Aeronautical Engineering firmly believes that education is for liberation. 
 

Contained therein is the notion that engineering education includes all fields of science that plays a pivotal role 

in the development of world-wide community contributing to the progress of civilization. This institute, 

adhering to the above understanding, is committed to the development of science and technology in 

congruence with the natural environs. It lays great emphasis on intensive research and education that blends 

professional skills and high moral standards with a sense of individuality and humanity. We thus promote ties 

with local communities and encourage transnational interactions in order to be socially accountable. This 

accelerates the process of transfiguring the students into complete human beings making the learning process 

relevant to life, instilling in them a sense of courtesy and responsibility. 
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Program Outcomes 

PO1   Engineering knowledge: An ability to apply knowledge of basic sciences, mathematical skills, engineering 

and technology to solve complex electronics and communication engineering problems (Fundamental 

Engineering Analysis Skills). 

PO2 Problem analysis: An ability to identify, formulate and analyze engineering problems using knowledge of 
Basic Mathematics and Engineering Sciences. (Engineering Problem Solving Skills). 

PO3 Design/development of solutions: An ability to provide solution and to design Electronics and 
Communication Systems as per social needs(Social Awareness) 

PO4 Conduct investigations of complex problems: An ability to investigate the problems in Electronics and 
Communication field and develop suitable solutions (Creative Skills). 

PO5 Modern tool usage An ability to use latest hardware and software tools to solve complex engineering 
problems (Software and Hardware Interface). 

PO6 The engineer and society: An ability to apply knowledge of contemporary issues like health, Safety and 
legal which influences engineering design ( Social Awareness). 

PO7 Environment and sustainability An ability to have awareness on society and environment for sustainable 
solutions to Electronics & Communication Engineering problems(Social awareness). 

PO8 Ethics: An ability to demonstrate understanding of professional and ethical responsibilities(Engineering 
impact assessment skills). 

PO9 Individual and team work: An ability to work efficiently as an individual and in multidisciplinary 
teams(Team Work). 

PO10 Communication: An ability to communicate effectively and efficiently both in verbal and written 
form(Communication Skills). 

PO11 Project management and finance: An ability to develop confidence to pursue higher education and for 
life-long learning(Continuing education awareness). 

PO12 Life-long learning: An ability to design, implement and manage the electronic projects for real world 
applications with optimum financial resources(Practical engineering analysis skills). 

Program Specific Outcomes 

PSO1 Professional Skills: An ability to understand the basic concepts in Electronics & Communication 

Engineering and to apply them to various areas, like Electronics, Communications, Signal processing, 

VLSI, Embedded systems etc., in the design and implementation of complex systems. 

PSO2 Problem-solving skills: An ability to solve complex Electronics and communication Engineering 

problems, using latest hardware and software tools, along with analytical skills to arrive cost effective 
and appropriate solutions. 

PSO3 Successful career and Entrepreneurship: An understanding of social-awareness & environmental- 

wisdom along with ethical responsibility to have a successful career and to sustain passion and zeal for 

real-world applications using optimal resources as an Entrepreneur. 
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ATTAINMENT OF PROGRAM OUTCOMES 

& PROGRAM SPECIFIC OUTCOMES 

 
S. No 

 
Experiment 

Program 

Outcomes 

Attained 

Program Specific 

Outcomes 

Attained 

1. Basic Arithmetic And Boolean Operations 
PO1, 
PO 12 PSO1, PSO2 

2. 
Sum Of ‘N’ Numbers Using ‘For’ Loop And Factorial Of 

A Give Number Using For Loop 

PO1, PO2, 

PO 12 PSO1, PSO2 

 

3. 
Sum Of ‘N’ Natural Numbers Using While 

Loop And Factorial Of A Give Number Using While Loop 
PO1, PO2, 

PO 12 

 

PSO1, PSO2 

4. 
Convert Degree Centi Grated To Fharan Heat Create A 

Sub Vi 

PO1, PO5, 
PO 12 PSO1, PSO2 

5. 
Array Maximum And Minimum And Sorting Even Numbers 
Using While Loop In An Array 

PO1, PO5, 
PO 12 PSO1, PSO2 

6. Analyzing And Logging Data By Using Wave Form Graphs 
PO1, PO5, 

PO 12 PSO1, PSO2 

7. Bundle And Unbundle Cluster 
PO1, PO2, 

PO11 PSO1, PSO2 

8. Flat And Stacked Sequence 
PO1, PO2, 

PO11 PSO1, PSO2 

9. 
Application Using Formula Node & Discrete Cosine 
Transform 

PO1, PO5, 
PO 12 PSO1, PSO2 

10.   Median filter 
PO1, PO2, 

PO11 PSO1, PSO2 

11. Convolution Of Two Signals 
PO1, PO2, 

PO11 PSO1, PSO2 

12. Windowing Technique 
PO1, PO2, 

PO11 PSO1, PSO2 

13. Data Acquisition Through Virtual 
PO1, PO2, 

PO11 PSO1, PSO2 

14. Instrumentation of An Amplifier To Acquire An Ecg Signal 
PO1, PO2, 

PO11 PSO1, PSO2 
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Course Overview: 

 

This course provides the basic knowledge of LABVIEW and application of knowledge to understand real time 

application USING LABVIEW. To prepare students to perform the analysis, design and implement distribute 

stand alone application using Lab VIEW. 

 

 

Course Out Comes: 
 

Upon the completion of Instrumentation laboratory practical course, the student will be able to: 

 
1. Familiar with Virtual Instrumentation. 

2. Understand the logical and arithmetic operation using lab view. 

3. Understand the concepts Arrays, loops, stack structures bundle functions. 

4. Design the automation application like home automation, robotic based applications. 

5. Analyze circuit performance with signal source from Lab view 

 

 

 
. 
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INSTRUCTIONS TO THE STUDENTS 
 

1. Students are required to attend all labs. 

 

2. Students should work individually in the hardware and software laboratories. 

 

3. Students have to bring the lab manual cum observation book, record etc. along with them whenever they 
come for lab work. 

 

4. Should take only the lab manual, calculator (if needed) and a pen or pencil to the work area. 

 

5. Should learn the pre lab questions. Read through the lab experiment to familiarize themselves with 

the components and assembly sequence. 

 

6. Should utilize 3 hours ’time properly to perform the experiment and to record the readings. Do 

the calculations, draw the graphs and take signature from the instructor. 

 

7. If the experiment is not completed in the stipulated time, the pending work has to be carried out in the 

leisure hours or extended hours. 

 

8. Should submit the completed record book according to the deadlines set up by the instructor. 

 

9. For practical subjects there shall be a continuous evaluation during the semester for 25 sessional marks 

and 50 end examination marks. 

 

10. Out of 25 internal marks, 15 marks shall be awarded for day-to-day work and 10 marks to be awarded 

by conducting an internal laboratory test. 
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INSTRUMENTATION LABORATORY 

 

 

 

S. No. List of Experiments Page No. 

1. Basic arithmetic and boolean operations  

 
2. 

Sum of ‘n’ numbers using ‘for’ loop and 

factorial of a give number using for loop 
 

 
3. 

 

Sum of ‘n’ natural numbers using while loop and factorial of a give 

number using while loop 
 

4. Convert ⁰ c to ⁰ f,create a sub vi 
 

 
5. 

Array maximum and minimum and sorting even numbers using while 

loop in an array 
 

 
6. Analyzing and logging data by using wave form graphs  

7. Bundle and unbundle cluster  

8. Flat and stacked sequence  

 
9. Application using formula node & discrete cosine transform  

10. 
 

Median filter 
 

11. Convolution of two signals  

12. 
 

Windowing technique 
 

13. Data acquisition through virtual  

 
14. 

 
Instrumentation of an amplifier to acquire an ecg signal 

 



EXPERIMENT NO: 1 

BASIC ARITHMETIC AND BOOLEN OPERATIONS 

 
 

AIM: To perform basic arithmetic and Boolean operations using Lab view. 

 

LEARNING OBJECTIVE: 

 To understand the Arithmetic operation using lab view 

 To understand the Boolean operation using lab view 

 
 

COMPONENTS REQUIRED: 

1. NI Lab VIEW ( 2015 LV- 64bitWin Eng) 
2. Personal computer 

 

THEORY: 
 

Basic Arithmetic and logical operation are performed using lab view and the outputs are 

observed in front panel and block diagram construction also done using lab view. 

 
ALGORITHM: 

 
Step 1: Start the Lab view and select the blank VI. 

Step 2: Create front and block diagram panel. 

Step 3: Numeric controls are given as inputs and numeric indicators are given as output they are 

selected by right clicking on the front panel. 

Step 4: Different arithmetic operators such as addition, subtraction, multiplication and division are 

generated in block diagram panel. 

Step 5: Using wiring operation inputs and outputs are connected to the respective operators in the block 

diagram panel. 

Step 6: Input values are given in the front panel and the program is executed. Hence the output is 

generated 



Block Diagram Panel: 
 

 

 

 

Front Panel: 
 

Input: Output: 

 



ALGORITHM FOR BOOLEAN OPERATION 

 

Step 1: Start the Lab view and select the blank 

VI. Step 2: Create front and block diagram panel. 

Step 3: To perform Boolean operation push buttons are taken as inputs and round LED as output. 

Step 4: Different Boolean operations such as AND, OR, XOR, NOT, NAND are selected from the block 

diagram panel. 

Step 5: Boolean inputs and outputs are wired in the block diagram panel. 

Step 6: Logic values 0 & 1 are given in the front panel and the program is executed. 

 

Block diagram: 
 

 

Front Panel: 
 

Input: Output: 
 
 



X1 X2 Y 

0 0 0 

0 1 0 

1 0 0 

1 1 1 

 

X1 X2 Y 

0 0 0 

0 1 1 

1 0 1 

1 1 1 

 

X1 X2 Y 

0 0 0 

0 1 1 

1 0 1 

1 1 0 

 

X1 X2 Y 

0 0 1 

0 1 1 

1 0 1 

1 1 0 

 

 
 

Truth Table: 

 
 

AND: OR: 
 

 
 

 

XOR: NAND: 
 

 



NOT: 

 
X Y 

0 

 
1 

1 

 
0 

 
RESULT: Thus the arithmetic operations were performed and the result is verified using lab view. 

 

 
 

VIVA QUESTIONS: 

1. What are arithmetic operations? 
 

2. What are Boolean operations? 



EXPERIMENT NO 2 

SUM OF ‘n’ NUMBERS USING ‘FOR’ LOOP AND FACTORIAL OF A 

GIVE NUMBER USING FOR LOOP 
 

Aim: To find the sum of ‘n’ numbers using FOR loop and factorial of a given number using FOR loop 

 
LEARNING OBJECTIVE: 

 

 To understand the for loop and factorial of a given numbers using lab view. 

 
COMPONENTS REQUIRED: 

 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

 

THEORY: 

Basic for loop function for a given numbers and finding factorial figure (a) shows the basic for loop and 

figure (b) shows factorial function. 

 
ALGORITHM: 
 

Step 1: Create blank VI. 

 

Step 2: Right click on the block diagram panel, select program, go to structures and select 

a FOR loop. 

Step 3: Right click on the border of the FOR loop and select add shift register; 

borders are converted into shift register. 

Step 4: Using wiring operations required connections are given in the block 

diagram. 

Step 5: Inputs are given in the front panel and the program is executed. 

 
 

BLOCK DIAGRAM: 
 



Front Panel: 
 

Input: Output: 

 

 

PROCEDURE FOR FACTORIAL OF A GIVE NUMBER USING FOR LOOP 

 
      Step 1: Create blank VI. 

Step 2: Right click on the block diagram panel , select program , go to structures and 

select a FOR loop. 

Step 3: Right click on the border of the FOR loop and select add shift register, 

borders are converted into shift register. 

Step 4: Using wiring operations required connections are given in the block 

diagram. 

Step 5: Inputs are given in the front panel and the program is executed. 

 
 

BLOCK DIAGRAM PANEL: 
 

 

 

 
 



Front Panel: 
 

Input: Output: 
 
 

 

 

 
RESULT: Thus the sum of ‘n’ natural numbers and factorial of a given number is using FOR loop                 

is performed in LAB view. 

 
VIVA QUESTIONS: 

 
1. What is the factorial formula? 

 
2. What is loop function? 



EXPERIMENT NO 3 
 

SUM OF ‘n’ NATURAL NUMBERS USING WHILE LOOP AND 

FACTORIAL OF A GIVE NUMBER USING WHILE LOOP 

 

                  AIM: To find the sum of n natural numbers using while loop. 

 

LEARNING OBJECTIVE: 

 

 To understand the while loop and factorial of a given numbers using lab view. 

 
COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

 

THEORY: 

 

The count terminal specifies the number of times to execute the code inside the For Loop. 

If you wire 0 or a negative number to the count terminal, the loop does not execute. This terminal 

is displayed by default. Executes its sub diagram n times, where n is the value wired to the count 

(N) Terminal. The iteration (i) terminal provides the current loop iteration count, which 

ranges from 0 to n-1. 

 

ALGORITHM: 

 

Step 1: Create blank VI. 

Step 2: Right click on the block diagram panel, select program, go to structures and 

select a WHILE loop. 

Step 3: The tunnels of the border are converted to shift register. 

Step 4: Generate an adder and greater than equal to inside the WHILE loop. 

Step 5: Using wiring operation required wiring is done in the block diagram panel. 

Step 6: Input values are given in front panel and the output is generated. 

 

 
BLOCK DIAGRAM PANEL: 

 

 



FRONT PANEL: 
 

Input: Output: 
 
 

 

 

ALGORITHM FOR FACTORIAL OF A GIVE NUMBER USING WHILE LOOP 

 
Step 1: Create blank VI. 

Step 2: Right click on the block diagram panel, select program, go to structures and 

select a WHILE loop. 

Step 3: Right click on the border of the WHILE loop and select add shift register; borders 

are converted into shift register. 

Step 4: Using wiring operations required connections are given in the block 

diagram. 

Step 5: Inputs are given in the front panel and the program is executed. 

 
 

BLOCK DIAGRAM PANEL: 
 

 
 

 

 

Front Panel: 

 

Input: Output: 

 



 

RESULT: Thus the sum of n natural numbers and factorial of a given number using WHILE loop is     

                   performed. 

 

VIVA QUESTIONS: 

1. What is while loop? 

2. What is the difference between while and for loop? 



EXPERIMENT NO 4 

 
CONVERT ⁰ C TO ⁰ F, CREATE A SUB VI 

AIM: To convert the centigrade to foreign heat using a sub VI 

 
LEARNING OBJECTIVE: 

 To understand the conversion of ᵒC to ᵒF using lab view 
 

THEORY:  
Complete the following steps to create a VI that takes a number representing 

degrees Celsius and converts it to a number representing degrees 
Fahrenheit. 

 

COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

 
ALGORITHM: 

. Step 1: Create blank VI. 

Step 2: Right click on the block diagram panel, select program, go to numeric’s and select a numeric 

function. 

Step 3:place all the numeric’s which required for the program . 

Step 5: Inputs are given in the front panel and the program is executed. 

 
 

CIRCUIT DIAGRAM: 

 

 
Create a SubVI 

 

Front Panel: 

The following front panel appears. 
 

 

 

 

1. Right-click the icon in the upper right corner of the front panel and select Edit Icon 

from the shortcut menu. The Icon Editor Dialog box appears. 



2. Double-click the Select tool on the left side of the Icon Editor Dialog box to select the default icon. 

3. Press the <Delete> key to remove thedefaulticon. 

4. Double-click the Rectangle tool to redraw the border. 

5. Create the following icon. 

a. Use the Select tool and the arrow keys to move the text and arrow you created. 

b. Select the B&W icon and select 256 Colors in the Copy from field to create a black and 

white icon, which Lab VIEW uses for printing unless you have a color printer. 

c. When the icon is complete, click the OK button to close the Icon Editor Dialog box. 

The icon appears in the upper right corner of the front panel and block diagram. 

 
6. Right-click the icon on the front panel and select Show Connector from the shortcut menu to 

define the connector pane terminal pattern. 

Lab VIEW selects a connector pane pattern based on the number of controls and indicators on the 

front panel. For example, this front panel has two terminals, deg C and deg F, so Lab VIEW selects 

a connector pane pattern with two terminals. 

7. Assign the terminals to the digital control and digital indicator. 

a. Select Help» Show Context Help to display the Context Help window. View 

each connection in the Context Help window as you make it. 

b. Click the left terminal in the connector pane. The tool automatically changes to the Wiring 

tool, and the terminal turns black. 

c. Click the deg C control. The left terminal turns orange, and a marquee highlights the 

control. 

d. Click an open area of the front panel. The marquee disappears, and the terminal changes to 

the data type color of the control to indicate that you connected the terminal. 

e. Click the right terminal in the connector pane and click the deg F indicator. The right 

terminal turns orange. 

f. Click an open area on the front panel. Both terminals aero range. 

g. Move the cursor over the connector pane. The Context Help window shows that both 

terminals are connected to floating-point values. 

8. Select File» Save to save the VI because you will use this VI later in the course. 

9. Select File» Close to close the Convert C to F VI. 

 

 
RESULT: conversion of the centigrade to foreign heat using a sub VI is performed 

 
 

VIVA QUESTIONS: 
 

1. What is sub vi? 
 

2. What is the use of sub vi? 



EXPERIMENT NO 5 

ARRAY MAXIMUM AND MINIMUM AND SORTING EVEN 

NUMBERS USING WHILE LOOP IN AN ARRAY 

 
             AIM: To find the maximum and minimum variable from an array. 

 

LEARNING OBJECTIVE: 

 To understand the maximum and minimum in array using lab view 

 To understand the sorting even number in array using lab view 

 
THEORY: 

Complete the following steps to find minimum and maximum and sorting the even numbers in           
an array 

 

COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 

2. Personal computer 

 
 

ALGORITHM: 
 

Step 1: Create blank VI. 

Step 2: Right click on the front panel →modern →array→ array matrix→ numeric control. Step 3: Create 

four numeric indicators in the front panel for maximum variable, index, minimum variable and index. 

Step 4: Using wiring operations required connections are given in the block diagram. Step 5: Inputs 

are given in the front panel and the program is executed. 

 
 

BLOCK DIAGRAM PANEL: 
 

 
 



Front Panel: 
 

Input: Output: 
 
 

 

 
ALGORITHM FOR SORTING OF NUMBERS USING WHILE LOOP 

 

Step 1: Create blank VI. 

Step 2: Right click on the block diagram panel, select program, go to structures and 

select a WHILE loop. 

Step 3: Create an array in the front panel and add numeric indicator to it. 

Step 4: Add the numeric control in the front panel. 

Step 5: Using wiring operations required connections are given in the block diagram. 

Step 6: Inputs are given in the front panel and the program is executed 

 
BLOCK DIAGRAM PANEL: 

 



 

FRONT PANEL: 

 

RESULT: Thus the maximum and minimum and sorting the even numbers from the given set of 

numbers using WHILE loop in an array is displayed. 

 
VIVA QUESTIONS: 

 

1. What is an array? 
 

2. What is maximum and minimum array? 



EXPERIMENT NO 6 

ANALYZING AND LOGGING DATA BY USING WAVE FORM GRAPHS 

 

 
AIM: To Analysing and logging data by using lab view. 

 
LEARNING OBJECTIVE: 

 To understand the data analyzing using lab view 

 To understand the usage of wave form graphs using lab view 

 
COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

 

THEORY:  
Complete the following steps to build a VI that measures temperature every 0.25 s for 10s.  

During the acquisition, the VI displays the measurements in real time on a waveform chart. After 

the acquisition is complete, the VI plots the data on a graph and calculates the minimum, maximum, 

and average temperatures. The VI displays the best fit of the temperature graph. 

 
 

ALGORITHM: 
 

 

1. Open a new VI and build the following front panel using the following tips. 
 



• Do not create the Mean, Max, and Min indicators yet. Create 
them on the Block Diagram by right clicking on the functions 
and choosing Create Indicator. Then position them on the 
Front Panel. 

 
BLOCK DIAGRAM 

 

2. Build the following block diagram. 
 

a. Select the Functions» Input» Simulate Signal. 
b. Choose a frequency, Amplitude, and an offset 
c. Place the Wait Until Next ms Multiple function located on the Functions» All 

Functions »Time & Dialog palette and create a constant of 250. Much like 
the Time Delay Express VI, this function causes the For Loop to execute every 
0.25 s (250 ms). 

d. Place the Array Max & Min function located on the Functions» All Functions 
»Array palette. This function returns the maximum and minimum amplitude of 
the wave. 

e. Place the Mean VI located on the Functions» All Functions» Analyze» 
Mathematics» Probability and Statistics palette. This VI returns the average 
of the amplitude of   the wave. 

f. Right-click the output terminals of the Array Max & Min function and Mean 
VI and select Create» Indicator from the shortcut menu to create the Max, 
Min, and Mean indicators. 

g. Place the Write Lab VIEW Measurements File Express VI located on the 
Functions» Output palette. Configure the VI to ask the user to choose the file 
to write and change the delimiter to Tab 

 

3. Save the VI as Temperature Logger.vi. 

4. Display the front panel and run the VI. 

5. After pressing STOP a dialog box will appear. Enter the name of the file 
to save the spreadsheet. 

6. Open the spreadsheet file to make sure the file was properly created by using 
Notepad or Excel, or by creating a VI to read the file as follows. 

• Create the following block diagram 
 

 
 

 

 

• Place the Read Lab VIEW Measurement File Express VI located  on the 

Functions » Input    palette. 

• Configure the VI to ask the user to choose the file to read 
and change the delimiter to Tab 

• Right click on the Signals Output and choose create graph indicator 



7. Run the VI 

8. Save and close both of the VI s. 

BLOCK DIAGRAM: 
 

 

 

 

 
 

ALGORITHM USING WAVEFORM GRAPHS 

 

 
Front Panel 

1. Open a new VI and build the following front panel using the following tips. 
 



 

 

 

 

 

 

 

 
 

BLOCK DIAGRAM 

a. Create a waveform graph indicator from the Controls» Graph 
Indicators palette. Use the position/size/select tool to move the plot 
legend to the side, and expand it to display two plots. Use the labeling 
tool to change the plot names and the properties page to choose different 
colors for your plots. 

b. Place a Stop button on the front panel. 

c. Place two vertical pointer slides from the Controls» Numeric 

Controls palette. Use the properties page again to change the slide 

fill color. 

 

1. Build the following  block diagram. 

 

 

a. Place a While Loop from Functions» Execution Control palette. 

b. Place a Wait Until Next ms Multiple from Functions» All Functions 

»Time & Dialog and create a constant with a value of 100. 

c. Place two Simulate Signal Express VIs from the Functions» Input 

and leave the Signal type as Sine for the first Simulate Signal VI and 

change the Signal Type to Square for the second VI. Wire both of the 

outputs into the waveform graph. A Merge Signals function will 

automatically be inserted. 

d. Expand the Simulate Signal Express VIs to show another Input / Output. 

By default, error out should appear. Change this to Frequency by 

clicking on error out and choosing Frequency. 

2. Save the VI as Multi plot Graph.vi. 

3. Display the front panel and run the VI. 

4. Save and close the VI.



 

RESULT: Hence analyzing the data by using wave forms is performed. 

 
VIVA QUESTIONS: 

 

1. How can we acquire the wave forms in lab wave? 
 

2. what is logging a data? 



EXPERIMENT NO 7 

BUNDLE AND UNBUNDLE CLUSTER 

 
AIM: To bundle and unbundle a cluster. 

 
LEARNING OBJECTIVE: 

 To understand the arithmetic operation using lab view 

 To understand the Boolean operation using lab view 

 
COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

 

 
THEORY: 

 
Use this border node to perform operations on one or more cluster elements and replace the 

elements in the same location in the cluster. Each cluster element you unbundle with the border node on the left 

side of the structure must be bundled back into the cluster with the border node on the right side of the structure. 

This node allows the Lab VIEW compiler to avoid storing a complete value copy of the cluster and cluster 

elements in memory. 

The border node on the left side of the structure is similar to the Unbundle by Name function. The border node 

on the right side of the structure is similar to the Bundle by Name function. 

 
ALGORITHM: 

Step 1: Create blank VI. 

Step 2: Select numeric control, string control for inputs. 

Step 3: Select bundle operation from a cluster. 

Step 4: Create a new cluster add numeric indicator, string indicator and round LED. 

Step 5: Using wiring operations required connections are given in the block diagram. 

Step 6: Inputs are given in the front panel and the program is executed. 

 

For unbundling cluster: 

 
Step 1: Create a new VI. 

Step 2: Create a cluster with numeric control, string and round LED. Step 3: 

Create numeric indicator, Boolean indictor and string indicator. 

Step 4: Using wiring operations required connections are given in the block diagram. 

Step 5: Inputs are given in the front panel and the program is executed. 



 

CIRCUIT DIAGRAM: 
 

 
 

Front Panel: Bundle cluster : 
 
 

 

Input: 

 

 

 

 

 
 

 

 



  

 

Unbundle cluster: Input: 
 

Output: 
 

 

 

Result: Hence a cluster is bundled and unbundled using Lab VIEW. 

 
VIVA QUESTIONS: 

 

1. What is bundled function? 
 

2. what is unbundled function what is the difference between two? 



 

 

EXPERIMENT NO  8 

FLAT AND STACKED SEQUENCE 

AIM: To perform functions using flat and stacked sequence. 

 
LEARNING OBJECTIVE: 

 To understand the flat and stacked sequence operation using lab view 

 
COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

 
THEORY: 

 
Consists of one or more sub diagrams, or frames, that execute sequentially. Use the Flat 

Sequence structure to ensure that a sub diagram executes before or after another sub diagram .Data flow 

for the Flat Sequence structure differs from data flow for other structures. Frames in a Flat Sequence 

structure execute from left to right and when all data values wired to a frame are available. The data 

leaves each frame as the frame finishes executing. This means the input of one frame can depend on the 

output of another frame. 

 
ALGORITHM: 

Step 1: Create blank VI. 

Step 2: Create flat and stacked sequence. 

Step 3: Right click on the boundary and add sequence local connect adder with the 

boundary. 

Step 4: Using wiring operations required connections are given in the block 

diagram. 

Step 5: Inputs are given in the front panel and the program is executed. 

 

 
CIRCUIT DIAGRAM: 

Flat sequence: 

 



Stacked sequence: 

 

 

 
 

 

 
Front Panel: 

 

Flat sequence: 
 

 

 

RESULT: Thus various functions using flat and stacked sequence using Lab VIEW was performed. 

 
VIVA QUESTIONS: 

1. What is a flat sequence? 

2. What is the difference between flat sequence and loop functions? 



EXPERIMENT NO 9 

APPLICATION USING FORMULA NODE & DISCRETE COSINE 

TRANSFORM 

AIM: To perform formula node and discrete cosine transform 

 
COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

 

LEARNING OBJECTIVE: 

 To understand the formula node and discrete cosine transform operation using lab view 

: THEORY: 

In this exercise, the objective is to use the Formula Node in a VI. Complete the following 

steps to build a VI that uses the Formula Node to perform a complex mathematical operation 

and graphs the results. 

 
Front Panel 

 

1. Open a blank VI and build the front panel shown in 
figure 1. Figure 1 

 



Block Diagram 
 

 

 

 

 

 
ALGORITHM: 

 
Place the Formula Node, located on the Functions>>All Functions>>Structures 

Palette , on the block diagram. 

1. Create the x input terminal by right-clicking the left border and selecting Add Input from the 

shortcut menu. Type x in the box that appears. 
2. Create the y and a output terminals by right-clicking the right border and selecting Add Output 

from the shortcut menu. Enter y and a, respectively, in the boxes that appear. You must create 
output terminals for temporary variables like a. 

Note: When you create an input or output terminal, you must use a variable name that 
exactly matches the one in the equation. Variable names are case sensitive. 

3. Type the following equations in the Formula Node, where ** is the exponentiation operator. 
Refer to the Lab VIEW Help for more information about syntax for the Formula Node. 

 
a = Tan h (x) + Cos(x) y = a3 + a 

 

4. Complete the block diagram as shown in figure 2. 
Save the VI as Formula Node Exercise.vi. 

 

Run the VI 

Display the front panel and run the VI. The graph displays the plot of the equation y = f ( x)
3
 + f ( x) 

where f ( x) = Tan h( x) + Cos(x) . During each iteration , the VI divides the iteration terminal value by 15.0. The 

quotient is wired to the Formula Node, which calculates the function value. The VI plots the array as a graph. 
 

Algorithm: 
 

1. Close the VI. 

2. Step 1: Create a blank VI 

3. Step 2: Generate a waveform from the signal processing block. 

4. Step 3: Create a discrete cosine transform and waveform graph in the front panel. 

5. Step 4: Using wiring operations required connections are given in the block diagram.



Block diagram panel: 
 

 
 

Front panel: 

 

 

 

 
RESULT: Hence formula node and discrete cosine transform was performed on the given input signal. 

 
VIVA QUESTIONS: 

1. What is a formula node? 

2. How discreet functions are performed? 



EXPERIMENT NO 10 

           MEDIAN FILTER 
 

               AIM: To apply filtering technique for a given input signal. 

 
COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

 

LEARNING OBJECTIVE: 

 To understand the median filter using lab view 

: THEORY: 

In this exercise, the objective is to use the signal processing and creating noise signal and eliminate the 

noise using median filter. 

 
ALGORITHM: 
 

Step 1: Create a blank VI. 

Step 2: In the block diagram panel go to signal processing and create a noise signal. Step 3: 

Select any one input signal. 

Step 4: Create median filter from signal processing block. 
Step 5: Using wiring operations required connections are given in the block diagram. Step 6: Inputs 

are given in the front panel and the program is executed. 

 

Block diagram panel: 
 

 

 



Front panel: 
 

 

 

 

 

 
Result: Hence filtering technique is applied on the input signal. 

 

VIVA QUESTIONS: 
 

1. What is noise signal? 
 

2. What is median filter? 



EXPERIMENT NO 11 

CONVOLUTION OF TWO SIGNALS 

 
AIM: To perform convolution of two signals. 

 
COMPONENTS REQUIRED: 

      NI Lab VIEW (2015 LV- 64bitWin Eng) 
      Personal computer 

 

LEARNING OBJECTIVE: 

 To understand the convolution of two signals using lab view 
 

          THEORY: 

 

 

 

 

In this exercise, the objective is to use the signal processing and convolution of two signals. 

 

             

Algoitm: 

 

 

 
 

Step 1: Create a blank VI. 

Step 2: Create two inputs and waveform graph. 

Step 3: Apply FFT for the two inputs and give it to multiplier. 
Step 4: In the receiver end IFFT is performed and the convolved output is displayed in 

the waveform graph. 
 

Block Diagram panel: 
 
 



Front panel: 

 

 

 

 
 



Result: Hence two signals were convolved and the result is verified durin  Lab 

VIEW. 

 
VIVA QUESTIONS: 

 

1. What is a convolution? 
 

2. What is correlation? 



EXPERIMENT NO 12 

WINDOWING TECHNIQUE 

    AIM: To apply different windowing technique on the give input signal 

 
COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

 

LEARNING OBJECTIVE: 

 To understand the windowing techniques of signals using lab view 
 

  

THEORY 

 

In this exercise, the objective is to use the signal processing and 

windowing technique of a given signals. 
 

Algorithm: 
 

Step 1: Create a blank VI. 

Step 2: Create handing, hamming, Blackman, chewy shave window on the block diagram panel. 

Step 3: Generate a input waveform and create extract single tone for all the windows. 

Step 4: Using wiring operations required connections are given in the block diagram. 

Step 5: Inputs are given in the front panel and the program is executed. 

 

Block diagram panel: 
 
 



Front panel: 
 

 

 
 

 
 

Result: Hence the characteristics of various windows are performed using Lab VIEW. 

VIVA QUESTIONS: 
 

1. What is an windowing technique? 
 

2. What are various characteristics of windows? 



EXPERIMENT NO 13 

DATA ACQUISATION THROUGH VIRTUAL INSTRUMENTATION 

 
AIM: To perform the Data acquisition through virtual instrumentation. 

 
LEARNING OBJECTIVE: 

 To understand the Data acquisition using lab view 

 
COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

: THEORY: 

In this exercise, the objective is to use the DAQ assistant and perform the 

signal processing. 

 
ALGORITHM: 

 
Step 1: Create blank VI. 

Step 2: Create a for loop . 

Step 3: Using wiring operations required connections are given in the block diagram. 

Step 5: Inputs are given in the front panel and the program is executed. 

 
 

CIRCUIT DIAGRAM: Front panel 



 

Block Diagram: 

 

 

 

RESULT: Data acquisition through virtual instrumentation is performed. 

 
VIVA QUESTIONS: 

 
1 What is acquisition? 

2 How signals are acquire? 



EXPERIMENT NO 14 

INSTRUMENTATION OF AN AMPLIFIER ACQUIRE AN ECG SIGNAL 

 

 
Aim: To acquire and analyze an ECG signal using NI ELVIS Lab VIEW. 

 
LEARNING OBJECTIVE: 

 To understand the Data acquisition using lab view 

 
COMPONENTS REQUIRED: 

1. NI Lab VIEW (2015 LV- 64bitWin Eng) 
2. Personal computer 

: THEORY: 

In this exercise, the objective is to use the DAQ assistant and perform the 

ECG signal. 
 

Algorithm: 
 

Procedure without Express: 

 

1. Construct the basic block diagram for acquiring a signal without using express. 
 
 

 

2. For acquiring ECG Signal: 

 

* From the front panel, set the number of samples to read as 3000 and the sampling rate as 1000.From the 
physical channel drop down menu select device and the channel no. (DEVICE 1 / AI0 CHANNEL). 



* Set the Voltage Maximum and Minimum to -5/5 V 

* Save the program (CTRL + S). From the Front panel toolbar menu select 

* Operate →Run (or press CTRL + R) to execute the program. 

Raw ECG Signal Output: 
 

 

 
 

3. Taking FFT for raw ECG: 

 

Right click on the block diagram. From the menu appearing select Signal ProcessingWfm 

Measure FFT Spectrum magnitude and phase. Place the FFT block in the block diagram. 

 
4. Connect the data in the DAQmx read terminal to Time signal terminal of the FFT block. 

 



5. Configuring FFT block: 

Keep the cursor over Window. Right click on it. A menu will pop up. Select Create → control. 
 
 

 

6. Similarly create a control for view. 
 
 

 
 

7. Displaying the FFT magnitude: 

 
In the front panel do right click. Select Graph Waveform Graph. Place the Waveform Graph in 
the front panel. 



 
 

 

8. Connect the FFT magnitude terminal of the FFT block to the waveform Graph in the block diagram. 

 

9. While running the application select ‗db On (F)‟ in the view palette in the front panel. Select 

Henning  window using the control in the front panel. 

 
Final Block Diagram: 

 
 



10. Save the program (CTRL + S). From the Front panel tool bar menu select Operate →Run (or 
press CTRL + R) to execute the program. The output is as shown in the figure. 

 
Final Front Panel: 

 
 



Final Block Diagram: 
 

 

 

 
Final Front Panel: 

 

 

 
 

Result: Thus the raw ECG signal (0-40Hz) was acquired and its FFT was 

obtained. Power line interference occurred at 50Hz. 

 

VIVA QUESTIONS: 

1. What is a ECG signal? 

2. What is the difference between the spectrum and CRO? 


